Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
open terminal failed: missing or unsuitable terminal: xterm-
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 17265

PostPosted: Sun Mar 25, 2018 9:27 pm    Post subject: open terminal failed: missing or unsuitable terminal: xterm- Reply with quote

Code:
$ tmux attach
open terminal failed: missing or unsuitable terminal: xterm-256color

Code:
$ tmux
open terminal failed: missing or unsuitable terminal: xterm-256color


The session does still exist (tmux list-sessions).

Assume the terminal supports 256 colours?
Code:
$ tmux -2 attach
open terminal failed: missing or unsuitable terminal: xterm-256color

_________________
The whole system has to go. The modern criminal justice system is incompatible with Neuroscience. --Sapolsky
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 17265

PostPosted: Sun Mar 25, 2018 9:30 pm    Post subject: Reply with quote

Unfortunately the solution is to kill the tmux server, which of course kills the session.

Code:
tmux kill-server


The cause was apparently having upgraded ncurses
Code:
>>> emerge (1 of 6) sys-libs/ncurses-6.1-r1


It'd be nice if emerge could warn if something running was likely break :)


I didn't find any related results, and hopefully I'll now remember to postpone upgrading if ncurses is on the list.
_________________
The whole system has to go. The modern criminal justice system is incompatible with Neuroscience. --Sapolsky
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5079

PostPosted: Sun Mar 25, 2018 9:37 pm    Post subject: Reply with quote

I had the same problem (with the same solution), but I found a workaround is to just set $TERM to something without -256color in it. -88color worked.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 17265

PostPosted: Sun Mar 25, 2018 9:55 pm    Post subject: Reply with quote

That's a certainly a better option if something "valuable" is in the session.
_________________
The whole system has to go. The modern criminal justice system is incompatible with Neuroscience. --Sapolsky
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19058
Location: here

PostPosted: Mon Mar 26, 2018 6:55 am    Post subject: Reply with quote

There is an open bug
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 17265

PostPosted: Mon Mar 26, 2018 12:59 pm    Post subject: Reply with quote

Thanks for the link. For whatever reason, didn't even occur to me that it was a bug.
_________________
The whole system has to go. The modern criminal justice system is incompatible with Neuroscience. --Sapolsky
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1312
Location: KUUSANKOSKI, Finland

PostPosted: Mon Mar 26, 2018 1:05 pm    Post subject: Reply with quote

I'm having this problem at the moment. I attach to my tmux session by TERM="xterm" tmux attach for now until I'm ready to terminate the session.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6109

PostPosted: Mon Mar 26, 2018 2:00 pm    Post subject: Reply with quote

It seems that after a reboot the issue vanished.
Back to top
View user's profile Send private message
hujuice
Apprentice
Apprentice


Joined: 16 Oct 2007
Posts: 263
Location: Rome, Italy

PostPosted: Tue Jun 05, 2018 10:21 am    Post subject: Reply with quote

Zucca wrote:
I'm having this problem at the moment. I attach to my tmux session by TERM="xterm" tmux attach for now until I'm ready to terminate the session.

It works for me too. Thank you.
HUjuice
_________________
Who hasn't a spine, should have a method.
Chi non ha carattere, deve pur avere un metodo.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum