Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VirtualBox: 'NS_ERROR_CALL_FAILED' / 'NS_ERROR_ABORT'...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Lebkoungcity
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2008
Posts: 104
Location: Lebkoungcity (=Nuremberg)

PostPosted: Thu May 31, 2018 11:02 am    Post subject: VirtualBox: 'NS_ERROR_CALL_FAILED' / 'NS_ERROR_ABORT'... Reply with quote

Hi,

I have an adapter to connect my laptop with the OBD-terminal of my car. Unfortunately there's only software for Windows and no option to use it with linux. (It is recognized by the kernel but there's no kernel module for it.) I have been able to use it with XP running in inside of virtualbox.


But this does not work anymore since virtualbox just throws errors at me when I start it - it spits out windows with errors but the command line remains clean.
It always starts with:

Quote:
Der globale Extradata-Schlüssel GUI/UpdateCheckCount konnte nicht auf den Wert {2} gesetzt werden. Callee RC: NS_ERROR_CALL_FAILED (0x800706BE)

(I would translate it to something like: 'The global extra-data-key GUI/UpdateCheckCount could not be set to value {2}.')

A few seconds later (doesn't matter if I click 'OK' in the first appearing window or not):
Quote:
Der globale Extradata-Schlüssel GUI/Toolbar/MachineTools/Order konnte nicht auf den Wert {None} gesetzt werden. Callee RC: NS_ERROR_ABORT (0x80004004)

('The global extra-data-key GUI/Toolbar/MachineTools/Order could not be set to value {none}.')

Then, after clicking 'OK':
Quote:
Der globale Extradata-Schlüssel GUI/Toolbar konnte nicht auf den Wert {} gesetzt werden. Callee RC: NS_ERROR_CALL_FAILED (0x800706BE)

('The global extra-data-key GUI/Toolbar could not be set to value {}.')

And then some more of this kind...

Afterwards the window of virtualbox is being rendered newly but any action in it will provoke this chain of error-boxes again. I can't fire up any virtual machine due to this behavior...

I played around with it and found out that I could open the settings-dialogue but any changes in there aren't saved - the next time I open it (doesn't matter if virtualbox was restarted or not) everything is set back to the original settings.

I switched from virtualbox to virtualbox-bin in January because of this (and because emerging app-emulation/virtualbox-5.1.30 took more then 8 hours (with distcc it didn't compile)) but the errors remain and I tried different versions oft it since then. At the moment I have app-emulation/virtualbox-bin-5.2.12.122591 on the machine.

I searched the forums and the net but found no solution that worked for me(!), nor found a resource that would teach me the cause of the errors...

I tried several times to re-emerge virtualbox(-bin) and virtualbox-modules in different orders, unmerge them completly, reboot so to be 100%sure the modules are not loaded and then re-emerge them, delete ~/.config/VirtualBox and all other folders of it - even starting with a complete new user - but nothing helped.

I found some people with more or less similar problems who tried to find help but either their solutions don't work for me or they were told to use a newer version or they did not get reactions. One person asked on the virtualbox-forums with virtualbox running on gentoo got the answer that she/he should seek for help on the gentoo forums because gentoo would use virtualbox in some kind of different way...

For now it's some months since I could not use virtualbox and now my car's idiot light saying I should check the engine comes up frequently I think the time has come for me to try it and ask if someone here might know what I could do.

Thanks a lot for your attention!
Andy
_________________
"The most dangerous world view is the world view of the ones who haven't viewed the world."
Alexander von Humboldt (1769-1859)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum