Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Python 3.6 per eselect news update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
1clue
Advocate
Advocate


Joined: 05 Feb 2006
Posts: 2438

PostPosted: Fri May 25, 2018 1:24 am    Post subject: Python 3.6 per eselect news update Reply with quote

Hi,

I got my updates yesterday, saw the news item 2018-05-22 Python 3.6 to become the default target and went about following the instructions, or at least I thought I did.

I got to about the middle of the message and things broke.

I put in /etc/portage/make.conf,

Code:
PYTHON_TARGETS="python2_7 python3_5 python3_6"
PYTHON_SINGLE_TARGET="python3_5"
...
USE="... python_single_target_pypy ..."


And now, when I get updates with emerge -aDNu --with-bdeps=y @world I get this:

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=app-text/asciidoc-8.6.0" has unmet requirements.
- app-text/asciidoc-8.6.10::gentoo USE="-examples -graphviz -highlight -test" PYTHON_SINGLE_TARGET="(-pypy) -python2_7" PYTHON_TARGETS="python2_7 (-pypy)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_pypy python_single_target_python2_7 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_pypy python_single_target_python2_7 ) python_single_target_pypy? ( python_targets_pypy ) python_single_target_python2_7? ( python_targets_python2_7 )

(dependency required by "sys-fs/btrfs-progs-4.10.2::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Not sure what I did wrong. Could somebody please point out the problem?
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1676

PostPosted: Fri May 25, 2018 2:08 am    Post subject: Reply with quote

Quote:
The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( python_single_target_pypy python_single_target_python2_7 )


It says what you need to do, in this case you need to add python_single_target_python2_7 to your package.use...
Back to top
View user's profile Send private message
1clue
Advocate
Advocate


Joined: 05 Feb 2006
Posts: 2438

PostPosted: Fri May 25, 2018 3:15 am    Post subject: Reply with quote

I added python_single_target_pypy to my make.conf USE declaration, I thought that would do it.
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1676

PostPosted: Fri May 25, 2018 3:54 am    Post subject: Reply with quote

If a use flag is in ()'s, it means it is masked/forced and can not be used until you unmask that USE flag.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 20153
Location: here

PostPosted: Fri May 25, 2018 5:42 am    Post subject: Reply with quote

ct85711 wrote:
If a use flag is in ()'s, it means it is masked/forced and can not be used until you unmask that USE flag.

And for unmask use /etc/portage/profile/package.use.mask
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
1clue
Advocate
Advocate


Joined: 05 Feb 2006
Posts: 2438

PostPosted: Fri May 25, 2018 7:44 pm    Post subject: Reply with quote

I reverted to my old make.conf and the system works.

Not really fixed since I'm still on my old python. I hope my system doesn't break whenever this upgrade goes down.

Thanks.
Back to top
View user's profile Send private message
bobbymcgee
n00b
n00b


Joined: 12 Apr 2018
Posts: 55

PostPosted: Fri May 25, 2018 11:16 pm    Post subject: Reply with quote

1clue,

I will expound further beyond ct85711's reply. There are a few packages like asciidoc that will never support python3. Sadly asciidoctor is looking like it'll be the only solution. These packages are dependent on being individually listed in package.use as python_single_target_python2_7. I imagine it'll be automatic in the profiles by the time of the switch though.

so add this to package.use:
Code:
app-text/asciidoc python_single_target_python2_7
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6242

PostPosted: Sat May 26, 2018 7:00 am    Post subject: Reply with quote

bobbymcgee wrote:
Sadly asciidoctor is looking like it'll be the only solution

https://github.com/asciidoc/asciidoc3
Back to top
View user's profile Send private message
bobbymcgee
n00b
n00b


Joined: 12 Apr 2018
Posts: 55

PostPosted: Sat May 26, 2018 8:08 am    Post subject: Reply with quote

yeah i should have said may never. it hasn't gone too far is the problem.
https://github.com/asciidoc/asciidoc3/pull/1
Back to top
View user's profile Send private message
ILMostro
n00b
n00b


Joined: 24 Jan 2018
Posts: 2

PostPosted: Mon Jun 25, 2018 9:47 am    Post subject: Reply with quote

That issue seems to have been resolved!
However, I'm still not sure if there's a connection between
https://github.com/asciidoc/asciidoc3 and https://github.com/asciidoc/asciidoc3 .

This should make it possible to progress with Bug 658780 sooner, as there is no need to deal with ruby.
Although, asciidoc3 is still not in portage tree.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum