Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] weird dependence issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
vcmota
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2017
Posts: 105

PostPosted: Thu May 24, 2018 12:47 pm    Post subject: [SOLVED] weird dependence issue Reply with quote

I am having this weird dependence issue, which I first taught it was something temporary, but that has been going on all of my gentoo install for a few weeks now. Whenever I perform a world update I get this warning:

Code:

~> sudo emerge --ask --update --deep --newuse --with-bdeps=y --changed-use @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

media-libs/freetype:2

  (media-libs/freetype-2.9.1-r3:2/2::gentoo, ebuild scheduled for merge) conflicts with
    <media-libs/freetype-2.9.1-r2 required by (app-text/texlive-core-2017-r3:0/0::gentoo, installed)
    ^                    ^^^^^^^^


Nothing to merge; quitting.
~>


The problems are: 1) freetype=> 2.9 is not even stable yet; 2) the version that I have on my system is 2.8 as you can see here:

Code:

~> equery l freetype
 * Searching for freetype ...
[IP-] [  ] media-libs/freetype-2.8:2
~> equery d freetype
 * These packages depend on freetype:
app-backup/spideroak-bin-6.3.0-r1 (media-libs/freetype:2)
app-doc/doxygen-1.8.13-r1 (dot ? media-libs/freetype)
app-office/libreoffice-6.0.3.2 (media-libs/freetype:2)
app-text/dvipng-1.15 (truetype ? >=media-libs/freetype-2.1.5)
app-text/dvisvgm-2.1.3 (media-libs/freetype:2)
app-text/ghostscript-gpl-9.21 (>=media-libs/freetype-2.4.9:2)
app-text/poppler-0.62.0-r1 (>=media-libs/freetype-2.3.9)
app-text/texlive-core-2017-r3 (media-libs/freetype:2)
                              (<media-libs/freetype-2.9.1-r2)
app-text/ttf2pk2-2.0_p20170524 (media-libs/freetype:2)
app-text/xdvik-22.87.03-r1 (media-libs/freetype:2)
app-text/xournal-0.4.8 (media-libs/freetype)
dev-java/icedtea-bin-3.7.0 (multilib ? >=media-libs/freetype-2.5.5:2
    [abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
    abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
    abi_s390_32(-)?,abi_s390_64(-)?])
                           (!multilib ? >=media-libs/freetype-2.5.5:2)
dev-qt/qtgui-5.9.4-r3 (>=media-libs/freetype-2.6.1:2)
media-gfx/graphviz-2.40.1-r1 (>=media-libs/freetype-2.1.10)
media-gfx/imagemagick-7.0.7.28 (truetype ? >=media-libs/freetype-2)
media-libs/fontconfig-2.12.6 (>=media-libs/freetype-2.7.1[abi_x86_32(-)?,
    abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
    abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,
    abi_s390_64(-)?])
media-libs/ftgl-2.1.3_rc5 (>=media-libs/freetype-2.0.9)
media-libs/gd-2.2.5 (truetype ? >=media-libs/freetype-2.5.0.1[abi_x86_32(-)?,
    abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
    abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,
    abi_s390_64(-)?])
media-libs/harfbuzz-1.7.6 (truetype ? >=media-libs/freetype-2.5.0.1:2
    [abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
    abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
    abi_s390_32(-)?,abi_s390_64(-)?])
media-libs/imlib2-1.4.9 (media-libs/freetype:2[abi_x86_32(-)?,abi_x86_64(-)?,
    abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,
    abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
media-libs/libass-0.13.6 (>=media-libs/freetype-2.5.0.1:2[abi_x86_32(-)?,
    abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
    abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,
    abi_s390_64(-)?])
media-libs/libprojectm-2.1.0-r2 (media-libs/freetype:2)
media-video/ffmpeg-3.3.6 (truetype ? >=media-libs/freetype-2.5.0.1:2
    [abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
    abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
    abi_s390_32(-)?,abi_s390_64(-)?])
media-video/vlc-2.2.8-r1 (truetype ? media-libs/freetype:2)
net-print/cups-filters-1.17.9 (media-libs/freetype:2)
sci-mathematics/octave-4.2.2 (opengl ? media-libs/freetype:2)
sys-boot/grub-2.02-r1 (truetype ? media-libs/freetype:2)
                      (fonts ? media-libs/freetype:2)
                      (truetype ? media-libs/freetype[static-libs(+)])
                      (themes ? media-libs/freetype:2)
www-client/chromium-66.0.3359.170 (media-libs/freetype)
www-client/firefox-52.8.0 (>=media-libs/freetype-2.4.10)
www-client/vivaldi-1.15.1147.36_p1 (media-libs/freetype)
www-plugins/adobe-flash-29.0.0.171 (nsplugin ? media-libs/freetype
    [abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
    abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
    abi_s390_32(-)?,abi_s390_64(-)?])
www-plugins/freshplayerplugin-0.3.5-r2 (media-libs/freetype:2)
x11-apps/mkfontscale-1.1.3 (media-libs/freetype:2)
x11-libs/cairo-1.14.12 (>=media-libs/freetype-2.5.0.1:2[abi_x86_32(-)?,
    abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
    abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,
    abi_s390_64(-)?])
x11-libs/libXfont2-2.0.3-r1 (truetype ? >=media-libs/freetype-2)
x11-libs/libXft-2.3.2-r1 (>=media-libs/freetype-2.5.0.1[abi_x86_32(-)?,
    abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
    abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,
    abi_s390_64(-)?])
x11-libs/pango-1.40.14-r1 (>=media-libs/freetype-2.5.0.1:2[abi_x86_32(-)?,
    abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
    abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,
    abi_s390_64(-)?])
~>


and 3) texlive-core has not being updated for months, I am not even sure that it has been updated from version 2016 to 2017 this year, I suspect that happened still in 2017; 4) as you may see above texlive-core depends of freetype 2.8, which is the curent stable version of freetype. Is this a bug in portage of something?

Thank you all.

Wrapped long lines to make the forum layout behave.Chiitoo


Last edited by vcmota on Thu May 24, 2018 8:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18821
Location: here

PostPosted: Thu May 24, 2018 1:11 pm    Post subject: Reply with quote

https://bugs.gentoo.org/656238
https://bugs.gentoo.org/656186
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
vcmota
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2017
Posts: 105

PostPosted: Thu May 24, 2018 8:40 pm    Post subject: Reply with quote

Thank you fedeliallalinea. I made a comment there, although the bug was already confirmed. There is also this bug here, which is related. The solution apparently has been found and added to the app-text/texlive-core-2017-r4 ebuild, but that is not stable yet, so I will wait. Thank you again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum