Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Disable turbo boost
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
sad_dam
n00b
n00b


Joined: 07 May 2018
Posts: 12

PostPosted: Mon May 21, 2018 11:28 pm    Post subject: Disable turbo boost Reply with quote

Hello, could you not tell me how to permanently disable turbo boost? Writing the script "echo 1 > /sys/devices/system/cpu/intel_pstate/no_turbo" into /etc/local.d does not always disable turbo boost, and if it does, sometimes I notice it turns back on and overheats my laptop. In bios i dont have an option to disable turbo boost, changing governor to powersave does not help at all.
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5643

PostPosted: Tue May 22, 2018 1:24 am    Post subject: Reply with quote

I've only ever seen it get turned back on when I unplug/replug my laptop. If you can't turn it off in the bios, then you'll have to keep turning it off by hand. I run this as a cron script:

Code:
#!/bin/bash

DEBUG=0

# This turns off Intel turbo boost because the BIOS won't let us do it in there
# Requirements: CONFIG_X86_INTEL_PSTATE

until [ -e /sys/devices/system/cpu/intel_pstate/no_turbo ]; do
        if [ "$DEBUG" -eq "1" ]; then
                printf "Waiting for no_turbo to appear...\n"
        fi
        sleep 5
done

OUTPUT=`cat /sys/devices/system/cpu/intel_pstate/no_turbo`

if [ "$OUTPUT" -ne "1" ]; then
        until [ "$OUTPUT" -eq "1" ]; do
                echo 1 > /sys/devices/system/cpu/intel_pstate/no_turbo
                OUTPUT=`cat /sys/devices/system/cpu/intel_pstate/no_turbo`
                if [ "$OUTPUT" -ne "1" ]; then
                        if [ "$DEBUG" -eq "1" ]; then
                        printf "Turbo did not get disabled, trying again...\n"
                        fi
                        sleep 5
                else
                        if [ "$DEBUG" -eq "1" ]; then
                                printf "Turbo should now be disabled...\n"
                        fi
                fi
        done
else
        if [ "$DEBUG" -eq "1" ]; then
                printf "Turbo is already disabled.\n"
        fi
fi

_________________
overlay | patches
Neddyseagoon wrote:
The problem with leaving is that you can only do it once and it reduces your influence.
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1312
Location: KUUSANKOSKI, Finland

PostPosted: Tue May 22, 2018 7:53 am    Post subject: Reply with quote

If it changes during (un)plug of the power cord, then I'd bind some post action script to the acpi events in question.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
sad_dam
n00b
n00b


Joined: 07 May 2018
Posts: 12

PostPosted: Wed May 23, 2018 6:19 am    Post subject: Reply with quote

Zucca wrote:
If it changes during (un)plug of the power cord, then I'd bind some post action script to the acpi events in question.

In fact, my turbo boost goes on when i suspend my laptop via s2ram. But in any case, i was hoping for some more decent way (system wide toggle switch for example) to turn off the turbo bost. When the turbo boost is on, during heavy compilation my laptop is heated up to 100 degrees, the cooler in the system is configured too bad, It runs at half of its speed even at 100 degree.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2543
Location: Illinois, USA

PostPosted: Wed May 23, 2018 1:48 pm    Post subject: Reply with quote

On my mobo's there is a BIOS setting if you never want it on. Also, manual frequency control and usually a max frequency (X times clock)
Back to top
View user's profile Send private message
Hotblack
n00b
n00b


Joined: 28 Dec 2004
Posts: 40

PostPosted: Wed May 23, 2018 2:23 pm    Post subject: Reply with quote

I suggest to take a look at tlp for power management.
I'm using it with my hp dv6 notebook, and it works great.

See here for the ebuild.

i.e. to disable turbo in config file:
Quote:
# Set the CPU "turbo boost" feature: 0=disable, 1=allow
# Requires an Intel Core i processor.
# Important:
# - This may conflict with your distribution's governor settings
# - A value of 1 does *not* activate boosting, it just allows it
CPU_BOOST_ON_AC=0
CPU_BOOST_ON_BAT=0
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2504
Location: Near Toronto

PostPosted: Wed May 23, 2018 3:55 pm    Post subject: Reply with quote

I put a file in

Code:
/usr/lib64/pm-utils/sleep.d/


to set things up properly after waking from ram sleep. I think
it should be easy to reset your BOOST to OFF there.

Another temperature saver I found recently is this undervolting
utility:

https://github.com/xdever/linux-intel-undervolt-tool

(only for intel cpu)
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum