Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Repairing system with damaged/lost database of world set
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
plhu
n00b
n00b


Joined: 20 May 2018
Posts: 1

PostPosted: Sun May 20, 2018 2:32 pm    Post subject: Repairing system with damaged/lost database of world set Reply with quote

Hi,
I do not know how, but apparently a part of my portage data has been damaged or lost. For some time, if I run 'eix -cI' I get no list of installed packages. If I run 'emerge -v sys-devel/glibc', I get like 600 packages to be new and to be installed. Despite that, emerge --search sys-libs/glibc shows me something in the 'Installed version'. I checked my /var/lib/portage/world file and it seems to contain the packages I have installed on my box (time stamp says 10 days old).
Is there any way how to fix this or do you have any hint of what could be missing?

Edit: I figured out what am I missing actually - the contents of /var/db/pkg directory is gone. I try to do emerge --nodeps to resolve the circular dependencies and emerge -e @world.

Lukas
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum