Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Card reader not working, worked a year ago
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3350

PostPosted: Wed May 02, 2018 10:14 am    Post subject: Card reader not working, worked a year ago Reply with quote

I have a Thinkpad T460p with a built-in SD card reader. A year ago I was able to use it to upload photos, now I'm not.

According to lspci I have:
Code:
$ /usr/sbin/lspci -s 02:00.0 -v
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader (rev 01)
   Subsystem: Lenovo ThinkPad T440p
   Flags: bus master, fast devsel, latency 0, IRQ 27
   Memory at f0500000 (32-bit, non-prefetchable) [size=4K]
   Capabilities: <access denied>
   Kernel driver in use: rtsx_pci
   Kernel modules: rtsx_pci


Simply inserting the SD card does nothing. If I manually load the modules I have:
Code:
$ lsmod | grep mmc
rtsx_pci_sdmmc         28672  0
mmc_core              167936  1 rtsx_pci_sdmmc
rtsx_pci               73728  1 rtsx_pci_sdmmc


Which also looks good. But alas, no card. No changes show on dmesg when I plug the card, and of course the device node doesn't show in /dev. Searching here showed someone with this problem in the past, which turned out to be a bad SD card. But this card is still working in the camera, I can take pictures as well as review them.

Any suggestions?
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19647
Location: here

PostPosted: Wed May 02, 2018 10:19 am    Post subject: Reply with quote

Can be also your problem?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7709
Location: ~Brussels - Belgique

PostPosted: Wed May 02, 2018 10:23 am    Post subject: Reply with quote

Oh, I have the same problem, and didn't not know since when the problem occured (use it too rarely).
Thanks for the link!
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3350

PostPosted: Wed May 02, 2018 8:58 pm    Post subject: Reply with quote

I don't believe that this is my problem. While it's a different SIM than the one I used a year ago, in the reference posted there were at least messages posted in dmesg - /var/log.messages, even if they were error messages. I get absolutely no indication of the SD card plug event. I just grabbed another SD card from a different camera and plugged it in. Still no indication of the plug event.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3350

PostPosted: Thu May 03, 2018 5:28 pm    Post subject: Reply with quote

I verified this, this evening. Had a root-tail open on /var/log/messages, and ran "modprobe rtsx-pci". No activity. I also ran "lsmod | grep rtsx" and it did load, along with rtsx_pci_sdmmc, mmc_core, and mfd_core.

Not sure about that last one, I believe it had already been loaded, as it's also used by lpc_ich. I see it's "multi-function driver", and the ich is Intel chipset-related.

Still, no messages, nothing to use as diagnostics.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1353
Location: KUUSANKOSKI, Finland

PostPosted: Thu May 03, 2018 5:58 pm    Post subject: Reply with quote

Try to watch messages with
run as root:
dmesg -l 1,2,3,4,5,6,7 -f kern,syslog,daemon,user -w
... and then load modules and insert the memory card.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3350

PostPosted: Thu May 03, 2018 7:18 pm    Post subject: Reply with quote

Had to rmmod the stuff first, but the dmesg command you suggested still printed nothing.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1353
Location: KUUSANKOSKI, Finland

PostPosted: Thu May 10, 2018 9:42 am    Post subject: Reply with quote

Do the related modules have any adjustable parameters?
Some kind of debug paramater at this point would be nice. :P
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum