Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
'uptime' vs 'w' number of users discrepancy
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
chris_harvey
n00b
n00b


Joined: 12 Mar 2010
Posts: 37
Location: Ottawa, Canada

PostPosted: Fri May 04, 2018 3:34 am    Post subject: 'uptime' vs 'w' number of users discrepancy Reply with quote

if I type 'uptime' I see
Code:
23:28:05 up 30 days,  3:03,  2 users,  load average: 0.41, 0.21, 0.13

If I type 'w' I see
Code:
 23:29:07 up 30 days,  3:04,  2 users,  load average: 0.24, 0.20, 0.13
USER     TTY        LOGIN@   IDLE   JCPU   PCPU WHAT
chris    :0.0      03Apr18 ?xdm?   7:09m  1:48  /usr/bin/i3


There is only one user in the list, but the header says "2 users"...where is the other user? What am I missing?
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5718

PostPosted: Sat May 05, 2018 6:30 am    Post subject: Reply with quote

I haven't seen this happen in a while, but it used to come down to utmp not being updated properly (session started but not cleaned up when closed).

I wonder, do you have utempter installed? (edit: I used to have this problem more often with than without)

Might also want to see if you have dbus/consolekit in your default runlevel.
_________________
overlay | patches
Neddyseagoon wrote:
The problem with leaving is that you can only do it once and it reduces your influence.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum