Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] A little help with ruby23 ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Myu
Apprentice
Apprentice


Joined: 22 Oct 2014
Posts: 162
Location: Belgium

PostPosted: Sun Apr 29, 2018 4:28 pm    Post subject: [Solved] A little help with ruby23 ? Reply with quote

So I don't know exactly how to solve that one, ruby 2.2 has been hard masked but the 2.3 upgrade is giving me issues.

It all started after a sync and @changed-deps

Code:
Dwarf ~ # emerge @changed-deps
Calculating dependencies... done!
[ebuild  NS    ] dev-lang/ruby-2.3.7 [2.2.10] USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -jemalloc -libressl -rubytests -socks5 -tk -xemacs"
[ebuild  N     ] dev-ruby/rubygems-2.7.6  USE="-server {-test}" RUBY_TARGETS="ruby23 (-ruby24) (-ruby25)"
[ebuild   R    ] virtual/rubygems-11  RUBY_TARGETS="ruby23*"
[ebuild   R    ] dev-ruby/power_assert-0.3.1  RUBY_TARGETS="ruby23*"
[ebuild   R    ] dev-ruby/minitest-5.9.1  RUBY_TARGETS="ruby23*"
[ebuild   R    ] dev-ruby/rake-10.5.0  RUBY_TARGETS="ruby23*"
[ebuild   R    ] dev-ruby/json-1.8.6-r1  RUBY_TARGETS="ruby23*"
[ebuild  N     ] dev-ruby/net-telnet-0.1.1-r1  USE="-doc {-test}" RUBY_TARGETS="ruby23 (-ruby24) (-ruby25)"
[ebuild   R    ] dev-ruby/test-unit-3.1.9  RUBY_TARGETS="ruby23*"
[ebuild  N     ] dev-ruby/did_you_mean-1.0.2  USE="{-test}" RUBY_TARGETS="ruby23"
[ebuild  N     ] dev-ruby/racc-1.4.14  USE="-doc {-test}" RUBY_TARGETS="ruby23 (-ruby24) (-ruby25)"
[ebuild   R    ] dev-ruby/rdoc-4.3.0  RUBY_TARGETS="ruby23*"
[ebuild   R    ] dev-ruby/trollop-2.1.2  RUBY_TARGETS="ruby23* (-ruby25)"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

virtual/rubygems:0

  (virtual/rubygems-11:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/rubygems-11[ruby_targets_ruby23] required by (dev-ruby/racc-1.4.14:0/0::gentoo, ebuild scheduled for merge)
                         ^^^^^^^^^^^^^^^^^^^                                                                                                               
    virtual/rubygems[ruby_targets_ruby23] required by (dev-ruby/racc-1.4.14:0/0::gentoo, ebuild scheduled for merge)
                     ^^^^^^^^^^^^^^^^^^^                                                                                                               
    virtual/rubygems[ruby_targets_ruby23] required by (dev-ruby/test-unit-3.1.9:2/2::gentoo, ebuild scheduled for merge)
                     ^^^^^^^^^^^^^^^^^^^                                                                                                                   
    =virtual/rubygems-11[ruby_targets_ruby23] required by (dev-ruby/rdoc-4.3.0:0/0::gentoo, ebuild scheduled for merge)
                         ^^^^^^^^^^^^^^^^^^^                                                                                                               
    virtual/rubygems[ruby_targets_ruby23] required by (dev-ruby/trollop-2.1.2:2/2::gentoo, ebuild scheduled for merge)
                     ^^^^^^^^^^^^^^^^^^^                                                                                                                 
    =virtual/rubygems-11[ruby_targets_ruby23] required by (dev-ruby/net-telnet-0.1.1-r1:1/1::gentoo, ebuild scheduled for merge)
                         ^^^^^^^^^^^^^^^^^^^                                                                                                                       
    virtual/rubygems[ruby_targets_ruby23] required by (dev-ruby/rdoc-4.3.0:0/0::gentoo, ebuild scheduled for merge)
                     ^^^^^^^^^^^^^^^^^^^                                                                                                               
    =virtual/rubygems-11[ruby_targets_ruby23] required by (dev-ruby/test-unit-3.1.9:2/2::gentoo, ebuild scheduled for merge)
                         ^^^^^^^^^^^^^^^^^^^                                                                                                                   
    =virtual/rubygems-11[ruby_targets_ruby23] required by (dev-ruby/did_you_mean-1.0.2:1/1::gentoo, ebuild scheduled for merge)
                         ^^^^^^^^^^^^^^^^^^^                                                                                                                       
    virtual/rubygems[ruby_targets_ruby23] required by (dev-ruby/minitest-5.9.1:5/5::gentoo, ebuild scheduled for merge)
                     ^^^^^^^^^^^^^^^^^^^                                                                                                                   
    =virtual/rubygems-11[ruby_targets_ruby23] required by (dev-ruby/minitest-5.9.1:5/5::gentoo, ebuild scheduled for merge)
                         ^^^^^^^^^^^^^^^^^^^                                                                                                                   
    =virtual/rubygems-11[ruby_targets_ruby23] required by (dev-ruby/rake-10.5.0:0/0::gentoo, ebuild scheduled for merge)
                         ^^^^^^^^^^^^^^^^^^^                                                                                                               
    =virtual/rubygems-11[ruby_targets_ruby23] required by (dev-ruby/trollop-2.1.2:2/2::gentoo, ebuild scheduled for merge)
                         ^^^^^^^^^^^^^^^^^^^                                                                                                                 
    virtual/rubygems[ruby_targets_ruby23] required by (dev-ruby/json-1.8.6-r1:0/0::gentoo, ebuild scheduled for merge)
                     ^^^^^^^^^^^^^^^^^^^                                                                                                                 
    =virtual/rubygems-11[ruby_targets_ruby23] required by (dev-lang/ruby-2.3.7:2.3/2.3::gentoo, ebuild scheduled for merge)
                         ^^^^^^^^^^^^^^^^^^^                                                                                                                   
    virtual/rubygems[ruby_targets_ruby23] required by (dev-ruby/power_assert-0.3.1:0/0::gentoo, ebuild scheduled for merge)
                     ^^^^^^^^^^^^^^^^^^^                                                                                                                       
    virtual/rubygems[ruby_targets_ruby23] required by (dev-ruby/net-telnet-0.1.1-r1:1/1::gentoo, ebuild scheduled for merge)
                     ^^^^^^^^^^^^^^^^^^^                                                                                                                       
    virtual/rubygems[ruby_targets_ruby23] required by (dev-ruby/rake-10.5.0:0/0::gentoo, ebuild scheduled for merge)
                     ^^^^^^^^^^^^^^^^^^^                                                                                                               
    =virtual/rubygems-11[ruby_targets_ruby23] required by (dev-ruby/power_assert-0.3.1:0/0::gentoo, ebuild scheduled for merge)
                         ^^^^^^^^^^^^^^^^^^^                                                                                                                       
    virtual/rubygems[ruby_targets_ruby23] required by (dev-lang/ruby-2.3.7:2.3/2.3::gentoo, ebuild scheduled for merge)
                     ^^^^^^^^^^^^^^^^^^^                                                                                                                   
    =virtual/rubygems-11[ruby_targets_ruby23] required by (dev-ruby/json-1.8.6-r1:0/0::gentoo, ebuild scheduled for merge)
                         ^^^^^^^^^^^^^^^^^^^                                                                                                                 
    virtual/rubygems[ruby_targets_ruby23] required by (dev-ruby/did_you_mean-1.0.2:1/1::gentoo, ebuild scheduled for merge)
                     ^^^^^^^^^^^^^^^^^^^                                                                                                                       

  (virtual/rubygems-11:0/0::gentoo, installed) pulled in by
    virtual/rubygems[ruby_targets_ruby22] required by (dev-ruby/paint-1.0.1:0/0::gentoo, installed)
                     ^^^^^^^^^^^^^^^^^^^                                                                                               
    virtual/rubygems[ruby_targets_ruby22] required by (dev-lang/ruby-2.2.10:2.2/2.2::gentoo, installed)
                     ^^^^^^^^^^^^^^^^^^^                                                                                                   
    virtual/rubygems[ruby_targets_ruby22] required by (games-misc/lolcat-42.1.43:0/0::gentoo, installed)
                     ^^^^^^^^^^^^^^^^^^^                                                                                                   

dev-ruby/json:0

  (dev-ruby/json-1.8.6-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-ruby/json-1.8.3[ruby_targets_ruby23] required by (dev-lang/ruby-2.3.7:2.3/2.3::gentoo, ebuild scheduled for merge)
                          ^^^^^^^^^^^^^^^^^^^                                                                                                                   
    >=dev-ruby/json-1.4:0[ruby_targets_ruby23] required by (dev-ruby/rdoc-4.3.0:0/0::gentoo, ebuild scheduled for merge)
                          ^^^^^^^^^^^^^^^^^^^                                                                                                               

  (dev-ruby/json-1.8.6-r1:0/0::gentoo, installed) pulled in by
    >=dev-ruby/json-1.8.1[ruby_targets_ruby22] required by (dev-lang/ruby-2.2.10:2.2/2.2::gentoo, installed)
                          ^^^^^^^^^^^^^^^^^^^                                                                                                   

dev-ruby/minitest:5

  (dev-ruby/minitest-5.9.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-ruby/minitest-5.8.3[ruby_targets_ruby23] required by (dev-lang/ruby-2.3.7:2.3/2.3::gentoo, ebuild scheduled for merge)
                              ^^^^^^^^^^^^^^^^^^^                                                                                                                   

  (dev-ruby/minitest-5.9.1:5/5::gentoo, installed) pulled in by
    >=dev-ruby/minitest-5.4.3[ruby_targets_ruby22] required by (dev-lang/ruby-2.2.10:2.2/2.2::gentoo, installed)
                              ^^^^^^^^^^^^^^^^^^^                                                                                                   

dev-ruby/rdoc:0

  (dev-ruby/rdoc-4.3.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-ruby/rdoc-4.2.1[ruby_targets_ruby23] required by (dev-lang/ruby-2.3.7:2.3/2.3::gentoo, ebuild scheduled for merge)
                          ^^^^^^^^^^^^^^^^^^^                                                                                                                   

  (dev-ruby/rdoc-4.3.0:0/0::gentoo, installed) pulled in by
    >=dev-ruby/rdoc-4.0.1[ruby_targets_ruby22] required by (dev-lang/ruby-2.2.10:2.2/2.2::gentoo, installed)
                          ^^^^^^^^^^^^^^^^^^^                                                                                                   

dev-ruby/test-unit:2

  (dev-ruby/test-unit-3.1.9:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-ruby/test-unit-3.1.5[ruby_targets_ruby23] required by (dev-lang/ruby-2.3.7:2.3/2.3::gentoo, ebuild scheduled for merge)
                               ^^^^^^^^^^^^^^^^^^^                                                                                                                   

  (dev-ruby/test-unit-3.1.9:2/2::gentoo, installed) pulled in by
    >=dev-ruby/test-unit-3.0.8[ruby_targets_ruby22] required by (dev-lang/ruby-2.2.10:2.2/2.2::gentoo, installed)
                               ^^^^^^^^^^^^^^^^^^^                                                                                                   

dev-ruby/rake:0

  (dev-ruby/rake-10.5.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-ruby/rake-10.4.2[ruby_targets_ruby23] required by (dev-lang/ruby-2.3.7:2.3/2.3::gentoo, ebuild scheduled for merge)
                           ^^^^^^^^^^^^^^^^^^^                                                                                                                   
    dev-ruby/rake[ruby_targets_ruby23] required by (dev-ruby/racc-1.4.14:0/0::gentoo, ebuild scheduled for merge)
                  ^^^^^^^^^^^^^^^^^^^                                                                                                               
    dev-ruby/rake[ruby_targets_ruby23] required by (dev-ruby/json-1.8.6-r1:0/0::gentoo, ebuild scheduled for merge)
                  ^^^^^^^^^^^^^^^^^^^                                                                                                                 

  (dev-ruby/rake-10.5.0:0/0::gentoo, installed) pulled in by
    >=dev-ruby/rake-0.9.6[ruby_targets_ruby22] required by (dev-lang/ruby-2.2.10:2.2/2.2::gentoo, installed)
                          ^^^^^^^^^^^^^^^^^^^                                                                                                   

dev-ruby/power_assert:0

  (dev-ruby/power_assert-0.3.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-ruby/power_assert-0.2.6[ruby_targets_ruby23] required by (dev-lang/ruby-2.3.7:2.3/2.3::gentoo, ebuild scheduled for merge)
                                  ^^^^^^^^^^^^^^^^^^^                                                                                                                   
    dev-ruby/power_assert[ruby_targets_ruby23] required by (dev-ruby/test-unit-3.1.9:2/2::gentoo, ebuild scheduled for merge)
                          ^^^^^^^^^^^^^^^^^^^                                                                                                                   

  (dev-ruby/power_assert-0.3.1:0/0::gentoo, installed) pulled in by
    >=dev-ruby/power_assert-0.2.2[ruby_targets_ruby22] required by (dev-lang/ruby-2.2.10:2.2/2.2::gentoo, installed)
                                  ^^^^^^^^^^^^^^^^^^^                                                                                                   

dev-ruby/trollop:2

  (dev-ruby/trollop-2.1.2:2/2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-ruby/trollop-2.1.2:2/2::gentoo, installed) pulled in by
    >=dev-ruby/trollop-2.1.2:2[ruby_targets_ruby22] required by (games-misc/lolcat-42.1.43:0/0::gentoo, installed)
                               ^^^^^^^^^^^^^^^^^^^                                                                                                   


!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might help emerge to give a more specific suggestion.


My portage-fu wasn't able to solve it, I've put RUBY_TARGETS="ruby23" in /etc/portage/make.conf but it didn't helped much

Anyone with the same issue or a fix ?

Cheers,

Myu
_________________
Gentoo stable (with bits of ~amd64) / Games ! (Linux & vfio-pci ) // Xfce

Feel free to PM me if you would like a simple ebuild and I'll see what I can do :]


Last edited by Myu on Mon Apr 30, 2018 3:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1312
Location: KUUSANKOSKI, Finland

PostPosted: Sun Apr 29, 2018 6:31 pm    Post subject: Reply with quote

Many of the conflicts is because ruby-2.2 still being in the system. As to why doesn't Portage recommend to remove it - I have no clue.

Anyway I'd try this:
Code:
emerge -aDN --backtrack=100 --with-bdeps y --complete-graph y @world
... depency calculations might take a while, but hopefully conflicts will be solved.

EDIT: You may want to add "--keep-going y" there too if the command produces a lot ot package (re)builds.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
Myu
Apprentice
Apprentice


Joined: 22 Oct 2014
Posts: 162
Location: Belgium

PostPosted: Sun Apr 29, 2018 8:21 pm    Post subject: Reply with quote

Hello Zucca,

Thanks for the proposal, the command didn't had any effect (system was up to date and didn't want to update to ruby23, I'm only prompted for ruby23 when I do @changed-deps)

but I followed your idea and removed ruby22 :

Code:

emerge --unmerge =ruby-2.2.10
emerge --ask --depclean


depclean cleaned all those blockers which allowed me to do a clean upgrade to ruby23

Code:
 * GNU info directory index is up-to-date.
Dwarf ~ # emerge --newuse --update --ask @changed-deps

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-eselect/eselect-ruby-20170723
[ebuild  N     ] dev-util/ragel-6.10  USE="-vim-syntax"
[ebuild  N     ] dev-lang/ruby-2.3.7  USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -jemalloc -libressl -rubytests -socks5 -tk -xemacs"
[ebuild  N     ] dev-ruby/rubygems-2.7.6  USE="-server {-test}" RUBY_TARGETS="ruby23 (-ruby24) (-ruby25)"
[ebuild   R    ] virtual/rubygems-11  RUBY_TARGETS="ruby23* (-ruby22%*)"
[ebuild  N     ] dev-ruby/did_you_mean-1.0.2  USE="{-test}" RUBY_TARGETS="ruby23"
[ebuild  N     ] dev-ruby/minitest-5.9.1  USE="-doc {-test}" RUBY_TARGETS="ruby23"
[ebuild  N     ] dev-ruby/rake-10.5.0  USE="-doc {-test}" RUBY_TARGETS="ruby23"
[ebuild  N     ] dev-ruby/net-telnet-0.1.1-r1  USE="-doc {-test}" RUBY_TARGETS="ruby23 (-ruby24) (-ruby25)"
[ebuild  N     ] dev-ruby/json-1.8.6-r1  USE="-doc {-test}" RUBY_TARGETS="ruby23 (-ruby24)"
[ebuild  N     ] dev-ruby/power_assert-0.3.1  USE="-doc {-test}" RUBY_TARGETS="ruby23"
[ebuild  N     ] dev-ruby/test-unit-3.1.9  USE="-doc {-test}" RUBY_TARGETS="ruby23"
[ebuild  N     ] dev-ruby/racc-1.4.14  USE="-doc {-test}" RUBY_TARGETS="ruby23 (-ruby24) (-ruby25)"
[ebuild  N     ] dev-ruby/rdoc-4.3.0  USE="-doc {-test}" RUBY_TARGETS="ruby23"


And all is back to normal :)

Thank you !

Myu
_________________
Gentoo stable (with bits of ~amd64) / Games ! (Linux & vfio-pci ) // Xfce

Feel free to PM me if you would like a simple ebuild and I'll see what I can do :]
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1312
Location: KUUSANKOSKI, Finland

PostPosted: Sun Apr 29, 2018 8:45 pm    Post subject: Reply with quote

Myu wrote:
but I followed your idea and removed ruby22
Normally it's not wise to do --unmerge. But in this case since ruby-2.2 is masked, I would have suggested it next.

There were still some packages that were depending on ruby-2.2. Check if those need rebuilding (although Portage should atomatically rebuild them).
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum