Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[python] dependance de meson (resolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
mcsky2
Guru
Guru


Joined: 25 Aug 2005
Posts: 307

PostPosted: Wed Apr 04, 2018 12:47 pm    Post subject: [python] dependance de meson (resolu) Reply with quote

Bonjour,
Je tourne en rond dans les dépendances python d'une mise à jour du programme meson. Je modifie package.use pour activer ou desactiver la version de python pour tel ou tel programme mais je passe de la version 3.6 à 3.5 en boucle. Dans mon make.conf, j'étais passé à la version 3.6 sans succès.
Je pense que je dois remettre un peu d'ordre la dedans mais je ne sais pas par ou commencer.
Merci pour votre aide.

Code:

eselect python list
 [1]   python3.6
 [2]   python2.7
 [3]   python3.4


Code:

SYNC="rsync://gentoo.modulix.net/gentoo-portage"
LINGUAS="fr fr_FR"
#ACCEPT_LICENSE="-* @FREE"
USE="gcrypt raw sslv2 icu printsupport pcre16 qt5 client weather networkmanager gnome-keyring python_targets_python3_5 ffmpeg -libav tracker gles2 egl opengl firefox-bookmarks introspection gusb scanner resolvconf pulseaudio vala autoipd systemd barcode -python_targets_python2_7 threads session minizip gtk gtk3 ntfsprogs openssl nss python cdda snmp static-ppds fax pop gconf dri pidgin -bluetooth hpijs weather-metar weather-xoap vim-syntax audacious \
     samba applet smbclient nsplugin sqlite kpathsea v4l dvi mdnsresponder-compat \
     imagemagick sse sse2 mmx mp4 aac apm alsa bash-completion \
     fat ntfs acpi cairo css evo exif ppds pdf lame lm_sensors jpeg jpeg2k \
     bzip2 wavpack hal ogg encode mad sdl scanner \
     spell mp3 vorbis xml gstreamer gimp gif v4l2 a52 acl \
     avahi caps usb mpeg flac hddtemp matroska \
     musepack theora win32codecs xosd xvid linguas_fr png consolekit X gnome \
     cups cdr dvdr nls truetype userlocales unicode type1 cleartype \
     corefonts"
EMERGE_DEFAULT_OPTS="--alphabetical"
VIDEO_CARDS="nouveau"
PORTAGE_ELOG_CLASSES="warn info error log"
PORTAGE_ELOG_SYSTEM="save"
PORT_LOGDIR="/var/log/portage"
ALSA_CARDS="intel8x0"
PORTAGE_TMPDIR="/data2/portage"
EMERGE_DEFAULT_OPTS="--autounmask=n"
SANE_BACKENDS="hp hp3500 hp3900 hp4200 hp5400 hp5590 hpljm1005 hpsj5s"
PYTHON_TARGETS="python2_7 python3_5 pypy1_9 jython2_5"
PYTHON_SINGLE_TARGET="python3_5"
USE_PYTHON="2.7 3.5"

# Set PORTDIR for backward compatibility with various tools:
#   gentoo-bashcomp - bug #478444
#   euse - bug #474574
#   euses and ufed - bug #478318
PORTDIR="/usr/portage"
CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
GRUB_PLATFORMS="emu efi-32 pc"
source /var/lib/layman/make.conf
L10N="fr"


Code:

app-text/asciidoc python_single_target_python2_7
sys-fs/cryptsetup python_targets_python3_4 gcrypt -kernel -nettle -openssl
net-misc/iputils -openssl
app-portage/elogviewer python_targets_python3_5
dev-python/pyparsing python_single_target_python3_6
dev-python/packaging -python_single_target_python3_4 -python_targets_python3_5 -python_targets_python3_6
sys-devel/gdb python_single_target_python2_7
gnome-extra/chrome-gnome-shell  python_single_target_python2_7
dev-python/certifi -python_targets_python3_5 python_targets_python3_6
dev-python/setuptools -python_targets_python3_5 python_targets_python3_6
dev-python/appdirs python_targets_python3_6
dev-util/meson -python_targets_python3_6 python_targets_python3_5 python3_4 -python3_5 -python3_6
dev-python/six -python_targets_python3_5 python_targets_python3_6


Last edited by mcsky2 on Wed May 16, 2018 7:12 am; edited 1 time in total
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 721
Location: S.O. France

PostPosted: Wed Apr 04, 2018 4:10 pm    Post subject: Reply with quote

Salut,

Tu peux poster le detail de la maj qu'on se fasse une idée?

Sinon c'est indispensable de definir python dans ton make.conf?
Back to top
View user's profile Send private message
mcsky2
Guru
Guru


Joined: 25 Aug 2005
Posts: 307

PostPosted: Thu Apr 05, 2018 6:18 am    Post subject: Reply with quote

Voila

Code:
emerge -uDaN world

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "dev-python/setuptools[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python3_5(-),-python_single_target_python3_6(-)]".
!!! One of the following packages is required to complete your request:
- dev-python/setuptools-34.0.2-r1::gentoo (Change USE: +python_targets_python3_5)
- dev-util/meson-0.45.1::gentoo (Change USE: -python_targets_python3_5, this change violates use flag constraints defined by dev-util/meson-0.45.1: 'any-of ( python_targets_python3_5 python_targets_python3_6 )')
(dependency required by "dev-util/meson-0.45.1::gentoo" [ebuild])
(dependency required by "x11-base/xorg-proto-2018.4::gentoo" [installed])
(dependency required by "x11-proto/xproto-7.0.31-r1::gentoo" [installed])
(dependency required by "x11-libs/gtk+-2.24.31-r1::gentoo" [installed])
(dependency required by "sys-devel/distcc-3.2_rc1-r4::gentoo[gtk,gnome]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 721
Location: S.O. France

PostPosted: Thu Apr 05, 2018 7:28 pm    Post subject: Reply with quote

Cest une voulu de définir python dans ton maké.conf et dans ton package.use?

Cest toi qui veux telle version de python pour tel programme ou c'est pour résoudre des blocages?
Tu force python 3.5 alors que tu ne l'a pas sur ton système. Normalement portage est capable de se débrouiller.
Tu as fait un joli mix.

Ça donne quoi si tu # les entrées dans make.conf et package.use et que tu lance un emerge -uDNvp @world?
Back to top
View user's profile Send private message
mcsky2
Guru
Guru


Joined: 25 Aug 2005
Posts: 307

PostPosted: Fri Apr 06, 2018 1:00 pm    Post subject: Reply with quote

Bonjour,
J'ai commenté ceci
Code:

#PYTHON_TARGETS="python2_7 python3_5 pypy1_9 jython2_5"
#PYTHON_SINGLE_TARGET="python3_5"
#USE_PYTHON="2.7 3.5"

et enlevé python_targets_python3_5 et python_targets_python2_7
dans le use sauf python

Dans le package.use, j'ai commenté tout ce qui concerne python sauf
sys-fs/cryptsetup python_targets_python3_4 gcrypt -kernel -nettle -openssl

Code:

emerge -uDNvp @world

These are the packages that would be merged, in order:

Calculating dependencies... done!


[nomerge       ] gnome-base/gnome-vfs-2.24.4-r5:2::gentoo  USE="acl ipv6 samba ssl -gnutls -kerberos -libressl {-test} -zeroconf"
[nomerge       ]  net-fs/samba-4.5.16::gentoo  USE="acl client cups fam ldap pam system-mitkrb5 systemd -addc -addns -ads -cluster (-dmapi) -gnutls -gpg -iprint -quota (-selinux) -syslog (-system-heimdal) {-test} -winbind -zeroconf" PYTHON_TARGETS="python2_7"
[nomerge       ]   dev-python/subunit-1.2.0-r1::gentoo  USE="-static-libs {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6"
[nomerge       ]    dev-python/testtools-2.3.0::gentoo [1.8.0::gentoo] USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6"
[ebuild  N     ]     dev-python/fixtures-3.0.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6" 56 KiB
[ebuild   R    ]   dev-python/subunit-1.2.0-r1::gentoo  USE="-static-libs {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 450 KiB
[ebuild     U  ]    dev-python/testtools-2.3.0::gentoo [1.8.0::gentoo] USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 227 KiB
[nomerge       ] media-gfx/mypaint-1.1.0-r2::gentoo  PYTHON_TARGETS="python2_7"
[ebuild   R    ]  dev-python/protobuf-python-3.5.1.1:0/15::gentoo  PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6" 0 KiB
[nomerge       ] media-gfx/inkscape-0.92.2::gentoo  USE="cdr dbus exif gnome imagemagick jpeg lcms nls openmp spell -dia -inkjar -latex -postscript -static-libs -visio -wpg" PYTHON_TARGETS="python2_7"
[ebuild   R    ]  media-gfx/scour-0.36::gentoo  PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6" 90 KiB
[nomerge       ] gnome-base/gnome-3.24.2:2.0::gentoo  USE="cdr classic cups extras -accessibility -bluetooth"
[nomerge       ]  gnome-base/gnome-extra-apps-3.24.2:3.0::gentoo  USE="games share shotwell tracker"
[ebuild   R    ]   media-sound/gnome-music-3.24.2::gentoo  PYTHON_SINGLE_TARGET="python3_5* -python3_4*" PYTHON_TARGETS="python3_5* -python3_4*" 1 522 KiB
[nomerge       ] x11-terms/terminator-1.91::gentoo  USE="dbus libnotify -debug {-test}" PYTHON_TARGETS="python2_7"
[ebuild     U  ]  dev-python/psutil-5.4.3::gentoo [5.4.1::gentoo] USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 403 KiB
[ebuild   R    ] dev-python/ipython-3.2.1-r1::gentoo  USE="smp wxwidgets -doc -examples -matplotlib -mongodb -nbconvert -notebook -octave -qt4 {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6" 10 630 KiB
[ebuild   R   ~] net-print/hplip-3.17.10-r1::gentoo  USE="X fax hpcups hpijs policykit qt5 scanner snmp static-ppds -doc -kde -libressl -libusb0 -minimal -parport" PYTHON_SINGLE_TARGET="python3_5* -python2_7 -python3_4* -python3_6" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6" 23 327 KiB
[ebuild   R    ] app-portage/layman-2.4.2-r1::gentoo  USE="git sqlite -bazaar -cvs -darcs (-g-sorcery) -gpg -mercurial -squashfs -subversion -sync-plugin-portage {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6" 0 KiB
[ebuild   R    ] app-portage/elogviewer-2.7-r1::gentoo  PYTHON_SINGLE_TARGET="python3_5* -python2_7 -python3_4*" PYTHON_TARGETS="python2_7 python3_5* -python3_4*" 0 KiB
[nomerge       ] app-portage/layman-2.4.2-r1::gentoo  USE="git sqlite -bazaar -cvs -darcs (-g-sorcery) -gpg -mercurial -squashfs -subversion -sync-plugin-portage {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6"
[nomerge       ]  dev-python/ssl-fetch-0.4::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6"
[nomerge       ]   dev-python/pyopenssl-17.5.0::gentoo [17.2.0::gentoo] USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6"
[nomerge       ]    dev-python/cryptography-2.1.4::gentoo [2.0.2-r1::gentoo] USE="-libressl {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6"
[nomerge       ]     virtual/python-ipaddress-1.0-r1::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6"
[ebuild     U  ]      dev-python/ipaddress-1.0.19::gentoo [1.0.18::gentoo] PYTHON_TARGETS="python2_7 (-pypy)" 33 KiB
[nomerge       ] dev-python/ipython-3.2.1-r1::gentoo  USE="smp wxwidgets -doc -examples -matplotlib -mongodb -nbconvert -notebook -octave -qt4 {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6"
[ebuild   R    ]  dev-python/pyzmq-16.0.2::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6" 1 003 KiB
[ebuild   R    ]   dev-python/gevent-1.2.1::gentoo  USE="-doc -examples" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6" 2 743 KiB
[ebuild   R    ]    virtual/python-greenlet-1.0::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 0 KiB
[nomerge       ] dev-python/protobuf-python-3.5.1.1:0/15::gentoo  PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6"
[ebuild   R    ]  dev-python/namespace-google-1::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6" 0 KiB
[nomerge       ] sys-fs/udisks-2.7.4-r1:2::gentoo  USE="acl gptfdisk introspection nls systemd -cryptsetup -debug -elogind -lvm (-selinux)"
[nomerge       ]  sys-apps/systemd-236-r5:0/2::gentoo  USE="acl gcrypt kmod lz4 pam policykit seccomp ssl sysv-utils (-apparmor) -audit -build -cryptsetup -curl -elfutils -gnuefi -http -idn -importd -libidn2 -lzma -nat -qrcode (-selinux) {-test} -usrmerge -vanilla -xkb"
[ebuild     U  ]   dev-python/lxml-4.1.1::gentoo [3.8.0::gentoo] USE="threads -doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6" 2 326 KiB
[nomerge       ] app-editors/vim-8.0.1298::gentoo  USE="X acl gpm nls python -cscope -debug -lua -luajit -minimal -perl -racket -ruby (-selinux) -tcl -terminal -vim-pager" PYTHON_SINGLE_TARGET="python3_5* -python2_7 -python3_4* -python3_6" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6"
[nomerge       ]  dev-util/ctags-20161028::gentoo  USE="xml -json -yaml"
[ebuild   R    ]   dev-python/docutils-0.13.1::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 1 695 KiB
[ebuild   R    ]    dev-python/pygments-2.2.0::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 2 065 KiB
[ebuild   R    ] dev-python/ssl-fetch-0.4::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6" 12 KiB
[ebuild   R    ]  dev-python/pyasn1-0.2.3::gentoo  USE="-doc" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 98 KiB
[ebuild   R    ]  dev-python/ndg-httpsclient-0.4.0::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 24 KiB
[nomerge       ] dev-python/ipython-3.2.1-r1::gentoo  USE="smp wxwidgets -doc -examples -matplotlib -mongodb -nbconvert -notebook -octave -qt4 {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6"
[nomerge       ]  dev-python/wxpython-3.0.2.0:3.0::gentoo  USE="cairo libnotify opengl -examples" PYTHON_TARGETS="python2_7"
[ebuild   R    ]   dev-python/pyopengl-3.1.0::gentoo  USE="-tk" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6" 1 146 KiB
[nomerge       ] dev-python/pyzmq-16.0.2::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6"
[ebuild   R    ]  dev-python/py-1.4.30::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 188 KiB
[nomerge       ] dev-python/ipython-3.2.1-r1::gentoo  USE="smp wxwidgets -doc -examples -matplotlib -mongodb -nbconvert -notebook -octave -qt4 {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6"
[ebuild     U  ]  dev-python/decorator-4.2.1::gentoo [4.1.2::gentoo] USE="-doc" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 33 KiB
[ebuild   R    ]  dev-python/simplegeneric-0.8.1-r1::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6" 13 KiB
[nomerge       ] gnome-base/gnome-3.24.2:2.0::gentoo  USE="cdr classic cups extras -accessibility -bluetooth"
[nomerge       ]  gnome-extra/gnome-shell-extensions-3.24.3::gentoo  USE="-examples"
[nomerge       ]   app-eselect/eselect-gnome-shell-extensions-20180306::gentoo
[nomerge       ]    gnome-base/gnome-shell-3.24.3::gentoo  USE="browser-extension ibus networkmanager nsplugin -bluetooth (-openrc-force)" PYTHON_TARGETS="python3_5* -python3_4* -python3_6%"
[ebuild   R    ]     gnome-extra/chrome-gnome-shell-8-r1::gentoo  PYTHON_SINGLE_TARGET="python3_5* -python2_7 -python3_4*" PYTHON_TARGETS="python2_7 python3_5* -python3_4*" 140 KiB
[ebuild     U  ]      dev-python/requests-2.18.4::gentoo [2.18.2-r1::gentoo] USE="ssl -socks5 (-test%)" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 124 KiB
[ebuild   R    ]       dev-python/urllib3-1.22::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 221 KiB
[ebuild     U  ]        dev-python/pyopenssl-17.5.0::gentoo [17.2.0::gentoo] USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 167 KiB
[ebuild     U  ]         dev-python/cryptography-2.1.4::gentoo [2.0.2-r1::gentoo] USE="-libressl {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 432 KiB
[ebuild     U  ]          dev-python/cffi-1.11.4:0/1.11.4::gentoo [1.9.1:0/1.9.1::gentoo] USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6" 427 KiB
[ebuild   R    ]           dev-python/pycparser-2.14::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 219 KiB
[ebuild   R    ]            dev-python/ply-3.9:0/3.9::gentoo  USE="-examples" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 148 KiB
[ebuild   R    ]          dev-python/asn1crypto-0.22.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 83 KiB
[ebuild   R    ]        dev-python/PySocks-1.6.7::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 277 KiB
[ebuild   R    ]       dev-python/chardet-3.0.4::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 1 829 KiB
[nomerge       ] x11-terms/guake-0.8.8::gentoo  PYTHON_TARGETS="python2_7"
[nomerge       ]  dev-python/gconf-python-2.28.1-r1:2::gentoo  USE="-examples" PYTHON_TARGETS="python2_7"
[nomerge       ]   dev-python/gnome-python-base-2.28.1-r1:2::gentoo
[nomerge       ]    dev-python/pygtk-2.24.0-r4:2::gentoo  USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7"
[ebuild   R    ]     dev-python/numpy-1.10.4::gentoo  USE="-doc -lapack {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6" 3 975 KiB
[nomerge       ] dev-python/fixtures-3.0.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[nomerge       ]  dev-python/testtools-2.3.0::gentoo [1.8.0::gentoo] USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6"
[ebuild  N     ]   dev-python/pyrsistent-0.13.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6" 95 KiB
[ebuild   R    ]   dev-python/mimeparse-1.6.0::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 7 KiB
[ebuild   R    ]   dev-python/unittest2-1.1.0::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 80 KiB
[ebuild   R    ] dev-python/reportlab-3.3.0-r2::gentoo  USE="-doc -examples" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6" 2 575 KiB
[nomerge       ] dev-python/gevent-1.2.1::gentoo  USE="-doc -examples" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6"
[ebuild   R    ]  dev-python/greenlet-0.4.12::gentoo  USE="-doc" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6" 56 KiB
[nomerge       ] dev-python/testtools-2.3.0::gentoo [1.8.0::gentoo] USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6"
[ebuild   R    ]  dev-python/traceback2-1.4.0::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 16 KiB
[ebuild   R    ]   dev-python/linecache2-1.0.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 11 KiB
[ebuild     U  ]  dev-python/extras-1.0.0::gentoo [0.0.3::gentoo] USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 7 KiB
[ebuild   R    ] dev-python/pillow-3.4.2-r1::gentoo  USE="jpeg jpeg2k lcms tiff truetype zlib -doc -examples {-test} -tk -webp" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6" 10 784 KiB
[nomerge       ] dev-python/ssl-fetch-0.4::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6"
[nomerge       ]  dev-python/requests-2.18.4::gentoo [2.18.2-r1::gentoo] USE="ssl -socks5 (-test%)" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6"
[nomerge       ]   dev-python/cryptography-2.1.4::gentoo [2.0.2-r1::gentoo] USE="-libressl {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6"
[ebuild   R    ]    dev-python/idna-2.5::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 128 KiB
[nomerge       ] gnome-base/gnome-3.24.2:2.0::gentoo  USE="cdr classic cups extras -accessibility -bluetooth"
[nomerge       ]  gnome-base/gnome-core-apps-3.24.2:3.0::gentoo  USE="cdr cups -bluetooth"
[nomerge       ]   gnome-base/gnome-settings-daemon-3.24.3::gentoo  USE="colord cups networkmanager policykit udev -debug (-openrc-force) -smartcard {-test} -wayland" INPUT_DEVICES="-wacom"
[nomerge       ]    sys-apps/systemd-236-r5:0/2::gentoo  USE="acl gcrypt kmod lz4 pam policykit seccomp ssl sysv-utils (-apparmor) -audit -build -cryptsetup -curl -elfutils -gnuefi -http -idn -importd -libidn2 -lzma -nat -qrcode (-selinux) {-test} -usrmerge -vanilla -xkb"
[ebuild   R    ]     sys-apps/kmod-24::gentoo  USE="python tools zlib -debug -doc -lzma -static-libs" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6" 525 KiB
[ebuild   R    ]      dev-python/cython-0.25.2::gentoo  USE="-doc -emacs {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6" 1 664 KiB
[ebuild     U  ]     dev-util/meson-0.45.1::gentoo [0.44.1::gentoo] PYTHON_TARGETS="python3_5* -python3_6 (-python3_4%*)" 1 137 KiB
[nomerge       ] dev-python/testtools-2.3.0::gentoo [1.8.0::gentoo] USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6"
[ebuild   R    ]  dev-python/pbr-3.1.1::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 101 KiB
[nomerge       ] sys-apps/portage-2.3.24-r1::gentoo  USE="(ipc) native-extensions xattr -build -doc -epydoc -gentoo-dev (-rsync-verify) (-selinux)" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6"
[ebuild   R    ]  dev-python/pyxattr-0.5.5::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4*" 27 KiB
[nomerge       ] media-gfx/inkscape-0.92.2::gentoo  USE="cdr dbus exif gnome imagemagick jpeg lcms nls openmp spell -dia -inkjar -latex -postscript -static-libs -visio -wpg" PYTHON_TARGETS="python2_7"
[nomerge       ]  dev-python/lxml-4.1.1::gentoo [3.8.0::gentoo] USE="threads -doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6"
[nomerge       ]   dev-python/setuptools-34.0.2-r1::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6"
[ebuild   R    ]    dev-python/packaging-16.8::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 44 KiB
[ebuild   R    ] sys-apps/file-5.32::gentoo  USE="python zlib -static-libs" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4* -python3_6" 779 KiB
[nomerge       ] sys-apps/shadow-4.5::gentoo  USE="acl cracklib nls pam xattr -audit (-selinux) -skey"
[ebuild   R    ]  sys-libs/cracklib-2.9.6-r1::gentoo  USE="nls python zlib -static-libs" PYTHON_TARGETS="python2_7 python3_5* -python3_4* -python3_6" 628 KiB
[nomerge       ] media-sound/gnome-music-3.24.2::gentoo  PYTHON_SINGLE_TARGET="python3_5* -python3_4*" PYTHON_TARGETS="python3_5* -python3_4*"
[nomerge       ]  dev-python/requests-2.18.4::gentoo [2.18.2-r1::gentoo] USE="ssl -socks5 (-test%)" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6"
[ebuild   R    ]   dev-python/certifi-2017.4.17::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 365 KiB
[nomerge       ] dev-python/pyrsistent-0.13.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild     U  ]  dev-python/six-1.11.0::gentoo [1.10.0::gentoo] USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 30 KiB
[ebuild   R    ]   dev-python/setuptools-34.0.2-r1::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4* -python3_6" 604 KiB

Total: 59 packages (12 upgrades, 2 new, 45 reinstalls), Size of downloads: 75 759 KiB

 * Error: circular dependencies:

(dev-python/six-1.11.0:0/0::gentoo, ebuild scheduled for merge) depends on
 (dev-python/setuptools-34.0.2-r1:0/0::gentoo, ebuild scheduled for merge) (buildtime)
  (dev-python/six-1.11.0:0/0::gentoo, ebuild scheduled for merge) (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.

!!! The following installed packages are masked:
- media-video/camorama-0.19-r2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (18 Mar 2018)
# Dead since 2011, relies on dead libraries (#644322, #644326, #644330, #644332
# #644340, #647600, #647608, #647698, #647700, #648998). Removal in a month.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 721
Location: S.O. France

PostPosted: Fri Apr 06, 2018 4:18 pm    Post subject: Reply with quote

Pourquoi vouloir définir une version de python, que ce soit dans ton make.conf ou dans ton package.use (3ème demande)?
Non pas que tu n'as pas le droit, mais je cherche à comprendre pourquoi ta sortie ne donne pas les mêmes infos que ta version de python installé..
Tu as besoin d'avoir python 3.4, 3.5 et 3.6 sur ton systeme?

C'est toi qui a forcé l'installation de python 3.6? Sur mon système stable il n'est pas installé.

Ca donne quoi ?
Code:
eix dev-lang/python


Essaye de lancer
Code:
emerge -1 --nodeps dev-python/six
avant de lancer la maj.
Back to top
View user's profile Send private message
mcsky2
Guru
Guru


Joined: 25 Aug 2005
Posts: 307

PostPosted: Mon Apr 09, 2018 7:39 am    Post subject: Reply with quote

Bonjour,
Code:

[I] dev-lang/python
     Available versions: 
     (2.7)  2.7.14-r1
     (3.4)  3.4.5-r1(3.4/3.4m)^t ~3.4.6-r1(3.4/3.4m) ~3.4.8(3.4/3.4m)
     (3.5)  3.5.4-r1(3.5/3.5m)^t ~3.5.5(3.5/3.5m)^t
     (3.6)  3.6.3-r1(3.6/3.6m)^t ~3.6.4(3.6/3.6m)^t ~3.6.5(3.6/3.6m)^t
       {-berkdb build doc examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test +threads tk +wide-unicode wininst +xml ELIBC="uclibc"}
     Installed versions:  2.7.14-r1(2.7)(16:53:35 10/01/2018)(gdbm ipv6 ncurses readline sqlite ssl threads wide-unicode xml -berkdb -build -doc -examples -hardened -libressl -tk -wininst ELIBC="-uclibc") 3.4.5-r1(3.4)^t(16:58:56 10/01/2018)(gdbm ipv6 ncurses readline sqlite ssl threads xml -build -examples -hardened -libressl -test -tk -wininst ELIBC="-uclibc") 3.6.3-r1(3.6)^t(17:12:51 10/01/2018)(gdbm ipv6 ncurses readline sqlite ssl threads xml -build -examples -hardened -libressl -test -tk -wininst)
     Homepage:            https://www.python.org/
     Description:         An interpreted, interactive, object-oriented programming language


Code:

emerge -1 --nodeps dev-python/six

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-python/six-1.11.0::gentoo
>>> Downloading 'http://distfiles.gentoo.org/distfiles/six-1.11.0.tar.gz'
--2018-04-09 09:40:21--  http://distfiles.gentoo.org/distfiles/six-1.11.0.tar.gz
Resolving distfiles.gentoo.org... 140.211.166.134, 64.50.233.100, 216.165.129.135, ...
Connecting to distfiles.gentoo.org|140.211.166.134|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 29860 (29K) [application/x-gzip]
Saving to: ‘/usr/portage/distfiles/six-1.11.0.tar.gz’

/usr/portage/distfi 100%[===================>]  29,16K   184KB/s    in 0,2s   

2018-04-09 09:40:21 (184 KB/s) - ‘/usr/portage/distfiles/six-1.11.0.tar.gz’ saved [29860/29860]

 * six-1.11.0.tar.gz BLAKE2B SHA512 size ;-) ...                         [ ok ]
>>> Unpacking source...
>>> Unpacking six-1.11.0.tar.gz to /data2/portage/portage/dev-python/six-1.11.0/work
>>> Source unpacked in /data2/portage/portage/dev-python/six-1.11.0/work
>>> Preparing source in /data2/portage/portage/dev-python/six-1.11.0/work/six-1.11.0 ...
 * Applying 1.9.0-mapping.patch ...                                      [ ok ]
>>> Source prepared.
>>> Configuring source in /data2/portage/portage/dev-python/six-1.11.0/work/six-1.11.0 ...
>>> Source configured.
>>> Compiling source in /data2/portage/portage/dev-python/six-1.11.0/work/six-1.11.0 ...
 * python2_7: running distutils-r1_run_phase distutils-r1_python_compile
/usr/bin/python2.7 setup.py build
running build
running build_py
copying six.py -> /data2/portage/portage/dev-python/six-1.11.0/work/six-1.11.0-python2_7/lib
warning: build_py: byte-compiling is disabled, skipping.

 * python3_5: running distutils-r1_run_phase distutils-r1_python_compile
/usr/bin/python3.5 setup.py build
/data2/portage/portage/dev-python/six-1.11.0/temp/environment: line 1019: /usr/bin/python3.5: No such file or directory
 * ERROR: dev-python/six-1.11.0::gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  124:  Called src_compile
 *   environment, line 2546:  Called distutils-r1_src_compile
 *   environment, line  760:  Called _distutils-r1_run_foreach_impl 'distutils-r1_python_compile'
 *   environment, line  279:  Called python_foreach_impl 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 2103:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 1474:  Called _multibuild_run '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 1472:  Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line  494:  Called distutils-r1_run_phase 'distutils-r1_python_compile'
 *   environment, line  751:  Called distutils-r1_python_compile
 *   environment, line  626:  Called esetup.py 'build'
 *   environment, line 1019:  Called die
 * The specific snippet of code:
 *       "${@}" || die "${die_args[@]}";
 *
 * If you need support, post the output of `emerge --info '=dev-python/six-1.11.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/six-1.11.0::gentoo'`.
 * The complete build log is located at '/var/log/portage/dev-python:six-1.11.0:20180409-074020.log'.
 * For convenience, a symlink to the build log is located at '/data2/portage/portage/dev-python/six-1.11.0/temp/build.log'.
 * The ebuild environment file is located at '/data2/portage/portage/dev-python/six-1.11.0/temp/environment'.
 * Working directory: '/data2/portage/portage/dev-python/six-1.11.0/work/six-1.11.0'
 * S: '/data2/portage/portage/dev-python/six-1.11.0/work/six-1.11.0'

>>> Failed to emerge dev-python/six-1.11.0, Log file:

Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 721
Location: S.O. France

PostPosted: Tue Apr 10, 2018 4:57 pm    Post subject: Reply with quote

A défaut de réponses on va la jouer au filing.

Quote:
/data2/portage/portage/dev-python/six-1.11.0/temp/environment: line 1019: /usr/bin/python3.5: No such file or directory

Tu as un 1er élément de réponse ici.

Poste ton package.keywords, ton fichier world, emerge --depclean -p et revdep-rebuild -p.
Back to top
View user's profile Send private message
mcsky2
Guru
Guru


Joined: 25 Aug 2005
Posts: 307

PostPosted: Mon Apr 23, 2018 3:31 pm    Post subject: Reply with quote

Bonjour,
J'ai forcé l'installation de python 3.5 et il est en train de recompiler 211 paquets.
A suivre
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum