Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201804-20 ] unADF
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2095

PostPosted: Mon Apr 23, 2018 3:26 am    Post subject: [ GLSA 201804-20 ] unADF Reply with quote

Gentoo Linux Security Advisory

Title: unADF: Remote code execution (GLSA 201804-20)
Severity: normal
Exploitable: remote
Date: 2018-04-22
Bug(s): #636388
ID: 201804-20

Synopsis

Multiple vulnerabilities have been found in unADF that may allow a
remote attacker to execute arbitrary code.


Background

An unzip like for .ADF files.

Affected Packages

Package: app-arch/unadf
Vulnerable: < 0.7.12-r1
Unaffected: >= 0.7.12-r1
Architectures: All supported architectures


Description

Multiple vulnerabilities were discovered in unADF that can lead to
remote code execution. Please review the CVE identifiers referenced below
for details.


Impact

A remote attacker, by enticing a user to process a specially crafted
file, could execute arbitrary code.


Workaround

There is no known workaround at this time.

Resolution

All unADF users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-arch/unadf-0.7.12-r1"
   


References

CVE-2016-1243
CVE-2016-1244
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum