Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xmodmap can't do anything
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message

Joined: 24 Jan 2018
Posts: 5

PostPosted: Wed Apr 18, 2018 9:02 am    Post subject: xmodmap can't do anything Reply with quote

I'm using the NEOv2 keyboard layout. In order to improve ergonomics, I want to use a different key as Control key. For that I thought of the space, since it can be pressed with thumbs. In order to do that I run the following script on X's startup: (using .xinit)


setxkbmap de neo

xmodmap -e "keycode 65 = $spare_modifier"
xmodmap -e "remove mod4 = $spare_modifier" # hyper_l is mod4 by default
xmodmap -e "add Control = $spare_modifier"

xmodmap -e "keycode any = space"

xcape -t 250 -e "$spare_modifier=space"

Running this manually, we get nice error messages. I think it's because Hyper_L is unused in this keyboard layout. Trying to add it doesn't yield to success.
λ ~/ xmodmap -e "add Mod4=Hyper_L"                         
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  118 (X_SetModifierMapping)
  Value in failed request:  0x17
  Serial number of failed request:  8
  Current serial number in output stream:  8

Now I thought "Ok, clear it first", but this works neither, same error message.
Any suggestions on how to add it or anything?

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum