Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problema con locale
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
Guru
Guru


Joined: 28 Jan 2016
Posts: 439

PostPosted: Fri Apr 13, 2018 1:50 pm    Post subject: problema con locale Reply with quote

Scusate ma ques't ultimo upgrade mi sta dando una marea di problemi ..
se provo ad aprire una qualsiasi finestra X (io utilizzo i3WM) ottengo (ad esempio per gparted) questo messaggio :
x
Code:

 sudo gparted

(process:1775): Gtk-WARNING **: 15:49:52.397: Locale not supported by C library.
   Using the fallback 'C' locale.
======================
libparted : 3.2
======================
terminate called after throwing an instance of 'Glib::ConvertError'
/usr/sbin/gparted: riga 193:  1775 Annullato               $BASE_CMD



questo succede con zsh (la shell che vorrei usare) ma non con bash
help :oops:
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Fri Apr 13, 2018 3:33 pm    Post subject: Reply with quote

Cosa ritorna il comando
Code:
$ locale

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
Guru
Guru


Joined: 28 Jan 2016
Posts: 439

PostPosted: Fri Apr 13, 2018 3:40 pm    Post subject: Reply with quote

Code:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Impossibile impostare LC_ALL alla localizzazione predefinita: File o directory non esistente
LANG=it_IT.UTF-8
LC_CTYPE=en_GB.UTF-8
LC_NUMERIC="it_IT.UTF-8"
LC_TIME="it_IT.UTF-8"
LC_COLLATE=C
LC_MONETARY="it_IT.UTF-8"
LC_MESSAGES="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_ALL=


ancora grazie per gli aiuti :)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Fri Apr 13, 2018 4:27 pm    Post subject: Reply with quote

Puoi postare anche locale -a
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
Guru
Guru


Joined: 28 Jan 2016
Posts: 439

PostPosted: Fri Apr 13, 2018 9:34 pm    Post subject: Reply with quote

Code:

 locale -a
locale: Cannot set LC_CTYPE to default locale: No such file or directory
C
POSIX
en_US.utf8
it_IT
it_IT.iso88591
it_IT.utf8
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Sat Apr 14, 2018 10:46 am    Post subject: Reply with quote

Il problema e' LC_CTYPE=en_GB.UTF-8 che come vedi dall'ultimo comando non ce l'hai installato.
Hai per caso settato questa variabile in qualche file?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
Guru
Guru


Joined: 28 Jan 2016
Posts: 439

PostPosted: Sun Apr 15, 2018 10:23 am    Post subject: Reply with quote

no non lo ho settato in nessun altro file ! solo in locale-gen ! come lo installo ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Sun Apr 15, 2018 1:52 pm    Post subject: Reply with quote

drudox wrote:
no non lo ho settato in nessun altro file ! solo in locale-gen ! come lo installo ?

Non e' difficile da installarlo basta seguire la guida.
Comunque il problema e' che non dovrebbe essere settato su en_GB.UTF-8.
Puoi postare il contenuto dei file /etc/env.d/02locale e del tuo .bashrc
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
Guru
Guru


Joined: 28 Jan 2016
Posts: 439

PostPosted: Mon Apr 16, 2018 11:01 am    Post subject: Reply with quote

certo

02locale :

Code:
# Configuration file for eselect
# This file has been automatically generated.
LANG="it_IT.utf8"
LC_COLLATE="C"


.bashrc
https://paste.pound-python.org/show/8viUBqVowltD6IfxcW3F/
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Mon Apr 16, 2018 11:22 am    Post subject: Reply with quote

Solo per prova prova a salvare il tuo .bashrc da qualche parte e poi sostituiscilo con uno vuoto.
Poi rilancia il terminale e controlla con il comando locale se il valore LC_CTYPE cambia. Questo solo per vedere se in tutto quel marasma di comandi che hai nel .bashrc non vada a cambiare quella variabile poi puoi tornare al tuo .bashrc
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
Guru
Guru


Joined: 28 Jan 2016
Posts: 439

PostPosted: Mon Apr 16, 2018 3:04 pm    Post subject: Reply with quote

si se uso quello di default (/etc/bash/bashrc)

locale mi restituisce questo :

Code:
LANG=it_IT.utf8
LC_CTYPE="it_IT.utf8"
LC_NUMERIC="it_IT.utf8"
LC_TIME="it_IT.utf8"
LC_COLLATE=C
LC_MONETARY="it_IT.utf8"
LC_MESSAGES="it_IT.utf8"
LC_PAPER="it_IT.utf8"
LC_NAME="it_IT.utf8"
LC_ADDRESS="it_IT.utf8"
LC_TELEPHONE="it_IT.utf8"
LC_MEASUREMENT="it_IT.utf8"
LC_IDENTIFICATION="it_IT.utf8"
LC_ALL=


ma se poi passo a zsh (che e` dove nasce il problema) mi restituisce nuovamente questo :
Code:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Impossibile impostare LC_ALL alla localizzazione predefinita: File o directory non esistente
LANG=it_IT.utf8
LC_CTYPE=en_GB.UTF-8
LC_NUMERIC="it_IT.utf8"
LC_TIME="it_IT.utf8"
LC_COLLATE=C
LC_MONETARY="it_IT.utf8"
LC_MESSAGES="it_IT.utf8"
LC_PAPER="it_IT.utf8"
LC_NAME="it_IT.utf8"
LC_ADDRESS="it_IT.utf8"
LC_TELEPHONE="it_IT.utf8"
LC_MEASUREMENT="it_IT.utf8"
LC_IDENTIFICATION="it_IT.utf8"
LC_ALL=
Back to top
View user's profile Send private message
drudox
Guru
Guru


Joined: 28 Jan 2016
Posts: 439

PostPosted: Mon Apr 16, 2018 7:22 pm    Post subject: Reply with quote

cosa ne pensi ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Mon Apr 16, 2018 7:48 pm    Post subject: Reply with quote

Cercando in un po' sul web vedo che molti hanno questo problema e come soluzione sembra aggiungere
Code:
export LC_CTYPE=${LANG%%:*}

nel file .zshenv

https://www.wdiaz.org/solving-error-in-zsh-and-locales-valueerror-unknown-locale-utf-8/
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
Guru
Guru


Joined: 28 Jan 2016
Posts: 439

PostPosted: Tue Apr 17, 2018 1:25 am    Post subject: Reply with quote

Risolto grazie 1000
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum