Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Downgrade freetype
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Windmill
Tux's lil' helper
Tux's lil' helper


Joined: 21 Feb 2014
Posts: 105

PostPosted: Sun Apr 15, 2018 1:15 pm    Post subject: Downgrade freetype Reply with quote

Hi, I have freetype 2.9 installed on my system, howewer I had problems with wine, and I found that older wine versions don't work with newer freetype (>2.8 ). So I masked 2.9, unmerged it and installed 2.8, but when I upgrade world packages still wants to pull in 2.9 and it asks me to unmask it, how to solve?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19644
Location: here

PostPosted: Sun Apr 15, 2018 1:44 pm    Post subject: Reply with quote

Post full output of emerge world and add also -t option.
Probably you have a installed package that require freetype 2.9
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Windmill
Tux's lil' helper
Tux's lil' helper


Joined: 21 Feb 2014
Posts: 105

PostPosted: Sun Apr 15, 2018 3:16 pm    Post subject: Reply with quote

Code:
[ebuild     U #] media-libs/freetype-2.9:2::gentoo [2.8:2::gentoo] USE="X adobe-cff bzip2 cleartype_hinting png -bindist -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils" ABI_X86="32* (64) (-x32)" 0 KiB

Total: 1 package (1 upgrade), Size of downloads: 0 KiB

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by app-text/ghostscript-gpl-9.21::gentoo
# required by net-print/cups-filters-1.20.3::gentoo[postscript]
# required by net-print/cups-2.2.7::gentoo
# required by app-emulation/wine-vanilla-2.0.4::wine
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/freetype:
=media-libs/freetype-2.9

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19644
Location: here

PostPosted: Sun Apr 15, 2018 3:47 pm    Post subject: Reply with quote

Try updating with adding --autounmask n option
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Windmill
Tux's lil' helper
Tux's lil' helper


Joined: 21 Feb 2014
Posts: 105

PostPosted: Sun Apr 15, 2018 6:40 pm    Post subject: Reply with quote

I identified the packages that were causing the problem, fontconfig and pango, so I marked all stable, but the latter gives this error when emerging
Code:
linking of temporary binary failed: Command '['/bin/sh', '../libtool', '--mode=link', '--tag=CC', 'x86_64-pc-linux-gnu-gcc', '-o', '/var/tmp/portage/x11-libs/pango-1.40.14-r1/work/pango-1.40.14-abi_x86_64.amd64/pango/tmp-introspectkwt2gtwe/PangoFT2-1.0', '-export-dynamic', '-march=native', '-O2', '-pipe', '-Wall', 'tmp-introspectkwt2gtwe/var/tmp/portage/x11-libs/pango-1.40.14-r1/work/pango-1.40.14-abi_x86_64.amd64/pango/tmp-introspectkwt2gtwe/PangoFT2-1.0.o', '-L.', 'libpango-1.0.la', 'libpangoft2-1.0.la', '-lgio-2.0', '-lgobject-2.0', '-Wl,--export-dynamic', '-lgmodule-2.0', '-pthread', '-lglib-2.0', '-lfreetype', '-Wl,-O1', '-Wl,--as-needed']' returned non-zero exit status 1
make[4]: *** [/usr/share/gobject-introspection-1.0/Makefile.introspection:160: PangoFT2-1.0.gir] Error 1
make[4]: Leaving directory '/var/tmp/portage/x11-libs/pango-1.40.14-r1/work/pango-1.40.14-abi_x86_64.amd64/pango'
make[3]: *** [Makefile:1304: all-recursive] Error 1
make[3]: Leaving directory '/var/tmp/portage/x11-libs/pango-1.40.14-r1/work/pango-1.40.14-abi_x86_64.amd64/pango'
make[2]: *** [Makefile:1046: all] Error 2
make[2]: Leaving directory '/var/tmp/portage/x11-libs/pango-1.40.14-r1/work/pango-1.40.14-abi_x86_64.amd64/pango'
make[1]: *** [Makefile:565: all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/x11-libs/pango-1.40.14-r1/work/pango-1.40.14-abi_x86_64.amd64'
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19644
Location: here

PostPosted: Sun Apr 15, 2018 6:52 pm    Post subject: Reply with quote

Pango unstable not require fontconfig-2.9
pango-1.42.0.ebuild:
        >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Mr. T.
Guru
Guru


Joined: 26 Dec 2016
Posts: 477

PostPosted: Sun Apr 15, 2018 7:13 pm    Post subject: Reply with quote

In my mind, Portage could have greatly simplified your problem. In my opinion, your issue comes from a misuse of emerge.
I believe that Portage may manages downgrades but its database is not updated during a manual uninstall.

@fedeliallalinea: I would rather have chosen --autounmask-keep-masks as suggested.

Conclusion: The documentation should be clearer, more precise and a user should test emerge options.
Back to top
View user's profile Send private message
Windmill
Tux's lil' helper
Tux's lil' helper


Joined: 21 Feb 2014
Posts: 105

PostPosted: Sun Apr 15, 2018 8:47 pm    Post subject: Reply with quote

I solved with @preserved-rebuild, thanks for all the help
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum