Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Qt5 dev-qt/qtgui-5.9.4-r3 fails to compile
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Adarion
n00b
n00b


Joined: 22 Aug 2005
Posts: 54

PostPosted: Wed Apr 04, 2018 10:14 pm    Post subject: [SOLVED] Qt5 dev-qt/qtgui-5.9.4-r3 fails to compile Reply with quote

edit: MOSTLY SOLVED
tldr: seemed to be caused by some things build against an older meson back at the days, recompile meson / make sure you have the most recent stable meson; then recompile xorg-proto, libxshmfence and possibly others (just in case, and make sure eveything else is up to date), then re-try qtgui.
--------

Hello

I did updates recently, Qt5.7.x to 5.9.4. On most machines it worked so far (FX, Kabini,...) until I got to my AMD E-350 based notebook. Here qtgui fails to compile (past some early checks?) - no matter what I do.
glibc glib and gcc are up to date to what is stable in amd64. Everything else seemed to compile so far. Moreover, I cleaned and removed ccache from FEATURES and I even tried CFLAGS via command line (CFLAGS="-march=x86_64 -mmmx -msse -msse2 -msse3) to have something very default and probably failsafe. Also chrooting the sdd form another box didn't help, not that I really expected it, but at least the error is thrown faster. ;-)
(Also removing previous versions of dev-qt/* didn't improve anything but the calculating dependencies process.)

here is the error message
Code:

Note: Also available for Linux: linux-clang linux-icc

Note: Dropped compiler flags '-pthread' when detecting library 'glib'.

Qt is now configured for building. Just run 'gmake'.
Once everything is built, you must run 'gmake install'.
Qt will be installed into '/usr'.

Prior to reconfiguration, make sure you remove any leftovers from
the previous build.

 * Running qt5_qmake in src/gui
 * Running qt5_qmake in src/openglextensions
 * Running qt5_qmake in src/platformheaders
 * Running qt5_qmake in src/platformsupport
 * Running qt5_qmake in src/plugins/generic
 * Running qt5_qmake in src/plugins/imageformats
 * Running qt5_qmake in src/plugins/platforms
 * Running qt5_qmake in src/plugins/platforminputcontexts
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-qt/qtgui-5.9.4-r3/work/qtbase-opensource-src-5.9.4 ...
 * Running emake in src/gui
make -j2
perl /var/tmp/portage/dev-qt/qtgui-5.9.4-r3/work/qtbase-opensource-src-5.9.4/mkspecs/features/data/unix/findclasslist.pl < QtGui.version.in > QtGui.version
x86_64-pc-linux-gnu-g++ -c -O2 -mtune=btver1 -march=btver1 -mfpmath=sse -O2 -pipe -mpopcnt -mmmx -msse -msse2 -msse3 -mssse3 -msse4a -std=c++1z -fvisibility=hidden -fvisibility-inlines-hidden -fno-exceptions -Wall -W -Wvla -Wdate-time -Wshift-overflow=2 -Wduplicated-cond -D_REENTRANT -fPIC -DQT_NO_USING_NAMESPACE -DQT_NO_FOREACH -DENABLE_PIXMAN_DRAWHELPERS -DQT_NO_NARROWING_CONVERSIONS_IN_CONNECT -DQT_BUILD_GUI_LIB -DQT_BUILDING_QT -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -DQT_DEPRECATED_WARNINGS -DQT_DISABLE_DEPRECATED_BEFORE=0x050000 -DQT_NO_EXCEPTIONS -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DQT_NO_DEBUG -DQT_CORE_LIB -msse4.1 -I. -I../../include -I../../include/QtGui -I../../include/QtGui/5.9.4 -I../../include/QtGui/5.9.4/QtGui -isystem /usr/include/libdrm -isystem /usr/include -isystem /usr/include/qt5/QtCore/5.9.4 -isystem /usr/include/qt5/QtCore/5.9.4/QtCore -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -I.moc -isystem /usr/include/libpng16 -I../../mkspecs/linux-g++ image/qimage_sse4.cpp -o .obj/qimage_sse4.o
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include/g++-v6/bits/stl_algo.h:59:0,
                 from /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include/g++-v6/algorithm:62,
                 from ../../include/QtCore/../../src/corelib/global/qglobal.h:109,
                 from ../../include/QtCore/qglobal.h:1,
                 from ../../include/QtGui/../../src/gui/kernel/qtguiglobal.h:43,
                 from ../../include/QtGui/qtguiglobal.h:1,
                 from ../../include/QtGui/../../src/gui/image/qimage.h:43,
                 from ../../include/QtGui/qimage.h:1,
                 from image/qimage_sse4.cpp:40:
/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include/g++-v6/cstdlib:75:25: fatal error: stdlib.h: No such file or directory
 #include_next <stdlib.h>
                         ^
compilation terminated.
make: *** [Makefile:1845: .obj/qimage_sse4.o] Error 1
make: *** Waiting for unfinished jobs....
 * ERROR: dev-qt/qtgui-5.9.4-r3::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtgui-5.9.4-r3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtgui-5.9.4-r3::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtgui-5.9.4-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtgui-5.9.4-r3/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtgui-5.9.4-r3/work/qtbase-opensource-src-5.9.4/src/gui'
 * S: '/var/tmp/portage/dev-qt/qtgui-5.9.4-r3/work/qtbase-opensource-src-5.9.4'

>>> Failed to emerge dev-qt/qtgui-5.9.4-r3, Log file:

>>>  '/var/tmp/portage/dev-qt/qtgui-5.9.4-r3/temp/build.log'


I'm quite confused why this is just failing like this and why it seemed to work in similar conditions elsewhere. Or maybe there is something else in the chain that needs updating - but that isn't automagically pulled in by portage in front of qtgui? (equery depgraph lists a bunch of libs, but not too many)

output from emerge --info '=dev-qt/qtgui-5.9.4-r3::gentoo'
Code:

Portage 2.3.24 (python 3.4.5-final-0, default/linux/amd64/17.0/desktop/plasma, gcc-6.4.0, glibc-2.25-r11, 4.15.12-gentoo-4-default x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.15.12-gentoo-4-default-x86_64-AMD_FX-tm-6300_Six-Core_Processor-with-gentoo-2.4.1
KiB Swap:     271356 total,    271356 free
Timestamp of repository gentoo: Wed, 04 Apr 2018 08:00:01 +0000
Head commit of repository gentoo: 6c81a3f14aa41558c51f48dc4907bd6015b604f7
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
ccache version 3.2.4 [disabled]
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.24.3-r1::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.4.5-r1::gentoo, 3.5.4-r1::gentoo, 3.6.3-r1::gentoo
dev-util/ccache:          3.2.4::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.14.1-r2::gentoo, 1.15.1-r2::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.15::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r11::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: no
    sync-rsync-extra-opts:

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -mtune=btver1 -march=btver1 -mfpmath=sse -O2 -pipe -mpopcnt -mmmx -msse -msse2 -msse3 -mssse3 -msse4a"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -mtune=btver1 -march=btver1 -mfpmath=sse -O2 -pipe -mpopcnt -mmmx -msse -msse2 -msse3 -mssse3 -msse4a"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --verbose-conflicts --keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"

LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en de en_GB"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aalib acl acpi alsa amd64 apng bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli crypt cups cxx dbus declarative dri dts dvd dvdr emboss emf encode exif fam fdformat flac fortran gdbm gif glamor gnutls gpm gtk iconv id3tag idn ipv6 jpeg jpeg2k kipi ladspa lcms ldap libcaca libnotify libsamplerate lm_sensors lzma mad mikmod mng modplug modules mp3 mp4 mpeg multilib ncurses nls nptl offlinehelp ogg opengl openmp openvg pam pango pdf phonon plasma png policykit ppds pulseaudio qml qt3support qt5 readline sdl seccomp secure-delete semantic-desktop smp spell ssl startup-notification svg system-cairo system-icu system-jpeg system-sqlite tcpd theora tiff timidity truetype udev udisks unicode upower usb vdpau vorbis widgets wmf wxwidgets x264 x265 xattr xcb xcomposite xml xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="intel-hda" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon krita words stage sheets" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 ssse3 sse4a" ELIBC="glibc" GPSD_PROTOCOLS="*" INPUT_DEVICES="keyboard mouse evdev joystick synaptics wacom v4l roccat_kone roccat_koneplus roccat_konextd roccat_konextdoptical" KERNEL="linux" L10N="en-US en-GB de-DE" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer pdfimport" LIRC_DEVICES="*" LLVM_TARGETS="AMDGPU BPF X86" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3 php5-2" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4 python3_6" QEMU_USER_TARGETS="arm armeb m68k mips mipsel ppc ppc64 ppc64abi32 i386 x86_64" RUBY_TARGETS="ruby22 ruby23" SANE_BACKENDS="*" USERLAND="GNU" VIDEO_CARDS="r600 radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


and eventually emerge -pqv '=dev-qt/qtgui-5.9.4-r3::gentoo'
Code:

[ebuild  N    ] dev-qt/qtgui-5.9.4-r3  USE="dbus egl evdev gif jpeg libinput png udev xcb -accessibility -debug -eglfs (-gles2) -ibus {-test} -tslib -tuio -vnc"


Does anyone have a hint?
(I did not yet try to remerge gcc-6.4.0-r1, in case something broke there (why should it?), as equery belongs stdlib.h lists it also as part of gcc and the error seemed to relate to it. I might also try gcc-7.3.0 but why did it work on all other machines yet?)
_________________
stop tcpa, swpatents, corrupt politicians and other scary stuff


Last edited by Adarion on Fri Apr 13, 2018 9:55 am; edited 1 time in total
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6839

PostPosted: Wed Apr 04, 2018 10:38 pm    Post subject: Reply with quote

similar to https://forums.gentoo.org/viewtopic-t-1079456-highlight-.html

i doubt the two same symptoms comes up by surprise, but i couldn't put my finger on what for now.
Back to top
View user's profile Send private message
Adarion
n00b
n00b


Joined: 22 Aug 2005
Posts: 54

PostPosted: Fri Apr 06, 2018 6:13 am    Post subject: Reply with quote

Thanks for the heads-up. But a slight relief to see I am not alone with this.
_________________
stop tcpa, swpatents, corrupt politicians and other scary stuff
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3493
Location: Germany

PostPosted: Sun Apr 08, 2018 11:29 am    Post subject: Qt5 dev-qt/qtgui-5.9.4-r3 fails to compile Reply with quote

Adarion wrote:
Does anyone have a hint?

Please try a
Code:
emerge -av1 xorg-proto libxshmfence qtgui
rebuild, it should work :)
Back to top
View user's profile Send private message
DrGreenthumb
n00b
n00b


Joined: 21 Aug 2003
Posts: 15
Location: Germany

PostPosted: Sun Apr 08, 2018 5:23 pm    Post subject: Re: Qt5 dev-qt/qtgui-5.9.4-r3 fails to compile Reply with quote

Please try a
Code:
emerge -av1 xorg-proto libxshmfence qtgui
rebuild, it should work :)[/quote]

Still the same on my system.
Many qt libs fail with the message:
Quote:
fatal error: stdlib.h: No such file or directory
#include_next <stdlib.h>

I can compile qtgui with gcc 5.4.0.
But the other libs break due to g++ unknown commandline options -Wshift-overflow=2 and -Wduplicated-cond

More ideas? :)
Back to top
View user's profile Send private message
Ethelred the Unready
n00b
n00b


Joined: 10 Apr 2018
Posts: 4

PostPosted: Tue Apr 10, 2018 3:24 pm    Post subject: Reply with quote

EDIT: This post about include paths is a Red Herring! What Josef.95 suggested worked for me
ie
emerge -av1 xorg-proto libxshmfence qtgui


It seems to be triggered by changes in gcc, and the solution isn't going to be in gcc. https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129

This affects multiple projects, and appears to be related to misusing features of gcc to hide warnings...

Quote:
I think you'll find most build systems that do "-isystem /usr/include" instead of "-I /usr/include" are only using "-isystem" for the change in the warning behavior. The change in the include path order is not wanted...


A fix will be needed in qtgui, and it isn't a recent bug either (I saw.. somewhere... someone trying to build Qt4 with new compilers having the same symptom), it is just recently exposed... :(

I don't fancy rolling back my system to gcc5 either... and still looking to see if there's a workaround for qtgui..


Last edited by Ethelred the Unready on Wed Apr 11, 2018 1:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
beandog
Developer
Developer


Joined: 04 May 2003
Posts: 2062
Location: /usa/utah

PostPosted: Tue Apr 10, 2018 6:57 pm    Post subject: Reply with quote

I hit this one today, too. Bleh.

Is it just gcc 6 then? I wonder if I should put gcc 5 back on. I stubbornly refused to upgrade mine for a loooooong time.
_________________
If it ain't broke, tweak it. packages | dvds | blurays | blog | wiki
Back to top
View user's profile Send private message
Ethelred the Unready
n00b
n00b


Joined: 10 Apr 2018
Posts: 4

PostPosted: Tue Apr 10, 2018 7:04 pm    Post subject: Reply with quote

Firstly - heads up - this doesn't fix it :( but I thought I would post what I tried, as it does seem relevant.

Firstly - I originally got the following error (failing on src/gui)
Code:

>>> Compiling source in /var/tmp/portage/dev-qt/qtgui-5.9.4-r3/work/qtbase-opensource-src-5.9.4 ...
 * Running emake in src/gui
make -j5 -s
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include/g++-v6/bits/stl_algo.h:59:0,
                 from /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include/g++-v6/algorithm:62,
                 from ../../include/QtCore/../../src/corelib/global/qglobal.h:109,
                 from ../../include/QtCore/qglobal.h:1,
                 from ../../include/QtGui/../../src/gui/kernel/qtguiglobal.h:43,
                 from ../../include/QtGui/qtguiglobal.h:1,
                 from ../../include/QtGui/../../src/gui/image/qimage.h:43,
                 from ../../include/QtGui/qimage.h:1,
                 from painting/qimagescale_p.h:53,
                 from painting/qimagescale_sse4.cpp:40:
/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include/g++-v6/cstdlib:75:25: fatal error: stdlib.h: No such file or directory
 #include_next <stdlib.h>
                         ^


Based on what the gcc people were suggesting, I searched for uses of "-isystem" to see if they should be replaced with "-I", and there were 2 Makefiles containing -isystem
Code:
# cd /var/tmp/portage/dev-qt/qtgui-5.9.4-r3
# grep isystem `find . -name Makefile`
./work/qtbase-opensource-src-5.9.4/src/openglextensions/Makefile:INCPATH       = -I. -I../../include -I../../include/QtOpenGLExtensions -I/var/tmp/portage/dev-qt/qtgui-5.9.4-r3/work/qtbase-opensource-src-5.9.4/include/QtOpenGLExtensions/5.9.4 -I/var/tmp/portage/dev-qt/qtgui-5.9.4-r3/work/qtbase-opensource-src-5.9.4/include/QtOpenGLExtensions/5.9.4/QtOpenGLExtensions -isystem /usr/include/libdrm -isystem /usr/include -I../../include/QtGui -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -I.moc -I../../mkspecs/linux-g++

./work/qtbase-opensource-src-5.9.4/src/gui/Makefile:INCPATH       = -I. -I../../include -I../../include/QtGui -I../../include/QtGui/5.9.4 -I../../include/QtGui/5.9.4/QtGui -isystem /usr/include/libdrm -isystem /usr/include -isystem /usr/include/qt5/QtCore/5.9.4 -isystem /usr/include/qt5/QtCore/5.9.4/QtCore -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -I.moc -isystem /usr/include/libpng16 -I../../mkspecs/linux-g++


I replaced the instances of "-isystem " with "-I " in the files.
Code:

# cd /var/tmp/portage/dev-qt/qtgui-5.9.4-r3
# find . -name Makefile -exec sed -i 's/-isystem /-I /g' {} +


Then manually built the (previously failed) qtgui project
Code:

# ebuild /usr/portage/dev-qt/qtgui/qtgui-5.9.4-r3.ebuild compile


It gets further, and now fails in src/platformsupport, but I don't know where to look from here..
Code:

>>> Compiling source in /var/tmp/portage/dev-qt/qtgui-5.9.4-r3/work/qtbase-opensource-src-5.9.4 ...
 * Running emake in src/gui
make -j5 -s
 * Running emake in src/openglextensions
make -j5 -s
 * Running emake in src/platformheaders
make -j5 -s
 * Running emake in src/platformsupport
make -j5 -s
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include/g++-v6/bits/stl_algo.h:59:0,
                 from /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include/g++-v6/algorithm:62,
                 from ../../../include/QtCore/../../src/corelib/global/qglobal.h:109,
                 from ../../../include/QtCore/qglobal.h:1,
                 from ../../../include/QtGui/../../src/gui/kernel/qtguiglobal.h:43,
                 from ../../../include/QtGui/qtguiglobal.h:1,
                 from ../../../include/QtGui/../../src/gui/kernel/qopenglcontext.h:43,
                 from ../../../include/QtGui/qopenglcontext.h:1,
                 from ../../../include/QtGui/QOpenGLContext:1,
                 from qopenglcompositor.cpp:40:
/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include/g++-v6/cstdlib:75:25: fatal error: stdlib.h: No such file or directory
 #include_next <stdlib.h>
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6505
Location: Austria

PostPosted: Tue Apr 10, 2018 7:19 pm    Post subject: Reply with quote

GCC is not the reason, please don't make random downgrades.

What version of meson do you all have installed. Make sure it is *not* meson-0.43.0, that version produced broken pkgconfig files. Then, rebuild x11-base/xorg-proto. Then, rebuild libxshmfence (I don't know if that was also involved, but probably not).

Then try again with qtgui.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Ethelred the Unready
n00b
n00b


Joined: 10 Apr 2018
Posts: 4

PostPosted: Tue Apr 10, 2018 9:56 pm    Post subject: Reply with quote

I have meson-0.45.1 on my machine

Code:
# emerge -1av xorg-proto libxshmfence

went fine.

I had to explicitly force qt5 to build,
Code:
# emerge -1av qtgui:5

it compiled and installed fine...

Code:
# emerge -uDN world

It is currently happily building, I will let you know how it finishes...

Thank you for that!
Back to top
View user's profile Send private message
Ethelred the Unready
n00b
n00b


Joined: 10 Apr 2018
Posts: 4

PostPosted: Wed Apr 11, 2018 12:09 pm    Post subject: Reply with quote

Still emerging, but qt builds have passed successfully. :)

I am puzzled as to what the original problem was. Is the cause related to include paths?

stdlib.h has always existed on my machine, and has nothing to do with the packages I had to rebuild.
Code:
$ equery belongs stdlib.h
 * Searching for stdlib.h ...
cross-avr/avr-libc-2.0.0 (/usr/avr/include/stdlib.h)
dev-libs/libbsd-0.8.6 (/usr/include/bsd/stdlib.h)
sys-boot/syslinux-6.04_pre1 (/usr/share/syslinux/com32/include/stdlib.h)
sys-devel/gcc-4.7.4-r1 (/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.4/include/g++-v4/tr1/stdlib.h)
sys-devel/gcc-6.4.0-r1 (/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include/g++-v6/stdlib.h)
sys-devel/gcc-6.4.0-r1 (/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/include/g++-v6/tr1/stdlib.h)
sys-kernel/gentoo-sources-4.9.76-r1 (/usr/src/linux-4.9.76-gentoo-r1/arch/powerpc/boot/stdlib.h)
sys-libs/glibc-2.25-r11 (/usr/include/stdlib.h)
sys-libs/glibc-2.25-r11 (/usr/include/bits/stdlib.h)


How can rebuilding an external package allow qtgui to suddenly find the file?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6505
Location: Austria

PostPosted: Wed Apr 11, 2018 12:58 pm    Post subject: Reply with quote

The problem was that meson produced broken pkgconfig files under some circumstances, xorg-proto's .pc file was affected, and every qmake-based buildsystem using that file broke due to usage of -isystem.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Adarion
n00b
n00b


Joined: 22 Aug 2005
Posts: 54

PostPosted: Thu Apr 12, 2018 7:02 am    Post subject: Reply with quote

Interesting. I had a recent meson, but maybe my xorg-proto was from an older time of meson. I rebuilt all of them, starting with meson, again; xorg-proto libxshmfence, and rebuilt even more stuff, and now I just passed qtgui with success.
I feel relieved! :)
I have to go through all the other dev-qt/somethings and following KDE updates, darktable,... but it looks much better so far.
Thanks!

Maybe this happened only, as described, when one had xorg-proto and the likes built with older meson, and not updated it ever since. I'll keep this in mind when I get to my boxes that receive updates less frequently.

Still, if there is a mis-use of older gcc features, then this should be fixed by upstream, who knows what else might break in the future.
_________________
stop tcpa, swpatents, corrupt politicians and other scary stuff
Back to top
View user's profile Send private message
Adarion
n00b
n00b


Joined: 22 Aug 2005
Posts: 54

PostPosted: Fri Apr 13, 2018 9:57 am    Post subject: Reply with quote

Nice! I woke up to a completely successful update throughout the whole stuff I had on this system. Everything seems to be fine now.
I'll take the hint with xorg-proto possibly built against an older meson into account for any other systems I still have to do.
Thanks for the help!
_________________
stop tcpa, swpatents, corrupt politicians and other scary stuff
Back to top
View user's profile Send private message
Zenkibou
n00b
n00b


Joined: 25 Jan 2013
Posts: 3

PostPosted: Sun Apr 29, 2018 12:41 pm    Post subject: Reply with quote

For those who are still trying to make it build,

I had to rebuild qtcore after meson/xorg-proto/libxshmfence/*proto*, otherwise it was still not building properly.

It looks good now, thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum