Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mozc - Fail to write in japanese
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Fulgurance
Guru
Guru


Joined: 15 Feb 2017
Posts: 350

PostPosted: Thu Feb 22, 2018 11:41 am    Post subject: Mozc - Fail to write in japanese Reply with quote

Hello, i learn japanese and i have japaneses friends and i need to have japanese keyboard. I have installaled ibus with mozc, but when i use shortcut and switch to mozc keyboard, NOTHING !

Is it bug ? Can you help me please ?

Code:
fulgurance@msi-gs73vr-6rf ~ $ cat /etc/X11/xinit/xinitrc
#!/bin/sh


userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/Xresources
sysmodmap=/etc/X11/xinit/Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then







    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs

if [ -n "`/etc/X11/chooser.sh`" ]; then
 command="`/etc/X11/chooser.sh`"
else
 failsafe="yes"
fi

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?* ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

if [ -n "$failsafe" ]; then
 export GTK_IM_MODULE=ibus &
 export QT_IM_MODULE=ibus &
 export XMODIFIERS=@im=ibus &
 ibus-daemon -drx &
 numlockx on &
 setxkbmap fr &
 pulseaudio &
 feh --bg-max ~/wallpaper.png &
 compton -m 0.8 -i 0.8 -e 0.8 --active-opacity 0.8 &
 i3
else
 exec $command
fi


Code:

fulgurance@msi-gs73vr-6rf ~ $ eix ibus
[I] app-i18n/ibus
     Available versions:  1.5.12 ~1.5.15 1.5.16 ~1.5.17 {+X +emoji gconf +gtk +gtk2 +introspection kde +libnotify nls +python test vala wayland PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6"}
     Installed versions:  1.5.16(11:13:21 21/02/2018)(X emoji gtk introspection nls python -gconf -gtk2 -kde -libnotify -test -vala -wayland PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6")
     Homepage:            https://github.com/ibus/ibus/wiki
     Description:         Intelligent Input Bus for Linux / Unix OS


Code:
fulgurance@msi-gs73vr-6rf ~ $ eix mozc
[I] app-i18n/mozc
     Available versions:  (~)2.20.2673.102 **9999 {debug emacs fcitx4 +gui +handwriting-tegaki handwriting-tomoe ibus renderer test}
     Installed versions:  2.20.2673.102(12:24:24 22/02/2018)(gui handwriting-tegaki ibus -debug -emacs -fcitx4 -handwriting-tomoe -renderer -test)
     Homepage:            https://github.com/google/mozc
     Description:         Mozc - Japanese input method editor
Back to top
View user's profile Send private message
C5ace
Apprentice
Apprentice


Joined: 23 Dec 2013
Posts: 225
Location: Brisbane, Australia

PostPosted: Fri Feb 23, 2018 10:11 am    Post subject: Reply with quote

I use Xfce with app-i18n/ibus-anthy, app-i18n/ibus and these fonts installed:
media-fonts/corefonts
media-fonts/droid
media-fonts/font-adobe-100dpi
media-fonts/font-adobe-75dpi
media-fonts/font-adobe-utopia-100dpi
media-fonts/font-adobe-utopia-75dpi
media-fonts/font-adobe-utopia-type1
media-fonts/font-jis-misc
media-fonts/font-sony-misc
media-fonts/intlfonts
media-fonts/ipamonafont
media-fonts/ja-ipafonts
media-fonts/kochi-substitute
media-fonts/mikachan-font-otf
media-fonts/mikachan-font-ttc
media-fonts/mikachan-font-ttf
media-fonts/sazanami

My /etc/localgen:
en_AU ISO-8859-1
en_AU.UTF-8 UTF-8

No ja_JP....

With Xfce there is a small icon on the taskbar to switch between EN and JA.

I can read and write Kanji, Hiragana and Katagan in Firefox, Thunderbird, LibreOffice, XFce-Terminal and all other Gui applications that accepts and displays Japanese text input.

My wife uses the same setup on her work PC as profession JA/EN and EN/JA traslator.

The keyboards used are standard 104 US keyboards.

EDIT:
To use Japanese handwriting install app-i18n/tomoe and related.


Last edited by C5ace on Fri Feb 23, 2018 10:27 am; edited 1 time in total
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2966
Location: Germany

PostPosted: Fri Feb 23, 2018 10:23 am    Post subject: Reply with quote

You're not setting the variables.
Code:

export FOOBAR=BARFOO &
wait
echo $FOOBAR
# no result


Get rid of the & in your export lines

Code:

export FOOBAR=BARFOO
wait
echo $FOOBAR
# BARFOO


I prefer to put these into /etc/env.d/
Back to top
View user's profile Send private message
Fulgurance
Guru
Guru


Joined: 15 Feb 2017
Posts: 350

PostPosted: Sat Feb 24, 2018 7:26 am    Post subject: Reply with quote

I have do this on my file and i have installed anthy, but the same problem :( When i switch to keyboard, no change, i keep french characters...
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2966
Location: Germany

PostPosted: Sat Feb 24, 2018 10:22 am    Post subject: Reply with quote

In X open a terminal (xterm or urxvt) then
Code:
echo "$GTK_IM_MODULE - $QT_IM_MODULE - $XMODIFIERS"


if you get ibus - ibus - @im=ibus, the variables are set. If you get - - - they are not set.

I don't use ibus myself, it's fcitx-anthy here. So in my case it's "fcitx - fcitx - @im=fcitx"

If the variables are set properly and it still does not work - then it's something else. Not sure what.

You have input modules installed? For example fcitx has useflags for gtk2, gtk3, qt4 and a separate package for fcitx-qt5.
Back to top
View user's profile Send private message
Fulgurance
Guru
Guru


Joined: 15 Feb 2017
Posts: 350

PostPosted: Mon Feb 26, 2018 4:53 pm    Post subject: Reply with quote

Code:
fulgurance@msi-gs73vr-6rf ~ $ echo "$GTK_IM_MODULE - $QT_IM_MODULE - $XMODIFIERS"
ibus - ibus - @im=ibus


Code:
fulgurance@msi-gs73vr-6rf ~ $ eix ibus
[I] app-i18n/ibus
     Available versions:  1.5.12 ~1.5.15 1.5.16 ~1.5.17 {+X +emoji gconf +gtk +gtk2 +introspection kde +libnotify nls +python test vala wayland PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6"}
     Installed versions:  1.5.16(15:58:04 22/02/2018)(X emoji gtk introspection nls python -gconf -gtk2 -kde -libnotify -test -vala -wayland PYTHON_TARGETS="python2_7 python3_4 python3_5 -python3_6")
     Homepage:            https://github.com/ibus/ibus/wiki
     Description:         Intelligent Input Bus for Linux / Unix OS


Is it compulsory to use graphical interface ?
Back to top
View user's profile Send private message
Fulgurance
Guru
Guru


Joined: 15 Feb 2017
Posts: 350

PostPosted: Tue Feb 27, 2018 10:02 am    Post subject: Reply with quote

I have switched to fcitx, but when i open fcitx-configtool, at the bottom of the window, i have message says me:
The first input method will be inactive state. Usually you need to put Keyboard or Keyboard - layout name in the first place.

But when i would like to choose keyboard, no keyboard is available, empty list !
Back to top
View user's profile Send private message
Fulgurance
Guru
Guru


Joined: 15 Feb 2017
Posts: 350

PostPosted: Mon Mar 05, 2018 11:16 am    Post subject: Reply with quote

Nothing ?
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2334
Location: イタリアのロディで

PostPosted: Wed Apr 04, 2018 11:05 am    Post subject: Reply with quote

I cannot write Japanese into qt5 programs.
GTK programs work flawlessly.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum