Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GNOME Without Systemd
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 23, 24, 25 ... 27, 28, 29  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
steveybaby2
n00b
n00b


Joined: 20 May 2004
Posts: 17
Location: UK

PostPosted: Mon Mar 19, 2018 10:20 pm    Post subject: Reply with quote

Thanks for the fixes for gucharmap-10.0.4 and gvfs-1.32.2.

I'm also having issues with the following two cases (webkit-gtk-2.4.11-r201 and geary-0.12.1), would you be able to offer any help please?

1) webkit-gtk-2.4.11-r201 which is failing to compile with the following error:

Code:
Source/JavaScriptCore/API/JSStringRef.cpp: In function ‘OpaqueJSString* JSStringCreateWithCharacters(const JSChar*,
 size_t)’:
Source/JavaScriptCore/API/JSStringRef.cpp:40:50: error: invalid conversion from ‘const JSChar* {aka const short uns
igned int*}’ to ‘const UChar* {aka const char16_t*}’ [-fpermissive]
     return OpaqueJSString::create(chars, numChars).leakRef();
                                                  ^
In file included from Source/JavaScriptCore/API/JSStringRef.cpp:31:0:
Source/JavaScriptCore/API/OpaqueJSString.h:49:39: note:   initializing argument 1 of ‘static WTF::PassRefPtr<Opaque
JSString> OpaqueJSString::create(const UChar*, unsigned int)’
     static PassRefPtr<OpaqueJSString> create(const UChar* characters, unsigned length)
                                       ^~~~~~
Source/JavaScriptCore/API/JSStringRef.cpp: In function ‘OpaqueJSString* JSStringCreateWithCharactersNoCopy(const JS
Char*, size_t)’:
Source/JavaScriptCore/API/JSStringRef.cpp:65:83: error: invalid conversion from ‘const JSChar* {aka const short uns
igned int*}’ to ‘const UChar* {aka const char16_t*}’ [-fpermissive]
     return OpaqueJSString::create(StringImpl::createWithoutCopying(chars, numChars)).leakRef();
                                                                                   ^
In file included from ./Source/WTF/wtf/text/WTFString.h:29:0,
                 from Source/JavaScriptCore/API/OpaqueJSString.h:31,
                 from Source/JavaScriptCore/API/JSStringRef.cpp:31:
./Source/WTF/wtf/text/StringImpl.h:393:54: note:   initializing argument 1 of ‘static WTF::PassRef<WTF::StringImpl>
 WTF::StringImpl::createWithoutCopying(const UChar*, unsigned int)’
     WTF_EXPORT_STRING_API static PassRef<StringImpl> createWithoutCopying(const UChar* characters, unsigned length
);
                                                      ^~~~~~~~~~~~~~~~~~~~
Source/JavaScriptCore/API/JSStringRef.cpp: In function ‘const JSChar* JSStringGetCharactersPtr(JSStringRef)’:
Source/JavaScriptCore/API/JSStringRef.cpp:86:30: error: invalid conversion from ‘const UChar* {aka const char16_t*}
’ to ‘const JSChar* {aka const short unsigned int*}’ [-fpermissive]
     return string->characters();
            ~~~~~~~~~~~~~~~~~~^~


It seems to be related to this issue reported on NixOS's equivalent package along with a fix: https://github.com/NixOS/nixpkgs/issues/30782
I've tried re-emerging icu but got the same error.

2) geary-0.12.1 fails to compile with a vala error (I've tried re-emerging this one too but it did make a difference):

Code:
error: Package `libsecret-1' not found in specified Vala API directories or GObject-Introspection GIR directories
Compilation failed: 1 error(s), 0 warning(s)
make[2]: *** [src/CMakeFiles/geary-client.dir/build.make:406: src/.geary-client.stamp] Error 1
make[2]: Leaving directory '/var/tmp/portage/mail-client/geary-0.12.1/work/geary-0.12.1_build'
make[1]: *** [CMakeFiles/Makefile2:733: src/CMakeFiles/geary-client.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
cd /var/tmp/portage/mail-client/geary-0.12.1/work/geary-0.12.1_build/src && touch .geary-mailer.stamp
Back to top
View user's profile Send private message
Elleni
Guru
Guru


Joined: 23 May 2006
Posts: 567

PostPosted: Mon Mar 19, 2018 11:04 pm    Post subject: Reply with quote

dantrell wrote:
Elleni wrote:
can you help me on this ? I am missing icons in some apps with gnome.
I don't think this one is related to me.

This one is though and has been corrected.


Thanks for corrected gucharmap.

As it is not related to you, may it be related to gnome in general ? Thing is, I dont have this icon prob in plasma.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 391
Location: Earth

PostPosted: Tue Mar 20, 2018 7:30 am    Post subject: Reply with quote

steveybaby2 wrote:
webkit-gtk-2.4.11-r201 which is failing to compile with the following error

I wasn't able to reproduce this issue but that might be the least of your concerns.

For one, our version of net-libs/webkit-gtk:2 is pretty much identical to Gentoo's version. That is to say, if our version doesn't build for you then Gentoo's version probably won't either.

Two, Gentoo took steps to purge the older vulnerable versions of WebKitGTK+ and recently masked them for removal. Accordingly, I completely decoupled the affected versions from the project overlays.

Basically, since I can't reproduce this issue and nothing in the project overlays pulls it in, I can't help you and since Gentoo wants to clean up the older vulnerable WebKitGTK+ slots, Gentoo probably can't help you.

steveybaby2 wrote:
geary-0.12.1 fails to compile with a vala error

This one though, I was able to reproduce and correct.

Elleni wrote:
Thing is, I dont have this icon prob in plasma.

I spun up a test install of GNOME 3.26 and the icon issue as shown in your screenshots wasn't present.

Did you try cross referencing your @world updates from around when it was last working to around when it stopped working?
_________________
Dantrell B.
Back to top
View user's profile Send private message
Shibotto
n00b
n00b


Joined: 19 Jun 2015
Posts: 57
Location: Italy

PostPosted: Tue Mar 20, 2018 11:51 am    Post subject: Reply with quote

Elleni wrote:
Hello dantrell,

can you help me on this ? I am missing icons in some apps with gnome.

Example:
Libreoffice Writer:
https://imagebin.ca/v/3uQbBn5unuGj

Virtual manager:
https://imagebin.ca/v/3uQcQHgcqv9q


Are you sure there are no icons? To me it just seems you are using a dark iconset over a dark theme. I took the liberty of modifying your screenshots and I definitely see something over there (although working on PNGs would have helped a lot :oops: ):
https://imgur.com/a/dVclZ
Back to top
View user's profile Send private message
steveybaby2
n00b
n00b


Joined: 20 May 2004
Posts: 17
Location: UK

PostPosted: Tue Mar 20, 2018 6:01 pm    Post subject: Reply with quote

dantrell wrote:
steveybaby2 wrote:
webkit-gtk-2.4.11-r201 which is failing to compile with the following error

I wasn't able to reproduce this issue but that might be the least of your concerns.

For one, our version of net-libs/webkit-gtk:2 is pretty much identical to Gentoo's version. That is to say, if our version doesn't build for you then Gentoo's version probably won't either.

Two, Gentoo took steps to purge the older vulnerable versions of WebKitGTK+ and recently masked them for removal. Accordingly, I completely decoupled the affected versions from the project overlays.

Basically, since I can't reproduce this issue and nothing in the project overlays pulls it in, I can't help you and since Gentoo wants to clean up the older vulnerable WebKitGTK+ slots, Gentoo probably can't help you.


Quite right, on my system there didn't seem to be any other package dependant on that version either, only a newer version of webkit-gtk. Not sure what happened, but an unmerge of the webkit-gtk-2.4.11-r201 package satisfied it and allowed me to have no warnings when updating @world. revdep-rebuild seems happen too.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 395
Location: Brazil

PostPosted: Wed Mar 21, 2018 2:35 pm    Post subject: Reply with quote

Not a bug, but rather a question / request:

Is this app available in the repo?

https://wiki.gnome.org/Apps/MultiWriter

If it isn't, could it? :) Thanks in advance
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 391
Location: Earth

PostPosted: Thu Mar 22, 2018 5:42 am    Post subject: Reply with quote

saboya wrote:
If it isn't, could it? :)

Done.

However, it won't be live just yet because, as is typical, the Meson versions went haywire. :twisted:

Stay tuned.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
Guru
Guru


Joined: 23 May 2006
Posts: 567

PostPosted: Thu Mar 22, 2018 6:21 pm    Post subject: Reply with quote

Shibotto wrote:
Are you sure there are no icons? To me it just seems you are using a dark iconset over a dark theme. I took the liberty of modifying your screenshots and I definitely see something over there (although working on PNGs would have helped a lot :oops: ):
https://imgur.com/a/dVclZ


You are right :oops:

Thanks for pointing that out :roll:

For the record - this happened with Gnome-OSX-IV-Space-Grey-1.0 Theme
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 395
Location: Brazil

PostPosted: Mon Mar 26, 2018 1:09 pm    Post subject: Reply with quote

dantrell wrote:
Done.

However, it won't be live just yet because, as is typical, the Meson versions went haywire. :twisted:

Stay tuned.

Awesome! Will keep an eye for it when it's live.

Also, recently this has come up: https://www.phoronix.com/scan.php?page=news_item&px=GNOME-Performance-Fix-Clutter

I backported the patch to clutter-1.26.2, used in Gnome 3.26 (even though the latest patch applies cleanly with an offset anyways). Worked fine here, not sure if it's worth the hassle, but I'm currently patching my local build with it.

Here's the gist: https://gist.github.com/saboya/b0ec1d646d2e646b193aa890d9b436ac
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 391
Location: Earth

PostPosted: Mon Mar 26, 2018 5:32 pm    Post subject: Reply with quote

saboya wrote:
Will keep an eye for it when it's live.

I gotta say, Meson has been making GNOME 3.28 in general a bit painful, hence the delay. :twisted:

saboya wrote:
Also, recently this has come up: https://www.phoronix.com/scan.php?page=news_item&px=GNOME-Performance-Fix-Clutter

Thanks for the heads up. I'll be backporting this as well.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Sol33t303
n00b
n00b


Joined: 23 Mar 2018
Posts: 29

PostPosted: Tue Mar 27, 2018 7:04 am    Post subject: Gentoo can't see newly installed profiles [SOLVED] Reply with quote

I have recently installed gentoo and it seems to have gone smoothly. But after following the instructions here https://wiki.gentoo.org/wiki/GNOME/GNOME_Without_systemd (I'm using OpenRC) the new profiles aren't showing up when I enter "eselect profile list". What could be the issue? They seem to be installed and I did emerge --sync. There also weren't any errors anywhere from what I could tell. I would copy and paste some of the commands output but I'm not sure how I would do that from the command line without a desktop environment. (I installed them using layman BTW).

Last edited by Sol33t303 on Tue Mar 27, 2018 2:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Tue Mar 27, 2018 7:19 am    Post subject: Reply with quote

How you installed overlay with layman or directly?

EDIT: next time use relative thread, dantrell is always there willing to help
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Sol33t303
n00b
n00b


Joined: 23 Mar 2018
Posts: 29

PostPosted: Tue Mar 27, 2018 7:25 am    Post subject: Reply with quote

I installed it with layman, I never saw that thread, next time I will post it there
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Tue Mar 27, 2018 7:58 am    Post subject: Reply with quote

You also added also a specific version of gnome overlay (dantrell-gnome-3-18, dantrell-gnome-3-22,...)?
With layman -a dantrell-gnome I see
Code:
# eselect profile list
  ....
  [54]  dantrell-gnome:default/linux/amd64/13.0/desktop/gnome+plasma (stable)
  [55]  dantrell-gnome:default/linux/amd64/17.0/desktop/gnome+plasma (stable)

with also layman -a dantrell-gnome-3-24
Code:
# eselect profile list
  ....
  [54]  dantrell-gnome:default/linux/amd64/13.0/desktop/gnome+plasma (stable)
  [55]  dantrell-gnome:default/linux/amd64/17.0/desktop/gnome+plasma (stable)
  [56]  dantrell-gnome-3-24:default/linux/amd64/13.0/desktop/gnome/3.24 (stable)
  [57]  dantrell-gnome-3-24:default/linux/amd64/13.0/desktop/gnome/3.24/extended (stable)
  [58]  dantrell-gnome-3-24:default/linux/amd64/17.0/desktop/gnome/3.24 (stable)
  [59]  dantrell-gnome-3-24:default/linux/amd64/17.0/desktop/gnome/3.24/extended (stable)

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Sol33t303
n00b
n00b


Joined: 23 Mar 2018
Posts: 29

PostPosted: Tue Mar 27, 2018 8:09 am    Post subject: Reply with quote

I tried doing that but it didn't work unfortunately, layman says they are installed whenever I try to install them again.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Tue Mar 27, 2018 10:05 am    Post subject: Reply with quote

Sol33t303 wrote:
I tried doing that but it didn't work unfortunately, layman says they are installed whenever I try to install them again.

That's is correct if you already added overlay.
And you don't see dantrell profiles?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Sol33t303
n00b
n00b


Joined: 23 Mar 2018
Posts: 29

PostPosted: Tue Mar 27, 2018 10:15 am    Post subject: Reply with quote

Nope, I can't see any of dantrells profiles. EDIT: I fixed it, when I first tried to install the overlays I was having trouble with compiling layman, so I tried installing them directly, after that didn't work I tried to fix layman and succeeded, I then installed the overlays through layman. But I never removed the files I created when I created because I presumed portage would just ignore them because they were configured incorrectly (I was going to remove them and other no longer needed files after I had finished setting up the system). So after removing them and doing emerge --sync I can now see the profiles.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Tue Mar 27, 2018 12:01 pm    Post subject: Reply with quote

Ok then edit first post and add tag [SOLVED] at topic title
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 17295

PostPosted: Thu Mar 29, 2018 1:56 am    Post subject: Reply with quote

fedeliallalinea wrote:
EDIT: next time use relative thread, dantrell is always there willing to help
Merged.
_________________
The whole system has to go. The modern criminal justice system is incompatible with Neuroscience. --Sapolsky
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 391
Location: Earth

PostPosted: Fri Mar 30, 2018 2:38 pm    Post subject: Reply with quote

saboya wrote:
https://wiki.gnome.org/Apps/MultiWriter

This is live now (although the last working version is used where the latest version isn't quite there yet).

As usual, inclusion can be managed through the USE flags on gnome-base/gnome-extra-apps.

saboya wrote:
Also, recently this has come up: https://www.phoronix.com/scan.php?page=news_item&px=GNOME-Performance-Fix-Clutter

This is live now too.

dantrell wrote:
After my next pass (or two) GNOME 3.28.0 (alpha) will be available for testing.

I finished my second pass but it needs a third one. :twisted:
_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 395
Location: Brazil

PostPosted: Fri Mar 30, 2018 11:25 pm    Post subject: Reply with quote

dantrell wrote:
saboya wrote:
https://wiki.gnome.org/Apps/MultiWriter

This is live now (although the last working version is used where the latest version isn't quite there yet).

Thanks a lot!

I have another question / request though: Is it possible to break this ebuild with more USE flags?

I was going to test multiwriter, so I added the USE flag and emerged gnome-extra-apps, only to find out I didn't have it installed and it pulls a bunch of things?

Code:
# emerge -1avt gnome-extra-apps

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  N     ] gnome-base/gnome-extra-apps-3.26.0:3.0::dantrell-gnome-3-26  USE="fonts multiwriter -bijiben -boxes -builder -california -empathy -epiphany -evolution (-flashback) -games -geary -gnote -latexila -recipes -share -shotwell -simple-scan -todo -tracker" 0 KiB
[ebuild  N     ]  media-sound/sound-juicer-3.24.0::dantrell-gnome  USE="flac vorbis -debug {-test}" 996 KiB
[ebuild  N     ]   app-cdr/brasero-3.12.2-r1:0/3.1::dantrell-gnome  USE="css introspection libburn mp3 nautilus tracker (-packagekit) -playlist {-test}" 3.655 KiB
[ebuild  N     ]    dev-libs/libisofs-1.4.8::gentoo  USE="acl xattr zlib -debug -static-libs -verbose-debug" 811 KiB
[ebuild  N     ]  gnome-extra/gnome-search-tool-3.6.0::gentoo  670 KiB
[ebuild  N     ]   sys-apps/mlocate-0.26-r2::gentoo  USE="nls (-selinux)" 351 KiB
[ebuild  N     ]  net-analyzer/gnome-nettool-3.8.1::dantrell-gnome  USE="-debug" 576 KiB
[ebuild  N     ]   net-analyzer/nmap-7.70::gentoo  USE="ipv6 nls nse ssl -libressl -libssh2 -ncat -ndiff -nmap-update -nping (-system-lua) -zenmap" PYTHON_TARGETS="python2_7" 10.226 KiB
[ebuild  N     ]    net-libs/libpcap-1.8.1::gentoo  USE="bluetooth dbus usb -netlink -static-libs" ABI_X86="32 (64) (-x32)" 736 KiB
[ebuild  N     ]   net-misc/whois-5.2.20::gentoo  USE="iconv nls -idn" 81 KiB
[ebuild  N     ]  gnome-extra/gconf-editor-3.0.1-r1::gentoo  1.419 KiB
[ebuild  N     ]  app-admin/gnome-system-log-20170809::dantrell-gnome  0 KiB
[ebuild  N     ]   app-text/gnome-doc-utils-0.20.10-r1::dantrell-gnome  PYTHON_TARGETS="python2_7" 515 KiB
[ebuild  N     ]  media-video/cheese-3.26.0:0/8::dantrell-gnome-3-26  USE="introspection {-test}" 1.799 KiB
[ebuild  N     ]   media-plugins/gst-plugins-v4l2-1.12.4:1.0::gentoo  USE="udev" ABI_X86="32 (64) (-x32)" 3.409 KiB
[ebuild  N     ]  gnome-extra/gnome-multi-writer-3.24.0::dantrell-gnome  USE="introspection" 370 KiB
[nomerge       ] media-video/cheese-3.26.0:0/8::dantrell-gnome-3-26  USE="introspection {-test}"
[ebuild  N     ]  media-plugins/gst-plugins-jpeg-1.12.4:1.0::gentoo  ABI_X86="32 (64) (-x32)" 0 KiB
[nomerge       ] gnome-base/gnome-extra-apps-3.26.0:3.0::dantrell-gnome-3-26  USE="fonts multiwriter -bijiben -boxes -builder -california -empathy -epiphany -evolution (-flashback) -games -geary -gnote -latexila -recipes -share -shotwell -simple-scan -todo -tracker"
[ebuild  N     ]  net-misc/vino-3.22.0::dantrell-gnome  USE="crypt gnome-keyring ipv6 jpeg ssl telepathy zlib -debug -zeroconf" 751 KiB
[nomerge       ] net-analyzer/gnome-nettool-3.8.1::dantrell-gnome  USE="-debug"
[ebuild  N     ]  net-dns/bind-tools-9.11.2_p1::gentoo  USE="ipv6 readline seccomp ssl xml -doc -gost -gssapi -idn -libressl -urandom" 9.555 KiB
[nomerge       ] gnome-base/gnome-extra-apps-3.26.0:3.0::dantrell-gnome-3-26  USE="fonts multiwriter -bijiben -boxes -builder -california -empathy -epiphany -evolution (-flashback) -games -geary -gnote -latexila -recipes -share -shotwell -simple-scan -todo -tracker"
[ebuild  N     ]  net-misc/vinagre-3.22.0-r2::dantrell-gnome  USE="ssh telepathy -rdp -spice -zeroconf" 1.539 KiB
[ebuild  N     ]   net-libs/gtk-vnc-0.7.2::dantrell-gnome  USE="gtk3 introspection pulseaudio -examples -python -sasl -vala" PYTHON_TARGETS="python2_7" 437 KiB
[ebuild  N     ]  gnome-extra/gnome-clocks-3.26.1::dantrell-gnome-3-26  782 KiB
[ebuild  N     ]   media-libs/gsound-1.0.2-r1::dantrell-gnome  USE="introspection vala" 276 KiB
[ebuild  N     ]  sci-geosciences/gnome-maps-3.26.2::dantrell-gnome-3-26  1.149 KiB
[ebuild  N     ]   dev-libs/folks-0.11.4:0/25::dantrell-gnome  USE="bluetooth eds telepathy -debug {-test} (-tracker) -utils" 1.927 KiB
[ebuild  N     ]   media-libs/libchamplain-0.12.16:0.12::dantrell-gnome  USE="gtk introspection -debug -vala" 610 KiB
[ebuild  N     ]   net-libs/libgfbgraph-0.2.3-r1:0.2::gentoo  USE="introspection" 265 KiB
[nomerge       ] app-cdr/brasero-3.12.2-r1:0/3.1::dantrell-gnome  USE="css introspection libburn mp3 nautilus tracker (-packagekit) -playlist {-test}"
[ebuild  N     ]  dev-libs/libburn-1.4.8-r2::gentoo  USE="-debug -static-libs" 955 KiB
[nomerge       ] gnome-base/gnome-extra-apps-3.26.0:3.0::dantrell-gnome-3-26  USE="fonts multiwriter -bijiben -boxes -builder -california -empathy -epiphany -evolution (-flashback) -games -geary -gnote -latexila -recipes -share -shotwell -simple-scan -todo -tracker"
[ebuild  N     ]  app-dicts/gnome-dictionary-3.26.1:0/10::dantrell-gnome  USE="introspection ipv6 -debug" 647 KiB
[ebuild  N     ]  media-sound/gnome-sound-recorder-3.24.0.1::dantrell-gnome  442 KiB
[ebuild  N     ]  gnome-extra/gnome-weather-3.26.0::dantrell-gnome  USE="{-test}" 5.237 KiB
[ebuild  N    #]  gnome-extra/gnome-power-manager-3.26.0::dantrell-gnome-3-26  USE="{-test}" 373 KiB
[ebuild  N     ]  gnome-extra/gnome-calendar-3.26.4::dantrell-gnome-3-26  2.386 KiB
[ebuild  N     ]  gnome-extra/gnome-characters-3.26.2::dantrell-gnome-3-26  USE="{-test}" 1.512 KiB
[ebuild  N     ]  gnome-extra/nautilus-sendto-3.8.5::dantrell-gnome  USE="-debug" 374 KiB
[ebuild  N     ]  gnome-extra/gucharmap-10.0.4:2.90::dantrell-gnome  USE="introspection -debug {-test} -vala" 1.689 KiB
[ebuild  N     ]  media-gfx/gnome-font-viewer-3.26.0::dantrell-gnome-3-26  92 KiB
[ebuild  N     ]  media-gfx/gnome-screenshot-3.26.0::dantrell-gnome  223 KiB
[nomerge       ] media-video/cheese-3.26.0:0/8::dantrell-gnome-3-26  USE="introspection {-test}"
[ebuild  N     ]  media-video/gnome-video-effects-0.4.3::dantrell-gnome  139 KiB
[nomerge       ] gnome-extra/gucharmap-10.0.4:2.90::dantrell-gnome  USE="introspection -debug {-test} -vala"
[ebuild  N     ]  app-i18n/unicode-data-10.0.0::dantrell-gnome  12.328 KiB
[nomerge       ] net-analyzer/nmap-7.70::gentoo  USE="ipv6 nls nse ssl -libressl -libssh2 -ncat -ndiff -nmap-update -nping (-system-lua) -zenmap" PYTHON_TARGETS="python2_7"
[ebuild  N     ]  dev-libs/liblinear-210-r1:0/3::gentoo  USE="-blas" 373 KiB
[nomerge       ] net-analyzer/gnome-nettool-3.8.1::dantrell-gnome  USE="-debug"
[ebuild  N     ]  net-misc/netkit-fingerd-0.17-r3::gentoo  25 KiB
[nomerge       ] gnome-base/gnome-extra-apps-3.26.0:3.0::dantrell-gnome-3-26  USE="fonts multiwriter -bijiben -boxes -builder -california -empathy -epiphany -evolution (-flashback) -games -geary -gnote -latexila -recipes -share -shotwell -simple-scan -todo -tracker"
[ebuild  N     ]  gnome-extra/gnome-getting-started-docs-3.26.2::dantrell-gnome-3-26  116.376 KiB
[ebuild  N     ]   gnome-extra/gnome-user-docs-3.26.2.1::dantrell-gnome-3-26  USE="{-test}" 14.199 KiB
[nomerge       ] media-sound/sound-juicer-3.24.0::dantrell-gnome  USE="flac vorbis -debug {-test}"
[ebuild  N     ]  media-libs/libdiscid-0.6.2::dantrell-gnome  USE="-static-libs" 393 KiB
[nomerge       ] gnome-base/gnome-extra-apps-3.26.0:3.0::dantrell-gnome-3-26  USE="fonts multiwriter -bijiben -boxes -builder -california -empathy -epiphany -evolution (-flashback) -games -geary -gnote -latexila -recipes -share -shotwell -simple-scan -todo -tracker"
[ebuild  N     ]  media-fonts/noto-20170403::gentoo  USE="X -cjk" 10.824 KiB
[ebuild  N     ]  media-fonts/symbola-9.17::gentoo  USE="X -doc" 4.027 KiB
[ebuild  N     ]  media-fonts/unifont-10.0.06::gentoo  USE="X -fontforge -utils" 15.285 KiB


Not sure if the dependencies are too tied together or packaging makes it hard to break it up, but is there a reason for not having more USE flags for a more fine-grained control over the installed apps? (I do realize I can emerge multi-writer by itself :) )

As always, thanks for your work. Looking forward to testing 3.28!
Back to top
View user's profile Send private message
redeltaglio
n00b
n00b


Joined: 04 Apr 2018
Posts: 7
Location: Barcelona, Spain

PostPosted: Wed Apr 04, 2018 8:54 pm    Post subject: gnome-base/gnome-control-center-3.24.4::dantrell-gnome-3-24 Reply with quote

Hello there,
i've got a problem as you can read in the object. Here you are the different reports needed to debug:

Code:

cyberdream ~/Bin # emerge --info '=gnome-base/gnome-control-center-3.24.4::dantrell-gnome-3-24'
Portage 2.3.24 (python 3.5.4-final-0, targets/desktop/gnome/extended, gcc-6.4.0, glibc-2.25-r11, 4.9.76-gentoo-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.9.76-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7-6700K_CPU_@_4.00GHz-with-gentoo-2.4.1
KiB Mem:    24600096 total,  18061260 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of repository gentoo: Wed, 04 Apr 2018 00:45:01 +0000
Head commit of repository gentoo: 6caf4bdf25cda641174efd171a8d1033e98ea15f
Head commit of repository awesome: 3e3206f1df6752cd9a212f3bf20cd7ffc94c8f59

Head commit of repository sakaki-tools: 8fef024699bbafd33b692c817fa75d505b0a7ba2

Head commit of repository dantrell-gnome-3-14: cf7e22d8da454e7f8c64485ac38804a72b0a3260

Head commit of repository dantrell-gnome-3-16: 22428ecff1ddb690a47c1fda75b63ffd9d4ced28

Head commit of repository dantrell-gnome-3-18: 3813bc58eccc0ae225b17c56f209676b64a36c61

Head commit of repository dantrell-gnome-3-20: 18804b640f6ad5c5d5caefced3fd8580f7af1a70

Head commit of repository dantrell-gnome-3-22: 00fb2d34205dc6e06298861d796e776fc3460654

Head commit of repository dantrell-gnome-3-24: 06cd4462e35a6ce2c4fc3076bb01308b227c9b0c

Head commit of repository dantrell-gnome: 8e3e6032f5eec7ef80f50b632254da93dc5c8e4d

sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.24.3-r1::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.4-r1::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.29::dantrell-gnome
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.15.1-r2::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r11::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.cz.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:
    sync-rsync-verify-metamanifest: no

awesome
    location: /usr/local/portage/awesome
    sync-type: git
    sync-uri: https://gitlab.awesome-it.de/overlays/awesome
    masters: gentoo
    priority: 50

sakaki-tools
    location: /usr/local/portage/sakaki-tools
    sync-type: git
    sync-uri: https://github.com/sakaki-/sakaki-tools.git
    masters: gentoo
    priority: 50

dantrell-gnome-3-14
    location: /usr/local/portage/dantrell-gnome-3-14
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-14.git
    masters: gentoo
    priority: 100

dantrell-gnome-3-16
    location: /usr/local/portage/dantrell-gnome-3-16
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-16.git
    masters: gentoo
    priority: 100

dantrell-gnome-3-18
    location: /usr/local/portage/dantrell-gnome-3-18
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-18.git
    masters: gentoo
    priority: 100

dantrell-gnome-3-20
    location: /usr/local/portage/dantrell-gnome-3-20
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-20.git
    masters: gentoo
    priority: 100

dantrell-gnome-3-22
    location: /usr/local/portage/dantrell-gnome-3-22
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-22.git
    masters: gentoo
    priority: 100

dantrell-gnome-3-24
    location: /usr/local/portage/dantrell-gnome-3-24
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-24.git
    masters: gentoo
    priority: 100

dantrell-gnome
    location: /usr/local/portage/dantrell-gnome
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome.git
    masters: gentoo
    priority: 150

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE CC-Sampling-Plus-1.0"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O3 -march=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=9 --load-average=8"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms split-elog strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gd.tuwien.ac.at/opsys/linux/gentoo/ http://ftp.fi.muni.cz/pub/linux/gentoo/ rsync://ftp.fi.muni.cz/pub/linux/gentoo/ ftp://ftp.fi.muni.cz/pub/linux/gentoo/ https://mirror.dkm.cz/gentoo/ rsync://mirror.dkm.cz/gentoo/ http://mirror.dkm.cz/gentoo/ ftp://mirror.dkm.cz/gentoo/ ftp://gentoo.mirror.web4u.cz/ http://gentoo.mirror.web4u.cz/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://ftp.ntua.gr/pub/linux/gentoo/ ftp://ftp.ntua.gr/pub/linux/gentoo/ ftp://ftp.heanet.ie/pub/gentoo/ rsync://ftp.heanet.ie/pub/gentoo/ http://ftp.heanet.ie/pub/gentoo/ http://gentoo.prz.rzeszow.pl rsync://gentoo.prz.rzeszow.pl/gentoo ftp://ftp.vectranet.pl/gentoo/ http://ftp.vectranet.pl/gentoo/ rsync://ftp.vectranet.pl/gentoo/ rsync://ftp.rnl.tecnico.ulisboa.pt/pub/gentoo/gentoo-distfiles/ ftp://ftp.rnl.tecnico.ulisboa.pt/pub/gentoo/gentoo-distfiles/ http://ftp.rnl.tecnico.ulisboa.pt/pub/gentoo/gentoo-distfiles/ ftp://ftp.dei.uc.pt/pub/linux/gentoo/ http://ftp.dei.uc.pt/pub/linux/gentoo/ http://mirrors.xservers.ro/gentoo/ ftp://gentoo.bloodhost.ru/ http://gentoo.bloodhost.ru/ rsync://gentoo.bloodhost.ru/gentoo-distfiles http://mirror.yandex.ru/gentoo-distfiles/ ftp://mirror.yandex.ru/gentoo-distfiles/ http://tux.rainside.sk/gentoo/ ftp://tux.rainside.sk/gentoo/ http://gentoo.wheel.sk/ ftp://gentoo.wheel.sk/pub/linux/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9 -l8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord crypt cups cxx dbus dri dts dvd dvdr eds elogind encode evo exif fam flac fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gtk3 gtkstyle iconv introspection ipv6 jpeg lcms ldap libnotify libsecret mad mng modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio readline sdl seccomp spell ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wayland x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" QEMU_SOFTMMU_TARGETS="m68k x86_64 aarch64 alpha arm i386 mips mips64 mips64el mipsel ppc ppc64 sparc sparc64" QEMU_USER_TARGETS="x86_64 aarch64 alpha arm i386 m68k mips mips64 mips64el mipsel mipsn32 mipsn32el ppc ppc64 ppc64abi32 ppc64le sparc sparc32plus sparc64 tilegx" RUBY_TARGETS="ruby22 ruby23" USERLAND="GNU" VIDEO_CARDS="intel i965 virgl" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

cyberdream ~/Bin #

Code:

cyberdream ~/Bin # emerge -pqv '=gnome-base/gnome-control-center-3.24.4::dantrell-gnome-3-24'
[ebuild     U ] gnome-base/gnome-control-center-3.24.4 [3.24.3] USE="bluetooth colord cups elogind gnome-online-accounts ibus networkmanager v4l* wayland -debug -kerberos -libinput (-systemd) -vanilla-datetime -vanilla-hostname" INPUT_DEVICES="-wacom"                                                                                                                         
cyberdream ~/Bin #

And if want to read here you hare the complete build log:

https://drive.google.com/open?id=1l6O4g4QPn86pmZBzgqPpWk5BIBz_hnv9
_________________
https://twitter.com/taglio
PGP: 90DC 1D49 FC85 DD2E 38AC 5301 6DAE 5C27 DFAF 0D6
"...a broken clock is always right twice a day..."
Back to top
View user's profile Send private message
redeltaglio
n00b
n00b


Joined: 04 Apr 2018
Posts: 7
Location: Barcelona, Spain

PostPosted: Wed Apr 04, 2018 9:54 pm    Post subject: gnome-base/gnome-control-center-3.24.4::dantrell-gnome-3-24 Reply with quote

don't want to cross post, but as a reddit user have indicate to me (https://www.reddit.com/r/Gentoo/comments/89tf6l/gentoo_forums_view_topic/dwtfjf1/) it's better to reply here. i've got a problem with the ebuild in object, here you are my post:

https://forums.gentoo.org/viewtopic-p-8205776.html#8205776

Best regards,

RG
_________________
https://twitter.com/taglio
PGP: 90DC 1D49 FC85 DD2E 38AC 5301 6DAE 5C27 DFAF 0D6
"...a broken clock is always right twice a day..."
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 391
Location: Earth

PostPosted: Thu Apr 05, 2018 1:41 pm    Post subject: Reply with quote

saboya wrote:
I have another question / request though: Is it possible to break this ebuild with more USE flags?

It is.

saboya wrote:
Not sure if the dependencies are too tied together or packaging makes it hard to break it up, but is there a reason for not having more USE flags for a more fine-grained control over the installed apps? (I do realize I can emerge multi-writer by itself :) )

The reason it isn't already is because I believe the defaults to be good enough and that more USE flags might just be more noise. There are basically three options here:

1. Leave it as-is.

2. Make every applicable package in that ebuild manageable.

3. Wrap all the packages in that ebuild not currently manageable into a "minimal" USE flag (or equivalent).

I'll think on it for a bit.

saboya wrote:
Looking forward to testing 3.28!

I have been a bit lazy with this but I blame Meson 100%.

redeltaglio wrote:
i've got a problem as you can read in the object.

Code:
../panels/mouse/.libs/libmouse-properties.a(gsd-device-manager.o): In function `gsd_device_manager_get':
gsd-device-manager.c:(.text+0x77f): undefined reference to `gsd_udev_device_manager_get_type'
collect2: error: ld returned 1 exit status

I wasn't immediately able to reproduce this.

My test install doesn't have Wayland and I see that yours does. It'll take me a bit to spin up a Wayland install to see if it's reproducible there.

In the meanwhile, do you remember your last buildable version of gnome-base/gnome-control-center? Was it 3.24.3?

redeltaglio wrote:
don't want to cross post

P.S. Since it was the same thread, just the one post was enough.
_________________
Dantrell B.
Back to top
View user's profile Send private message
redeltaglio
n00b
n00b


Joined: 04 Apr 2018
Posts: 7
Location: Barcelona, Spain

PostPosted: Fri Apr 06, 2018 5:53 am    Post subject: Reply with quote

dantrell wrote:


In the meanwhile, do you remember your last buildable version of gnome-base/gnome-control-center? Was it 3.24.3?



hello there. Yes it was,
_________________
https://twitter.com/taglio
PGP: 90DC 1D49 FC85 DD2E 38AC 5301 6DAE 5C27 DFAF 0D6
"...a broken clock is always right twice a day..."
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 23, 24, 25 ... 27, 28, 29  Next
Page 24 of 29

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum