Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Guix 0.14 fails to work - how to use it?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
pun_guin
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2018
Posts: 97

PostPosted: Thu Mar 22, 2018 9:58 am    Post subject: Guix 0.14 fails to work - how to use it? Reply with quote

Since I am still flirting with binary package management :), I looked around for potential options without having to replace Gentoo entirely. Guix seems like the best option as it is actively maintained, quite cross-platform and there are recent(ish) blog articles which claim that it would work.

So I tried:

Code:
# emerge --ask guix


The process went flawlessly (albeit rather slow), the post-installation documentation roughly equals what the blog article suggests. However, something seems to have gone wrong:

Code:
$ guix pull
substitute: Backtrace:
substitute: In ice-9/boot-9.scm:
substitute:  160: 9 [catch #t #<catch-closure 56524aa17320> ...]
substitute: In unknown file:
substitute:    ?: 8 [apply-smob/1 #<catch-closure 56524aa17320>]
substitute: In ice-9/boot-9.scm:
substitute:   66: 7 [call-with-prompt prompt0 ...]
substitute: In ice-9/eval.scm:
substitute:  432: 6 [eval # #]
substitute: In ice-9/boot-9.scm:
substitute: 2412: 5 [save-module-excursion #<procedure 56524aa3a900 at ice-9/boot-9.scm:4084:3 ()>]
substitute: 4089: 4 [#<procedure 56524aa3a900 at ice-9/boot-9.scm:4084:3 ()>]
substitute: 1734: 3 [%start-stack load-stack ...]
substitute: 1739: 2 [#<procedure 56524aa4ebd0 ()>]
substitute: In unknown file:
substitute:    ?: 1 [primitive-load "/usr/bin/guix"]
substitute: In guix/ui.scm:
substitute: 1452: 0 [run-guix-command substitute "--query"]
substitute:
substitute: guix/ui.scm:1452:12: In procedure run-guix-command:
substitute: guix/ui.scm:1452:12: In procedure setvbuf: Wrong type argument in position 1 (expecting port that supports 'setvbuf'): #<input-output: gnutls-session-port 56524b70bc30>
guix pull: error: corrupt input while restoring archive from #<closed: file 0>


Similar problems occur with guix package and generally most guix commands.
The binary installation seems to not have this error, but I fear it might interfere with the rest of the system, so I do not really want to do that.

Does anyone of you have a clue what might be wrong here? :)
_________________
I already use the new Genthree.
Back to top
View user's profile Send private message
Shoaloak
n00b
n00b


Joined: 05 Nov 2016
Posts: 48

PostPosted: Fri Mar 23, 2018 9:29 pm    Post subject: Reply with quote

I'm a Guix noob, so I can't really help you a lot.
But did you do a
Code:
guix pull
after install to be up-to-date? Maybe this causes the faulty .scm errors.
Otherwise, I would definitely recommend checking out the #guix folks on IRC. :wink:
_________________
Happy hacking.
Back to top
View user's profile Send private message
pun_guin
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2018
Posts: 97

PostPosted: Sat Mar 24, 2018 6:09 pm    Post subject: Reply with quote

I could not perform a guix pull because of that issue either.
_________________
I already use the new Genthree.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum