Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bluetooth not pairing [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6172
Location: /usr/lib64/lv2

PostPosted: Tue Mar 20, 2018 6:56 pm    Post subject: Bluetooth not pairing [SOLVED] Reply with quote

I have a Lenovo Legion Y520. I seem to have successfully installed Bluez. (https://wiki.gentoo.org/wiki/Bluetooth) I can find the laptop's bluetooth device, bluetooth is in default runlevel, and I can initiate pairing either way using blueman. But pairing fails with an incorrect password error.

I'm new to using bluetooth on a laptop. What could I be missing?
_________________
Gentoo Studio in open beta. Feedback wanted.


Last edited by audiodef on Thu Mar 22, 2018 1:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
agent_jdh
Veteran
Veteran


Joined: 08 Aug 2002
Posts: 1778
Location: Scotland

PostPosted: Tue Mar 20, 2018 8:13 pm    Post subject: Reply with quote

I had the same problem with a new Dell laptop. Totally new to bluetooth.

Most issues resolved by adding user to group plugdev. And using pulseaudio, which I didn't really want to do, but seems basically to be needed for bluetooth audio, which is what I use it for.

Also can you lsmod to see what drivers are installed? If you've got s far as pairing it's probably not drivers though.
_________________
Jingle Jangle Jewellery
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6172
Location: /usr/lib64/lv2

PostPosted: Wed Mar 21, 2018 2:06 am    Post subject: Reply with quote

I did add my user to the plugdev group. Pairing is initiated, but doesn't complete. Not sure why a "password" is involved - just confirm the generated code by clicking on the OK dialog of the paired device should work.

No pulseaudio here, and won't touch it, but still, pairing itself should work. I'm trying to get it to complete a pairing.
_________________
Gentoo Studio in open beta. Feedback wanted.
Back to top
View user's profile Send private message
agent_jdh
Veteran
Veteran


Joined: 08 Aug 2002
Posts: 1778
Location: Scotland

PostPosted: Wed Mar 21, 2018 6:44 pm    Post subject: Reply with quote

You could try Xubuntu or Kubuntu live usb boot to see what drivers etc are installed. I use KDE, and a lot of behind the scenes stuff is probably handled by it.
_________________
Jingle Jangle Jewellery
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6172
Location: /usr/lib64/lv2

PostPosted: Thu Mar 22, 2018 12:12 pm    Post subject: Reply with quote

I think I might try that.

Booted into Gentoo today (first time since installing Bluez) and got a pop-up:
Code:

Failed to apply network settings
You might not be able to connect to the Bluetooth network via this machine
Exception
g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dbus.exceptions.DBusException: Not authorized (36)


User is in bluetooth group, so I dunno.

EDIT:

Solved by switching from Blueman to Blueberry. Now I just need to actually try to do something with the connection.
_________________
Gentoo Studio in open beta. Feedback wanted.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum