Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Radeon DRM] Screen goes blank while loading
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1120
Location: Romania

PostPosted: Tue Mar 20, 2018 6:47 pm    Post subject: [Radeon DRM] Screen goes blank while loading Reply with quote

When loading the DRM driver (loaded by udev-trigger in sysinit runlevel, before the boot runlevel) it takes a few seconds and the screen goes blank, no messages can be seen until the radeon module is loaded.

Because there's no VGA/text console in UEFI mode, I have to use efifb or simplefb to get boot messages.
Does switching from efi/simple framebuffer to radeondrm framebuffer cause the screen to go blank?

dmesg:
Code:

[drm] radeon kernel modesetting enabled.
checking generic (c0000000 500000) vs hw (c0000000 10000000)
fb: switching to radeondrmfb from simple
Console: switching to colour dummy device 80x25
[drm] initializing kernel modesetting (KABINI 0x1002:0x9830 0x1849:0x9830 0x00).
[drm] doorbell mmio base: 0xD0000000
[drm] doorbell mmio size: 8388608
ATOM BIOS: AMD
radeon 0000:00:01.0: VRAM: 512M 0x0000000000000000 - 0x000000001FFFFFFF (512M used)
radeon 0000:00:01.0: GTT: 2048M 0x0000000020000000 - 0x000000009FFFFFFF
[drm] Detected VRAM RAM=512M, BAR=256M
[drm] RAM width 128bits DDR
[TTM] Zone  kernel: Available graphics memory: 3792090 kiB
[TTM] Zone   dma32: Available graphics memory: 2097152 kiB
[TTM] Initializing pool allocator
[TTM] Initializing DMA pool allocator
[drm] radeon: 512M of VRAM memory ready
[drm] radeon: 2048M of GTT memory ready.
[drm] Loading kabini Microcode
[drm] Internal thermal controller without fan control
[drm] radeon: dpm initialized
[drm] Found UVD firmware Version: 1.64 Family ID: 9
[drm] Found VCE firmware/feedback version 40.2.2 / 15!
[drm] GART: num cpu pages 524288, num gpu pages 524288
[drm] PCIE GART of 2048M enabled (table at 0x000000000030E000).
radeon 0000:00:01.0: WB enabled
radeon 0000:00:01.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0x000000005be6eacd
radeon 0000:00:01.0: fence driver on ring 1 use gpu addr 0x0000000020000c04 and cpu addr 0x000000002beffbc4
radeon 0000:00:01.0: fence driver on ring 2 use gpu addr 0x0000000020000c08 and cpu addr 0x0000000027d7ce45
radeon 0000:00:01.0: fence driver on ring 3 use gpu addr 0x0000000020000c0c and cpu addr 0x000000002a6f6506
radeon 0000:00:01.0: fence driver on ring 4 use gpu addr 0x0000000020000c10 and cpu addr 0x000000004cc150dd
radeon 0000:00:01.0: fence driver on ring 5 use gpu addr 0x0000000000078d30 and cpu addr 0x000000005f655586
radeon 0000:00:01.0: fence driver on ring 6 use gpu addr 0x0000000020000c18 and cpu addr 0x00000000b915d5c4
radeon 0000:00:01.0: fence driver on ring 7 use gpu addr 0x0000000020000c1c and cpu addr 0x00000000f64f0b54
[drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[drm] Driver supports precise vblank timestamp query.
radeon 0000:00:01.0: radeon: using MSI.
[drm] radeon: irq initialized.
[drm] ring test on 0 succeeded in 3 usecs
[drm] ring test on 1 succeeded in 3 usecs
[drm] ring test on 2 succeeded in 3 usecs
[drm] ring test on 3 succeeded in 4 usecs
[drm] ring test on 4 succeeded in 4 usecs
[drm] ring test on 5 succeeded in 2 usecs
[drm] UVD initialized successfully.
[drm] ring test on 6 succeeded in 16 usecs
[drm] ring test on 7 succeeded in 3 usecs
[drm] VCE initialized successfully.
[drm] ib test on ring 0 succeeded in 0 usecs
[drm] ib test on ring 1 succeeded in 0 usecs
[drm] ib test on ring 2 succeeded in 0 usecs
[drm] ib test on ring 3 succeeded in 0 usecs
[drm] ib test on ring 4 succeeded in 0 usecs
[drm] ib test on ring 5 succeeded
[drm] ib test on ring 6 succeeded
[drm] ib test on ring 7 succeeded
[drm] Radeon Display Connectors
[drm] Connector 0:
[drm]   HDMI-A-1
[drm]   HPD1
[drm]   DDC: 0x6530 0x6530 0x6534 0x6534 0x6538 0x6538 0x653c 0x653c
[drm]   Encoders:
[drm]     DFP1: INTERNAL_UNIPHY
[drm] Connector 1:
[drm]   HDMI-A-2
[drm]   HPD2
[drm]   DDC: 0x6540 0x6540 0x6544 0x6544 0x6548 0x6548 0x654c 0x654c
[drm]   Encoders:
[drm]     DFP2: INTERNAL_UNIPHY
[drm] Connector 2:
[drm]   VGA-1
[drm]   DDC: 0x65c0 0x65c0 0x65c4 0x65c4 0x65c8 0x65c8 0x65cc 0x65cc
[drm]   Encoders:
[drm]     CRT1: INTERNAL_KLDSCP_DAC1
[drm] fb mappable at 0xC0722000
[drm] vram apper at 0xC0000000
[drm] size 5242880
[drm] fb depth is 24
[drm]    pitch is 5120
fbcon: radeondrmfb (fb0) is primary device
Console: switching to colour frame buffer device 160x64
radeon 0000:00:01.0: fb0: radeondrmfb frame buffer device
[drm] Initialized radeon 2.50.0 20080528 for 0000:00:01.0 on minor 0


[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6267
Location: /usr/lib64/lv2

PostPosted: Wed Mar 21, 2018 2:10 am    Post subject: Reply with quote

I just installed Gentoo on a new UEFI laptop, having the same issue as you, although with a different video card.

As long as you're getting into your system, you can always check dmesg to see what happened during boot.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1120
Location: Romania

PostPosted: Wed Mar 21, 2018 7:00 am    Post subject: Reply with quote

audiodef wrote:
I just installed Gentoo on a new UEFI laptop, having the same issue as you, although with a different video card.

As long as you're getting into your system, you can always check dmesg to see what happened during boot.

The radeon driver is loaded by udev-trigger, if rc_coldplug="YES" (default) in /etc/conf.d/udev-trigger.

If I set it to "NO", the screen does not go blank and I see all messages from OpenRC version to login prompt, but the radeon driver is not loaded.

When I load it myself (modprobe radeon) the screen goes blank for a few seconds, the messages are shown above from dmesg. I see no errors.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum