Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Mathematica and freetype-2.9 undefined symbol
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Gh0str1d3r
Guru
Guru


Joined: 27 May 2008
Posts: 411

PostPosted: Mon Mar 19, 2018 4:08 pm    Post subject: [SOLVED] Mathematica and freetype-2.9 undefined symbol Reply with quote

Hi all,

since today, I can't start mathematica on my gentoo linux machine. It gives the following error:

Code:
/usr/local/Wolfram/Mathematica/11.3/SystemFiles/FrontEnd/Binaries/Linux-x86-64/Mathematica: symbol lookup error: /usr/lib64/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var


What could be the reason for this problem? The file /usr/lib64/libfontconfig.so.1 is part of the media-libs/fontconfig package. Re-installing the package does not help. revdep-rebuild and emerge @preserved-rebuild don't find the broken link. Any suggestions?


Last edited by Gh0str1d3r on Thu Mar 22, 2018 12:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21121
Location: here

PostPosted: Mon Mar 19, 2018 4:13 pm    Post subject: Reply with quote

You upgraded media-libs/freetype?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Gh0str1d3r
Guru
Guru


Joined: 27 May 2008
Posts: 411

PostPosted: Mon Mar 19, 2018 4:15 pm    Post subject: Reply with quote

I rebuilt that package, too.

Code:
eix freetype                     
[I] media-libs/freetype
     Available versions:  (2) 2.8^d (~)2.8.1^d (~)2.9^d **9999^d
       {X +adobe-cff bindist bzip2 +cleartype_hinting debug doc fontforge harfbuzz infinality png static-libs utils ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  2.9(2)^d(12:04:07 PM 03/19/2018)(X adobe-cff bzip2 cleartype_hinting png -bindist -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")
     Homepage:            https://www.freetype.org/
     Description:         A high-quality and portable font engine
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21121
Location: here

PostPosted: Mon Mar 19, 2018 4:18 pm    Post subject: Reply with quote

You tried to downgrade package to 2.8?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Gh0str1d3r
Guru
Guru


Joined: 27 May 2008
Posts: 411

PostPosted: Mon Mar 19, 2018 4:27 pm    Post subject: Reply with quote

Same error with 2.8.1

Edit: I forgot to rebuild media-libs/fontconfig after the downgrade of media-libs/freetype. Now it works. Is this a bug?
Back to top
View user's profile Send private message
Gh0str1d3r
Guru
Guru


Joined: 27 May 2008
Posts: 411

PostPosted: Tue Mar 20, 2018 10:51 am    Post subject: Reply with quote

Actually, after downgrading, I can't start kde anymore. The error message is "Could not start kdeinit5" when I try to log in. When I upgrade again to freetype-2.9 then I can also log in again. Is there any way that would allow me to work with kde and with mathematica?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21121
Location: here

PostPosted: Tue Mar 20, 2018 11:14 am    Post subject: Reply with quote

Gh0str1d3r wrote:
Edit: I forgot to rebuild media-libs/fontconfig after the downgrade of media-libs/freetype. Now it works. Is this a bug?

I don't think, just that mathematica (a binary package) need version 2.8.


Code:
Actually, after downgrading, I can't start kde anymore. The error message is "Could not start kdeinit5" when I try to log in. When I upgrade again to freetype-2.9 then I can also log in again. Is there any way that would allow me to work with kde and with mathematica?

Yes because I have freetype 2.8 and media-libs/fontconfig 2.12.6 with plasma unstable 5.12.3.
Probably you can run these step (I'm not sure if work and I've no idea if break somethings :P )
Code:
# emerge -1 =media-libs/freetype-2.8.1
# emerge -1 media-libs/fontconfig
# revdep-rebuild --library 'libfontconfig.so.1'

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Gh0str1d3r
Guru
Guru


Joined: 27 May 2008
Posts: 411

PostPosted: Thu Mar 22, 2018 12:55 pm    Post subject: Reply with quote

Works, thank you!
Back to top
View user's profile Send private message
FR3141
n00b
n00b


Joined: 13 Jan 2018
Posts: 25

PostPosted: Sat Mar 24, 2018 2:21 pm    Post subject: Reply with quote

Gh0str1d3r wrote:

Code:
# emerge -1 =media-libs/freetype-2.8.1
# emerge -1 media-libs/fontconfig
# revdep-rebuild --library 'libfontconfig.so.1'


I have the same issue but I don't want to downgrade and then rebuild a dozen or so packages.

Is it possible to suppy mathematica with the earlier version of freetype libraries through a variable like LD_LIBRARY_PATH or something similar? Does mathematica have a directory where the older libraries could be installed?
Back to top
View user's profile Send private message
FR3141
n00b
n00b


Joined: 13 Jan 2018
Posts: 25

PostPosted: Sat Mar 24, 2018 2:49 pm    Post subject: Re: [SOLVED] Mathematica and freetype-2.9 undefined symbol Reply with quote

Gh0str1d3r wrote:

since today, I can't start mathematica on my gentoo linux machine. It gives the following error:

Code:
/usr/local/Wolfram/Mathematica/11.3/SystemFiles/FrontEnd/Binaries/Linux-x86-64/Mathematica: symbol lookup error: /usr/lib64/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var



I discovered the source of the problem. Mathematica includes its own freetype.so.6 library in the directory ${TopDirectory}/SystemFiles/Libraries/Linux-x86-64. This freetype library will call the system fontconfig which will give the error.

To fix this, just remove or rename the mathematica freetype.so.6 library. This will force Mathematica to use the system freetype library.

This solution will allow one to keep the latest freetype-2.9 and no downgrade will be necessary.

If Mathematica gives other errors on startup, like with libz.so, check if that library is installed in ${TopDirectory}/SystemFiles/Libraries/Linux-x86-64 and if so then remove or rename it.

I hope this helps.
Back to top
View user's profile Send private message
wdsci
Tux's lil' helper
Tux's lil' helper


Joined: 02 Oct 2007
Posts: 148
Location: US

PostPosted: Sun Nov 04, 2018 3:34 am    Post subject: Reply with quote

Thanks! I had the same problem (well, with Wolfram CDF Player) and I was able to get it working using your solution of removing libfreetype.so.6 and libz.so.1 from /usr/local/Wolfram/CDFPlayer/11.3/SystemFiles/Libraries/Linux-x86-64/.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum