Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Kate crashes on edit *.CSS files
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 01 Dec 2014
Posts: 131
Location: Athens

PostPosted: Sun Mar 18, 2018 10:11 pm    Post subject: [solved] Kate crashes on edit *.CSS files Reply with quote

Hello guys,
Today i tried to edit a CSS file ( it's just a txt file with .css ending) with KDE-Kate editor and kate crash immediately, every time i am writing any character (even space bar). This behavior appears only in CSS files, HTML or C files i can write on them.
I have already rebuild Kate twice, no luck...
Any ideas about what happened???
Thank you.
P.S. my emerge info (if it helps...)

master@gentoo ~ $ emerge --info
Portage 2.3.24 (python 3.5.4-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-7.3.0, glibc-2.25-r10, 4.15.10-gentoo x86_64)
System uname: Linux-4.15.10-gentoo-x86_64-Intel-R-_Core-TM-_i7-8700K_CPU_@_3.70GHz-with-gentoo-2.4.1
KiB Mem:    16361360 total,  14198256 free
KiB Swap:   16777212 total,  16777212 free
Timestamp of repository gentoo: Sat, 17 Mar 2018 23:30:01 +0000
Head commit of repository gentoo: 8d9802f10404e661b9ff37d732cc4d307442082c
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.4-r1::gentoo, 3.6.3-r1::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.12::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.15.1-r2::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0-r1::gentoo, 7.2.0-r1::gentoo, 7.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r10::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000
    sync-rsync-verify-metamanifest: no

    location: /var/lib/layman/jorgicio
    masters: gentoo
    priority: 50

CFLAGS="-march=broadwell -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.1/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=broadwell -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox selinux sesandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi activities alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif experimental fam flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg kde kipi kwallet lcms ldap libnotify mad mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qml qt3support qt5 readline sdl seccomp selinux semantic-desktop spell ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis widgets wxwidgets x264 xattr xcb xcomposite xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="libinput evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" QEMU_SOFTMMU_TARGETS="x86_64" QEMU_USER_TARGETS="x86_64" RUBY_TARGETS="ruby22 ruby23" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Last edited by papas on Mon Mar 19, 2018 5:34 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 02 Oct 2003
Posts: 480
Location: France

PostPosted: Mon Mar 19, 2018 12:59 pm    Post subject: Reply with quote


Try to run kate from command line, so that you could see the actual error.

Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 01 Dec 2014
Posts: 131
Location: Athens

PostPosted: Mon Mar 19, 2018 3:07 pm    Post subject: Reply with quote

Thank you
Back to top
View user's profile Send private message

Joined: 08 Mar 2003
Posts: 24807
Location: here

PostPosted: Mon Mar 19, 2018 4:09 pm    Post subject: Reply with quote

papas wrote:
Thank you

And what was the problem?
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 01 Dec 2014
Posts: 131
Location: Athens

PostPosted: Mon Mar 19, 2018 4:26 pm    Post subject: Reply with quote

i really don't know. I just arrived home, and tried run Kate from CLI and:

kf5.kio.core: Refilling KProtocolInfoFactory cache in the hope to find "mtp"
ASSERT: "index >= 0" in file jit/qv4regalloc.cpp, line 1139
KCrash: Application 'kate' crashing...
KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit

i guess i have to rebuild something with -jit use flag... but what????
bonus, extra mystery:
if i remove the .css ending in the same file, i can write!!!!!

the newest message is :

master@gentoo ~ $ wQSocketNotifier: Invalid socket 8 and type 'Read', disabling...
QSocketNotifier: Invalid socket 19 and type 'Read', disabling...

 19:06:22 up  1:02,  3 users,  load average: 0.48, 0.84, 0.49
master   tty7      18:06    1:02m  1:57   0.00s /usr/bin/ck-launch-session /usr/bin/dbus-launch --
master   pts/0     18:06    1:00m  0.00s  1.30s kded5 [kdeinit5]                                 
master   pts/1     18:06    0.00s  0.04s  0.00s w
[1]+ Exit 253        kate

Finally found this:

[Moderator edit: fixed [url] tag. Explicit linking does not work when the URL contains leading whitespace. -Hu]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum