Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Citrix and Pulseaudio troubles
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 527

PostPosted: Wed Feb 28, 2018 3:57 pm    Post subject: Citrix and Pulseaudio troubles Reply with quote

On my main computers, I've been having trouble using a Citrix Skype plugin (across several versions of the Citrix Receiver, plugin, headsets, kernels, upgrades...). It stopped working about a year ago. On my old desktop, it worked occasionally, but I could not discern any pattern between when it worked and when it did not. When I try to make a call, I see an entry in pavucontrol under 'playback' that keeps appearing and disappearing, and the call is never established. This works on my laptop, but on none of my desktops. I am not at all sure why; I researched some of the messages that I found in the log below (this is what pulseaudio shows when I try to make a call), but none of it helped.

As far as I can tell, it works fine on the same hardware in Debian -- at least, it works on a KVM virtual machine with the same configuration as the Gentoo one that I normally use.

https://pastebin.com/WS2jtfJ3


Last edited by keet on Tue Mar 06, 2018 9:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
blopsalot
Apprentice
Apprentice


Joined: 28 Jan 2017
Posts: 231

PostPosted: Mon Mar 05, 2018 6:32 am    Post subject: Reply with quote

i think it uses gstreamer, do you have media-libs/gst-plugins-good installed?
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 527

PostPosted: Tue Mar 06, 2018 1:29 am    Post subject: Reply with quote

blopsalot wrote:
i think it uses gstreamer, do you have media-libs/gst-plugins-good installed?


I do, but on my working computer:

Code:
grep -r gst /etc/portage
...
/etc/portage/package.use/citrix:media-plugins/gst-plugins-meta dv dvb http lame libass libvisual mms modplug opus taglib theora vaapi vcd vpx wavpack
/etc/portage/package.use/citrix:media-libs/gst-plugins-base theora
...


Oh, what's this /etc/portage/package.use/citrix?

Code:
cat /etc/portage/package.use/citrix
media-libs/libcanberra abi_x86_32
media-plugins/gst-plugins-meta dv dvb http lame libass libvisual mms modplug opus taglib theora vaapi vcd vpx wavpack
media-libs/gst-plugins-base theora
media-plugins/libvisual-plugins abi_x86_32


It's probably something that I made long ago when I was first making it work. I wonder how I figured that out... I'm replicating that configuration and emerging gst-plugins-meta... hopefully that will work.

Thanks!
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 527

PostPosted: Tue Mar 06, 2018 2:29 am    Post subject: Reply with quote

That didn't work, either... When I run RTMediaEngineSrv manually, I do see this error:

Code:
AvPulseDeviceFinder error: pa_sourcelist_cb: Failed to obtain source list


However, I found only an irrelevant forum post when I searched for it.
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 527

PostPosted: Thu Mar 08, 2018 6:56 pm    Post subject: Reply with quote

Now it is working. I'm not sure why. I upgraded to Citrix Receiver 13.9 and reinstalled the Media Engine after I installed the gstreamer packages... maybe they need to be installed after the gstreamer packages.

Edit: ... and I'm back to the 'intermittent' part; it worked yesterday, but this morning, it's not working.
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5623

PostPosted: Sun Mar 18, 2018 9:26 am    Post subject: Reply with quote

just throwing it out there, have you tried net-misc/icaclient ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum