Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(ERLEDIGT) [portage] Verständnisfrage zum maskieren
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1080
Location: Schwabenländle

PostPosted: Fri Mar 16, 2018 4:26 pm    Post subject: (ERLEDIGT) [portage] Verständnisfrage zum maskieren Reply with quote

Hallo Zusammen,

nach einem world Update hat mir mein System "x11-drivers/nvidia-drivers-390.42" installiert, leider aber taugen die Nvidia Treiber >= 390.xx nichts.

Ich habe nun versucht folgendes in die keywords einzutragen:

Code:
<=x11-drivers/nvidia-drivers-387.34


Leider aber versucht portage immer wieder den 390.42 zu installieren.

Ich hab dann versucht, zusätzlich das in der package.mask zu setzen,

Code:
>x11-drivers/nvidia-drivers-390.42


aber auch damit will portage den 390.42 zu installieren. :(

Mit,

Code:
emerge =x11-drivers/nvidia-drivers-387.34


kann ich zwar den gewünschten Treiber installieren, leider aber kommt beim Aufruf des world Updates dann aber wieder:

Code:
vdr01_64 ~ # emerge -avuDN @world

 * IMPORTANT: 3 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] virtual/w3m-0::gentoo  0 KiB
[ebuild     U  ] x11-drivers/nvidia-drivers-390.42:0/390::gentoo [387.34:0/387::gentoo] USE="X acpi driver gtk3 kms tools uvm -compat (-multilib) -pax_kernel -static-libs -wayland" 0 KiB

Total: 2 packages (1 upgrade, 1 new), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No]




Wo habe ich denn hier den Denkfehler?


Last edited by 3PO on Sun Mar 18, 2018 7:26 am; edited 1 time in total
Back to top
View user's profile Send private message
Tyrus
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2018
Posts: 107

PostPosted: Fri Mar 16, 2018 5:52 pm    Post subject: Re: [portage] Verständnisfrage zum maskieren Reply with quote

3PO wrote:

Ich hab dann versucht, zusätzlich das in der package.mask zu setzen,

Code:
>x11-drivers/nvidia-drivers-390.42


aber auch damit will portage den 390.42 zu installieren. :(


Wenn du 390.42 ausschliessen willst, muss das mindestens ">=" heissen. Du maskierst nur alles nach der Version 390.42.
Persönlich würde ich aber nur ein "=" benutzen. Sonst bleibst du ewig auf der alten Version stehen, weill du alles was nachkommt maskiert hast.

Was mich noch intressiert - was genau stimmt denn mit den 390er Versionen nicht? Hast du da irgendwo Probleme?
Ich nutze den grade auch. Aber ist bisher nicht negativ aufgefallen.

Achja und du kannst mit der 387er Version keine Kernel ab 4.15.x nutzen.
Irgendwann musst du dann sowieso auf eine neuere Version rauf wegen dem Kernel.
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1080
Location: Schwabenländle

PostPosted: Fri Mar 16, 2018 7:37 pm    Post subject: Reply with quote

Funktioniert leider auch mit ">=" nicht. :(
Back to top
View user's profile Send private message
mike155
Guru
Guru


Joined: 17 Sep 2010
Posts: 559
Location: Frankfurt, Germany

PostPosted: Fri Mar 16, 2018 11:20 pm    Post subject: Reply with quote

Ich habe es gerade mal bei mir getestet:

"emerge -p nvidia-drivers" will Version 390.42 installieren.

Wenn ich ">=x11-drivers/nvidia-drivers-390.42" an "/etc/portage/package.mask" anfüge und dann "emerge -p nvidia-drivers" starte, will er Version 387.34 installieren. eix zeigt auch an, dass 390.42 jetzt maskiert ist.

Der Vorschlag von Tyrus funktioniert also. Hast Du vielleicht noch etwas in package.unmask stehen, was den Eintrag in package.mask wieder rückgängig macht? Oder irgendetwas ähnliches?
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1080
Location: Schwabenländle

PostPosted: Sun Mar 18, 2018 7:23 am    Post subject: Reply with quote

mike155 wrote:
[...] Hast Du vielleicht noch etwas in package.unmask stehen, was den Eintrag in package.mask wieder rückgängig macht? ...


Genau daran hat es gelegen, da war noch ein uralter Eintrag drin. ^^

Nun geht es wieder.

DANKE!
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1080
Location: Schwabenländle

PostPosted: Sun Mar 18, 2018 7:24 am    Post subject: Re: [portage] Verständnisfrage zum maskieren Reply with quote

Tyrus wrote:
[...] Achja und du kannst mit der 387er Version keine Kernel ab 4.15.x nutzen. ...

Doch, das geht, man braucht halt einen Patch, ;)
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1080
Location: Schwabenländle

PostPosted: Sun Mar 18, 2018 7:25 am    Post subject: Re: [portage] Verständnisfrage zum maskieren Reply with quote

Tyrus wrote:
[...] Was mich noch intressiert - was genau stimmt denn mit den 390er Versionen nicht? Hast du da irgendwo Probleme? ...

Damit geht z.B. das OSD beim VDR nicht.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum