Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
spotify dbus error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
diracsdelta
n00b
n00b


Joined: 27 Jan 2018
Posts: 2

PostPosted: Sat Jan 27, 2018 7:51 am    Post subject: spotify dbus error Reply with quote

Hello,

First time gentoo user here. Super happy with gentoo, but having some issues with dbus.

I just installed Spotify, and would like to use its api with dbus. However, this isn't quite working out. Specifically, I get the following error when I start spotify:

Code:
GLib-GIO-CRITICAL **: g_dbus_connection_send_message: assertion 'G_IS_DBUS_CONNECTION (connection)' failed


And when I try to run dbus-send --print-reply --dest=org.mpris.MediaPlayer2.spotify /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.PlayPause, it errors out and returns "Error org.freedesktop.DBus.Error.SErviceUnknown: the name org.mpris.MediaPlayer2.spotify was not provided by any .service files" I've tried all three ebuilds (69, 70, 70r1), and all produce this error.

I don't have systemd (I use openrc). The first thing I thought was that maybe some dependencies are missing or perhaps pulseaudio is messing stuff up. So I double checked that dbus and glib was in my global useflags in make.conf and disabled the pulseaudio tag. However, this didn't help. I'm not sure how to proceed from here...Any advice? Maybe there's something simple I'm missing...

[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Sun Mar 11, 2018 2:40 am    Post subject: Reply with quote

I don't use Spotify myself, so I can only give a couple of suggestions based on the ebuild. Have you tried to remove the cache?
Code:
rm -rf ~/.cache/spotify


And do you have the package installed with USE=systray enabled? It looks like that useflag will enable a dbus script.

If neither of these suggestions help, I would advise to file a bug.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
diracsdelta
n00b
n00b


Joined: 27 Jan 2018
Posts: 2

PostPosted: Sun Mar 11, 2018 3:33 am    Post subject: Reply with quote

I tried removing the cache, and I have enabled the systray flag. Neither fixes my error. Where should I submit my bug?
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Tue Mar 13, 2018 8:54 am    Post subject: Reply with quote

https://bugs.gentoo.org/
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Aicop
n00b
n00b


Joined: 17 Jun 2018
Posts: 1

PostPosted: Sun Jun 17, 2018 11:03 pm    Post subject: Reply with quote

For me it was resolved by enable the consolekit service and modifying the .xinitrc to use ck-launch-session to start the desktop , such as
Code:

exec ck-launch-session dbus-launch --sh-syntax --exit-with-session startkde


Which was also required to allow my screen to be unlocked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum