Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sci-libs/fftw will (k)ein avx2 Use-Flag
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
LuxJux
Apprentice
Apprentice


Joined: 01 Mar 2016
Posts: 290

PostPosted: Wed Mar 07, 2018 5:17 pm    Post subject: sci-libs/fftw will (k)ein avx2 Use-Flag Reply with quote

Guten Abend. Hoffentlich könnt ihr mir bei diesem Problem weiterhelfen

Code:

.
.
.

echo "/* Generated automatically.  DO NOT EDIT! */";   \
echo "#define SIMD_HEADER \"simd-avx2.h\"";      \
echo "#include \"../common/"genus".c\"";         \
) >genus.c
(                     \
echo "/* Generated automatically.  DO NOT EDIT! */";   \
echo "#define SIMD_HEADER \"simd-avx2.h\"";      \
echo "#include \"../common/"codlist".c\"";         \
) >codlist.c
make  all-am
make[5]: Entering directory '/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2-single-abi_x86_64.amd64/dft/simd/avx2'
/bin/sh ../../../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2 -I../../..  -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/kernel -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support  -march=core-avx2 -mfma -O2 -march=x86-64 -pipe -c -o n1fv_2.lo n1fv_2.c
/bin/sh ../../../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2 -I../../..  -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/kernel -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support  -march=core-avx2 -mfma -O2 -march=x86-64 -pipe -c -o n1fv_3.lo n1fv_3.c
/bin/sh ../../../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2 -I../../..  -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/kernel -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support  -march=core-avx2 -mfma -O2 -march=x86-64 -pipe -c -o n1fv_4.lo n1fv_4.c
/bin/sh ../../../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2 -I../../..  -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/kernel -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support  -march=core-avx2 -mfma -O2 -march=x86-64 -pipe -c -o n1fv_5.lo n1fv_5.c
/bin/sh ../../../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2 -I../../..  -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/kernel -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support  -march=core-avx2 -mfma -O2 -march=x86-64 -pipe -c -o n1fv_6.lo n1fv_6.c
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2 -I../../.. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/kernel -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support -march=core-avx2 -mfma -O2 -march=x86-64 -pipe -c n1fv_2.c  -fPIC -DPIC -o .libs/n1fv_2.o
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2 -I../../.. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/kernel -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support -march=core-avx2 -mfma -O2 -march=x86-64 -pipe -c n1fv_3.c  -fPIC -DPIC -o .libs/n1fv_3.o
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2 -I../../.. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/kernel -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support -march=core-avx2 -mfma -O2 -march=x86-64 -pipe -c n1fv_4.c  -fPIC -DPIC -o .libs/n1fv_4.o
In file included from /var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/n1f.h:21:0,
                 from /var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2/../common/n1fv_2.c:35,
                 from n1fv_2.c:3:
/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support/simd-avx2.h:43:2: error: #error "compiling simd-avx2.h without avx2 support"
 #error "compiling simd-avx2.h without avx2 support"
  ^~~~~
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2 -I../../.. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/kernel -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support -march=core-avx2 -mfma -O2 -march=x86-64 -pipe -c n1fv_5.c  -fPIC -DPIC -o .libs/n1fv_5.o
In file included from /var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/n1f.h:21:0,
                 from /var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2/../common/n1fv_3.c:35,
                 from n1fv_3.c:3:
/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support/simd-avx2.h:43:2: error: #error "compiling simd-avx2.h without avx2 support"
 #error "compiling simd-avx2.h without avx2 support"
  ^~~~~
In file included from /var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/n1f.h:21:0,
                 from /var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2/../common/n1fv_4.c:35,
                 from n1fv_4.c:3:
/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support/simd-avx2.h:43:2: error: #error "compiling simd-avx2.h without avx2 support"
 #error "compiling simd-avx2.h without avx2 support"
  ^~~~~
In file included from /var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/n1f.h:21:0,
                 from /var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2/../common/n1fv_5.c:35,
                 from n1fv_5.c:3:
/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support/simd-avx2.h:43:2: error: #error "compiling simd-avx2.h without avx2 support"
 #error "compiling simd-avx2.h without avx2 support"
  ^~~~~
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2 -I../../.. -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/kernel -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd -I/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support -march=core-avx2 -mfma -O2 -march=x86-64 -pipe -c n1fv_6.c  -fPIC -DPIC -o .libs/n1fv_6.o
In file included from /var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/n1f.h:21:0,
                 from /var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/dft/simd/avx2/../common/n1fv_6.c:35,
                 from n1fv_6.c:3:
/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2/simd-support/simd-avx2.h:43:2: error: #error "compiling simd-avx2.h without avx2 support"
 #error "compiling simd-avx2.h without avx2 support"
  ^~~~~
make[5]: *** [Makefile:761: n1fv_2.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
make[5]: *** [Makefile:761: n1fv_5.lo] Error 1
make[5]: *** [Makefile:761: n1fv_3.lo] Error 1
make[5]: *** [Makefile:761: n1fv_4.lo] Error 1
make[5]: *** [Makefile:761: n1fv_6.lo] Error 1
make[5]: Leaving directory '/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2-single-abi_x86_64.amd64/dft/simd/avx2'
make[4]: *** [Makefile:514: all] Error 2
make[4]: Leaving directory '/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2-single-abi_x86_64.amd64/dft/simd/avx2'
make[3]: *** [Makefile:394: all-recursive] Error 1
make[3]: Leaving directory '/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2-single-abi_x86_64.amd64/dft/simd'
make[2]: *** [Makefile:505: all-recursive] Error 1
make[2]: Leaving directory '/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2-single-abi_x86_64.amd64/dft'
make[1]: *** [Makefile:684: all-recursive] Error 1
make[1]: Leaving directory '/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2-single-abi_x86_64.amd64'
make: *** [Makefile:549: all] Error 2
 * ERROR: sci-libs/fftw-3.3.6_p2::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=sci-libs/fftw-3.3.6_p2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sci-libs/fftw-3.3.6_p2::gentoo'`.
 * The complete build log is located at '/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/temp/build.log'.
 * The ebuild environment file is located at '/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/temp/environment'.
 * Working directory: '/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2-single-abi_x86_64.amd64'
 * S: '/var/calculate/tmp/portage/sci-libs/fftw-3.3.6_p2/work/fftw-3.3.6-pl2'



Hier gabs im italienischen Bereich Hilfestellung

Code:
echo "sci-libs/fftw-3.3.6_p2 -cpu_flags_x86_avx2" >> /etc/portage/package.use/custom

hat nicht geholfen.
Der Fehler bleibt der gleiche.
--------------------------------------------------------------------------------------

Hinweis
Code:
make[5]: *** [Makefile:761: n1fv_2.lo] Error 1
dazu finde ich im buildlog nichts

00cpuflags
Code:
*/* CPU_FLAGS_X86: aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3


Prozessor: Quad i5 Haswell
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19663
Location: here

PostPosted: Wed Mar 07, 2018 5:34 pm    Post subject: Re: sci-libs/fftw will (k)ein avx2 Use-Flag Reply with quote

LuxJux wrote:
Hier gabs im italienischen Bereich Hilfestellung

Code:
echo "sci-libs/fftw-3.3.6_p2 -cpu_flags_x86_avx2" >> /etc/portage/package.use/custom

hat nicht geholfen.
Der Fehler bleibt der gleiche.

Sie haben das '=' vergessen
Code:
echo "=sci-libs/fftw-3.3.6_p2 -cpu_flags_x86_avx2" >> /etc/portage/package.use/custom

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
LuxJux
Apprentice
Apprentice


Joined: 01 Mar 2016
Posts: 290

PostPosted: Wed Mar 07, 2018 6:14 pm    Post subject: Reply with quote

Solved. Emerge läuft erstmal....(durch) (Großes WebQT- update)

Dauert wohl noch etwas.
Danke für die schnelle Fehlerlösung.
Back to top
View user's profile Send private message
Tyrus
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2018
Posts: 111

PostPosted: Thu Mar 08, 2018 1:34 am    Post subject: Reply with quote

@LuxJux:

Wie hast du denn die CPU-Flags für deinen Prozessor ermittelt? Mich wundert das du das Use-Flag deaktivieren musst. Stellt 00cpuflags deine korrekten CPU-Flags dar?
Ich hab sci-libs/fftw-3.3.6_p2 bei mir auch installiert. Aber bei mir lässt es sich mit cpu_flags_x86_avx2 durchkompilieren. Wirkt irgendwie auf mich so als ob dein Prozessor eventuell kein avx2 kann. Dann sollte es aber net in 00cpuflags auftauchen.
Back to top
View user's profile Send private message
LuxJux
Apprentice
Apprentice


Joined: 01 Mar 2016
Posts: 290

PostPosted: Thu Mar 08, 2018 12:48 pm    Post subject: Reply with quote

Ob der Prozessor das wirklich kann, weis ich nicht. Habe mich hieran gehalten

https://forums.gentoo.org/viewtopic-t-1075726.html
Back to top
View user's profile Send private message
Tyrus
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2018
Posts: 111

PostPosted: Thu Mar 08, 2018 1:12 pm    Post subject: Reply with quote

Verstehe. Ich denke du hast da nicht die richtigen Flags für deinen Prozessor.
Es gibt ein hilfreiches Tool. Installier mal app-portage/cpuid2cpuflags.

Dann bekommste mit
Code:

cpuid2cpuflags

die passenden CPU-Flags für deinen Prozessor.

Ansonsten schau mal in die Wiki hier: https://wiki.gentoo.org/wiki/CPU_FLAGS_X86

Ich hab das was 'cpuid2cpuflags' ausgibt in der make.conf eingetragen unter CPU_FLAGS_X86="<DEINE FLAGS>.
Nutze diese 00cpuflags-Datei nicht.

Das kannste aber ruhig lassen. Solltest aber dann die passenden CPU-Flags da eintragen und dann wird der Eintrag von gestern in "/etc/portage/package.use/custom" auch obsolet vermutlich. Also dann wenn dein Prozessor das avx2-Feature nicht unterstützt.
Back to top
View user's profile Send private message
LuxJux
Apprentice
Apprentice


Joined: 01 Mar 2016
Posts: 290

PostPosted: Thu Mar 08, 2018 2:05 pm    Post subject: Reply with quote

Hier mein Eintrag aus der make.conf (Den hatte ich vorher schon mit cpuid2cpuflags gesetzt gehabt.)
Code:
# CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"


Wegen der Kompatibilität (nicht nur wegen Paludis, möglicherweise betrifft das noch andere Programme) hatte ich dies geändert.
Besteht denn die Möglichkeit zu testen, ob mein I5 diesen USE-Befehl tatsächlich beherrscht ?
Dann wäre es natürlich sinnvoll den Eintrag manuell zu entfernen.



Edit: Vielleicht schmeckt portage ja nicht, das da noch "Reste" in der make.conf sind. Die Zeile wurde gelöscht.
Die beiden Eintrage
Code:
echo "=sci-libs/fftw-3.3.6_p2 -cpu_flags_x86_avx2" >> /etc/portage/package.use/custom
echo "sci-libs/fftw-3.3.6_p2 -cpu_flags_x86_avx2" >> /etc/portage/package.use/custom

wurden ebenfalls gelöscht.
emerge bricht mit Fehlermeldung ab. Daran scheint es wohl nicht zu liegen.

echo "=sci-libs/fftw-3.3.6_p2 -cpu_flags_x86_avx2" >> /etc/portage/package.use/custom

wurde wieder hinzugefügt. Keine Probleme. Nothing to merge


Last edited by LuxJux on Thu Mar 08, 2018 2:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tyrus
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2018
Posts: 111

PostPosted: Thu Mar 08, 2018 2:37 pm    Post subject: Reply with quote

Nein du hattest es in make.conf auskommentiert, das war schon korrekt. Wenn Paludis den Eintrag über 00cpuflags benötigt dann passt das schon es so zu machen.
Ich kenn mich mit Paludis gar net aus und kann da nichts zu sagen, hab immer nur portage ausschliesslich genutzt.

Die CPU-Flags findest du zum Teil in /proc/cpuinfo. Das kommt vom kernel selber. cpuid2cpuflags nutzt diese Info auch vermutlich.

Wegen avx2 kann ich jetzt nicht sagen warum das bei dir fehlschlägt. Hast du ffmpeg installiert? Da wird das avx2-Flag auch gebraucht. Du müsstest halt mal schaun ob du sonst Pakete die das Flag nutzen durchkompilieren kannst.

Zu deinem File 00cpuflags. Wenn
Code:

CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"


die Ausgabe von cpu2cpuflags ist dann hast du in 00cpuflags trotzdem das 'f16c' zuviel drin. Das sollte dann raus,
Back to top
View user's profile Send private message
LuxJux
Apprentice
Apprentice


Joined: 01 Mar 2016
Posts: 290

PostPosted: Thu Mar 08, 2018 2:55 pm    Post subject: Reply with quote

Von meiner Warte aus würde ich hier gern schließen.
Mein Problem mit fftw ist erledigt.

Wieso fehlerhafte USE-flags ausgelesen werden übersteigt meinen Horizont
Doch ein neues Thema dazu zu erstellen, ähm
Hat vielleicht jemand Lust sich dem anzunehmen ?
Interessant ist das schon....und da würd ich auch bestimmt mitlesen

Edit: Bezüglich der Übersichtlichkeit wäre es hilfreich, entsprechende Beiträge dann zu verschieben.
Back to top
View user's profile Send private message
Tyrus
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2018
Posts: 111

PostPosted: Thu Mar 08, 2018 3:05 pm    Post subject: Reply with quote

Nee ist ok.
Für mich ist ewtas seltsam das fftw bei mir mit dem Flag durchkompiliert. Hab grade extra nochmal getestet ob sich irgendwas geändert hat seit dem letzten syncen.
Wir müssen kein neues Thema draus machen. Behalt es im Hinterkopf. Falls ähnliches nochmal auftritt.


Last edited by Tyrus on Thu Mar 08, 2018 3:08 pm; edited 2 times in total
Back to top
View user's profile Send private message
LuxJux
Apprentice
Apprentice


Joined: 01 Mar 2016
Posts: 290

PostPosted: Thu Mar 08, 2018 3:05 pm    Post subject: Reply with quote

Tyrus wrote:
Ich kenn mich mit Paludis gar net aus und kann da nichts zu sagen, hab immer nur portage ausschliesslich genutzt.

Die CPU-Flags findest du zum Teil in /proc/cpuinfo. Das kommt vom kernel selber. cpuid2cpuflags nutzt diese Info auch vermutlich.

Wegen avx2 kann ich jetzt nicht sagen warum das bei dir fehlschlägt. Hast du ffmpeg installiert? Da wird das avx2-Flag auch gebraucht. Du müsstest halt mal schaun ob du sonst Pakete die das Flag nutzen durchkompilieren kannst.


Es gibt so viele Programme. Paludis hab ich zwar mal angetestet, komm damit aber nicht klar. ( Anderes Thema)
Benutze auch nur portage
Gedankendang: Alle Rädchen greifen ineinander
Back to top
View user's profile Send private message
LuxJux
Apprentice
Apprentice


Joined: 01 Mar 2016
Posts: 290

PostPosted: Thu Mar 08, 2018 3:14 pm    Post subject: Reply with quote

Tyrus wrote:
Hast du ffmpeg installiert? Da wird das avx2-Flag auch gebraucht.


Da bin ich grad überfragt. Hab vlc installiert. Der schmiert mir aus unerfindlichen Gründen (manchmal) einfach ab.
https://forums.gentoo.org/viewtopic-t-1069890.html
Vielleicht hängst das ja damit zusammen
Back to top
View user's profile Send private message
LuxJux
Apprentice
Apprentice


Joined: 01 Mar 2016
Posts: 290

PostPosted: Thu Mar 08, 2018 3:23 pm    Post subject: Reply with quote

Für was ist das avx2 useflag eigentlich ?
Hier wird es nicht mit aufgeführt. Vom Gefühl her würde ich sagen, das hat was mit Graphik zu tun.
Back to top
View user's profile Send private message
Tyrus
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2018
Posts: 111

PostPosted: Thu Mar 08, 2018 3:29 pm    Post subject: Reply with quote

LuxJux wrote:
Für was ist das avx2 useflag eigentlich ?


Code:

mithrandir@luthien ~ $ equery u sci-libs/fftw
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for sci-libs/fftw-3.3.6_p2:
 U I
 + + abi_x86_32         : 32-bit (x86) libraries
 + + cpu_flags_x86_avx  : Adds support for Advanced Vector Extensions instructions
 + + cpu_flags_x86_avx2 : Adds support for Advanced Vector Extensions 2 instructions
 + + cpu_flags_x86_fma3 : Use the Fused Multiply Add 3 instruction set ([fma] in cpuinfo)
 - - cpu_flags_x86_fma4 : Use the Fused Multiply Add 4 instruction set
 + + cpu_flags_x86_sse  : Use the SSE instruction set
 + + cpu_flags_x86_sse2 : Use the SSE2 instruction set
 + + doc                : Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
 + + fortran            : Add support for fortran
 - - mpi                : Add MPI (Message Passing Interface) layer to the apps that support it
 + + openmp             : Build support for the OpenMP (support parallel computing), requires >=sys-devel/gcc-4.2 built with USE="openmp"
 + + quad               : Build quadruple precision lib
 - - static-libs        : Build static versions of dynamic libraries as well
 - - test               : Workaround to pull in packages needed to run with FEATURES=test. Portage-2.1.2 handles this internally, so don't set it
                          in make.conf/package.use anymore
 + + threads            : Add threads support for various packages. Usually pthreads


Dem equery kannste entnehmen das die CPU "Advanced Vector Extensions 2 instructions" unterstützt wenn du das aktivierst.
In der Wikipedia findest du dazu: https://de.wikipedia.org/wiki/Advanced_Vector_Extensions
Back to top
View user's profile Send private message
LuxJux
Apprentice
Apprentice


Joined: 01 Mar 2016
Posts: 290

PostPosted: Thu Mar 08, 2018 3:36 pm    Post subject: Reply with quote

Tyrus wrote:
Ansonsten schau mal in die Wiki hier: https://wiki.gentoo.org/wiki/CPU_FLAGS_X86


Sicher, daß dies auch für ein AMD64 gilt ?
Back to top
View user's profile Send private message
Tyrus
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2018
Posts: 111

PostPosted: Thu Mar 08, 2018 3:43 pm    Post subject: Reply with quote

Zum vlc - der unterstützt folgende CPU-Flags:

Code:

 + + cpu_flags_x86_mmx : Use the MMX instruction set
 + + cpu_flags_x86_sse : Use the SSE instruction set


avx2 spielt da keine Rolle.

Nur so am Rande - hast du den Effekt beim Spulen mi dem vlc denn immernoch?
Bei mir crasht der auch schonmal. Liegt aber dann eher an der Videoquelle. Das mit dem Spulen muss ich mal testen bei mir. *hust*
Back to top
View user's profile Send private message
Tyrus
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2018
Posts: 111

PostPosted: Thu Mar 08, 2018 3:45 pm    Post subject: Reply with quote

LuxJux wrote:
Tyrus wrote:
Ansonsten schau mal in die Wiki hier: https://wiki.gentoo.org/wiki/CPU_FLAGS_X86


Sicher, daß dies auch für ein AMD64 gilt ?


Ja steht extra da in der Note:
Quote:

Note
The same CPU_FLAGS_X86 variable is used both on x86 and amd64 architectures on Intel and AMD CPUs.
Back to top
View user's profile Send private message
LuxJux
Apprentice
Apprentice


Joined: 01 Mar 2016
Posts: 290

PostPosted: Thu Mar 08, 2018 4:01 pm    Post subject: Reply with quote

............
Closed
Back to top
View user's profile Send private message
Tyrus
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2018
Posts: 111

PostPosted: Thu Mar 08, 2018 4:07 pm    Post subject: Reply with quote

Ich weiß zwar nicht wie du da jetzt drauf kommst/gekommen bist, aber ja ich hab eine nvidia-Grafikkarte. *grübelnd am Kopf kratz* *grinsen muss*

Edit:
Ich hatte deine Frage vor dem Close gelesen. Hihi. ;)
Eventuell machen wir das dann per PN weiter ... *grins*
Back to top
View user's profile Send private message
LuxJux
Apprentice
Apprentice


Joined: 01 Mar 2016
Posts: 290

PostPosted: Thu Mar 08, 2018 4:11 pm    Post subject: Reply with quote

Tyrus wrote:
Nur so am Rande - hast du den Effekt beim Spulen mi dem vlc denn immernoch?
Bei mir crasht der auch schonmal. Liegt aber dann eher an der Videoquelle. Das mit dem Spulen muss ich mal testen bei mir. *hust*


ja, passiert immer noch.
Neuerdings verabschiedet sich der Seamaokey , auch ohne Fehlermeldung

Die Umstellung auf "~amd" erfolgt dann demnächst.
Hoffe natürlich, daß die Fehler dann bereinigt sind. :)
Back to top
View user's profile Send private message
Tyrus
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2018
Posts: 111

PostPosted: Thu Mar 08, 2018 4:20 pm    Post subject: Reply with quote

Als Tip wenn dir mal was einfach so abschmiert. Starte es direkt aus der console. Manchmal sieht man da noch nen bischen was passiert ist bevors abraucht.
Seamonkey nutz ich selber nicht. Hab da den Firefox.

Der Vlc spult bei mir jetzt nicht erkennbar falsch im Augenblick. Ich gestehe aber das ich die Spulfunktion selten nutze. Springe meist mit der Maus. *hust*
Dabei sollte aber erwähnt werden das es Videoquellen gibt die schlicht falsche Gesamtlänge haben und wenn du dann in einen Bereich springst den es net gibt geht der vlc bei mir auch zu.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum