Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SEMISOLVED]Fail to compile mono..
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
cz0
Apprentice
Apprentice


Joined: 13 Jun 2005
Posts: 237
Location: /earth/russia/moscow

PostPosted: Sun Feb 25, 2018 9:41 am    Post subject: [SEMISOLVED]Fail to compile mono.. Reply with quote

Hi.
I'm using keepass and mono is quite vital for me. I'm doing whole world rebuilds time to time (once a year or so, just to keep things consistent) and after some update in the past, I've found, that I'm not able to build mono anymore:
Code:

Compiled: 25186/25188 (99%), No GOT slots: 16302 (64%), Direct calls: 40364 (73%)
Executing the native assembler: "as"   -o /var/tmp/portage/dev-lang/mono-4.4.1.0/temp/mono_aot_oIo8Aj.o /var/tmp/portage/dev-lang/mono-4.4.1.0/temp/mono_aot_oIo8Aj
Executing the native linker: "ld"  -shared -o /var/tmp/portage/dev-lang/mono-4.4.1.0/work/mono-4.4.1-abi_x86_32.x86/mcs/class/lib/build/mscorlib.dll.so.tmp  /var/tmp/portage/dev-lang/mono-4.4.1.0/temp/mono_aot_oIo8Aj.o
make[7]: *** [Makefile:36: ../../class/lib/build//mscorlib.dll.so] Error 1
make[6]: *** [../../build/rules.make:143: do-all] Error 2
make[5]: *** [build/rules.make:170: all-recursive] Error 1
make[4]: *** [Makefile:49: profile-do--build--all] Error 2
make[3]: *** [Makefile:45: profiles-do--all] Error 2
make[2]: *** [Makefile:543: all-local] Error 2
make[2]: Leaving directory '/var/tmp/portage/dev-lang/mono-4.4.1.0/work/mono-4.4.1-abi_x86_32.x86/runtime'
make[1]: *** [Makefile:513: all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/dev-lang/mono-4.4.1.0/work/mono-4.4.1-abi_x86_32.x86'
make: *** [Makefile:442: all] Error 2
 * ERROR: dev-lang/mono-4.4.1.0::gentoo failed (compile phase):
 *   emake failed

Code:

emerge --info '=dev-lang/mono-4.4.1.0::gentoo'
Portage 2.3.19 (python 3.5.4-final-0, default/linux/amd64/17.0, gcc-6.4.0, glibc-2.25-r10, 4.9.76-gentoo-r1_ice x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.9.76-gentoo-r1_ice-x86_64-Intel-R-_Core-TM-_i5-3230M_CPU_@_2.60GHz-with-gentoo-2.4.1
KiB Mem:     7923352 total,   1131904 free
KiB Swap:    3844092 total,   3844092 free
Timestamp of repository gentoo: Sun, 25 Feb 2018 08:45:01 +0000
Head commit of repository gentoo: 7bc7a47974c8683cdbaa41d5365257fc184767ea
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.4-r1::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.12::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r10::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://mirror.yandex.ru/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 PUEL AdobeFlash-11.x RAR"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -msse4 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -msse4 -O2 -pipe"
DISTDIR="/usr/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru ru_RU ru_RU_0"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 aspell berkdb bzip2 caps chardet cli consolekit crypt cue cups cxx dbus dhcp djvu dri egl encode exif flac fortran gdbm gpm gudev hddtemp iconv ipv6 jpeg lm_sensors modules mp2 mp3 multilib ncurces ncurses networkmanager nls nptl nsplugin ogg opengl openmp pam pcre pdf ppds python qt3support qt5 raw readline real seccomp slang smp spell sqlite ssl svg tcpd threads tiff unicode usb userlocales v4l2 vim vorbis wavpack wifi x264 xattr xvid xvmc zlib" ABI_X86="64 32" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 sse4_2 ssse3 aes avx popcnt" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="ru ru_RU ru_RU_0" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby22 ruby23" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

dev-lang/mono-4.4.1.0::gentoo was built with the following:
USE="nls (-doc) -minimal -pax_kernel -xen" ABI_X86="32 (64) (-x32)"
CFLAGS="-march=core2 -O2 -pipe"
CXXFLAGS="-march=core2 -O2 -pipe"

All the rest of the world compiles without problems. Any ideas here?


Last edited by cz0 on Sat Mar 03, 2018 8:21 am; edited 1 time in total
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3613
Location: Hamburg

PostPosted: Sun Feb 25, 2018 10:02 am    Post subject: Re: Fail to compile mono.. Reply with quote

OT but:
cz0 wrote:
Hi.
I'm doing whole world rebuilds time to time (once a year or so, just to keep things consistent)
A rebuild is no longer needed IMO, just do an
Code:
emerge --update --newuse --changed-use --with-bdeps=y --changed-deps=y --deep @world -a
or so, at that you can do once a week if you want.
Back to top
View user's profile Send private message
cz0
Apprentice
Apprentice


Joined: 13 Jun 2005
Posts: 237
Location: /earth/russia/moscow

PostPosted: Sun Feb 25, 2018 11:42 am    Post subject: Re: Fail to compile mono.. Reply with quote

toralf wrote:
A rebuild is no longer needed IMO, just do an
Code:
emerge --update --newuse --changed-use --with-bdeps=y --changed-deps=y --deep @world -a
or so, at that you can do once a week if you want.

Heh.. I've been using Gentoo for more then a decade by now, so, seem to be a little bit off new stuff. Thanks for advice, I will use that for keeping system in good shape. But, I think, this will not fix mono :(
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3613
Location: Hamburg

PostPosted: Sun Feb 25, 2018 12:14 pm    Post subject: Re: Fail to compile mono.. Reply with quote

cz0 wrote:

Heh.. I've been using Gentoo for more then a decade by now, so, seem to be a little bit off new stuff.
same here - there's still a lot of evolution all over the places.
Back to top
View user's profile Send private message
cz0
Apprentice
Apprentice


Joined: 13 Jun 2005
Posts: 237
Location: /earth/russia/moscow

PostPosted: Sun Feb 25, 2018 4:56 pm    Post subject: Reply with quote

Same for mono-4.6.1.5-r1
Code:

Compiled: 25397/25469 (99%), No GOT slots: 16482 (64%), Direct calls: 41376 (74%)
70 methods have other problems (0%)
Executing the native assembler: "as"   -o /var/tmp/portage/dev-lang/mono-4.6.1.5-r1/temp/mono_aot_2WTPzC.o /var/tmp/portage/dev-lang/mono-4.6.1.5-r1/temp/mono_aot_2WTPzC
Executing the native linker: "ld"  -shared -o /var/tmp/portage/dev-lang/mono-4.6.1.5-r1/work/mono-4.6.1-abi_x86_32.x86/mcs/class/lib/build/mscorlib.dll.so.tmp  /var/tmp/portage/dev-lang/mono-4.6.1.5-r1/temp/mono_aot_2WTPzC.o
make[7]: *** [Makefile:36: ../../class/lib/build//mscorlib.dll.so] Error 1
make[6]: *** [../../build/rules.make:221: do-all] Error 2
make[5]: *** [build/rules.make:248: all-recursive] Error 1
make[4]: *** [Makefile:49: profile-do--build--all] Error 2
make[3]: *** [Makefile:45: profiles-do--all] Error 2
make[2]: *** [Makefile:543: all-local] Error 2
make[2]: Leaving directory '/var/tmp/portage/dev-lang/mono-4.6.1.5-r1/work/mono-4.6.1-abi_x86_32.x86/runtime'
make[1]: *** [Makefile:512: all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/dev-lang/mono-4.6.1.5-r1/work/mono-4.6.1-abi_x86_32.x86'
make: *** [Makefile:441: all] Error 2
 * ERROR: dev-lang/mono-4.6.1.5-r1::gentoo failed (compile phase):
 *   emake failed
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1673

PostPosted: Sun Feb 25, 2018 5:11 pm    Post subject: Reply with quote

cz0, just so you know; you didn't provide the output that has the actual error. You only provided the message that it died. The error messages you need to look at is often farther up in the error log; like in programming in that you work top down on resolving errors, as the bottom error messages are often from the errors above it.
Back to top
View user's profile Send private message
cz0
Apprentice
Apprentice


Joined: 13 Jun 2005
Posts: 237
Location: /earth/russia/moscow

PostPosted: Sun Feb 25, 2018 9:49 pm    Post subject: Reply with quote

Nothing suspicious above this section:
Code:

Compilation succeeded - 16 warning(s)
MCS     [build] mcs.exe
AOT     [build] mscorlib.dll.so
AOT     [build] mcs.exe.so
ld: /var/tmp/portage/dev-lang/mono-4.4.1.0/temp/mono_aot_eTXSyb.o: relocation R_X86_64_32 against `.bss' can not be used when making a shared object; recompile with -fPIC
ld: final link failed: Nonrepresentable section on output
AOT of image ./../../class/lib/build/mcs.exe failed.
Mono Ahead of Time compiler - compiling assembly /var/tmp/portage/dev-lang/mono-4.4.1.0/work/mono-4.4.1-abi_x86_32.x86/mcs/class/lib/build/mcs.exe
Code: 4383943(64%) Info: 118855(1%) Ex Info: 2026921(29%) Unwind Info: 80(0%) Class Info: 65543(0%) PLT: 6722(0%) GOT Info: 150439(2%) Offsets: 92119(1%) GOT: 60652
Compiled: 21098/21098 (100%), No GOT slots: 12333 (58%), Direct calls: 23500 (110%)
Executing the native assembler: "as"   -o /var/tmp/portage/dev-lang/mono-4.4.1.0/temp/mono_aot_eTXSyb.o /var/tmp/portage/dev-lang/mono-4.4.1.0/temp/mono_aot_eTXSyb
Executing the native linker: "ld"  -shared -o ./../../class/lib/build//mcs.exe.so.tmp  /var/tmp/portage/dev-lang/mono-4.4.1.0/temp/mono_aot_eTXSyb.o
ld: /var/tmp/portage/dev-lang/mono-4.4.1.0/temp/mono_aot_L0tFi4.o: relocation R_X86_64_32 against `.bss' can not be used when making a shared object; recompile with -fPIC
ld: final link failed: Nonrepresentable section on output
AOT of image ./../../class/lib/build//mscorlib.dll failed.
Mono Ahead of Time compiler - compiling assembly /var/tmp/portage/dev-lang/mono-4.4.1.0/work/mono-4.4.1-abi_x86_32.x86/mcs/class/lib/build/mscorlib.dll
Code: 4772815(62%) Info: 125957(1%) Ex Info: 2355923(31%) Unwind Info: 103(0%) Class Info: 100752(1%) PLT: 6911(0%) GOT Info: 129734(1%) Offsets: 113542(1%) GOT: 63192
Compiled: 25186/25188 (99%), No GOT slots: 16302 (64%), Direct calls: 40364 (73%)
Executing the native assembler: "as"   -o /var/tmp/portage/dev-lang/mono-4.4.1.0/temp/mono_aot_L0tFi4.o /var/tmp/portage/dev-lang/mono-4.4.1.0/temp/mono_aot_L0tFi4
Executing the native linker: "ld"  -shared -o /var/tmp/portage/dev-lang/mono-4.4.1.0/work/mono-4.4.1-abi_x86_32.x86/mcs/class/lib/build/mscorlib.dll.so.tmp  /var/tmp/portage/dev-lang/mono-4.4.1.0/temp/mono_aot_L0tFi4.o
make[7]: *** [Makefile:36: ../../class/lib/build//mscorlib.dll.so] Error 1
make[6]: *** [../../build/rules.make:143: do-all] Error 2
make[5]: *** [build/rules.make:170: all-recursive] Error 1
make[4]: *** [Makefile:49: profile-do--build--all] Error 2
make[3]: *** [Makefile:45: profiles-do--all] Error 2
make[2]: *** [Makefile:543: all-local] Error 2
make[2]: Leaving directory '/var/tmp/portage/dev-lang/mono-4.4.1.0/work/mono-4.4.1-abi_x86_32.x86/runtime'
make[1]: *** [Makefile:513: all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/dev-lang/mono-4.4.1.0/work/mono-4.4.1-abi_x86_32.x86'
make: *** [Makefile:442: all] Error 2


This lines looks promising:
Code:

ld: /var/tmp/portage/dev-lang/mono-4.4.1.0/temp/mono_aot_eTXSyb.o: relocation R_X86_64_32 against `.bss' can not be used when making a shared object; recompile with -fPIC
ld: final link failed: Nonrepresentable section on output
AOT of image ./../../class/lib/build/mcs.exe failed.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 20124
Location: here

PostPosted: Mon Feb 26, 2018 7:09 am    Post subject: Reply with quote

You tried patch proposed in this bug?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
R0b0t1
Apprentice
Apprentice


Joined: 05 Jun 2008
Posts: 255

PostPosted: Tue Feb 27, 2018 12:55 am    Post subject: Reply with quote

I wasn't able to get 4.4.1.0 installed and use 5.4.1.6 instead. Is this possible in your case, perhaps by switching to the unstable version of keepass? What about keepassx, written in C++?

My experience with Mono has been middling at best, but I do think the platform will improve.
Back to top
View user's profile Send private message
konspiracy
n00b
n00b


Joined: 22 Sep 2015
Posts: 6

PostPosted: Tue Feb 27, 2018 10:29 pm    Post subject: Reply with quote

I'm having this same issue with the same error message.
Back to top
View user's profile Send private message
cz0
Apprentice
Apprentice


Joined: 13 Jun 2005
Posts: 237
Location: /earth/russia/moscow

PostPosted: Wed Feb 28, 2018 7:49 pm    Post subject: Reply with quote

keepass is the latest (build with ~amd64), so switching to mono-5.x.x is kind of okeysh.. well, at least if suggested solution will not fix that. I didn't try yet (simply had no time). keepassxc is not a solution - it does not support no Argon2 hashing algorithm, neither Rejindale version of AES. Both a currently the best choice for password managing.
Back to top
View user's profile Send private message
cz0
Apprentice
Apprentice


Joined: 13 Jun 2005
Posts: 237
Location: /earth/russia/moscow

PostPosted: Wed Feb 28, 2018 10:22 pm    Post subject: Reply with quote

Well, actually I did a dry-run builds (with -1B) for mono-4.8.0.524 and mono-5.4.1.6 and both succeeded. Is it safe to update to, lets say. 4.8 and try to build keepass against it?
Back to top
View user's profile Send private message
R0b0t1
Apprentice
Apprentice


Joined: 05 Jun 2008
Posts: 255

PostPosted: Thu Mar 01, 2018 6:55 pm    Post subject: Reply with quote

I expect them to work as C#/Mono are stable ecosystems. They still may not, but it would be surprising.
Back to top
View user's profile Send private message
cz0
Apprentice
Apprentice


Joined: 13 Jun 2005
Posts: 237
Location: /earth/russia/moscow

PostPosted: Thu Mar 01, 2018 7:39 pm    Post subject: Reply with quote

The problem here is that "one-way try", updating to mono-4.8 will succeed, but in case keepass will fail to build against it, I will not be able to roll back to 4.4.whatever and get all my passwords locked up. Can anybody try to build mono-4.8 and try to build keepass-2.38 against it? A have to Gentoo machines and both are desktops with keepass vital.
Back to top
View user's profile Send private message
Tyrus
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2018
Posts: 118

PostPosted: Thu Mar 01, 2018 8:40 pm    Post subject: Reply with quote

Quote:

>>> app-admin/keepass-2.38 merged.


That was with dev-lang/mono-4.8.0.524.

That means still no 100% guarantee. If you are still pessimistic I suggest you backup your Gentoo-System.
Back to top
View user's profile Send private message
cz0
Apprentice
Apprentice


Joined: 13 Jun 2005
Posts: 237
Location: /earth/russia/moscow

PostPosted: Thu Mar 01, 2018 10:06 pm    Post subject: Reply with quote

Tyrus wrote:
That means still no 100% guarantee. If you are still pessimistic I suggest you backup your Gentoo-System.

Thanks! I will try to update mono and rebuild keepass at work. That system is more fault tolerant.
P.S. "Stable" mono-4.6 is a bug..
Back to top
View user's profile Send private message
cz0
Apprentice
Apprentice


Joined: 13 Jun 2005
Posts: 237
Location: /earth/russia/moscow

PostPosted: Fri Mar 02, 2018 7:44 pm    Post subject: Reply with quote

Current keepass successfully compiled against mono-4.8. This does not solve issue with broken mono-4.4, but anyways..
Back to top
View user's profile Send private message
R0b0t1
Apprentice
Apprentice


Joined: 05 Jun 2008
Posts: 255

PostPosted: Sat Mar 03, 2018 5:23 am    Post subject: Reply with quote

Making a problem irrelevant is pretty close to solving it (if they're not the same).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum