Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
OpenCL on AMD GPU
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
bronzeboyvn
n00b
n00b


Joined: 31 Mar 2009
Posts: 56
Location: Vietnam

PostPosted: Wed Feb 21, 2018 3:08 pm    Post subject: Reply with quote

Code:
equery -CN f amdgpu-pro-opencl
equery -CN f ocl-icd

give same output as you do

equery -CN f ocl-icd
Code:

 * Searching for ocl-icd ...                                                                                                                                                                     
 * Contents of dev-libs/ocl-icd-2.2.11-r1:                                                                                                                                                       
/etc                                                                                                                                                                                             
/etc/OpenCL                                                                                                                                                                                       
/etc/OpenCL/vendors                                                                                                                                                                               
/etc/OpenCL/vendors/ocl-icd.icd                                                                                                                                                                   
/usr                                                                                                                                                                                             
/usr/include                                                                                                                                                                                     
/usr/include/ocl_icd.h                                                                                                                                                                           
/usr/lib                                                                                                                                                                                         
/usr/lib/debug                                                                                                                                                                                   
/usr/lib/debug/usr                                                                                                                                                                               
/usr/lib/debug/usr/lib32                                                                                                                                                                         
/usr/lib/debug/usr/lib32/OpenCL                                                                                                                                                                   
/usr/lib/debug/usr/lib32/OpenCL/vendors
/usr/lib/debug/usr/lib32/OpenCL/vendors/ocl-icd
/usr/lib/debug/usr/lib32/OpenCL/vendors/ocl-icd/libOpenCL.so.1.0.0.debug
/usr/lib/debug/usr/lib64
/usr/lib/debug/usr/lib64/OpenCL
/usr/lib/debug/usr/lib64/OpenCL/vendors
/usr/lib/debug/usr/lib64/OpenCL/vendors/ocl-icd
/usr/lib/debug/usr/lib64/OpenCL/vendors/ocl-icd/libOpenCL.so.1.0.0.debug
/usr/lib32
/usr/lib32/OpenCL
/usr/lib32/OpenCL/vendors
/usr/lib32/OpenCL/vendors/ocl-icd
/usr/lib32/OpenCL/vendors/ocl-icd/include
/usr/lib32/OpenCL/vendors/ocl-icd/include/CL
/usr/lib32/OpenCL/vendors/ocl-icd/include/CL/cl.h
/usr/lib32/OpenCL/vendors/ocl-icd/include/CL/cl_ext.h
/usr/lib32/OpenCL/vendors/ocl-icd/include/CL/cl_gl.h
/usr/lib32/OpenCL/vendors/ocl-icd/include/CL/cl_gl_ext.h
/usr/lib32/OpenCL/vendors/ocl-icd/include/CL/cl_platform.h
/usr/lib32/OpenCL/vendors/ocl-icd/include/CL/opencl.h
/usr/lib32/OpenCL/vendors/ocl-icd/libOpenCL.la
/usr/lib32/OpenCL/vendors/ocl-icd/libOpenCL.so -> libOpenCL.so.1.0.0
/usr/lib32/OpenCL/vendors/ocl-icd/libOpenCL.so.1 -> libOpenCL.so.1.0.0
/usr/lib32/OpenCL/vendors/ocl-icd/libOpenCL.so.1.0.0
/usr/lib32/pkgconfig
/usr/lib32/pkgconfig/OpenCL.pc
/usr/lib32/pkgconfig/ocl-icd.pc
/usr/lib64
/usr/lib64/OpenCL
/usr/lib64/OpenCL/vendors
/usr/lib64/OpenCL/vendors/ocl-icd
/usr/lib64/OpenCL/vendors/ocl-icd/include
/usr/lib64/OpenCL/vendors/ocl-icd/include/CL
/usr/lib64/OpenCL/vendors/ocl-icd/include/CL/cl.h
/usr/lib64/OpenCL/vendors/ocl-icd/include/CL/cl_ext.h
/usr/lib64/OpenCL/vendors/ocl-icd/include/CL/cl_gl.h
/usr/lib64/OpenCL/vendors/ocl-icd/include/CL/cl_gl_ext.h
/usr/lib64/OpenCL/vendors/ocl-icd/include/CL/cl_platform.h
/usr/lib64/OpenCL/vendors/ocl-icd/include/CL/opencl.h
/usr/lib64/OpenCL/vendors/ocl-icd/libOpenCL.la
/usr/lib64/OpenCL/vendors/ocl-icd/libOpenCL.so -> libOpenCL.so.1.0.0
/usr/lib64/OpenCL/vendors/ocl-icd/libOpenCL.so.1 -> libOpenCL.so.1.0.0
/usr/lib64/OpenCL/vendors/ocl-icd/libOpenCL.so.1.0.0
/usr/lib64/pkgconfig
/usr/lib64/pkgconfig/OpenCL.pc
/usr/lib64/pkgconfig/ocl-icd.pc
/usr/share
/usr/share/doc
/usr/share/doc/ocl-icd-2.2.11-r1
/usr/share/doc/ocl-icd-2.2.11-r1/NEWS.bz2
/usr/share/doc/ocl-icd-2.2.11-r1/README.bz2
/usr/share/doc/ocl-icd-2.2.11-r1/examples
/usr/share/doc/ocl-icd-2.2.11-r1/examples/ocl_icd_bindings.c.bz2

because I have ABI_X86="32 64"

Here's content of /etc/OpenCL/vendors/ocl-icd.icd
Code:

 * abi_x86_32.x86: running echo /usr/lib64/OpenCL/vendors/ocl-icd/libOpenCL.so
/usr/lib64/OpenCL/vendors/ocl-icd/libOpenCL.so
 * abi_x86_64.amd64: running echo /usr/lib64/OpenCL/vendors/ocl-icd/libOpenCL.so
/usr/lib64/OpenCL/vendors/ocl-icd/libOpenCL.so


Adding LD_LIBRARY_PATH="/opt/amdgpu/lib64" can't help. How you get dev-util/clinfo, it always requires to reinstall mesa with opecl.
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1346
Location: KUUSANKOSKI, Finland

PostPosted: Wed Feb 21, 2018 3:17 pm    Post subject: Reply with quote

bronzeboyvn wrote:
Adding LD_LIBRARY_PATH="/opt/amdgpu/lib64" can't help. How you get dev-util/clinfo, it always requires to reinstall mesa with opecl.
Sure you can install it without mesa:
shellcmd: eshowkw clinfo :
Keywords for dev-util/clinfo:
                |                                 |   u   | 
                | a a         p   a     n r     s |   n   | 
                | l m   h i   p   r m m i i s   p | e u s | r
                | p d a p a p c x m i 6 o s 3   a | a s l | e
                | h 6 r p 6 p 6 8 6 p 8 s c 9 s r | p e o | p
                | a 4 m a 4 c 4 6 4 s k 2 v 0 h c | i d t | o
----------------+---------------------------------+-------+-------
[I]2.2.17.10.25 | o ~ o o o o o o o o o o o o o o | 6 o 0 | gentoo
           9999 | o o o o o o o o o o o o o o o o | 6 o   | gentoo

_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
bronzeboyvn
n00b
n00b


Joined: 31 Mar 2009
Posts: 56
Location: Vietnam

PostPosted: Wed Feb 21, 2018 3:24 pm    Post subject: Reply with quote

emerge -pv clinfo
Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/mesa-17.2.8::gentoo  USE="classic d3d9 dri3 egl gallium gbm gles2 llvm nptl opencl* openmax osmesa vaapi vdpau wayland xa xvmc -bindist -debug -gles1 -pax_kernel -pic (-selinux) -unwind -valgrind -vulkan" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="radeon radeonsi (-freedreno) -i915 -i965 (-imx) -intel -nouveau -r100 -r200 -r300 -r600 (-vc4) -virgl (-vivante) -vmware" 0 KiB
[ebuild  N    ~] virtual/opencl-0-r5::gentoo-gpu  ABI_X86="32 (64) (-x32)" VIDEO_CARDS="-fglrx -intel -nvidia" 0 KiB
[ebuild  N    ~] dev-util/clinfo-2.2.17.10.25::gentoo  0 KiB

Total: 3 packages (2 new, 1 reinstall), Size of downloads: 0 KiB

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by virtual/opencl-0-r5::gentoo-gpu
# required by dev-util/clinfo-2.2.17.10.25::gentoo
# required by clinfo (argument)
>=media-libs/mesa-17.2.8 opencl
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1346
Location: KUUSANKOSKI, Finland

PostPosted: Wed Feb 21, 2018 4:34 pm    Post subject: Reply with quote

You might want to emerge -1 =virtual/opencl-0-r5::gentoo. Since the same package in gentoo-gpu is the one that pulls mesa[opencl].

On that note I have set all overlay to have lower priority than ::gentoo. I then manually give them higher piority if needed. This is certainly not the normal way, but I thought to share because on my setup the virtual/opencl::gentoo get priority over the one in ::gentoo-gpu.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
bronzeboyvn
n00b
n00b


Joined: 31 Mar 2009
Posts: 56
Location: Vietnam

PostPosted: Thu Feb 22, 2018 12:54 am    Post subject: Reply with quote

it also requires opencl, it's not because of gentoo-gpu overlay.

emerge -1 virtual/opencl::gentoo
Code:

Calculating dependencies... done!
[ebuild   R    ] media-libs/mesa-17.2.8  USE="opencl*"
[ebuild  N    ~] virtual/opencl-0-r5  ABI_X86="32 (64) (-x32)" VIDEO_CARDS="amdgpu -i965 -nvidia"

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by virtual/opencl-0-r5::gentoo
# required by virtual/opencl::gentoo (argument)
>=media-libs/mesa-17.2.8 opencl

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose                                                                                                                               
experimental or unstable packages.
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3350

PostPosted: Thu Feb 22, 2018 2:12 am    Post subject: Reply with quote

I'm not really doing any of this yet, just keeping my eye on it. When some time clears, I plan to jump in...

Anyway, I just looked at the ebuild:
Code:
# amdgpu-pro-opencl and intel-ocl-sdk are amd64-only
RDEPEND="app-eselect/eselect-opencl
   || (
      >=media-libs/mesa-9.1.6[opencl,${MULTILIB_USEDEP}]
      video_cards_amdgpu? (
         abi_x86_64? ( !abi_x86_32? ( dev-libs/amdgpu-pro-opencl ) ) )
      video_cards_i965? (
         dev-libs/beignet )
      video_cards_nvidia? (
         >=x11-drivers/nvidia-drivers-290.10-r2 )
      abi_x86_64? ( !abi_x86_32? ( dev-util/intel-ocl-sdk ) )
   )"

This looks to me as if you have five choices:
1 - mesa with opencl
2 - amdgpu with amdgpu-pro-opencl
3 - Intel i965 with beignet
4 - nVidia with binary drivers
5 - looks like some sort of Intel software emulation?

This also looks as if the complete solution is in the main portage tree?
Has anyone run this way?
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1346
Location: KUUSANKOSKI, Finland

PostPosted: Thu Feb 22, 2018 9:46 am    Post subject: Reply with quote

At this point I'm starting to wonder how I got my setup working... :D

@bronzeboyvn: You can emerge clinfo with --nodeps switch so that it does not pull any dependencies.
I'm starting to doubt that the 32-bit ABI you have enabled in your system might mess things up... But let's not go there yet. If you can emerge clinfo and then succesfully run LD_LIBRARY_PATH="/opt/amdgpu/lib64" clinfo we know that it works. It's only matter of setting some links up.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3350

PostPosted: Thu Feb 22, 2018 10:56 am    Post subject: Reply with quote

This morning I rebuild mesa with -opencl, then tried re-emergin clinfo. It wanted mesa with +opencl again.

Then I took a second look at that ebuild snippet I posted, and noticed that its dependent on NOT using the 32-bit ABI. So if I want to use amdgpu-pro-opencl I'll have to stick with 64-bit only, at least for any code which uses opencl. Now to find out how to do that. I want to keep 32-bit opengl for important things like games, but I don't think 64-bit only for opencl is a problem.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1346
Location: KUUSANKOSKI, Finland

PostPosted: Thu Feb 22, 2018 1:10 pm    Post subject: Reply with quote

I've built my Gentoo system strictly 64-bit. No multilib, nothing 32-bit.

And no. I don't have steam. Off-topic a bit, but I wonder how to Arch Linux etc other fully 64-bit systems cope with steam...
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
bronzeboyvn
n00b
n00b


Joined: 31 Mar 2009
Posts: 56
Location: Vietnam

PostPosted: Sat Feb 24, 2018 2:03 am    Post subject: progress Reply with quote

I have little progress:
+ reinstalled whole system with ABI_X86="64", don't use 32bit anymore
+ installed Mesa without opencl
+ installed amdgpu-pro-opencl
+ select ocl-icd
+ content of /etc/OpenCL/vendors/ocl-icd.icd: /usr/lib64/OpenCL/vendors/ocl-icd/libOpenCL.so

So I have almost same output as Zucca has. Only don't have headers: /usr/lib64/OpenCL/vendors/ocl-icd/include/CL, but I have /usr/include/CL folder where its headers are softlinks to headers in /usr/lib64/OpenCL/global/include/CL-1.2
I installed package clinfo, it still returns 1 line: Number of platforms 0
Another info: in virtual console (Crtl + Alt + F1), startkde gives output: $DISPLAY is not set or cannot connect to the X server

I'm waiting for your advise.
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3350

PostPosted: Sat Feb 24, 2018 5:59 pm    Post subject: Reply with quote

So I'm thinking of giving this a try, though I have a multilib system. Nothing on my system is built with USE="opencl" at the moment - a few days back I rebuilt mesa to drop it, hoping to get amdgpu-pro-opencl in there.

Looking at the virtual/opencl ebuild it appeared that it was wanting to rebuild mesa with opencl and not use amdgpu-pro-opencl because I have a multilib system. So I added "/etc/portage/package.use/opencl" with the contents:
Code:
dev-util/clinfo            -abi_x86_32
virtual/opencl             -abi_x86_32
dev-libs/amdgpu-pro-opencl -abi_x86_32
dev-libs/ocl-icd           -abi_x86_32
app-eselect/eselect-opencl -abi_x86_32

Trying to emerge clinfo still wants to rebuild mesa with opencl. I need to keep mesa multilib so that 32-bit opengl stuff will continue to work, but I'm willing to have opencl 64-bit only. I was expecting this to call in amdgpu-pro-opencl.

I just tried installing amdgpu-pro-opencl, to see if doing that first would push things down the other path. But when I went to the download site as instructed, it gave me a zero-length file.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
bronzeboyvn
n00b
n00b


Joined: 31 Mar 2009
Posts: 56
Location: Vietnam

PostPosted: Sun Feb 25, 2018 12:10 pm    Post subject: Reply with quote

depontius wrote:
when I went to the download site as instructed, it gave me a zero-length file.


Because of https site, you can use wget with --referer argument
Code:
wget --referer=http://support.amd.com  https://www2.ati.com/drivers/linux/ubuntu/amdgpu-pro-17.50-511655.tar.xz
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1346
Location: KUUSANKOSKI, Finland

PostPosted: Sun Feb 25, 2018 7:30 pm    Post subject: Reply with quote

My Desktop is building 128 packages at the moment.
After the update is over and I have edited all the neccessary files I'll be back on this topic.

@bronzeboyvn: shouldn't you run startkde within the xinitrc, not from cli? The error suggest that X hasn't started and thus $DISPLAY is not set.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3350

PostPosted: Sun Feb 25, 2018 10:31 pm    Post subject: Reply with quote

bronzeboyvn wrote:
Because of https site, you can use wget with --referer argument
Code:
wget --referer=http://support.amd.com  https://www2.ati.com/drivers/linux/ubuntu/amdgpu-pro-17.50-511655.tar.xz


Thanks, that seems to be working. I usually have https-everywhere, but just realized that it was a casualty of the firefox-58 upgrade. I need to reinstall.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
bronzeboyvn
n00b
n00b


Joined: 31 Mar 2009
Posts: 56
Location: Vietnam

PostPosted: Mon Feb 26, 2018 5:40 am    Post subject: Reply with quote

Zucca wrote:
shouldn't you run startkde within the xinitrc, not from cli? The error suggest that X hasn't started and thus $DISPLAY is not set.


I ran startkde from virtual console. Atfer execute rc-update add dbus and xdm I boot into KDE Plasma normally.
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1346
Location: KUUSANKOSKI, Finland

PostPosted: Mon Feb 26, 2018 9:15 pm    Post subject: Reply with quote

Ok. Let's continue by comparing package versions:
shellcmd: find /var/db/pkg -type f -name repository -printf "%h::" -exec cat {} \; | sed "s|/var/db/pkg/||" | grep -E "ncl|ocl" :
virtual/opencl-0-r5::gentoo
app-eselect/eselect-opencl-1.1.0-r6::gamarouns
dev-libs/opencl-clhpp-2.0.10-r1::zucca
dev-libs/ocl-icd-2.2.11-r1::gentoo-gpu
dev-libs/amdgpu-pro-opencl-17.50.511655::gentoo
... don't mind the opencl-clhpp just yet.

Then list contents of /usr/include/CL:
shellcmd: ls -lhF /usr/include/CL/ :
total 320K
-rw-r--r-- 1 root root 293K Nov 24 10:43 cl2.hpp
lrwxrwxrwx 1 root root   54 Jan 11 22:56 cl_ext.h -> ../../lib64/OpenCL/vendors/ocl-icd/include/CL/cl_ext.h
lrwxrwxrwx 1 root root   57 Jan 11 22:56 cl_gl_ext.h -> ../../lib64/OpenCL/vendors/ocl-icd/include/CL/cl_gl_ext.h
lrwxrwxrwx 1 root root   53 Jan 11 22:56 cl_gl.h -> ../../lib64/OpenCL/vendors/ocl-icd/include/CL/cl_gl.h
lrwxrwxrwx 1 root root   50 Jan 11 22:56 cl.h -> ../../lib64/OpenCL/vendors/ocl-icd/include/CL/cl.h
lrwxrwxrwx 1 root root   59 Jan 11 22:56 cl_platform.h -> ../../lib64/OpenCL/vendors/ocl-icd/include/CL/cl_platform.h
lrwxrwxrwx 1 root root   54 Jan 11 22:56 opencl.h -> ../../lib64/OpenCL/vendors/ocl-icd/include/CL/opencl.h

_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
bronzeboyvn
n00b
n00b


Joined: 31 Mar 2009
Posts: 56
Location: Vietnam

PostPosted: Tue Feb 27, 2018 4:22 am    Post subject: compare Reply with quote

Hi Zucca,

Here is my output

shellcmd: find /var/db/pkg -type f -name repository -printf "%h::" -exec cat {} \; | sed "s|/var/db/pkg/||" | grep -E "ncl|ocl" :

dev-libs/amdgpu-pro-opencl-17.50.511655::gentoo
dev-libs/ocl-icd-2.2.11::gentoo
virtual/opencl-0-r5::gentoo
app-eselect/eselect-opencl-1.1.0-r4::gentoo


shellcmd: ls -lhF /usr/include/CL/ :

total 0
lrwxrwxrwx 1 root root 45 Feb 24 12:39 cl.h -> //usr/lib64/OpenCL/global/include/CL-1.2/cl.h
lrwxrwxrwx 1 root root 49 Feb 24 12:39 cl_egl.h -> //usr/lib64/OpenCL/global/include/CL-1.2/cl_egl.h
lrwxrwxrwx 1 root root 49 Feb 24 12:39 cl_ext.h -> //usr/lib64/OpenCL/global/include/CL-1.2/cl_ext.h
lrwxrwxrwx 1 root root 48 Feb 24 12:39 cl_gl.h -> //usr/lib64/OpenCL/global/include/CL-1.2/cl_gl.h
lrwxrwxrwx 1 root root 52 Feb 24 12:39 cl_gl_ext.h -> //usr/lib64/OpenCL/global/include/CL-1.2/cl_gl_ext.h
lrwxrwxrwx 1 root root 54 Feb 24 12:39 cl_platform.h -> //usr/lib64/OpenCL/global/include/CL-1.2/cl_platform.h
lrwxrwxrwx 1 root root 49 Feb 24 12:39 opencl.h -> //usr/lib64/OpenCL/global/include/CL-1.2/opencl.h
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1346
Location: KUUSANKOSKI, Finland

PostPosted: Tue Feb 27, 2018 5:11 pm    Post subject: Reply with quote

Hmm...
Now try to select ocl-icd using "eselect opencl".
Then test some program that uses OpenCL.

Did you manage to emerge clinfo without "mesa +opencl"?
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3350

PostPosted: Tue Feb 27, 2018 5:53 pm    Post subject: Reply with quote

I see that bronzeboyvn has used only gentoo in his opencl, no overlays. I'm at the same point. I'm away from that system, so I can't give you that comparison at the moment. I can however say that I was not able to emerge clinfo. I got the include issues mentioned near the front of this thread. Tonight I'll give you the same output that's been done by zucca and bronzeboyvn.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1346
Location: KUUSANKOSKI, Finland

PostPosted: Tue Feb 27, 2018 6:35 pm    Post subject: Reply with quote

Well...
I've done some magic before...
shellcmd: equery -CN g --depth=1 =virtual/opencl-0-r5 :
 * Searching for opencl0-r5 in virtual ...
 * dependency graph for virtual/opencl-0-r5
 `--  virtual/opencl-0-r5  ~amd64
   `--  app-eselect/eselect-opencl-1.1.0-r6  (app-eselect/eselect-opencl) ~amd64
   `--  media-libs/mesa-18.0.0_rc4  (>=media-libs/mesa-9.1.6) ~amd64  [opencl abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)? abi_ppc_32(-)? abi_ppc_64(-)? abi_s390_32(-)? abi_s390_64(-)?]
   `--  dev-libs/amdgpu-pro-opencl-17.50.511655  (dev-libs/amdgpu-pro-opencl) ~amd64
   `--  dev-libs/beignet-1.3.2  (dev-libs/beignet) ~amd64
   `--  x11-drivers/nvidia-drivers-390.25  (>=x11-drivers/nvidia-drivers-290.10-r2) ~amd64
   `--  dev-util/intel-ocl-sdk-4.4.0.117-r1  (dev-util/intel-ocl-sdk) Intel-SDP license(s)
[ virtual/opencl-0-r5 stats: packages (7), max depth (1) ]
shellcmd: equery -C u mesa 2> /dev/null | tr "\n" " " :
-bindist +classic +d3d9 -debug +dri3 +egl +gallium +gbm -gles1 +gles2 +llvm +nptl -opencl +openmax +osmesa -pax_kernel -pic -unwind +vaapi -valgrind +vdpau -video_cards_i915 -video_cards_i965 -video_cards_intel -video_cards_nouveau -video_cards_r100 -video_cards_r200 -video_cards_r300 -video_cards_r600 +video_cards_radeon +video_cards_radeonsi -video_cards_virgl -video_cards_vmware -vulkan +wayland +xa +xvmc
Looks like virtual/opencl should pull mesa with +opencl, but installed one isn't compiled with it.
I may have installed virtual/opencl with --nodeps.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3350

PostPosted: Tue Feb 27, 2018 8:23 pm    Post subject: Reply with quote

When you virtual/mesa, "mesa +opencl" is one of the options, but if you already have amddpu-pro-opencl and "mesa -opencl" when virtual/opencl is installed, it won't insist on rebuilding mesa with +opencl. That is where I am right now.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3350

PostPosted: Tue Feb 27, 2018 9:57 pm    Post subject: Reply with quote

equery -CN g --depth=1 =virtual/opencl-0-r5
Code:
 * Searching for opencl0-r5 in virtual ...

 * dependency graph for virtual/opencl-0-r5
 `--  virtual/opencl-0-r5  ~amd64
   `--  app-eselect/eselect-opencl-1.1.0-r1  (app-eselect/eselect-opencl) amd64
   `--  media-libs/mesa-17.2.8  (>=media-libs/mesa-9.1.6) amd64  [opencl abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)? abi_ppc_32(-)? abi_ppc_64(-)? abi_s390_32(-)? abi_s390_64(-)?]
   `--  dev-libs/amdgpu-pro-opencl-17.50.511655  (dev-libs/amdgpu-pro-opencl) ~amd64
   `--  dev-libs/beignet-1.3.1  (dev-libs/beignet) amd64
   `--  x11-drivers/nvidia-drivers-304.137  (>=x11-drivers/nvidia-drivers-290.10-r2) amd64
   `--  dev-util/intel-ocl-sdk-4.4.0.117-r1  (dev-util/intel-ocl-sdk) [~amd64 keyword]
[ virtual/opencl-0-r5 stats: packages (7), max depth (1) ]


equery -C u mesa 2> /dev/null | tr "\n" " "
Code:
+abi_x86_32 -bindist +classic -d3d9 -debug +dri3 +egl +gallium +gbm -gles1 -gles2 +llvm +nptl -opencl -openmax +osmesa -pax_kernel -pic -unwind +vaapi -valgrind +vdpau -video_cards_i915 -video_cards_i965 -video_cards_intel -video_cards_nouveau -video_cards_r100 -video_cards_r200 -video_cards_r300 -video_cards_r600 +video_cards_radeon +video_cards_radeonsi -video_cards_virgl -video_cards_vmware -vulkan -wayland +xa +xvmc


find /var/db/pkg -type f -name repository -printf "%h::" -exec cat {} \; | sed "s|/var/db/pkg/||" | grep -E "ncl|ocl"
Code:
app-eselect/eselect-opencl-1.1.0-r1::gentoo
dev-libs/ocl-icd-2.2.11::gentoo
dev-libs/amdgpu-pro-opencl-17.50.511655::gentoo
virtual/opencl-0-r5::gentoo


ls -lhF /usr/include/CL/
Code:
total 0
lrwxrwxrwx 1 root root 45 Feb 25 19:56 cl_ext.h -> ../../lib64/OpenCL/global/include/CL/cl_ext.h
lrwxrwxrwx 1 root root 48 Feb 25 19:56 cl_gl_ext.h -> ../../lib64/OpenCL/global/include/CL/cl_gl_ext.h
lrwxrwxrwx 1 root root 44 Feb 25 19:56 cl_gl.h -> ../../lib64/OpenCL/global/include/CL/cl_gl.h
lrwxrwxrwx 1 root root 41 Feb 25 19:56 cl.h -> ../../lib64/OpenCL/global/include/CL/cl.h
lrwxrwxrwx 1 root root 43 Feb 25 19:56 cl.hpp -> ../../lib64/OpenCL/global/include/CL/cl.hpp
lrwxrwxrwx 1 root root 50 Feb 25 19:56 cl_platform.h -> ../../lib64/OpenCL/global/include/CL/cl_platform.h
lrwxrwxrwx 1 root root 45 Feb 25 19:56 opencl.h -> ../../lib64/OpenCL/global/include/CL/opencl.h

_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1346
Location: KUUSANKOSKI, Finland

PostPosted: Tue Feb 27, 2018 10:56 pm    Post subject: Reply with quote

What I see is different from my setup to your is the links under /usr/include/CL/.
You could manually change them... It might cause problems later.

Files under /usr/lib64/OpenCL/global/include/CL* directories belong to eselect-opencl.
shellcmd: eshowkw -O eselect-opencl :
Keywords for app-eselect/eselect-opencl:
            |                               s a     |       | 
            |                               p m     |       | 
            |                               a d   x |       | 
            |                               r 6   8 |       | 
            |                               c 4   6 |   u   | 
            | a a   a       p         s n r | |   | |   n   | 
            | l m   r h i   p   m s   p i i f f m f | e u s | r
            | p d a m p a p c x 6 3   a o s b b i b | a s l | e
            | h 6 r 6 p 6 p 6 8 8 9 s r s c s s p s | p e o | p
            | a 4 m 4 a 4 c 4 6 k 0 h c 2 v d d s d | i d t | o
------------+---------------------------------------+-------+----------
   1.1.0-r1 | o + o o o o o o + o o o o o o o ~ o ~ | 4 o 0 | gentoo   
   1.1.0-r2 | o ~ o o o o o o ~ o o o o o o o ~ o ~ | 4 #   | gentoo   
   1.1.0-r3 | o ~ o o o o o o ~ o o o o o o o ~ o ~ | 4 #   | gentoo   
   1.1.0-r4 | o ~ o ~ o o o o ~ o o o o o o o ~ o ~ | 5 o   | gentoo   
[I]1.1.0-r6 | o ~ o o o o ~ o ~ o o o o o o o ~ o ~ | 6 o   | gamarouns

I'm using the eselect module from gamarouns overlay. This might be the answer.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3350

PostPosted: Tue Feb 27, 2018 11:03 pm    Post subject: Reply with quote

eshowkw -O eselect-opencl
Code:
Keywords for app-eselect/eselect-opencl:
            |                             |   u   | 
            | a a         p   a         s |   n   | 
            | l m   h i   p   r m m s   p | e u s | r
            | p d a p a p c x m 6 i 3   a | a s l | e
            | h 6 r p 6 p 6 8 6 8 p 9 s r | p e o | p
            | a 4 m a 4 c 4 6 4 k s 0 h c | i d t | o
------------+-----------------------------+-------+-------
[I]1.1.0-r1 | o + o o o o o + o o o o o o | 4 o 0 | gentoo
   1.1.0-r2 | o ~ o o o o o ~ o o o o o o | 4 #   | gentoo
   1.1.0-r3 | o ~ o o o o o ~ o o o o o o | 4 #   | gentoo
   1.1.0-r4 | o ~ o o o o o ~ ~ o o o o o | 5 o   | gentoo


As mentioned, in this respect mine is all stock Gentoo. eselect opencl list
Code:
Available OpenCL implementations:
  [1]   ocl-icd *

_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
bronzeboyvn
n00b
n00b


Joined: 31 Mar 2009
Posts: 56
Location: Vietnam

PostPosted: Wed Feb 28, 2018 1:34 am    Post subject: same Reply with quote

Hi Zucca,
I have almost same output as you have after remove abi_x86_32 in whole system. There's only one difference at file headers that link to /usr/lib64/OpenCL/global/include/CL-1.2/
I can install opencl, clinfo without mesa+opencl. So "eselect opencl list" gives only one option: ocl-icd

shellcmd: equery -CN g --depth=1 =virtual/opencl-0-r5 :

* Searching for opencl0-r5 in virtual ...

 * dependency graph for virtual/opencl-0-r5
 `--  virtual/opencl-0-r5  ~amd64
   `--  app-eselect/eselect-opencl-1.1.0-r6  (app-eselect/eselect-opencl) ~amd64
   `--  media-libs/mesa-18.0.0_rc4  (>=media-libs/mesa-9.1.6) ~amd64  [opencl abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)? abi_ppc_32(-)? abi_ppc_64(-)? abi_s390_32(-)? abi_s390_64(-)?]
   `--  dev-libs/amdgpu-pro-opencl-17.50.511655  (dev-libs/amdgpu-pro-opencl) ~amd64
   `--  dev-libs/beignet-1.3.1  (dev-libs/beignet) amd64
   `--  x11-drivers/nvidia-drivers-387.22  (>=x11-drivers/nvidia-drivers-290.10-r2) amd64
   `--  dev-util/intel-ocl-sdk-4.4.0.117-r1  (dev-util/intel-ocl-sdk) [~amd64 keyword]
[ virtual/opencl-0-r5 stats: packages (7), max depth (1) ]


shellcmd: equery -C u mesa 2> /dev/null | tr "\n" " " :

-abi_x86_32 -bindist +classic +d3d9 -debug +dri3 +egl +gallium +gbm -gles1 +gles2 +llvm +nptl -opencl +openmax +osmesa -pax_kernel -pic -unwind -vaapi -valgrind +vdpau -video_cards_i915 -video_cards_i965 -video_cards_intel -video_cards_nouveau -video_cards_r100 -video_cards_r200 -video_cards_r300 -video_cards_r600 +video_cards_radeon +video_cards_radeonsi -video_cards_virgl -video_cards_vmware +vulkan +wayland +xa +xvmc


shellcmd: eshowkw -O eselect-opencl :

Keywords for app-eselect/eselect-opencl:
            |                                 |   u   | 
            | a a         p   a         s n r |   n   | 
            | l m   h i   p   r m m s   p i i | e u s | r
            | p d a p a p c x m 6 i 3   a o s | a s l | e
            | h 6 r p 6 p 6 8 6 8 p 9 s r s c | p e o | p
            | a 4 m a 4 c 4 6 4 k s 0 h c 2 v | i d t | o                                                                                                                                         
------------+---------------------------------+-------+----------                                                                                                                                 
   1.1.0-r1 | o + o o o o o + o o o o o o o o | 4 o 0 | gentoo                                                                                                                                   
   1.1.0-r2 | o ~ o o o o o ~ o o o o o o o o | 4 #   | gentoo                                                                                                                                   
   1.1.0-r3 | o ~ o o o o o ~ o o o o o o o o | 4 #   | gentoo                                                                                                                                   
   1.1.0-r4 | o ~ o o o o o ~ ~ o o o o o o o | 5 o   | gentoo                                                                                                                                   
[I]1.1.0-r6 | o ~ o o o ~ o ~ o o o o o o o o | 6 o   | gamarouns
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 2 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum