Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 5 and dual monitor set-ups
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1676
Location: Edinburgh, UK

PostPosted: Sat Feb 10, 2018 12:54 pm    Post subject: KDE 5 and dual monitor set-ups Reply with quote

Hi all,

I'm running KDE 5 (or whatever they call it) and have had trouble getting the dual monitor configuration to 'stick'. In other words, if I log out or reboot the display settings are reset to something that doesn't work. I have a script that gets xrandr to reset the monitors to be correct, but cannot get this to automatically run. If I use KDE to set it to automatically start, nothing happens, i.e., the problem is the same. I've also putting it in .xprofile, but that doesn't seem to be working either.

The xrandr script is as follows:

Code:

#!/bin/bash
xrandr \
--output DP2 --mode 1920x1080 --pos 1200x540 --rotate normal --set "Broadcast RGB" "Full" \
--output HDMI1 --off --mode 1920x1200 --pos 0x0 --rotate left


Anybody cracked this problem yet?

Best,

Alex
Back to top
View user's profile Send private message
i4dnf
Apprentice
Apprentice


Joined: 18 Sep 2005
Posts: 264
Location: Bucharest, Romania

PostPosted: Mon Feb 12, 2018 10:48 am    Post subject: Reply with quote

Systemsettings -> Startup and Shutdown -> Background Services and disable Kscreen2, problem solved. Once setup you shouldn't even need the xrandr workaround.
(caveat: it won't adjust the layout dinamycally anymore when physically [dis]connecting screens, you'll have to adjust it manually from Systemsettings)
_________________
"The only difference between me and a madman is that I am not MAD" (SALVATOR DALI)
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1676
Location: Edinburgh, UK

PostPosted: Thu Feb 15, 2018 11:44 am    Post subject: Reply with quote

i4dnf wrote:
Systemsettings -> Startup and Shutdown -> Background Services and disable Kscreen2, problem solved. Once setup you shouldn't even need the xrandr workaround.
(caveat: it won't adjust the layout dinamycally anymore when physically [dis]connecting screens, you'll have to adjust it manually from Systemsettings)


Hi there,

Thanks for responding. Turning off kscreen at system settings did not work. When I log out and log back in the screens are back to mirroring with one screen, which I have set up in portrait orientation, being in landscape.

Best,

Alex
Back to top
View user's profile Send private message
i4dnf
Apprentice
Apprentice


Joined: 18 Sep 2005
Posts: 264
Location: Bucharest, Romania

PostPosted: Sat Feb 17, 2018 12:00 pm    Post subject: Reply with quote

If this is a "static" setup, have you tried doing the necessary configuration in xorg.conf[.d], instead of relying on the xrandr script?
_________________
"The only difference between me and a madman is that I am not MAD" (SALVATOR DALI)
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1676
Location: Edinburgh, UK

PostPosted: Sat Feb 17, 2018 7:40 pm    Post subject: Reply with quote

i4dnf wrote:
If this is a "static" setup, have you tried doing the necessary configuration in xorg.conf[.d], instead of relying on the xrandr script?


I believe so. I have been trying many different things. It still doesn't hold after logging out of KDE. If I simply tell it to lock the account, there appears to be no problem.

Best,

Alex
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 254
Location: Northern California

PostPosted: Mon Feb 19, 2018 5:18 pm    Post subject: Reply with quote

I'm currently running three 4K displays in Plasma 5 without issues, using the amdgpu open-source driver.

The kscreen2 service is running. The three monitors are configured side-by-side in landscape ('Normal') orientation using the standard System Settings --> Display and Monitor --> Displays dialog. No xorg.conf or xrandr files needed.

In the past, when I've run into KDE issues with my multi-monitor setups, I've found issues in the following places:

~/.config/plasma-org.kde.plasma.desktop-appletsrc

Look for the 'plugin=org.kde.panel' "containment" (that's what KDE calls it) and make sure lastScreen=0. If not, change it and then "killall plasmashell; kstart plasmashell" to see if that fixes it.

Also, check out the kscreen.log file in:

~/.local/share/kscreen

That directory also contains randomly-named config files for kscreen2. I've had success in the past deleting those when things go wonky and letting kscreen recreate them. Unfortunately, wonky happens more often than not whenever KDE upgrades. And although I haven't had to do it recently, in the past I've occasionally made a kscreen config file read-only after kscreen made a working one in order to get it to stop moving displays around.
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1676
Location: Edinburgh, UK

PostPosted: Sun Feb 25, 2018 1:26 pm    Post subject: Reply with quote

Hi there,

Thanks for this. Unfortunately, it did not solve the problem, which is the same as ever.

Best,

Alex

radio_flyer wrote:
I'm currently running three 4K displays in Plasma 5 without issues, using the amdgpu open-source driver.

The kscreen2 service is running. The three monitors are configured side-by-side in landscape ('Normal') orientation using the standard System Settings --> Display and Monitor --> Displays dialog. No xorg.conf or xrandr files needed.

In the past, when I've run into KDE issues with my multi-monitor setups, I've found issues in the following places:

~/.config/plasma-org.kde.plasma.desktop-appletsrc

Look for the 'plugin=org.kde.panel' "containment" (that's what KDE calls it) and make sure lastScreen=0. If not, change it and then "killall plasmashell; kstart plasmashell" to see if that fixes it.

Also, check out the kscreen.log file in:

~/.local/share/kscreen

That directory also contains randomly-named config files for kscreen2. I've had success in the past deleting those when things go wonky and letting kscreen recreate them. Unfortunately, wonky happens more often than not whenever KDE upgrades. And although I haven't had to do it recently, in the past I've occasionally made a kscreen config file read-only after kscreen made a working one in order to get it to stop moving displays around.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum