Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
steam on ~amd64
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 588
Location: Sota algun pi o alzina...

PostPosted: Sat Dec 16, 2017 11:55 am    Post subject: Reply with quote

this is my steam :lol: https://i.imgur.com/RD0ea6V.png no way!

Code:

$ glxinfo | egrep -i 'opengl|opencl'
OpenGL vendor string: X.Org
OpenGL renderer string: AMD Radeon (TM) RX 470 Graphics (POLARIS10 / DRM 3.19.0 / 4.14.13-gentoo, LLVM 5.0.1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.3.1
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.3.1
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.3.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

_________________
--Intel i5 6600 --GA-Z170-HD3P --Ripjaws V 2x8 2400 --Radeon RX 470 G1 4G --Gentoo & Windows


Last edited by papu on Wed Jan 17, 2018 9:59 am; edited 2 times in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5286

PostPosted: Sat Dec 16, 2017 7:21 pm    Post subject: Reply with quote

Works for me, when run as STEAM_RUNTIME=1 STEAM_RUNTIME_PREFER_HOST_LIBRARIES=1 steam. Other combinations I've tried usually leave it stuck with nothing on screen and chrome processes stuck in the background.
Back to top
View user's profile Send private message
seijikun
n00b
n00b


Joined: 10 Jan 2016
Posts: 5

PostPosted: Sun Jan 07, 2018 12:15 pm    Post subject: Reply with quote

@papu Have you found a fix for this? I'm having the same problem.
When I somehow manage to login, the main window looks like this:
https://imgur.com/a/x4axl

Using the tray-icon to enable the Big Picture mode causes Steam to segfault.
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 588
Location: Sota algun pi o alzina...

PostPosted: Sun Jan 07, 2018 5:52 pm    Post subject: Reply with quote

seijikun wrote:
@papu Have you found a fix for this? I'm having the same problem.
When I somehow manage to login, the main window looks like this:
https://imgur.com/a/x4axl

Using the tray-icon to enable the Big Picture mode causes Steam to segfault.


not fix! when starts via console it shows information like this:

Code:
~ $ steam
Running Steam on gentoo 1.0.0.54-r4 64-bit
STEAM_RUNTIME is enabled by the user
Pins up-to-date!
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
/usr/share/themes/Breeze/gtk-2.0/widgets/entry:70: error: unexpected identifier 'direction', expected character '}'

(steam:4604): Gtk-WARNING **: No s'ha trobat el motor de tema al module_path: «adwaita»,
/usr/share/themes/Breeze/gtk-2.0/widgets/styles:36: error: invalid string constant "combobox_entry", expected valid string constant
/usr/share/themes/Breeze/gtk-2.0/widgets/entry:70: error: unexpected identifier 'direction', expected character '}'

(steam:4604): Gtk-WARNING **: No s'ha trobat el motor de tema al module_path: «adwaita»,
/usr/share/themes/Breeze/gtk-2.0/widgets/styles:36: error: invalid string constant "combobox_entry", expected valid string constant
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Installing breakpad exception handler for appid(steam)/version(1513371133)
Generating new string page texture 12: 48x256, total string texture memory is 49,15 KB
Generating new string page texture 13: 256x256, total string texture memory is 311,30 KB
Generating new string page texture 14: 128x256, total string texture memory is 442,37 KB
Local Device Found
  type: 045e 028e
  path: sdl://0
  serial_number:
  Manufacturer:
  Product:      XInput Controller
  Release:      114
  Interface:    -1

!! Steam controller device opened for index 0.
Steam Controller reserving XInput slot 0
Couldn't initialize virtual gamepad: Couldn't open /dev/uinput for writing
Installing breakpad exception handler for appid(steam)/version(1513371133)
Controller 0 connected, configuring it now...
Installing breakpad exception handler for appid(steam)/version(1513371133)
[0107/185128.346923:ERROR:web_plugin_impl.cc(38)] Widevine registration is not supported after context initialization
WARNING: radv is not a conformant vulkan implementation, testing use only.
!! Controller 0 attributes:
  Type: 31
  ProductID: 654
  Serial: Awaiting_Logon
  Capabilities: 00000003
  Firmware Version: 0
  Firmware Build Time: 2147483647 (dt, 19 gen 2038 03:14:07 GMT)
  Bootloader Build Time: 2147483647 (dt, 19 gen 2038 03:14:07 GMT)
Loaded Config for Local Override Path for App ID 413080: /home/papu/.local/share/Steam//controller_base/empty.vdf
Controller 0 mapping uses xinput : false
[0107/185129.347455:ERROR:web_plugin_impl.cc(38)] Widevine registration is not supported after context initialization
[0107/185130.348371:ERROR:web_plugin_impl.cc(38)] Widevine registration is not supported after context initialization
[0107/185131.348986:ERROR:web_plugin_impl.cc(38)] Widevine registration is not supported after context initialization
Setting breakpad minidump AppID = 769
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561197960265728 [API loaded no]
Installing breakpad exception handler for appid(steam)/version(1513371133)
[0107/185132.350457:ERROR:web_plugin_impl.cc(38)] Widevine registration is not supported after context initialization
Installing breakpad exception handler for appid(steam)/version(1513371133)

_________________
--Intel i5 6600 --GA-Z170-HD3P --Ripjaws V 2x8 2400 --Radeon RX 470 G1 4G --Gentoo & Windows
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1595
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Thu Jan 11, 2018 9:52 pm    Post subject: Reply with quote

seijikun wrote:
@papu Have you found a fix for this? I'm having the same problem.
When I somehow manage to login, the main window looks like this:
https://imgur.com/a/x4axl


I get the same here with my amdgpu setup, hadn't run steam i a while with the nvidia card so I'm not sure if it was still working.

I do see the text of the windows at times but it disappears instantly as soon as I mouse the cursor over it. Also the cursor in the username and password dialogs is visible at times. Seems like a gtk or qt or whatever they are using. Doesn't matter if it's with steamruntime or not.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 588
Location: Sota algun pi o alzina...

PostPosted: Wed Jan 24, 2018 12:12 pm    Post subject: Reply with quote

yesterday, i got media-libs/mesa-18.0.0_rc2 and seems that steam client are visible right now :roll:

Code:
~ $ glxinfo | egrep -i opengl
OpenGL vendor string: X.Org
OpenGL renderer string: AMD Radeon (TM) RX 470 Graphics (POLARIS10 / DRM 3.19.0 / 4.14.15-gentoo, LLVM 5.0.1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.0-rc2
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.0-rc2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.0.0-rc2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10


https://i.imgur.com/NDDhCID.png
_________________
--Intel i5 6600 --GA-Z170-HD3P --Ripjaws V 2x8 2400 --Radeon RX 470 G1 4G --Gentoo & Windows
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1595
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Wed Jan 24, 2018 7:31 pm    Post subject: Reply with quote

papu wrote:
yesterday, i got media-libs/mesa-18.0.0_rc2 and seems that steam client are visible right now :roll:

https://i.imgur.com/NDDhCID.png


Same here, just tried it and it is visible again with the mesa-18 rc2.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
mikefot
Guru
Guru


Joined: 19 Nov 2014
Posts: 351

PostPosted: Wed Feb 07, 2018 6:15 pm    Post subject: Reply with quote

Dear All,

Excuse my dumbness here, but can I summarise what you are meant to do nowadays to make steam run here.

Step 1:

You delete these library files:

Code:
rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6
rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1
rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libgcc_s.so.1
rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libstdc++.so.6
rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libxcb.so.1
rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgpg-error.so.0


BUT

like zombies, some keep coming back to life to mess things up so you do

Code:
export LIBGL_DRIVERS_PATH=/usr/lib32/mesa:/usr/lib64/mesa
export LD_LIBRARY_PATH=/usr/lib32/:/usr/lib64/


and there some other things you need to worry about as well:

e.g. masked emul-linux (what is this?); needing to use wine (why?) and mesa version voodoo concerns etc.

I am running an amd64 gentoo testing install on a kaveri box - I get the radeonsi errors etc.


Comments appreciated here.

Regards

Michael Fothergill
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1564
Location: /mnt/Gentoo/Europe

PostPosted: Tue Feb 13, 2018 11:45 am    Post subject: Reply with quote

Steam 2018

Hi,

For some reason (probably some changes), my steam on Gentoo doesn't work anymore (it used to be fine last years). I use stable amd64, and do just systenm update,

I have a messgae:
you are missing the following 32 bit libraries and steam may not run libdrm.so.2

What should I do? Unistall the old version and install a new one? I have a layman version (I think). Or maybe I should add some USE flags like was told here, but it says "This section can be skipped when using the steam-launcher ebuild from an overlay."?
https://wiki.gentoo.org/wiki/Steam

Code:
# emerge --info
Portage 2.3.19 (python 3.5.4-final-0, default/linux/amd64/17.0/desktop/plasma, gcc-6.4.0, glibc-2.25-r10, 4.9.76-gentoo-r1 x86_64)
=================================================================
System uname: Linux-4.9.76-gentoo-r1-x86_64-Intel-R-_Core-TM-_i5-2450M_CPU_@_2.50GHz-with-gentoo-2.4.1
KiB Mem:     8080212 total,   3766548 free
KiB Swap:    9484148 total,   9484148 free
Timestamp of repository gentoo: Tue, 13 Feb 2018 11:30:01 +0000
Head commit of repository gentoo: 795f9a3fc61cf0ddeabfd87363af3f9f66f04794
Head commit of repository steam-overlay: 46d2624c5f248bf28e25c25e172e60c2eb988e5f

sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.4-r1::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.12::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo, 6.4.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r10::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:

cg
    location: /var/lib/layman/cg
    masters: gentoo
    priority: 50

steam-overlay
    location: /usr/local/steam-overlay
    sync-type: git
    sync-uri: https://github.com/anyc/steam-overlay/
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://mirrors.soeasyto.com/distfiles.gentoo.org/ http://104.19.136.75/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pl en en_GB"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/mnt/twardy/tmp"
USE="12bit X a52 aac acl acpi activities alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit crypt cuda cups cxx cycles dbus declarative dri dts dvd dvdr emboss encode exif fam ffmpeg fftw flac fortran freesound frei0r gdbm gif gpm gtk iconv ipv6 jpeg kde kipi kwallet ladspa lcms ldap libnotify libsamplerate mad mng modules mp3 mp4 mpeg multilib ncurses nls nptl nvenc ogg openal opencv opengl openimageio openmp pam pango pcre pdf phonon plasma png policykit ppds qml qt3support qt5 readline rtaudio scanner sdl seccomp semantic-desktop spell ssl startup-notification svg tcpd theora tiff truetype udev udisks unicode upower usb uvm vaapi vdpau vorbis widgets wxwidgets x264 x265 xattr xcb xcomposite xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" L10N="pl en en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby22 ruby23" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="intel nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
rh
n00b
n00b


Joined: 19 Sep 2006
Posts: 57

PostPosted: Sat Feb 24, 2018 5:14 pm    Post subject: Reply with quote

Xywa wrote:

I have a messgae:
you are missing the following 32 bit libraries and steam may not run libdrm.so.2

What should I do? Unistall the old version and install a new one? I have a layman version (I think). Or maybe I should add some USE flags like was told here, but it says "This section can be skipped when using the steam-launcher ebuild from an overlay."?
https://wiki.gentoo.org/wiki/Steam


I order to compile 32-bit version of libdrm, add this to your use flags:
Code:
x11-libs/libdrm abi_x86_32


However, setting the 32-bit ABI globally is an option I would personnally prefer. This goes to make.conf
Quote:
ABI_X86="64 32"


First one lets you control which libraries are build with 32-bit support per package, saving some compiling time and disk space. Second one asks 32-bit support for all packages, saving time with troubleshooting and administrating per package lists.
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 588
Location: Sota algun pi o alzina...

PostPosted: Sun Apr 08, 2018 2:06 pm    Post subject: Reply with quote

papu wrote:
yesterday, i got media-libs/mesa-18.0.0_rc2 and seems that steam client are visible right now :roll:

Code:
~ $ glxinfo | egrep -i opengl
OpenGL vendor string: X.Org
OpenGL renderer string: AMD Radeon (TM) RX 470 Graphics (POLARIS10 / DRM 3.19.0 / 4.14.15-gentoo, LLVM 5.0.1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.0-rc2
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.0-rc2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.0.0-rc2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10


https://i.imgur.com/NDDhCID.png


steam is hidden again! wtf

Code:
~ $ glxinfo | egrep -i 'opengl'
OpenGL vendor string: X.Org
OpenGL renderer string: AMD Radeon (TM) RX 470 Graphics (POLARIS10 / DRM 3.23.0 / 4.15.15-gentoo, LLVM 6.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.0
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.0
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.0.0
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:


:(
_________________
--Intel i5 6600 --GA-Z170-HD3P --Ripjaws V 2x8 2400 --Radeon RX 470 G1 4G --Gentoo & Windows
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1564
Location: /mnt/Gentoo/Europe

PostPosted: Mon Apr 09, 2018 3:55 pm    Post subject: Reply with quote

Hi,

I did everything from Wiki list: https://wiki.gentoo.org/wiki/Steam#Dependencies
Quote:
Create the following set of required Steam dependencies:

and my Steam works perfectly now.
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 588
Location: Sota algun pi o alzina...

PostPosted: Tue Apr 10, 2018 7:12 pm    Post subject: Reply with quote

i find the solution on my system, that is compiling steam-launcher with no steamruntime, now my steam is again visible and working.

i get the idea from the README.md of https://github.com/anyc/steam-overlay

Code:

~ $ cat /etc/portage/package.use/steam
games-util/steam-client-meta   flash steamfonts trayicon -steamruntime
games-util/steam-launcher      -steamruntime

~ $ emerge -a steam-launcher

~ $ steam &
...
Running Steam on gentoo  64-bit
STEAM_RUNTIME is disabled by the user
...



https://i.imgur.com/3PyJqdm.png


p.d: for more information i am using
- ACCEPT_KEYWORDS="~amd64"
- ABI_X86="64 32"
- steam-overlay via layman
- kde-plasma

:wink:
_________________
--Intel i5 6600 --GA-Z170-HD3P --Ripjaws V 2x8 2400 --Radeon RX 470 G1 4G --Gentoo & Windows
Back to top
View user's profile Send private message
siebz0r
n00b
n00b


Joined: 18 Feb 2009
Posts: 25

PostPosted: Fri Apr 20, 2018 2:53 pm    Post subject: Reply with quote

I got the invalid pointer message and kept getting it no matter what fix I attempted:

Code:

Running Steam on gentoo 1.0.0.54-r4 64-bit                                                                 
STEAM_RUNTIME is disabled by the user                                                                     
Installing breakpad exception handler for appid(steam)/version(0)                                         
*** Error in `/home/siebz0r/.local/share/Steam/ubuntu12_32/steam': munmap_chunk(): invalid pointer: 0xf7f7f6f0 ***


I finally managed to solve it; I had a custom locale instead of the en_US.UTF-8 but apparently this locale is absolutely necessary.

/etc/locale.gen:
Code:
en_US.UTF-8 UTF-8

Then run
Code:
locale-gen


Found that here: https://wiki.archlinux.org/index.php/Steam#Installation
Hope this helps someone. :D
Back to top
View user's profile Send private message
Atha
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 159

PostPosted: Fri May 04, 2018 8:26 pm    Post subject: Reply with quote

Xywa wrote:
Hi,

I did everything from Wiki list: https://wiki.gentoo.org/wiki/Steam#Dependencies
Quote:
Create the following set of required Steam dependencies:

and my Steam works perfectly now.


Same for me. Followed the manual installation path after setting up the dependencies and it works just fine.

Steam is an x86 (32-Bit) Linux program, so it cannot work out-of-the-box on amd64.

Which profile are you using? Mine is 17.1:
Code:
$ eselect profile show
Current /etc/portage/make.profile symlink:
  default/linux/amd64/17.1/desktop/plasma/systemd

Even though it is marked experimental, the new multilib approach seems to work great. I didn't have any problems with steam and steam games.

Maybe older profiles that have /lib32 and /usr/lib32 instead of /lib and /usr/lib have issues, but profile 17.1 does not. (You might want to follow this thread if you're interested in migrating...)

I think everyone understands that steam will only really be of use if you have the required graphics card capabilites, i.e. graphics drivers and OpenGL implementation (including S3TC, now included in mesa). I can confirm that amdgpu (from the gentoo-sources, currently 4.16.6) and mesa (currently I use 18.0.2, even though 18.1-rc is out already...) work well with a Radeon RX Vega 64 graphics card. I don't know about older AMD/ATI graphics cards or nvidia...

Fixes: links, S3TC
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum