Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bräuchte Hilfe beim Testen von Profil 17.1 experimentell
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 109

PostPosted: Mon Jan 08, 2018 2:50 pm    Post subject: Bräuchte Hilfe beim Testen von Profil 17.1 experimentell Reply with quote

Hallöchen

Also ich war so frei über die W-Ferien das 17.1 Profil mal zu testen.
Habe mich auch an die Anleitung gehalten was in der Gentoo-News stand.
Leider hab ich irgendwo einen Knopf im System ich bekomme jetzt immer diese Fehlermeldung.

Code:
Beginning configuration for readline-7.0 for i686-pc-linux-gnu

checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc -m32
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... configure: error: in `/tmp/portage/sys-libs/readline-7.0_p3/work/readline-7.0-abi_x86_32.x86':
configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details

!!! Please attach the following file when seeking support:
!!! /tmp/portage/sys-libs/readline-7.0_p3/work/readline-7.0-abi_x86_32.x86/config.log
 * ERROR: sys-libs/readline-7.0_p3::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *               ebuild.sh, line  124:  Called src_configure
 *             environment, line 2774:  Called multilib-minimal_src_configure
 *             environment, line 1926:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *             environment, line 2140:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *             environment, line 1856:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *             environment, line 1854:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *             environment, line  371:  Called multilib-minimal_abi_src_configure
 *             environment, line 1920:  Called multilib_src_configure
 *             environment, line 2366:  Called econf '--cache-file=/tmp/portage/sys-libs/readline-7.0_p3/work/readline-7.0-abi_x86_32.x86/config.cache' '--docdir=$(datarootdir)/doc/readline-7.0_p3' '--with-curses' '--disable-static'
 *        phase-helpers.sh, line  665:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *         die "$@"
 *
 * If you need support, post the output of `emerge --info '=sys-libs/readline-7.0_p3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/readline-7.0_p3::gentoo'`.
 * The complete build log is located at '/tmp/portage/sys-libs/readline-7.0_p3/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/sys-libs/readline-7.0_p3/temp/environment'.
 * Working directory: '/tmp/portage/sys-libs/readline-7.0_p3/work/readline-7.0-abi_x86_32.x86'
 * S: '/tmp/portage/sys-libs/readline-7.0_p3/work/readline-7.0'

>>> Failed to emerge sys-libs/readline-7.0_p3, Log file:


Es war bis auf den Test mit dem 17.1 Profil ein stable Installation.
Vorher ist auch alles ohne Probleme durchgelaufen.

Bin von default/linux/amd64/13.0/desktop auf default/linux/amd64/17.0/desktop gewechselt und dachte ich probier mal default/linux/amd64/17.1/desktop.

Die gute Nachricht ist man kann damit noch arbeiten die schlechte man kann eben nichts installieren wegen der Fehlermeldung.
Wenn irgendwelche weiteren Infos benötigt werden bitte sagen, ich werde sie schnellst möglich dann reinstellen.

Danke schon mal für die Hilfestellung
lg
Schatti
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 109

PostPosted: Tue Jan 09, 2018 6:03 pm    Post subject: Reply with quote

Hab heute versucht rauszufinden wo ich das mit multilib (siehe oben Fehlermeldung) einstellen könnten außer mit den Profilen (no-multilib).

Hat wer mehr Ahnung wie ich den Fehler beheben könnte !? Hoffe doch nicht alles neu machen zu müssen 8O
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2077
Location: Germany

PostPosted: Wed Jan 10, 2018 8:46 pm    Post subject: Reply with quote

Hi Schattenschlag,

ich hab jetzt zuerst nicht geantwortet weil ich dachte ich kann dir nich helfen bezüglich experimentel 17.1 Profile.

ABER.

Ich vermute du hast den Wechsel zu gcc-6.4.0 nicht ordentlich gemacht und deswegen keine funktionierende compiler Umgebung:

Code:
checking whether we are cross compiling... configure: error: in `/tmp/portage/sys-libs/readline-7.0_p3/work/readline-7.0-abi_x86_32.x86':
configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.


Kann aber auch sein das irgendeine cross-compiling Setting falsch ist und du da noch mal das wiki zum thema cross compile anschauen solltest.

Wie auch immer ich glaub du hast einfach das gcc-upgrade von 5.x auf 6.x noch nicht ordentlich vollzogen. Geh noch mal upgrading gcc durch und schau ob du insbesondere an den Revdep-rebuild Befehl gedacht hast:

Code:
#revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc


Kopieren nicht abtippen. Ich hab bei einem System emerge zerschossen weil ich das abgetippt hatte, die falschen Anführungs-Zeichen verwendet hatte und revdep-rebuild meinte es gibt nix zu tun... ;) Aber den Bug hast du nicht sonst, hätte emerge autoclean dir bei dem fehlen von dem revdep rebuild wahrscheinlich auch portage zerlegt. Ist ne andere Story die ich zuende erzählt hab im profil 17 (nachbar) Thread.

Was vielleicht auch einfach nur nicht geklappt hat ist dein readline-7.0 update und das hat sich mit sandbox verschluckt. probiere mal readline neu zu bauen und zu gucken ob es da beim emerge zu einem Block auch mit sandbox und man-pages kommt.

Den dann aufzulösen.

Gut möglich das da das Problem ist und gar nicht in dem profile 17.1 schritt. # source /etc/profile nach dem Profil-Wechsel hast du ja auch ausgeführt oder?

Grüße

Chris
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 109

PostPosted: Fri Jan 12, 2018 5:33 pm    Post subject: Reply with quote

Hi ChrisJumper

Habe jetzt deinen Tipp ausprobiert leider ohne wirklichen Erfolg :(
Glaube ich habe da echt was zerschossen mit dem 17.1 Profil.

Der Befehl von dir bringt das zum Tage

Code:
stahlwerk13 /home/skull # revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please file bugs at: https://bugs.gentoo.org/
 * Collecting system binaries and libraries
 * Checking dynamic linking consistency
 * Assign files to packages
   * Warning: "app-crypt/truecrypt-7.1a" ebuild not found..
   !! Could not find ebuild for app-crypt/truecrypt:0
   !! Could not find ebuild for app-crypt/truecrypt
   Installed package: app-crypt/truecrypt is no longer available
   * Warning: "sys-devel/gcc-5.4.0-r3" ebuild not found..
   * Warning: "media-gfx/gimp-2.9.8" ebuild not found..
   * Warning: "www-plugins/adobe-flash-28.0.0.126" ebuild not found..
   * Warning: "media-video/vlc-2.2.8" ebuild not found..

emerge --exclude gcc --oneshot --complete-graph=y media-libs/audiofile:0/1 dev-libs/liborcus:0/0.12 dev-cpp/gconfmm:0 media-libs/x265:0/102 sys-apps/groff:0 app-text/libwpg:0.3 media-libs/flac:0 dev-libs/elfutils:0 app-i18n/uchardet:0 app-text/libwps:0 media-libs/libcdr:0 dev-lang/swig:0 dev-libs/icu:0/58.2 net-print/cups-filters:0 media-gfx/exiv2:0/26 sys-devel/llvm:4 dev-libs/gmp:0/10.4 dev-cpp/libcmis:0.5 dev-cpp/gtkmm:2.4 app-arch/p7zip:0 x11-libs/wxGTK:2.8 dev-java/icedtea-web:0 x11-libs/vte:2.91 sys-devel/clang:4 media-libs/libvisio:0 dev-cpp/glibmm:2 dev-lang/spidermonkey:0/mozjs185 media-libs/tiff:0 media-sound/id3v2:0 sys-devel/gcc:5 dev-util/re2c:0 media-sound/audacious:0 app-office/libreoffice:0 dev-libs/libixion:0/0.12 media-libs/libmodplug:0 sys-devel/gcc:7.2.0 app-text/libabw:0 media-gfx/gthumb:0 media-gfx/gimp:2 dev-util/ninja:0 media-libs/mesa:0 dev-libs/libcdio:0/15 dev-util/codeblocks:0 app-text/hunspell:0/1.6 media-libs/libmp4v2:0 dev-util/gperf:0 media-libs/libopenraw:0 dev-util/cmake:0 net-libs/libproxy:0 media-sound/pavucontrol:0 app-text/mythes:0 media-libs/gegl:0.3 dev-cpp/clucene:1 sys-libs/compiler-rt-sanitizers:4.0.1 media-sound/pulseaudio:0 sys-libs/db:5.3 media-libs/lensfun:0 media-libs/webrtc-audio-processing:0 www-plugins/adobe-flash:2 app-text/libodfgen:0 sys-block/gparted:0 app-text/libstaroffice:0 www-client/seamonkey:0 media-plugins/gst-plugins-modplug:1.0 sys-block/thin-provisioning-tools:0 dev-cpp/cairomm:0 media-gfx/graphite2:0 app-text/libetonyek:0 dev-libs/libical:0/2 net-p2p/rtorrent:0 dev-libs/libpcre:3 media-libs/gexiv2:0 dev-libs/libsigc++:2 sys-apps/gptfdisk:0 media-libs/libpagemaker:0 x11-libs/wxGTK:3.0 app-text/opensp:0 app-text/openjade:0 media-tv/me-tv:0 media-gfx/darktable:0 media-libs/ilmbase:0/11 dev-libs/librevenge:0 app-text/libwpd:0.10 dev-cpp/gtkmm:3.0 media-video/vlc:0 media-libs/libzmf:0 dev-cpp/atkmm:0 dev-util/cppunit:0 app-text/libmspub:0 media-libs/glu:0 dev-cpp/pangomm:1.4 mail-mta/nullmailer:0 media-libs/openexr:0/21 media-gfx/gmic:0 www-client/firefox:0 media-plugins/audacious-plugins:0 media-libs/libvpx:0/3 app-crypt/gpgme:1/11 app-portage/eix:0 net-misc/tigervnc:0 x11-libs/fltk:1 dev-cpp/libxmlpp:2.6 media-libs/libraw:0/16 sys-devel/gettext:0 sys-devel/gcc:6.4.0 media-libs/id3lib:0 net-libs/gnutls:0/30 media-gfx/graphicsmagick:0/1.3 app-text/poppler:0/68 media-libs/libfreehand:0 sys-libs/ncurses:0/6 net-libs/libtorrent:0 media-video/ffmpegthumbnailer:0 dev-libs/boost:0/1.63.0 app-text/libmwaw:0 media-libs/taglib:0 net-print/cups:0 app-text/libebook:0 app-text/qpdf:0/13 dev-libs/pugixml:0
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "sys-devel/gcc:5".


hab es auch mit der Version gcc-7.2 probiert gleiches spiel ...

Hmm ich werd Samstag noch mal versuchen muss leider jetzt in den Nachtdienst, danke aber fürs helfen ...


lg
schatti
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2077
Location: Germany

PostPosted: Sat Jan 13, 2018 7:11 pm    Post subject: Reply with quote

Ich hoffe ich sag dir da nichts falsches, wenn ich bei mir selber was kaputt mache tut mir das nicht so weh als wenn ich jemanden einen schlechten Tipp gebe.


Code:
* Assign files to packages
   * Warning: "app-crypt/truecrypt-7.1a" ebuild not found..
   !! Could not find ebuild for app-crypt/truecrypt:0
   !! Could not find ebuild for app-crypt/truecrypt
   Installed package: app-crypt/truecrypt is no longer available
   * Warning: "sys-devel/gcc-5.4.0-r3" ebuild not found..
   * Warning: "media-gfx/gimp-2.9.8" ebuild not found..
   * Warning: "www-plugins/adobe-flash-28.0.0.126" ebuild not found..
   * Warning: "media-video/vlc-2.2.8" ebuild not found..


Aber es kann halt sein das man Pakete noch installiert hat, die in aktuelleren Portage Versionen nicht mehr enthalten sind. Dann greift der Versuch von Revdep Rebuild ins Leere diese Pakete erneut zu installieren. Es fehlt dem quasi das Ebuild dazu.

Du hast jetzt verschiedene Möglichkeiten. Wenn du es besser weißt ob du das Paket noch brauchst oder nicht, kannst du es mit # emerge -C trotzdem entfernen. Vorher sollte man das mit dem kleinen c probieren weil, das kleine c prüft ob dein World-File irgendwo das Pakete noch als Abhängigkeit hat und entfernt es dann doch nicht. Mit dem großen C ignorierst du das und entfernst das trotzdem.

Bei veralteten Paketen kann es ja auch noch sein das du Overlays hast oder andere Pakete die das Paket noch in der Version brauchen etc.

Du kannst der Sache jetzt nach gehen, schaust du dir mit eix die einzelnen Pakete an findest du z.B das von media-gfx/gimp-2.9.8 nur eine Version im Portage Tree ist die 2.9.8-r1 lautet, deswegen kann revdep-rebuild das Paket nicht finden.

Wenn du jetzt zuvor gimp aktualisierst auf 2.9.8-r1 (emerge -u gimp) und dann den revdep-rebuild Befehl noch mal ausführst verschwindet das aus der Warnung Liste und es geht los.

Bei manchen Paketen ist das einfach weil man weiß das eine Anwendung wie GIMP oder media-video/vlc eine einzelne Anwendung ist die wahrscheinlich nicht von anderen Bibliotheken oder Paketen gebraucht wird um etwas zu bauen oder kompilieren. Wenn du diese aus deinem System entfernst weißt du manch mal schon intuitiv wo das genutzt wird und kannst zum Beispiel ausschließen das dein libreoffice Writer nicht mehr geht, oder das dein email-programm nicht mehr geht wenn du das Paket entfernst. Eigentlich sogar ziemlich genau das du das Pakete auch einfach Aktualisieren kannst. Und damit ist das Problem auch schon aus der Welt. Weil bei manchen Paketen ersetzt ja eine Version die andere und die sind dann nicht in Slots die sich gegenseitig blocken. Wohl kann es sein das neuere Versionen andere Abhängigkeiten ziehen die du dann auch managen musst. Aber das siehst du dann ja auch. In der Regel ist der Stable Tree immer so ausgewogen das du wenig manuell eingreifen musst. Je mehr Unstable markierte Pakete oder welche aus Overlays dessen Natur du nicht so gut kennst, in deinen Portage tree ziehst je... ich sag mal "fummeliger" kann dein System werden. Wenn man weiß was man macht ist das egal weil man bestimmte Fälle ausschließen kann. Außerdem sagt Portage einem in der Regel ja bevor ein Paket installiert wird ob es zu einem Block kommt oder man andere Unstable-Pakete dafür unter package.keywords Listen muss.

Alternativ könntest du auch ganz am Ende von dem Revdep-Rebuild Befehl, diese mehrere Zeichen lange Zeile (oder das wirkt wie ein großer Abschnitt) mit dem emerge Aufruf verwenden und diese Pakete die hier den Block verursachen raus nehmen. Dann läuft das Revdep Rebuild in der Regel durch und du musst dich manuell nachträglich um diese acht Pakete kümmern.

Wichtig ist dabei das keine Pakete dabei sind die dein System oder Buildsystem zerschießen. Ein Beispiel: Wäre wenn du noch keinen neueren gcc installiert hättest und nur gcc-5.4.0-r3, dann wäre es wirklich schlecht wenn du den mit emerge -C entfernst. Schau auch ob du den compiler, also in dem Fall am besten 7.2 oder 6.4 nicht nur per emerge installiert hast, sondern ihn per gcc-config auch ausgewählt hast so das er per Sternchen aktiv ist oder ein gcc -v dir anzeigt das du den auch gerade verwendest. Damals musste man noch ein env-update vor dem source /etc/profile machen, ich weiß nicht mehr warum das aktuell nicht der fall ist.

Vielleicht macht das gcc-config jetzt automatisch oder aktualisiert die anderen Fenster/Sitzungen automatisch über die Aktualisierung der Umgebung.

Vielleicht kennt ja jemand ein Parameter den man noch an revdep-rebuild übergeben kann damit es diese Pakete automatisch erst mal ignoriert. Aber so funktioniert das nicht, das ist wie mit anderen Problemen die emerge nicht von alleine Auflösen kann und Entscheidung des Admin.
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 109

PostPosted: Tue Jan 23, 2018 8:55 am    Post subject: Reply with quote

Hab jetzt alles noch einmal probiert also die ganzen Tipps.
Leider ohne Erfolg es kommt immer und immer wieder die gleiche Fehlermeldung.
Werd dies gleich zum Anlass nehmen und mein System mal neu installieren.

Danke aber für die Hilfestellung

mfg
schatti
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2097
Location: Bardowick, Germany

PostPosted: Tue Jan 23, 2018 3:03 pm    Post subject: Reply with quote

nicht so eilig. Ganz unten nach deinem revdep-rebuild versuch steht's doch:
Code:
emerge: there are no ebuilds to satisfy "sys-devel/gcc:5"
Also 'emerge --unmerge sys-devel/gcc:5' durchführen, und dann klappt das auch mit dem revdep-rebuild. ;-)

Es wäre auch gut zu schauen, was 'gcc-config -l' ausgibt.
_________________
elogind
CygwinOnSteroids
"A conservative is a man who is too cowardly to fight and too fat to run."
-- Elbert Hubbard
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3347
Location: Germany

PostPosted: Wed Jan 24, 2018 4:24 am    Post subject: Reply with quote

Schattenschlag wrote:
Code:
Beginning configuration for readline-7.0 for i686-pc-linux-gnu

checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc -m32
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... configure: error: in `/tmp/portage/sys-libs/readline-7.0_p3/work/readline-7.0-abi_x86_32.x86':
configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details

!!! Please attach the following file when seeking support:
!!! /tmp/portage/sys-libs/readline-7.0_p3/work/readline-7.0-abi_x86_32.x86/config.log
 * ERROR: sys-libs/readline-7.0_p3::gentoo failed (configure phase):
 *   econf failed

Schau bitte mal ob der benötigte
CONFIG_IA32_EMULATION=y
Support im aktuell laufenden Kernel vorhanden ist.
Zudem prüfe bitte auch ob
Code:
eselect binutils list
auf eine aktuelle vorhandene Version gesetzt ist.
Wenn da noch kein Fehler zu finden ist, dann poste (im pastebin) bitte auch mal die "emerge --info"-Ausgabe, und das
/tmp/portage/sys-libs/readline-7.0_p3/work/readline-7.0-abi_x86_32.x86/config.log

/edit:
Und bitte die Ausgabe von
Code:
emerge -pvO binutils gcc sandbox
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 109

PostPosted: Mon Jan 29, 2018 12:01 pm    Post subject: Reply with quote

CONFIG_IA32_EMULATION=y

Code:

Symbol: IA32_EMULATION [=y]                                                                   
   Type  : boolean                                                                               
   Prompt: IA32 Emulation                                                                         
     Location:                                                                                   
   (1) -> Executable file formats / Emulations                                                   
     Defined at arch/x86/Kconfig:2799                                                             
     Depends on: X86_64 [=y]                                                                     
     Selects: ARCH_WANT_OLD_COMPAT_IPC [=y] && BINFMT_ELF [=y] && COMPAT_BINFMT_ELF [=y] && COM


eselect binutils list

Code:
eselect binutils list
 [1] x86_64-pc-linux-gnu-2.29.1 *



emerge --info

https://pastebin.com/eeyV1nhc

config log von readline finde ich nicht !? kein ordner oder irgendwelche logs im tmp Ordner.
eix -s readline gibt aber das hier aus

Code:
[U] sys-libs/readline
     Verfügbare Versionen:   
     (4)    4.3_p5
     (5)    5.2_p14
     (0)    6.3_p8-r3 7.0_p3(0/7)
       {static-libs utils ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installierte Versionen: 6.3_p8-r3(15:05:11 03.12.2017)(-static-libs -utils ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")
     Startseite:             http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
     Beschreibung:           Another cute console display library


emerge -pvO binutils gcc sandbox

Code:



emerge -pvO binutils gcc sandbox

Performing Global Updates
(Could take a couple of minutes if you have a lot of binary packages.)
  .='update pass'  *='binary update'  #='/var/db update'  @='/var/db move'
  s='/var/db SLOT move'  %='binary move'  S='binary SLOT move'
  p='update /etc/portage/package.*'
/usr/portage/profiles/updates/1Q-2016............................................
/usr/portage/profiles/updates/2Q-2016.............................................................
/usr/portage/profiles/updates/3Q-2016.........................
/usr/portage/profiles/updates/4Q-2016...................................
/usr/portage/profiles/updates/1Q-2017.....................................
/usr/portage/profiles/updates/2Q-2017....
/usr/portage/profiles/updates/3Q-2017.........................
/usr/portage/profiles/updates/4Q-2017.......
/usr/portage/profiles/updates/1Q-2018....



These are the packages that would be merged, in order:

[ebuild   R    ] sys-devel/binutils-2.29.1-r1:2.29.1::gentoo  USE="cxx nls -multitarget -static-libs {-test} -vanilla" 0 KiB
[ebuild     U  ] sys-devel/gcc-6.4.0-r1:6.4.0::gentoo [6.4.0:6.4.0::gentoo] USE="cxx fortran (multilib) nls nptl openmp pch (pie) sanitize ssp vtv (-altivec) (-awt) -cilk -debug -doc (-fixed-point) (-gcj) -go -graphite (-hardened) (-jit) (-libssp) -mpx -objc -objc++ -objc-gc -pgo -regression-test -vanilla" 14 KiB
[ebuild     U  ] sys-apps/sandbox-2.12::gentoo [2.10-r4::gentoo] ABI_X86="(32) (64) (-x32)" 415 KiB

Total: 3 packages (2 upgrades, 1 reinstall), Size of downloads: 428 KiB


emerge --unmerge sys-devel/gcc:5
Code:

emerge --unmerge sys-devel/gcc:5
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

--- Couldn't find 'sys-devel/gcc:5' to unmerge.

>>> No packages selected for removal by unmerge


revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc
Code:

revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please file bugs at: https://bugs.gentoo.org/
 * Collecting system binaries and libraries
 * Checking dynamic linking consistency
 * Assign files to packages
   * Warning: "media-libs/mesa-17.2.7" ebuild not found..
   * Warning: "app-crypt/truecrypt-7.1a" ebuild not found..
   !! Could not find ebuild for app-crypt/truecrypt:0
   !! Could not find ebuild for app-crypt/truecrypt
   Installed package: app-crypt/truecrypt is no longer available
   * Warning: "sys-devel/gcc-5.4.0-r3" ebuild not found..
   !! Could not find ebuild for sys-devel/gcc:5.4.0


Ich glaube das hat was mit den Befehlen zu tun was man ausführen soll fürs 17.1 Profil (steht in den NEWS)
Bin aber leider noch nicht dazu gekommen mir das genauer anzugucken was da damals genau passiert ist den dem Befehl ausführen.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3347
Location: Germany

PostPosted: Mon Jan 29, 2018 5:00 pm    Post subject: Reply with quote

Quote:
config log von readline finde ich nicht !? kein ordner oder irgendwelche logs im tmp Ordner.

Ja, sich PORTAGE_TMPDIR auf /tmp zu setzen ist idR keine gute Idee, /tmp wird beim reboot geleert.

Vorschlag: Erstelle das config.log neu.
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 109

PostPosted: Mon Jan 29, 2018 5:30 pm    Post subject: Reply with quote

Oh backe stimmt sorry das hatte ich total vergessen und übersehen das mit PORTAGE_TMPDIR ...

Mist Ding .... egal was ich kompilieren will es kommt immer die oben beschriebene Fehlermeldung.
Und leider kommt es nicht zum kompilieren von Readline da immer irgendein Programm vorher sich rein schleicht.
Hmm also so zerschossen hatte ich mein Gentoo glaube ich echt noch nie ... :roll: :roll:

Versuche am Wochenende mir mal die ganze Befehle (news 17.1) genauer nochmal anzugucken eventuell finde ich da was hilfreiches...

Hmm laut gcc-config -l wäre ja 5.4.0 von gcc installiert !?
Code:

 [1] x86_64-pc-linux-gnu-5.4.0
 [2] x86_64-pc-linux-gnu-6.4.0
 [3] x86_64-pc-linux-gnu-7.2.0 *


Ich kann es auch auswählen ... aber wieso jammert er immer noch !?
Hab es auch (hoffentlich richtig) von der Maskierung befreit. Kann es sein das es durch das profil 17 es nicht mehr installierbar ist !?
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 5973

PostPosted: Wed Jan 31, 2018 6:09 am    Post subject: Reply with quote

Schattenschlag wrote:
Oh backe stimmt sorry das hatte ich total vergessen und übersehen das mit PORTAGE_TMPDIR ...

Mist Ding .... egal was ich kompilieren will es kommt immer die oben beschriebene Fehlermeldung.

Wenn Dein /tmp mit noexec gemounted ist (was eigentlich empfehlenswert ist), liegt auch das am PORTAGE_TMPDIR: Du musst auf einer Partition kompilieren, von der aus sich Programme ausführen lassen.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3347
Location: Germany

PostPosted: Tue Feb 06, 2018 4:31 am    Post subject: Bräuchte Hilfe beim Testen von Profil 17.1 experimentell Reply with quote

Schattenschlag wrote:
Code:
emerge --info
Portage 2.3.13 (python 3.5.4-final-0, default/linux/amd64/17.0/desktop, gcc-5.4.0, glibc-2.25-r9, 4.14.10-gentoo-r1 x86_64)
=================================================================
[...]

Laut deiner emerge --info ist ein 17.0 Profil gesetzt (und auch noch der alte inzwischen hart maskierte gcc-5.4.0)
Beachte, nach der Migration auf ein 17.1 Profil gibt es so ohne weiteres kein Weg zurück.
Scheinbar hast du (so wie in der News im Migrationsguide vorgeschlagen) vergessen aufs neue Profil umzustellen, oder im nachhinein das Profil zurückgesetzt?
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2097
Location: Bardowick, Germany

PostPosted: Tue Feb 06, 2018 7:02 am    Post subject: Re: Bräuchte Hilfe beim Testen von Profil 17.1 experimentell Reply with quote

Josef.95 wrote:
Schattenschlag wrote:
Code:
emerge --info
Portage 2.3.13 (python 3.5.4-final-0, default/linux/amd64/17.0/desktop, gcc-5.4.0, glibc-2.25-r9, 4.14.10-gentoo-r1 x86_64)
=================================================================
[...]

Laut deiner emerge --info ist ein 17.0 Profil gesetzt (und auch noch der alte inzwischen hart maskierte gcc-5.4.0)
Beachte, nach der Migration auf ein 17.1 Profil gibt es so ohne weiteres kein Weg zurück.
Scheinbar hast du (so wie in der News im Migrationsguide vorgeschlagen) vergessen aufs neue Profil umzustellen, oder im nachhinein das Profil zurückgesetzt?
Und auch im 17.0 Profil ist jeder gcc unter 6.4.0 hart maskiert.
_________________
elogind
CygwinOnSteroids
"A conservative is a man who is too cowardly to fight and too fat to run."
-- Elbert Hubbard
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 109

PostPosted: Tue Feb 06, 2018 2:21 pm    Post subject: Reply with quote

Hallöchen

Sorry hatte viel herum experimentiert, da ist mir nicht aufgefallen das ich eventuell falsche Infos gepostet habe.

Ich habe von 13 -> auf 17 und dann auf 17.1 umgestellt.
Wo bei im Profil 17.1 nur Probleme aufgetaucht sind. (was ja nix schlimmes ist wegen experimentell).
das auch der 5.4.0 hart maskiert ist war mir klar steht auch in den Infos. Muss sagen das ich schon länger mit dem gcc-7.2.0 rum düse.

Die Fehlermeldung ganz am Anfang dieses Thread ist das was nach der genauen Anleitung rauskommt. Und da bin ich dann irgendwie gescheitert dieses zu lösen,
alle Softlinks von lib waren weg (wegen dem scriptbefehl -> News) und noch viel andere Dinge.

Hab es jetzt ein zweites mal Probiert das 17.1 Profil, (Testrechner -> Backup von 17.0) wieder wie in den News stehend alles gemacht und die gleichen Fehlermeldungen.
Könnte der Fehler damit zusammenhängen das ich multilib Systeme verwende !?

mfg
schatti
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3347
Location: Germany

PostPosted: Thu Feb 08, 2018 11:32 am    Post subject: Reply with quote

Schattenschlag wrote:
Hab es jetzt ein zweites mal Probiert das 17.1 Profil, (Testrechner -> Backup von 17.0) wieder wie in den News stehend alles gemacht und die gleichen Fehlermeldungen.
Ja, aber in der Fehlermeldung steht das man für genaueres bitte im config.log nachschauen möge,
das hast du aber bisher scheinbar noch nicht gemacht. Warum nutzt du diesen (wahrscheinlich hilfreichen) Vorschlag nicht?! :)

Josef.95 wrote:
Schau bitte mal ob der benötigte
CONFIG_IA32_EMULATION=y
Support im aktuell laufenden Kernel vorhanden ist.
Schattenschlag wrote:
CONFIG_IA32_EMULATION=y

Code:

Symbol: IA32_EMULATION [=y]                                                                   
   Type  : boolean                                                                               
   Prompt: IA32 Emulation                                                                         
     Location:                                                                                   
   (1) -> Executable file formats / Emulations                                                   
     Defined at arch/x86/Kconfig:2799                                                             
     Depends on: X86_64 [=y]                                                                     
     Selects: ARCH_WANT_OLD_COMPAT_IPC [=y] && BINFMT_ELF [=y] && COMPAT_BINFMT_ELF [=y] && COM

[...]

Hm, ich bin mir ziemlich sicher das es fast nur am fehlenden 32bit Support im Kernel liegen kann.
Machst du das ganze eventuell via chroot von einem anderen System mit anderen Kernel aus?
Mag ja sein das CONFIG_IA32_EMULATION=y in deiner .config gesetzt ist, aber ist der aktuell genutzte Kernel mit dem es beim mergen beim configure zu dem Fehler kommt wirklich damit gebaut?

Vorschlag: Prüfe das bitte noch mal nach.
Schau mal bitte direkt im System mit dem es zu dem Fehler kommt via
Code:
zgrep IA32_EMULATION /proc/config.gz


/edit: Falls der /proc/config.gz Support nicht vorhanden ist baue bitte
CONFIG_IKCONFIG=y
CONFIG_IKCONFIG_PROC=y
mit ein.
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 109

PostPosted: Sat Feb 10, 2018 1:42 pm    Post subject: Reply with quote

Hmm kann ich gern nochmal überprüfen, josef.95. (versuche es dieses Wochenende noch zu schaffen)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum