Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
One or more updates/rebuilds have been skipped due to a de
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Langest
n00b
n00b


Joined: 19 Jan 2018
Posts: 47

PostPosted: Tue Jan 30, 2018 8:06 pm    Post subject: One or more updates/rebuilds have been skipped due to a de Reply with quote

Hello! When emerging I get the following message.
Code:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

media-libs/harfbuzz:0
  (media-libs/harfbuzz-1.7.2:0/0.9.18::gentoo, ebuild scheduled for merge) conflicts with
    >=media-libs/harfbuzz-1.3.3:=[icu(+)] required by (net-libs/webkit-gtk-2.18.6:4/37::gentoo, installed)
    >=media-libs/harfbuzz-1.3.3:0/0.9.18=[icu(+)] required by (net-libs/webkit-gtk-2.18.6:4/37::gentoo, installed)

dev-libs/glib:2
  (dev-libs/glib-2.52.3:2/2::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/glib-2.32:2[dbus] required by (gnome-extra/nm-applet-1.8.6:0/0::gentoo, installed)
                                   ^^^^
    >=dev-libs/glib-2.40:2/2=[dbus] required by (sys-auth/consolekit-1.2.0:0/0::gentoo, installed)
                                        ^^^^
    >=dev-libs/glib-2.40:2=[dbus] required by (sys-auth/consolekit-1.2.0:0/0::gentoo, installed)
                                      ^^^^
sys-libs/zlib:0
  (sys-libs/zlib-1.2.11-r1:0/1::gentoo, ebuild scheduled for merge) conflicts with
    sys-libs/zlib[minizip] required by (games-strategy/widelands-0.18-r1:0/0::gentoo, installed)
                  ^^^^^^^
x11-libs/cairo:0
  (x11-libs/cairo-1.14.8:0/0::gentoo, ebuild scheduled for merge) conflicts with
    x11-libs/cairo[opengl] required by (net-libs/webkit-gtk-2.18.6:4/37::gentoo, installed)
                      ^^^^^^
net-wireless/wpa_supplicant:0
  (net-wireless/wpa_supplicant-2.6-r3:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=net-wireless/wpa_supplicant-0.7.3-r3[dbus] required by (net-misc/networkmanager-1.8.4:0/0::gentoo, installed)


Which seems like nothing is critically broken but, as it says, I have a conflict which I should solve. I am guessing that I got this conflict because I unmasked some packages, but I am not sure. Because some of these seem to come from packages that I did not need to unmask.
How can I proceed to find out what causes the conflict and how can I solve it?

Thank you!
Langest
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7640
Location: Goose Creek SC

PostPosted: Tue Jan 30, 2018 9:05 pm    Post subject: Reply with quote

try
emerge -avuND --with-bdeps=y --backtrack=50 world
If the same conflicts still arise try
echo media-libs/harfbuzz icu >> /etc/portage/package.use
echo dev-libs/glib dbus >> /etc/portage/package.use
echo sys-libs/zlib minizip >> /etc/portage/package.use
echo x11-libs/cairo opengl >> /etc/portage/package.use
echo net-wireless/wpa_supplicant dbus >> /etc/portage/package.use
emerge -avuND --with-bdeps=y --backtrack=50 world
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Langest
n00b
n00b


Joined: 19 Jan 2018
Posts: 47

PostPosted: Wed Jan 31, 2018 8:41 pm    Post subject: Reply with quote

Thank you for the help!

I tried running
Code:
emerge -avuND --with-bdeps=y --backtrack=50 world
but it didn't solve anything.
However, after adding the lines to /etc/portage/package.use it no longer outputs anything as I run emerge.
Code:
These are the packages that would be merged, in order:
Calculating dependencies... done!
Nothing to merge; quitting.

What did these magic lines do?
Add a dependency? Seems like they made whatever I already had installed sufficient for not complaining.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7640
Location: Goose Creek SC

PostPosted: Fri Feb 02, 2018 2:36 am    Post subject: Reply with quote

as an example :
Code:
(net-wireless/wpa_supplicant-2.6-r3:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=net-wireless/wpa_supplicant-0.7.3-r3[dbus] required by (net-misc/networkmanager-1.8.4:0/0::gentoo, installed)

Portage should have scheduled net-wireless/wpa_supplicant-2.6-r3:0/0::gentoo for merge with the dbus USE flag enabled because networkmanager depends on wpa_supplicant with dbus support, but it failed to do so. It appears your system was quite "stale" which may have caused the calculation to fail. The additions to package.use explicitly added the flags that portage should have calculated for the update packages.

[Moderator edit: added [code] tags to preserve output layout. -Hu]
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum