Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Libreoffice-5.4.2.2 will not start
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6514
Location: Austria

PostPosted: Wed Jan 17, 2018 11:26 pm    Post subject: Reply with quote

...did you check my OpenGL link already?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
blopsalot
Apprentice
Apprentice


Joined: 28 Jan 2017
Posts: 231

PostPosted: Wed Jan 17, 2018 11:41 pm    Post subject: Reply with quote

what about this:
Code:
export SAL_DISABLE_OPENCL; soffice


asturm wrote:
...did you check my OpenGL link already?

yes did u see this?
Code:
<item oor:path="/org.openoffice.Office.Common/VCL"><prop oor:name="UseOpenGL" oor:op="fuse"><value>false</value></prop></item>
<item oor:path="/org.openoffice.Office.Common/VCL"><prop oor:name="ForceOpenGL" oor:op="fuse"><value>false</value></prop></item>
Back to top
View user's profile Send private message
mike155
Guru
Guru


Joined: 17 Sep 2010
Posts: 566
Location: Frankfurt, Germany

PostPosted: Wed Jan 17, 2018 11:53 pm    Post subject: Reply with quote

I looked at your strace file and it doesn't contain anything wrong.

What worries me is that your strace file is only 1594 lines long. If I strace LibreOffice, my strace file is at least 20.000 lines long.

But I get a strace file with 1590 lines if I strace LibreOffice and LibreOffice is already running. So maybe LibreOffice didn't really start in your strace test, because some LibreOffice processes were still running from your last tests... That would also explain why the test proposed by mgwolff didn't work.

Can you please make sure that no LibreOffice processes are running (look at the output of "ps -fe" and kill all LibreOffice processes) and redo the strace test. Is your strace file now longer? If it is longer (at least 5000 lines): please post it and also redo the tests proposed by mgwolff, asturm and blopsalot.

EDIT: I rechecked your strace file:

Code:
2238  connect(3, {sa_family=AF_UNIX, sun_path="/tmp/OSL_PIPE_1000_SingleOfficeIPC_db1e7eee18c324ec912d5118a2d21af"}, 110

This line shows that other LibreOffice processes were still running when your straced LibreOffice. You should really kill all LibreOffice processes before doing any test - otherwise LibreOffice won't start. Instead, it will try to connect to already running LibreOffice processes.


Last edited by mike155 on Thu Jan 18, 2018 12:05 am; edited 2 times in total
Back to top
View user's profile Send private message
mgwolff
n00b
n00b


Joined: 18 Dec 2017
Posts: 28

PostPosted: Wed Jan 17, 2018 11:54 pm    Post subject: Reply with quote

The wiki link recommends to use:

Code:

<item oor:path="/org.openoffice.Office.Common/VCL"><prop oor:name="UseOpenGL" oor:op="fuse"><value>true</value></prop></item>


However, for me, that does not work. I had to use:

Code:

<item oor:path="/org.openoffice.Office.Common/Misc"><prop oor:name="UseOpenCL" oor:op="fuse"><value>false</value></prop></item>


So, "Misc" instead of "VCL" and "false" instead of "true".

For me, "export SAL_DISABLE_OPENCL; soffice" did not work.
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2570
Location: Edmonton, AB

PostPosted: Thu Jan 18, 2018 12:02 am    Post subject: Reply with quote

asturm wrote:
...did you check my OpenGL link already?


How do I do it?
_________________
#Thelma
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6514
Location: Austria

PostPosted: Thu Jan 18, 2018 12:03 am    Post subject: Reply with quote

mgwolff wrote:
The wiki link recommends to use:

Only if you don't read the instructions. It just shows the default values in that output. Obviously you should set it to false.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
mgwolff
n00b
n00b


Joined: 18 Dec 2017
Posts: 28

PostPosted: Thu Jan 18, 2018 12:11 am    Post subject: Reply with quote

asturm wrote:
mgwolff wrote:
The wiki link recommends to use:

Only if you don't read the instructions. It just shows the default values in that output. Obviously you should set it to false.


It's badly worded to say the least. The colon makes it seem as if the following lines are the desired outcome.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6514
Location: Austria

PostPosted: Thu Jan 18, 2018 12:14 am    Post subject: Reply with quote

...last sentence above the code snippet...

Quote:
and change UseOpenGL and ForceOpenGL entries to false:


There's only so much one can do.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
blopsalot
Apprentice
Apprentice


Joined: 28 Jan 2017
Posts: 231

PostPosted: Thu Jan 18, 2018 12:15 am    Post subject: Reply with quote

mike155 wrote:
I looked at your strace file and it doesn't contain anything wrong.

What worries me is that your strace file is only 1594 lines long. If I strace LibreOffice, my strace file is at least 20.000 lines long.

But I get a strace file with 1590 lines if I strace LibreOffice and LibreOffice is already running. So maybe LibreOffice didn't really start in your strace test, because some LibreOffice processes were still running from your last tests... That would also explain why the test proposed by mgwolff didn't work.

Can you please make sure that no LibreOffice processes are running (look at the output of "ps -fe" and kill all LibreOffice processes) and redo the strace test. Is your strace file now longer? If it is longer (at least 5000 lines): please post it and also redo the tests proposed by mgwolff, asturm and blopsalot.

EDIT: I rechecked your strace file:

Code:
2238  connect(3, {sa_family=AF_UNIX, sun_path="/tmp/OSL_PIPE_1000_SingleOfficeIPC_db1e7eee18c324ec912d5118a2d21af"}, 110

This line shows that other LibreOffice processes were still running when your straced LibreOffice. You should really kill all LibreOffice processes before doing any test - otherwise LibreOffice won't start. Instead, it will try to connect to already running LibreOffice processes.


just restart your computer and then follow mgwolfs instructions. lol

edit:
asturm: assuming mgwolf's advice works, there should probably be an opencl use flag added until upstream figures out whats wrong with intel opencl https://bugs.documentfoundation.org/show_bug.cgi?id=105084
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6514
Location: Austria

PostPosted: Thu Jan 18, 2018 12:33 am    Post subject: Reply with quote

That would be premature. It works with root => permissions issue. I'll rather add the link and instructions to pkg_postinst.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic


Last edited by asturm on Thu Jan 18, 2018 12:36 am; edited 1 time in total
Back to top
View user's profile Send private message
blopsalot
Apprentice
Apprentice


Joined: 28 Jan 2017
Posts: 231

PostPosted: Thu Jan 18, 2018 12:36 am    Post subject: Reply with quote

just seems easier from a support standpoint.

edit: i think the amount of characters typed would be about the same either way :)

edit2: if anyone wants to at any point

Code:
if ! use opencl ; then
      mkdir -p "${BUILD_OBJ_DIR}/share/registry/data/"
      echo "<?xml version="1.0" encoding="UTF-8"?>" > "${BUILD_OBJ_DIR}/share/registry/data/disableopencl.xcu" || die
      echo "<oor:items xmlns:oor="http://openoffice.org/2001/registry" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">" >> "${BUILD_OBJ_DIR}/share/registry/data/disableopencl.xcu" || die
      echo "<item oor:path="/org.openoffice.Office.Common/Misc"><prop oor:name="UseOpenCL" oor:op="fuse"><value>false</value></prop></item>" >> "${BUILD_OBJ_DIR}/share/registry/data/disableopencl.xcu" || die
      echo "</oor:items>" >> "${BUILD_OBJ_DIR}/share/registry/data/disableopencl.xcu" || die
fi
Back to top
View user's profile Send private message
mgwolff
n00b
n00b


Joined: 18 Dec 2017
Posts: 28

PostPosted: Thu Jan 18, 2018 2:51 am    Post subject: Reply with quote

asturm wrote:
That would be premature. It works with root => permissions issue. I'll rather add the link and instructions to pkg_postinst.


If you think it is a permission issue, can you indicate which file / folder has the wrong permissions?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6514
Location: Austria

PostPosted: Thu Jan 18, 2018 9:49 am    Post subject: Reply with quote

It's not about any folder of libreoffice; it's about X, if you are in the video group, and maybe how you start your session.

blopsalot wrote:
edit2: if anyone wants to at any point

We don't do USE flags for config settings.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
mgwolff
n00b
n00b


Joined: 18 Dec 2017
Posts: 28

PostPosted: Thu Jan 18, 2018 2:49 pm    Post subject: Reply with quote

asturm wrote:
It's not about any folder of libreoffice; it's about X, if you are in the video group, and maybe how you start your session.

blopsalot wrote:
edit2: if anyone wants to at any point

We don't do USE flags for config settings.


I added myself to the "video" group and now LibreOffice starts without changing "registrymodifications.xcu". When emerging LibreOffice the user should be alerted of this problem!
Back to top
View user's profile Send private message
mike155
Guru
Guru


Joined: 17 Sep 2010
Posts: 566
Location: Frankfurt, Germany

PostPosted: Thu Jan 18, 2018 3:03 pm    Post subject: Reply with quote

Quote:
I added myself to the "video" group and now LibreOffice starts without changing "registrymodifications.xcu". When emerging LibreOffice the user should be alerted of this problem!

I'm glad that adding yourself to group 'video' solves the problem. I would like to hear if this also solves the problem of Joseph_sys.

But this does not mean that every user who wants to use LibreOffice must be member of the 'video' group. I just removed myself from this group, logged out, logged in and I still can start LibreOffice.

It's more like: users, who have <...> must be in group 'video' if they want to use LibreOffice. We don't know what <...> is. Maybe it's the graphics card or a special version of the graphics driver or some special USE flags in mesa, libdrm, whatever. We don't know yet.
Back to top
View user's profile Send private message
blopsalot
Apprentice
Apprentice


Joined: 28 Jan 2017
Posts: 231

PostPosted: Sat Jan 20, 2018 12:04 am    Post subject: Reply with quote

asturm wrote:
It's not about any folder of libreoffice; it's about X, if you are in the video group, and maybe how you start your session.

blopsalot wrote:
edit2: if anyone wants to at any point

We don't do USE flags for config settings.


my idea stands, opencl in libreoffice is obviously screwed up, why just leave no control when so easy to disable. it disables automatically on my 780ti, so i wonder what platform it even actually works.

pass that memo to the firefox maintainers, specifically to remove the nsplugin from the 57 ebuilds as it is doing nothing and confusing users.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6514
Location: Austria

PostPosted: Sat Jan 20, 2018 1:37 am    Post subject: Reply with quote

Nothing in this thread so far indicates that OpenCL is screwed up.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2570
Location: Edmonton, AB

PostPosted: Sat Jan 20, 2018 1:42 am    Post subject: Reply with quote

asturm wrote:
Nothing in this thread so far indicates that OpenCL is screwed up.


The strange part is that on the same box I created a new "user" and
Libreoffice works just fine.
But it will not work when I log in.

I've deleted the folder setting. /home/joseph/.config/libreoffice/
and copied the same folder from new user directory back to my directory.
Libreofice still will not start.
_________________
#Thelma
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6514
Location: Austria

PostPosted: Sat Jan 20, 2018 1:45 am    Post subject: Reply with quote

Yes, I've seen your bug comment.

Code:
soffice --help
X11 connection rejected because of wrong authentication.

(process:24269): dconf-CRITICAL **: unable to create file '/var/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.
LibreOffice 5.4.2.2.0 40m0(Build:2)

Something about your user session is broken, it is completely unrelated to LibreOffice.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2570
Location: Edmonton, AB

PostPosted: Sat Jan 20, 2018 1:48 am    Post subject: Reply with quote

asturm wrote:
Yes, I've seen your bug comment.

Code:
soffice --help
X11 connection rejected because of wrong authentication.

(process:24269): dconf-CRITICAL **: unable to create file '/var/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.
LibreOffice 5.4.2.2.0 40m0(Build:2)

Something about your user session is broken, it is completely unrelated to LibreOffice.


I agree, I just login to that box over ssh and I notice this error; so I was under impression that might be related to libreoffice; but it is not.
_________________
#Thelma
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2570
Location: Edmonton, AB

PostPosted: Sat Jan 20, 2018 6:07 am    Post subject: Reply with quote

I've reinstalled "Libreoffice" but it complained:
Code:
>>> Emerging (1 of 1) app-office/libreoffice-5.4.2.2::gentoo
>>> Jobs: 0 of 1 complete, 1 running                Load avg: 6.27, 7.29, 7.37X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
>>> Jobs: 0 of 1 complete, 1 running                Load avg: 6.27, 7.29, 7.37X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
>>> Installing (1 of 1) app-office/libreoffice-5.4.2.2::gentoo
>>> Recording app-office/libreoffice in "world" favorites file...

_________________
#Thelma
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12826

PostPosted: Sat Jan 20, 2018 6:16 pm    Post subject: Reply with quote

Your $DISPLAY points to an X11 server that you are not permitted to use. This could be because your $DISPLAY is wrong (perhaps it is remembered by tmux from a past ssh session when it was right), or it could be that your $XAUTHORITY is wrong, or it could be that the xauth tokens in your $XAUTHORITY are missing or wrong. Compare the output of echo $DISPLAY; echo $XAUTHORITY; xauth list from a working and non-working terminal, where "working" means you can start a trivial X11 application and it will start quickly and correctly. Although in practice not too dangerous, you should not post raw xauth list output, since a user who can connect to your X server and possesses that output can authenticate to your X server.
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2570
Location: Edmonton, AB

PostPosted: Sat Jan 20, 2018 8:49 pm    Post subject: Reply with quote

Hu wrote:
Your $DISPLAY points to an X11 server that you are not permitted to use. This could be because your $DISPLAY is wrong (perhaps it is remembered by tmux from a past ssh session when it was right), or it could be that your $XAUTHORITY is wrong, or it could be that the xauth tokens in your $XAUTHORITY are missing or wrong. Compare the output of echo $DISPLAY; echo $XAUTHORITY; xauth list from a working and non-working terminal, where "working" means you can start a trivial X11 application and it will start quickly and correctly. Although in practice not too dangerous, you should not post raw xauth list output, since a user who can connect to your X server and possesses that output can authenticate to your X server.


Thank you for reply.
After unmerging and emerging libreoffice and rebooting the computer I've noticed the "libreoffice" works on all accounts even over ssh.
So rebooting (shutting it down) seems to fix something.

I don't like those magic solution, like MS Windows the first question they ask you to reboot the computer :-/
_________________
#Thelma
Back to top
View user's profile Send private message
blopsalot
Apprentice
Apprentice


Joined: 28 Jan 2017
Posts: 231

PostPosted: Sun Jan 21, 2018 1:10 am    Post subject: Reply with quote

a c++ program that hangs without proper permissions is broken where i come from.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6514
Location: Austria

PostPosted: Mon Jan 22, 2018 6:08 pm    Post subject: Reply with quote

Joseph_sys wrote:
So rebooting (shutting it down) seems to fix something.

I don't like those magic solution, like MS Windows the first question they ask you to reboot the computer :-/

If you have a broken session, sure. That is not unique to a certain operating system...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum