Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge --update --deep --newuse @world Error [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Tue Jan 16, 2018 8:57 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Sei sicuro che il grub.cfg che hai postato e' completo? Usa wgetpaste per postarlo per essere certi.
Una cosa che mi e' venuta in mente e' che il kernel 4.14 viene selezionato prima dal menu di grub, hai provato a controllare la lista che ti da andando sul 'Advanced options for Gentoo GNU/Linux'?


Dunque wgetpaste non da esito voluto ma:
Code:
Apparently nothing was received. Perhaps the connection failed. Enable --verbose or
--debug to get the output from wget that can help diagnose it correctly.


Quindi mi sono abilitato:
Code:
script -a <myFolder>


e ho salvato l'output da schermo che ti assicuro ora è completo:

Code:
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="0"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod ext2
set root='hd0,msdos4'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos4 --hint-efi=hd0,msdos4 --hint-baremetal=ahci0,msdos4  e975192d-834b-429f-a365-98f6137c299d
else
  search --no-floppy --fs-uuid --set=root e975192d-834b-429f-a365-98f6137c299d
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=it_IT
  insmod gettext
fi
terminal_output gfxterm
if [ x$feature_timeout_style = xy ] ; then
  set timeout_style=menu
  set timeout=5
# Fallback normal timeout code in case the timeout_style feature is
# unavailable.
else
  set timeout=5
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Gentoo GNU/Linux' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-e975192d-834b-429f-a365-98f6137c299d' {
   load_video
   if [ "x$grub_platform" = xefi ]; then
      set gfxpayload=keep
   fi
   insmod gzio
   insmod part_msdos
   insmod ext2
   set root='hd0,msdos2'
   if [ x$feature_platform_search_hint = xy ]; then
     search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  7f8a691f-8302-444d-a6d9-787d4d9ed4db
   else
     search --no-floppy --fs-uuid --set=root 7f8a691f-8302-444d-a6d9-787d4d9ed4db
   fi
   echo   'Caricamento Linux 4.14.7-gentoo...'
   linux   /vmlinuz-4.14.7-gentoo root=UUID=e975192d-834b-429f-a365-98f6137c299d ro 
   echo   'Caricamento ramdisk iniziale...'
   initrd   /initramfs-genkernel-x86-4.14.7-gentoo
}
submenu 'Opzioni avanzate per Gentoo GNU/Linux' $menuentry_id_option 'gnulinux-advanced-e975192d-834b-429f-a365-98f6137c299d' {
   menuentry 'Gentoo GNU/Linux, con Linux 4.14.7-gentoo' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.14.7-gentoo-advanced-e975192d-834b-429f-a365-98f6137c299d' {
      load_video
      if [ "x$grub_platform" = xefi ]; then
         set gfxpayload=keep
      fi
      insmod gzio
      insmod part_msdos
      insmod ext2
      set root='hd0,msdos2'
      if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  7f8a691f-8302-444d-a6d9-787d4d9ed4db
      else
        search --no-floppy --fs-uuid --set=root 7f8a691f-8302-444d-a6d9-787d4d9ed4db
      fi
      echo   'Caricamento Linux 4.14.7-gentoo...'
      linux   /vmlinuz-4.14.7-gentoo root=UUID=e975192d-834b-429f-a365-98f6137c299d ro 
      echo   'Caricamento ramdisk iniziale...'
      initrd   /initramfs-genkernel-x86-4.14.7-gentoo
   }
   menuentry 'Gentoo GNU/Linux, con Linux 4.14.7-gentoo (modalità ripristino)' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.14.7-gentoo-recovery-e975192d-834b-429f-a365-98f6137c299d' {
      load_video
      if [ "x$grub_platform" = xefi ]; then
         set gfxpayload=keep
      fi
      insmod gzio
      insmod part_msdos
      insmod ext2
      set root='hd0,msdos2'
      if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  7f8a691f-8302-444d-a6d9-787d4d9ed4db
      else
        search --no-floppy --fs-uuid --set=root 7f8a691f-8302-444d-a6d9-787d4d9ed4db
      fi
      echo   'Caricamento Linux 4.14.7-gentoo...'
      linux   /vmlinuz-4.14.7-gentoo root=UUID=e975192d-834b-429f-a365-98f6137c299d ro single
      echo   'Caricamento ramdisk iniziale...'
      initrd   /initramfs-genkernel-x86-4.14.7-gentoo
   }
   menuentry 'Gentoo GNU/Linux, con Linux 4.14.7-gentoo.old' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.14.7-gentoo.old-advanced-e975192d-834b-429f-a365-98f6137c299d' {
      load_video
      if [ "x$grub_platform" = xefi ]; then
         set gfxpayload=keep
      fi
      insmod gzio
      insmod part_msdos
      insmod ext2
      set root='hd0,msdos2'
      if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  7f8a691f-8302-444d-a6d9-787d4d9ed4db
      else
        search --no-floppy --fs-uuid --set=root 7f8a691f-8302-444d-a6d9-787d4d9ed4db
      fi
      echo   'Caricamento Linux 4.14.7-gentoo.old...'
      linux   /vmlinuz-4.14.7-gentoo.old root=UUID=e975192d-834b-429f-a365-98f6137c299d ro 
      echo   'Caricamento ramdisk iniziale...'
      initrd   /initramfs-genkernel-x86-4.14.7-gentoo
   }
   menuentry 'Gentoo GNU/Linux, con Linux 4.14.7-gentoo.old (modalità ripristino)' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.14.7-gentoo.old-recovery-e975192d-834b-429f-a365-98f6137c299d' {
      load_video
      if [ "x$grub_platform" = xefi ]; then
         set gfxpayload=keep
      fi
      insmod gzio
      insmod part_msdos
      insmod ext2
      set root='hd0,msdos2'
      if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  7f8a691f-8302-444d-a6d9-787d4d9ed4db
      else
        search --no-floppy --fs-uuid --set=root 7f8a691f-8302-444d-a6d9-787d4d9ed4db
      fi
      echo   'Caricamento Linux 4.14.7-gentoo.old...'
      linux   /vmlinuz-4.14.7-gentoo.old root=UUID=e975192d-834b-429f-a365-98f6137c299d ro single
      echo   'Caricamento ramdisk iniziale...'
      initrd   /initramfs-genkernel-x86-4.14.7-gentoo
   }
   menuentry 'Gentoo GNU/Linux, con Linux 4.9.72-gentoo' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.9.72-gentoo-advanced-e975192d-834b-429f-a365-98f6137c299d' {
      load_video
      if [ "x$grub_platform" = xefi ]; then
         set gfxpayload=keep
      fi
      insmod gzio
      insmod part_msdos
      insmod ext2
      set root='hd0,msdos2'
      if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  7f8a691f-8302-444d-a6d9-787d4d9ed4db
      else
        search --no-floppy --fs-uuid --set=root 7f8a691f-8302-444d-a6d9-787d4d9ed4db
      fi
      echo   'Caricamento Linux 4.9.72-gentoo...'
      linux   /vmlinuz-4.9.72-gentoo root=/dev/sda4 ro 
   }
   menuentry 'Gentoo GNU/Linux, con Linux 4.9.72-gentoo (modalità ripristino)' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.9.72-gentoo-recovery-e975192d-834b-429f-a365-98f6137c299d' {
      load_video
      if [ "x$grub_platform" = xefi ]; then
         set gfxpayload=keep
      fi
      insmod gzio
      insmod part_msdos
      insmod ext2
      set root='hd0,msdos2'
      if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  7f8a691f-8302-444d-a6d9-787d4d9ed4db
      else
        search --no-floppy --fs-uuid --set=root 7f8a691f-8302-444d-a6d9-787d4d9ed4db
      fi
      echo   'Caricamento Linux 4.9.72-gentoo...'
      linux   /vmlinuz-4.9.72-gentoo root=/dev/sda4 ro single
   }
   menuentry 'Gentoo GNU/Linux, con Linux 4.9.72-gentoo.old' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.9.72-gentoo.old-advanced-e975192d-834b-429f-a365-98f6137c299d' {
      load_video
      if [ "x$grub_platform" = xefi ]; then
         set gfxpayload=keep
      fi
      insmod gzio
      insmod part_msdos
      insmod ext2
      set root='hd0,msdos2'
      if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  7f8a691f-8302-444d-a6d9-787d4d9ed4db
      else
        search --no-floppy --fs-uuid --set=root 7f8a691f-8302-444d-a6d9-787d4d9ed4db
      fi
      echo   'Caricamento Linux 4.9.72-gentoo.old...'
      linux   /vmlinuz-4.9.72-gentoo.old root=/dev/sda4 ro 
   }
   menuentry 'Gentoo GNU/Linux, con Linux 4.9.72-gentoo.old (modalità ripristino)' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.9.72-gentoo.old-recovery-e975192d-834b-429f-a365-98f6137c299d' {
      load_video
      if [ "x$grub_platform" = xefi ]; then
         set gfxpayload=keep
      fi
      insmod gzio
      insmod part_msdos
      insmod ext2
      set root='hd0,msdos2'
      if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  7f8a691f-8302-444d-a6d9-787d4d9ed4db
      else
        search --no-floppy --fs-uuid --set=root 7f8a691f-8302-444d-a6d9-787d4d9ed4db
      fi
      echo   'Caricamento Linux 4.9.72-gentoo.old...'
      linux   /vmlinuz-4.9.72-gentoo.old root=/dev/sda4 ro single
   }
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###


in particolare:

submenu 'Opzioni avanzate per Gentoo GNU/Linux' $menuentry_id_option 'gnulinux-advanced-e975192d-834b-429f-a365-98f6137c299d' {
menuentry 'Gentoo GNU/Linux, con Linux 4.14.7-gentoo' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.14.7-gentoo-advanced-e975192d-834b-429f-a365-98f6137c299d'
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18584
Location: here

PostPosted: Wed Jan 17, 2018 6:43 am    Post subject: Reply with quote

Code:
...
menuentry 'Gentoo GNU/Linux, con Linux 4.9.72-gentoo' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.9.72-gentoo-advanced-e975192d-834b-429f-a365-98f6137c299d' {
      load_video
      if [ "x$grub_platform" = xefi ]; then
         set gfxpayload=keep
      fi
      insmod gzio
      insmod part_msdos
      insmod ext2
      set root='hd0,msdos2'
      if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  7f8a691f-8302-444d-a6d9-787d4d9ed4db
      else
        search --no-floppy --fs-uuid --set=root 7f8a691f-8302-444d-a6d9-787d4d9ed4db
      fi
      echo   'Caricamento Linux 4.9.72-gentoo...'
      linux   /vmlinuz-4.9.72-gentoo root=/dev/sda4 ro
   }
...

Come vedi se scegli il sotto menu puoi fare partire il kernel 4.9.72.
Quindi quando fai il boot scegli questo per vedere se funziona. Una volta verificato dalla partizione di /boot puoi rimuovere tutti i file relativi al kernel 4.14.xx e fare ripartire il comando grub-mkconfig cosi' da avere solo l'entry per il kernel 4.9.72.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Wed Jan 17, 2018 8:39 am    Post subject: Reply with quote

    1- Sì, l'opzione c'è e il si avvia ma ho ancora questi errori :
    Code:
    [b][color=red]Some local file systema failoure to mount             [!!][/color][/b]

    e

    net.eth0 ERROR e mi pare anche ethernet ma è troppo veloce.
    Come procedo per risolvere?

    2- Per quanto riguarda l'eliminazione della vecchia versione del kernel come procedo? Non vorrei eliminare file in uso.
    L'articolo https://wiki.gentoo.org/wiki/Kernel/Removal è giustamente generico infatti quando dice:
    "Be sure to verify that it is not removing the sources for the currently running kernel"
    a me suona francamente poco chiaro il criterio da adottare nel fare questa cernita poichè il sistema lo conosco veramente poco.


Questo aggiornamento del kernel richiede conoscenze che al momento non ho.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18584
Location: here

PostPosted: Wed Jan 17, 2018 9:04 am    Post subject: Reply with quote

1) Hai lanciato il comando
Code:
# emerge @module-rebuild


2) Una volta che sei sicuro che il kernel 4.9.72 fa il boot correttamente i passi per eliminare quello non piu' in uso sono
Eliminazione dei sorgenti tramite emerge
Code:
# emerge -C sys-kernel/gentoo-sources-4.14.7

Eliminazione della cartella del kernel dove saranno presenti ancora alcuni files
Code:
# rm -r /usr/src/linux-4.14.7-gentoo 

Eliminazione dei moduli del kernel
Code:
# rm -r /lib/modules/4.14.7-gentoo

Eliminazione del kernel compilato da /boot
Code:
# rm /boot/*4.14.7*

Rigenerazione del menu di grub
Code:
# grub-mkconfig -o /boot/grub/grub.conf

Ovviamente prima di ogni rm prova a sostituirlo con ls per vedere se stai cancellando i files/directory corretti
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Wed Jan 17, 2018 9:21 am    Post subject: Reply with quote

    1-
    Code:
    #emerge @module-rebuild
    >>>Auto-cleaning packages...

    >>>No outdted packages were found on your system.

    Questo dovrebbe risolvere problemi di rete e dei file system non caricati?
    in ifconfig -a non ho eth0 ma : enp0s3, lo, sit0.


    2- l'uso di ls che mi consigli riguarda solo un verifica di corretta editazione delle denominazioni/percorsi di file/directory da eliminare?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18584
Location: here

PostPosted: Wed Jan 17, 2018 9:34 am    Post subject: Reply with quote

cesma wrote:
Questo dovrebbe risolvere problemi di rete e dei file system non caricati?
in ifconfig -a non ho eth0 ma : enp0s3, lo, sit0.

Ok la tua interfaccia dovrebbe essere la enp0s3 su virtualbox.
La rete l'hai configurata come da guida? Se si hai utilizzato eth0 come nome? Se si ti rimando a questo a questo pezzo della guida
Quote:
If after booting the system we find out that the assumption about the network interface name (which is currently documented as eth0) was wrong, then execute the following steps to rectify this:

1. Update the /etc/conf.d/net file with the correct interface name (like enp3s0 instead of eth0).
2. Create new symbolic link (like /etc/init.d/net.enp3s0).
3. Remove the old symbolic link (rm /etc/init.d/net.eth0).
4. Add the new one to the default runlevel.
5. Remove the old one using rc-update del net.eth0 default.



cesma wrote:
2- l'uso di ls che mi consigli riguarda solo un verifica di corretta editazione delle denominazioni/percorsi di file/directory da eliminare?

Esatto e' solo un controllo in piu' prima di fare un rm
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Wed Jan 17, 2018 9:45 am    Post subject: Reply with quote

fedeliallalinea wrote:
cesma wrote:
Questo dovrebbe risolvere problemi di rete e dei file system non caricati?
in ifconfig -a non ho eth0 ma : enp0s3, lo, sit0.

Ok la tua interfaccia dovrebbe essere la enp0s3 su virtualbox.
La rete l'hai configurata come da guida? Se si hai utilizzato eth0 come nome? Se si ti rimando a questo a questo pezzo della guida
Quote:
If after booting the system we find out that the assumption about the network interface name (which is currently documented as eth0) was wrong, then execute the following steps to rectify this:

1. Update the /etc/conf.d/net file with the correct interface name (like enp3s0 instead of eth0).
2. Create new symbolic link (like /etc/init.d/net.enp3s0).
3. Remove the old symbolic link (rm /etc/init.d/net.eth0).
4. Add the new one to the default runlevel.
5. Remove the old one using rc-update del net.eth0 default.



All'installazione ho usato la modalità di auto configurazione net-setupappunto disponibile solo su liveCD, infatti all'avvio vedevo l'ip 127.0.0.1
di mascheramento avendo lato Host la rete impostata come NAT.
Aggiungo che mentre prima:
Code:
#ls /sys/class/net
enp0s3 lo sit0

prima eth0 era visualizzata ora no. Procedo con i passaggi sopra?

EDIT: /etc/conf.d/net non è presente questo file nella directory, c'è un net-oline.


Per quanto riguarda quel warning [!!] all'avvio che mi dici?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18584
Location: here

PostPosted: Wed Jan 17, 2018 9:58 am    Post subject: Reply with quote

cesma wrote:
prima eth0 era visualizzata ora no. Procedo con i passaggi sopra?

Questo probabilmente e' dovuto all'attivazione di udev che rinomina l'interfaccia di rete

cesma wrote:
Procedo con i passaggi sopra?

Si

cesma wrote:
EDIT: /etc/conf.d/net non è presente questo file nella directory, c'è un net-oline.

Lascia perdere questo passaggio anche nel mio virtualbox non ce l'ho ma la rete funziona comunque

cesma wrote:
Per quanto riguarda quel warning [!!] all'avvio che mi dici?

Scusa, mi sono perso mi potresti dire ancora a cosa ti riferisci
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Wed Jan 17, 2018 10:43 am    Post subject: Reply with quote

    1-
    Quote:
    cesma ha scritto:
    Per quanto riguarda quel warning [!!] all'avvio che mi dici?

    Scusa, mi sono perso mi potresti dire ancora a cosa ti riferisci


    Si vede chiaramente durante il boot questo messaggio:

    Some local file systema failoure to mount [!!]

    2-
    Quote:
    cesma ha scritto:
    Procedo con i passaggi sopra?

    Si

    cesma ha scritto:
    EDIT: /etc/conf.d/net non è presente questo file nella directory, c'è un net-oline.


    Ho seguito i passaggi usando la denominazione che da Vbox, al reboot non ho più l'errore di 'montaggio' risorsa ma no pinga; credo dipenda dall'errata
    impostazione degli ip in /etc/conf.d/net
    Code:
    config_enp3s0="192.168.0.2 netmask 255.255.255.0 brd 192.168.0.255"
    routes_enp3s0="default via 192.168.0.1"
    config_enp3s0="dhcp"

    io come ti dicevo al momento sono in NAT tra HOST e GUEST ? Credo sia 127.0.0.1 invece di 192.168.0.2 puoi verificare le tue impostazioni?Cosa ne pensi?

Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18584
Location: here

PostPosted: Wed Jan 17, 2018 12:03 pm    Post subject: Reply with quote

cesma wrote:
Some local file systema failoure to mount [!!]

Posta per favore il tuo /etc/fstab

cesma wrote:
Ho seguito i passaggi usando la denominazione che da Vbox, al reboot non ho più l'errore di 'montaggio' risorsa ma no pinga; credo dipenda dall'errata
impostazione degli ip in /etc/conf.d/net
Code:
config_enp3s0="192.168.0.2 netmask 255.255.255.0 brd 192.168.0.255"
routes_enp3s0="default via 192.168.0.1"
config_enp3s0="dhcp"

io come ti dicevo al momento sono in NAT tra HOST e GUEST ? Credo sia 127.0.0.1 invece di 192.168.0.2 puoi verificare le tue impostazioni?Cosa ne pensi?

Lascia solo l'utima riga ed commenta le prime due
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Wed Jan 17, 2018 1:18 pm    Post subject: Reply with quote

Quote:
cesma wrote:
Ho seguito i passaggi usando la denominazione che da Vbox, al reboot non ho più l'errore di 'montaggio' risorsa ma no pinga; credo dipenda dall'errata
impostazione degli ip in /etc/conf.d/net
Code:
config_enp3s0="192.168.0.2 netmask 255.255.255.0 brd 192.168.0.255"
routes_enp3s0="default via 192.168.0.1"
config_enp3s0="dhcp"

Quote:
Quote:
io come ti dicevo al momento sono in NAT tra HOST e GUEST ? Credo sia 127.0.0.1 invece di 192.168.0.2 puoi verificare le tue impostazioni?Cosa ne pensi?

Lascia solo l'utima riga ed commenta le prime due

Ho anche dns_domain="homenetwork", comunque ho commentato le prime due lasciando l'indirizzamento in DHCP ma nulla durante il boot continua a darmi ERROR ma 'stavolta su snp3S0....credo a questo punto ci fosse anche prima e che mi sia sfuggito.
Che la nuova configurazione kernel manchi di qualche opzione e/o driver scheda ethernet?

Quote:
cesma wrote:
Some local file systema failoure to mount [!!]

Posta per favore il tuo /etc/fstab

Code:
cat /etc/fstab
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed); notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>         <mountpoint>   <type>      <opts>      <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#
# NOTE: Even though we list ext4 as the type here, it will work with ext2/ext3
#       filesystems.  This just tells the kernel to use the ext4 driver.
#
# NOTE: You can use full paths to devices like /dev/sda3, but it is often
#       more reliable to use filesystem labels or UUIDs. See your filesystem
#       documentation for details on setting a label. To obtain the UUID, use
#       the blkid(8) command.

#LABEL=boot      /boot      ext4      noauto,noatime   1 2
#UUID=58e72203-57d1-4497-81ad-97655bd56494      /      ext4      noatime      0 1
#LABEL=swap      none      swap      sw      0 0
#/dev/cdrom      /mnt/cdrom   auto      noauto,ro   0 0
/dev/sda2   /boot        ext4    defaults,noatime     0 2
/dev/sda3   none         swap    sw                   0 0
/dev/sda4   /            ext4    noatime              0 1

/dev/cdrom  /mnt/cdrom   auto    noauto,user          0 0 

#VirtualBox shared folder autoloading
Linux_Gentoo /mnt/scambio_vbox vboxsf defaults 0 0
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Wed Jan 17, 2018 1:39 pm    Post subject: Reply with quote

Problema rete risolto, nella guida c'è una denominazione della rete ingannevole (https://wiki.gentoo.org/wiki/Handbook:AMD64/Installation/System#Automatically_start_networking_at_boot)
chiama enp3s0 invece del mio enp0s3, ho corretto e ora ERRORI in boot sulla rete spariti e la rete pinga.....coffe power!!!!

Mi manca l'altra segnalazione in fase di boot per il quale ti riposto /etc/fstab.

Quote:

Some local file systema failoure to mount [!!]


Posta per favore il tuo /etc/fstab

Codice:
cat /etc/fstab
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed); notail increases performance of ReiserFS (at the expense of storage
# efficiency). It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs> <mountpoint> <type> <opts> <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#
# NOTE: Even though we list ext4 as the type here, it will work with ext2/ext3
# filesystems. This just tells the kernel to use the ext4 driver.
#
# NOTE: You can use full paths to devices like /dev/sda3, but it is often
# more reliable to use filesystem labels or UUIDs. See your filesystem
# documentation for details on setting a label. To obtain the UUID, use
# the blkid(8) command.

#LABEL=boot /boot ext4 noauto,noatime 1 2
#UUID=58e72203-57d1-4497-81ad-97655bd56494 / ext4 noatime 0 1
#LABEL=swap none swap sw 0 0
#/dev/cdrom /mnt/cdrom auto noauto,ro 0 0
/dev/sda2 /boot ext4 defaults,noatime 0 2
/dev/sda3 none swap sw 0 0
/dev/sda4 / ext4 noatime 0 1

/dev/cdrom /mnt/cdrom auto noauto,user 0 0

#VirtualBox shared folder autoloading
Linux_Gentoo /mnt/scambio_vbox vboxsf defaults 0 0
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18584
Location: here

PostPosted: Wed Jan 17, 2018 2:12 pm    Post subject: Reply with quote

cesma wrote:
Mi manca l'altra segnalazione in fase di boot per il quale ti riposto /etc/fstab.

L'unica cosa che mi viene in mente guardando la linea
Code:
Linux_Gentoo /mnt/scambio_vbox vboxsf defaults 0 0

hai creato la directory /mnt/scambio_vbox?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Wed Jan 17, 2018 2:25 pm    Post subject: Reply with quote

fedeliallalinea wrote:
cesma wrote:
Mi manca l'altra segnalazione in fase di boot per il quale ti riposto /etc/fstab.

L'unica cosa che mi viene in mente guardando la linea
Code:
Linux_Gentoo /mnt/scambio_vbox vboxsf defaults 0 0

hai creato la directory /mnt/scambio_vbox?


Scriverci dntro dal mio guest riesco, infatti se faccio:

Quote:
script -a /mnt/scambio_vbox/xyz


mi scrive il file, però nella riga:
Code:
Linux_Gentoo /mnt/scambio_vbox vboxsf defaults 0 0


Linux_Gentoo è il nome della cartella che ho la host (un disco esterno il cui percorso è tipo D:\Linux_Gentoo) è corretto oppure
vuole una descrizione più estesa?

Adesso commento nel /etc/fstab e riavvio, e ti dico.

EDIT: sì è quello, il senso di quella riga dovrebbe essere l'auto montaggio della cartella condivisa al boot. Con il kernel di prima non ho mai avuto quella segnalazione forse non centra ma insieme alle impostazioni della rete è l'unica cosa che con l'aggiornamento ha generato errori.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18584
Location: here

PostPosted: Wed Jan 17, 2018 2:58 pm    Post subject: Reply with quote

Quindi mi pare di capire che hai risolto, o sbaglio?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Wed Jan 17, 2018 3:02 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Quindi mi pare di capire che hai risolto, o sbaglio?


esatto, sai se ci sono metodi alternativi per il montaggio automatico della cartella?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18584
Location: here

PostPosted: Wed Jan 17, 2018 3:16 pm    Post subject: Reply with quote

Si ce ne sono altri ma quello nel /etc/fstab e', a mio parere, la piu' corretta.
Anche la sintassi della tua riga nel fstab e' corretta devi solo vedere se si chiama Linux_Gentoo la cartella condivida dall'interfaccia vbox (per intenderci quello che hai scritto in "Folder Name" in questa finestra)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Wed Jan 17, 2018 3:33 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Si ce ne sono altri ma quello nel /etc/fstab e', a mio parere, la piu' corretta.
Anche la sintassi della tua riga nel fstab e' corretta devi solo vedere se si chiama Linux_Gentoo la cartella condivida dall'interfaccia vbox (per intenderci quello che hai scritto in "Folder Name" in questa finestra)


Non centra il nome altrimenti avrei un ERROR perchè non riuscirei a linkare la risorsa come quando inserisci un percorso che non esiste, io invece ho un WARNING.
Credo piuttosto si tratti della VBox e in particolare delle GuestAdditions....ora provo.


EDIT: infatti le ho re-installate e al reboot nessun problema.....mi è gia capitato con drivers diverse periferiche , fatto grazie.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum