Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge --ask app-admin/sudo ERROR [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Thu Jan 11, 2018 8:47 pm    Post subject: Reply with quote

Ho eseguito quanto consigliato e l'esito di questi comandi :
Code:
# quickpkg sys-apps/systemd
# emerge -C sys-apps/systemd
# emerge -1 sys-fs/eudev
# emerge -uDN @world
# echo "sys-apps/systemd" >> /etc/portage/package.mask

tutto ok fino a # emerge -uDN @world alla fine del quale mi ha dato un error:

nonostante il quale sono riuscito ad installare il pacchetto sudo correttamente.

Ora però il comando :
Code:
#chmod 666 /dev/null
#chmode 777 /dev/null
#ls -l /dev/null


ritorna sempre e comunque dopo il reboot:
Code:
#crw-r---- 1 3 11 gen 21.02 /dev/null

A tale proposito mi piacerebbe capire un po meglio come approcciare questo tipo di errore (file log da controllare?).
Più in generale mi sembra di non riuscire a capire l'approccio corretto per utilizzare/padroneggiare al meglio tutto il materiale presente in rete e quindi il S.O. stesso, infatti anche dopo la lettura della guida ufficiale per l'installazione ho la sensazione che le domande riguardo l'architettura siano esponenzialmente aumentate mentre poche restano le certezze sul funzionamento. Ora mi domando sono sulla strada giusta o sto annegando in un bicchiera d'acqua? Serve ritornare sulla documentazione? Se sì da che punto iniziare poichè troppo spesso la documentazione stessa si perde in "verbose" presentazioni filosofiche che divergono dall'argomento principale.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Fri Jan 12, 2018 7:32 am    Post subject: Reply with quote

cesma wrote:
tutto ok fino a # emerge -uDN @world alla fine del quale mi ha dato un error:

Ok questo e' un'altro errore che mettiamo a posto piu' tardi.

cesma wrote:
ritorna sempre e comunque dopo il reboot:

Sono a corto di idee a questo punto proverei a ricreare il nodo
Code:
# rm  /dev/null
# mknod -m 666 /dev/null c 1 3

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Fri Jan 12, 2018 8:05 am    Post subject: Reply with quote

fedeliallalinea wrote:

Sono a corto di idee a questo punto proverei a ricreare il nodo
Code:
# rm  /dev/null
# mknod -m 666 /dev/null c 1 3


Googolando avevo già provato anch'io questi comandi ma al reboot si perdono nuovamente i permessi (in particolare i valori 1 3 dipendono dal sistema o sono valori uguali per ogni installazione?);sempre googolando ho trovato questi post che mi sembrano interessanti ma che non avendo le competenze ti giro magari ti danno qualche spunto:


che mi dici?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Fri Jan 12, 2018 9:42 am    Post subject: Reply with quote

cesma wrote:
(in particolare i valori 1 3 dipendono dal sistema o sono valori uguali per ogni installazione?);

Penso dipendano dal sistema ma per linux sono giusti
man null:
       Data written to the /dev/null and /dev/zero special files is discarded.

       Reads from /dev/null always return end of file (i.e., read(2) returns 0), whereas reads from /dev/zero always return bytes containing zero ('\0' characters).

       These devices are typically created by:

           mknod -m 666 /dev/null c 1 3
           mknod -m 666 /dev/zero c 1 5
           chown root:root /dev/null /dev/zero

L'unica cosa che non ti ho detto di fare e' chown root:root /dev/null ma non penso che sia il problema.

cesma wrote:
sempre googolando ho trovato questi post che mi sembrano interessanti ma che non avendo le competenze ti giro magari ti danno qualche spunto:


che mi dici?

Li ho visti anche io ma non mi pare di vedere una soluzione, comunque prova a postare l'output del comando mount e di grep DEVTMPFS /usr/src/linux/.config (ti avviso che ora sto andando a tentativi)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Fri Jan 12, 2018 9:57 am    Post subject: Reply with quote

Appena riesco provo.
Accetto il rischio e faccio da cavia volentieri ormai vorrei capire anch'io al più reinstallo; ti dirò che io nel mio mestiere spesso devo procedere allo stesso modo anche se accademicamente la cosa è sempre stata, almeno ai mie tempi di studente universitario, considerata alquanto deprecabile.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Fri Jan 12, 2018 2:11 pm    Post subject: Reply with quote

fedeliallalinea ecco l'output:

Code:
#mount
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=10240k,nr_inodes=218392,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
/dev/sda4 on / type ext4 (rw,noatime,data=ordered)
tmpfs on /run type tmpfs (rw,nodev,relatime,size=198636k,mode=755)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
shm on /dev/shm type tmpfs (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
selinuxfs on /sys/fs/selinux type selinuxfs (rw,relatime)
cgroup_root on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,size=10240k,mode=755)
openrc on /sys/fs/cgroup/openrc type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/rc/sh/cgroup-release-agent.sh,name=openrc)
none on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
cpuset on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cpu on /sys/fs/cgroup/cpu type cgroup (rw,nosuid,nodev,noexec,relatime,cpu)
cpuacct on /sys/fs/cgroup/cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct)
freezer on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
/dev/sda2 on /boot type ext4 (rw,noatime,data=ordered)
Linux_Gentoo on /mnt/scambio_vbox type vboxsf (rw,nodev,relatime)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
#
#grep DEVTMPFS /usr/src/linux/.config
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y


Ti posto anche questo link : https://bbs.archlinux.org/viewtopic.php?id=142816
il mio output del file: /etc/udev/rules.d/60-vboxadd.rules è:
Code:
KERNEL=="vboxguest", NAME="vboxguest", OWNER="vboxadd", MODE="0660"
KERNEL=="vboxuser", NAME="vboxuser", OWNER="vboxadd", MODE="0666"

Se /dev/null è: inserita o eredita o dipende o tutte queste, da una ramificazione o gruppo che al riavvio della VM in qualche moda forza il ripristino dei diritti al valore della gerarchia?Può essere?

Leggevo inoltre che la modifica del file /etc/fstab può creare problemi; in effetti io ho inserito la cartella condivisa tra host e guest (ultima riga) e montaggio automatico, se non sbaglio ho letto ciò sulla guida relativa a vbox per le cartelle condivise.
Posto il file: https://pastebin.com/VX5CEx6u
Qui si parla di qualcosa di simile per una distribuzione Arch: https://bbs.archlinux.org/viewtopic.php?id=175062

Spero che il contributo sia di aiuto.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Sun Jan 14, 2018 1:57 pm    Post subject: Reply with quote

Credo di aver letto un bel po ma confesso di non raccapezzarmi più e comincia ad subentrare lo sconforto.
Per ovviare a questo tipo di problemi perchè non si dà un esempio di distribuzione ben installata con un minimo di pacchetti e utilità a chi come me approccia questo sistema (ho scrupolosamente seguito la guida ufficiale)?
Sarebbe una gran cosa se chi ne ha competenza nella comunità spiegasse come e dove leggere (emerge --info ???commentare il codice????) e come approcciare le metodologie di una installazione ottimizzata?
Il bello di installarsi e ottimizzarsi/customizzarsi il sistema a propria misura magari potrebbe essere la fase successiva, dopo aver ottenuto padronanza degli strumenti base che si hanno a disposizione.
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 618
Location: tra veneto e friuli (italy)

PostPosted: Sun Jan 14, 2018 2:48 pm    Post subject: Reply with quote

Ciao,
per avere un sistema privo di systemd, puoi usare una pagina del wiki:
Gentoo Without systemd
Credo ti manchi la USE da impostare su "-systemd" e mascherare anche udev, comunque controlla.
Per rendere omogenea l'installazione, credo sia bene dare una ricompilata ai pacchetti che avevano la USE systemd attiva, controlla la lista con:
emerge -puDNv @world
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Sun Jan 14, 2018 3:23 pm    Post subject: Reply with quote

xdarma wrote:
Ciao,
per avere un sistema privo di systemd, puoi usare una pagina del wiki:
Gentoo Without systemd
Credo ti manchi la USE da impostare su "-systemd" e mascherare anche udev, comunque controlla.
Per rendere omogenea l'installazione, credo sia bene dare una ricompilata ai pacchetti che avevano la USE systemd attiva, controlla la lista con:
emerge -puDNv @world


Ok, grazie del consiglio proverò.
Il mio problema però non era avere o meno il systemd che probabilmente ho installato senza volere per ovviare al problema originario,
inizialmente infatti l'installazione non includevo questo pacchetto, la guida ufficiale è abbastanza chiara. ':)'

Mi sai dire qualche cosa riguardo l'impossibilità di mantenere /dev/null modificati a favore di root anche dopo il riavvio del s.o. . ':?'
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 618
Location: tra veneto e friuli (italy)

PostPosted: Sun Jan 14, 2018 5:39 pm    Post subject: Reply with quote

cesma wrote:
Mi sai dire qualche cosa riguardo l'impossibilità di mantenere /dev/null modificati a favore di root anche dopo il riavvio del s.o. . ':?'

No, purtroppo non ti so aiutare.
Però la mia avversione per systemd mi fa propendere per l'ipotesi che systemd+udev stiano interferendo, per questo ti consiglio di "bonificare" il sistema.
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Sun Jan 14, 2018 8:47 pm    Post subject: Reply with quote

cesma a questo punto ti consiglierei, se sai un po' di inglese, di postare sul forum internazionale e li secondo me qualcuno ti sa indirizzare nella giusta direzione
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Mon Jan 15, 2018 7:29 am    Post subject: Reply with quote

fedeliallalinea wrote:
cesma a questo punto ti consiglierei, se sai un po' di inglese, di postare sul forum internazionale e li secondo me qualcuno ti sa indirizzare nella giusta direzione


L'inglese non è un problema, farò così.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Mon Jan 15, 2018 7:39 am    Post subject: Reply with quote

cesma wrote:
L'inglese non è un problema, farò così.

Ottimo vedrai che li qualcuno sapra' aiutarti, io purtroppo ho finito le idee (e sono curioso di sapere il problema)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Mon Jan 15, 2018 9:51 am    Post subject: Reply with quote

fedeliallalinea wrote:
cesma wrote:
L'inglese non è un problema, farò così.

Ottimo vedrai che li qualcuno sapra' aiutarti, io purtroppo ho finito le idee (e sono curioso di sapere il problema)


Per chi fosse interessato lascio il link del thread aperto sul forum inglese:

https://forums.gentoo.org/viewtopic-t-1075476.html .

Fatemi sapere se è il caso di cambiare il titolo in [risolto] visto che comunque il pacchetto sudo siamo riusciti a installarlo.

Alla prossima ciauz.. :twisted:
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Mon Jan 15, 2018 12:06 pm    Post subject: Reply with quote

cesma wrote:
Fatemi sapere se è il caso di cambiare il titolo in [risolto] visto che comunque il pacchetto sudo siamo riusciti a installarlo.

Io aspetterei che risolvi il problema di /dev/null e poi posti qua la soluzione prima di mettere risolto, cosi' che se a qualcun altro succede sa cosa fare.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Mon Jan 15, 2018 1:02 pm    Post subject: Reply with quote

fedeliallalinea wrote:
cesma wrote:
Fatemi sapere se è il caso di cambiare il titolo in [risolto] visto che comunque il pacchetto sudo siamo riusciti a installarlo.

Io aspetterei che risolvi il problema di /dev/null e poi posti qua la soluzione prima di mettere risolto, cosi' che se a qualcun altro succede sa cosa fare.


Stavo procedendo nella direzione consigliatami da xdarma (eliminazione e mascheramento del systemd) una volta però completati i passaggi (ho scelto una politica di unico file contenente tutti i mascheramenti : https://wiki.gentoo.org/wiki/Gentoo_Without_systemd) dovendo aggiornare la var USE ho riscontarto alcuni errori , te li posto o creo un nuovo post?.....ho provato a chiedere a xdarma in privato ma al momento si vede che è offline.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Mon Jan 15, 2018 1:15 pm    Post subject: Reply with quote

cesma wrote:
Stavo procedendo nella direzione consigliatami da xdarma (eliminazione e mascheramento del systemd) una volta però completati i passaggi (ho scelto una politica di unico file contenente tutti i mascheramenti : https://wiki.gentoo.org/wiki/Gentoo_Without_systemd) dovendo aggiornare la var USE ho riscontarto alcuni errori , te li posto o creo un nuovo post?.....ho provato a chiedere a xdarma in privato ma al momento si vede che è offline.

Apri un nuovo thread che mi pare sia un'altro problema
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 618
Location: tra veneto e friuli (italy)

PostPosted: Mon Jan 15, 2018 8:56 pm    Post subject: Reply with quote

cesma wrote:
.....ho provato a chiedere a xdarma in privato ma al momento si vede che è offline.

Scusami, frequento poco il forum ed ero solo di passaggio.
Comunque sei in buone mani, vai tranquillo. ;-)
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
cesma
n00b
n00b


Joined: 08 Jan 2018
Posts: 61

PostPosted: Tue Jan 16, 2018 10:06 am    Post subject: Reply with quote

Per riassumere lo scenario, l'output del comando e concludere:
Code:
#ls -l /dev/null
crw-rw---- 1 root root 1, 3 13 gen /dev/null


risulta non re-impostabile ne con chmod ne con mknod -m 666 /dev/null c 1 3 e al riavvio in qualche
modo ritorna ad avere root senza diritti sulla directory /dev/null.
In realtà questo problema è esteso a tutte le cartelle i cui permessi sono dovrebbe definire da udev.

Infatti le voci presenti in /dev sono create dal kernel, questo è ciò che compete alle opzioni di configurazione del kernel DEVTMPFS.
I permessi sono poi corretti da udev dopo che il kernel ha creato /dev.
Il dubbio è quindi che udev non sia stato avviato o che sia andato in crash per qualche motivo, è infatti lo stage3 che setta questo bit.

Per capire se /udev è ora avviato eseguire:
Code:
#ps -Alf | grep udev
5 S root       653     1  0  80   0 -  5888 SyS_ep Jan14 ?        00:00:00 /sbin/udevd --daemon
0 S root      7602  7595  0  80   0 -  1724 -      15:40 pts/3    00:00:00 grep --colour=auto udev


il bit /sbin/udevd --daemon è un bit importante che se non è presente
e non settato indica che udev non è stato avviato (come a me effettivamente
risultava)
Code:
ps -Alf | grep udev
0 S root      4278  4177  0  80   0 -  1579 pipe_w 00:48 pts/0    00:00:00 grep --colour=auto
.

Per risolvere il problema bisogna verificare se si stia operando con Systemd o OpenRC (quest'ultimo il mo caso)
e lo si deduce da:

Code:
# emerge --info


infatti risulta:
Code:
sys-apps/openrc:          0.34.11::gentoo


Quindi risolvo facendo:
Code:
#rc-update add udev sysinit
#rc-update add udev-trigger sysinit


Riavviando infatti:
Code:
ls -l /dev/null
crw-rw-rw- 1 root root 1, 3 May 12  2013 /dev/null


Ipotesi del mal funzionamento:
Quando il sistema parte, il servizio kernel DEVTMPFS popola /dev.
Il kernel non si preoccupa dei permessi. Opera come root, incluso l'avvio di udev.
Quando poi udev parte genera un evento per ogni voce presente in /dev ed esegue le regole definite: creando dei collegamenti simbolici, modificando i permessi e così via discorrendo.
Il kernel crea /dev/null senza alcun accesso per gli utenti.
udev poi li cambia quando processa l'evento relativo a /dev/null.

Per capire che servizi sono e in quale runlevel sono si può guardare
l'output di:
Code:
#ls -R /etc/runlevels


Il sospetto è che udev e/o udev-trigger sia stato rimosso in qualche modo da sysnit sysinit.
Potrebbe anche però essere plausibile che il file usato come stage3 contenesse un bug perchè questi settaggi dovrebbero sono pertinenza dello stage3.

Direi che il mio caro amico NeddySeagoon ne sa prorpio una più del diavolo riguardo la distribuzione.
Lascio il link del thread sul forum in inglese: https://forums.gentoo.org/viewtopic-t-1075476-postdays-0-postorder-asc-start-0.html

Grazie e alla prossima.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Tue Jan 16, 2018 10:08 am    Post subject: Reply with quote

Potrebbe anche darsi che ha fatto casino quando hai installato il pacchetto systemd in un ambiente openrc.

Effettivamente non mi e' venuto in mente di controllare che udev fosse attivo perche' e' impostato default solitamente all'installazione
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sabayonino
Guru
Guru


Joined: 03 Jan 2012
Posts: 585

PostPosted: Tue Jan 16, 2018 12:58 pm    Post subject: Reply with quote

quoto. potrebbe essere come indica fedeliallalinea

https://wiki.gentoo.org/wiki/Chroot

prima che sistemassero la pagine della wiki , la parte
Code:
mount --make-rslave /mnt/mychroot/"blah"


era indicata per il primo boot per coloro che utilizzavano systemd e facevano l'installazione da un chroot con openrc

Ora sembra che vada per entrambe le situazioni
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum