Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] how do I stop a emerge forced glibc DOWNGRADE?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
assemblerhead
n00b
n00b


Joined: 23 Jan 2016
Posts: 14
Location: TX,US

PostPosted: Fri Jan 12, 2018 5:11 pm    Post subject: [SOLVED] how do I stop a emerge forced glibc DOWNGRADE? Reply with quote

net-libs/libnsl forced an upgrade to sys-libs/glibc-2.26-r5 from sys-libs/glibc-2.25-r9

I have tried the portage methods of masking, accepting keywords,portage.package.use ...
... and emerge immediately tries to force a downgrade.

How do I get off this insane loop-de-loop? Or am I going to have to wipe the drive and reload from scratch?

Output of the command :
Code:
emerge -pv --update --newuse --deep --tree --with-bdeps=y @world

Calculating dependencies... done!
[ebuild     U  ] www-plugins/adobe-flash-28.0.0.137:22::gentoo [28.0.0.126:22::gentoo] USE="nsplugin ppapi" ABI_X86="32 64 (-x32)" 34,716 KiB
[ebuild  N     ] virtual/libc-0::gentoo  0 KiB
[nomerge       ] dev-ruby/test-unit-3.1.9:2::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby22 (-ruby23)"
[nomerge       ]  dev-ruby/power_assert-0.3.1::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby22 (-ruby23)"
[nomerge       ]   virtual/rubygems-11::gentoo  RUBY_TARGETS="ruby22 (-rbx) (-ruby23)"
[nomerge       ]    dev-ruby/rubygems-2.6.14::gentoo  USE="-server {-test}" RUBY_TARGETS="ruby22 (-ruby23) (-ruby24)"
[ebuild   R    ]     dev-lang/ruby-2.2.9:2.2::gentoo  USE="berkdb gdbm ipv6 ncurses readline ssl tk -debug -doc -examples -jemalloc -libressl -rdoc -rubytests -socks5* -xemacs" 0 KiB
[ebuild     U  ] sys-devel/gcc-6.4.0-r1:6.4.0::gentoo [6.4.0:6.4.0::gentoo] USE="cxx fortran graphite (multilib) nls nptl objc objc++ objc-gc openmp pch (pie) sanitize ssp vtv (-altivec) (-awt) -cilk -debug -doc (-fixed-point) (-gcj) -go (-hardened) (-jit) (-libssp) -mpx -pgo -regression-test -vanilla" 14 KiB
[nomerge       ] media-libs/mesa-17.3.1::gentoo  USE="dri3 egl gallium gbm gles2 llvm nptl opencl openmax osmesa pic unwind vdpau vulkan wayland xa xvmc -bindist -classic -d3d9 -debug -gles1 -pax_kernel (-selinux) -vaapi -valgrind" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="i915 radeon radeonsi (-freedreno) -i965 (-imx) -intel -nouveau -r100 -r200 -r300 -r600 (-vc4) -virgl (-vivante) -vmware"
[ebuild     U  ]  virtual/libelf-3:0/1::gentoo [1:0/1::gentoo] ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     UD#] sys-libs/glibc-2.25-r10:2.2::gentoo [2.26-r5:2.2::gentoo] USE="audit caps gd (multilib) rpc%* suid -debug (-hardened) -headers-only -nscd -profile (-selinux) -systemtap (-vanilla) (-doc%)" 0 KiB

Total: 6 packages (3 upgrades, 1 downgrade, 1 new, 1 reinstall), Size of downloads: 34,729 KiB

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by virtual/libc-0::gentoo
# required by @system
# required by @world (argument)
# /etc/portage/package.mask/glibc:
=sys-libs/glibc-2.25-r10

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.


Code tags added by NeddySeagoon
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41298
Location: 56N 3W

PostPosted: Fri Jan 12, 2018 7:53 pm    Post subject: Reply with quote

assemblerhead,

Please post the output of
Code:
emerge --info

and everything in /etc/portage/package.mask
and everything in /etc/portage/package.umask

-- edit --

You have to try really hard to break gentoo so badly you need a reinstall.
This isn't one of those times.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
assemblerhead
n00b
n00b


Joined: 23 Jan 2016
Posts: 14
Location: TX,US

PostPosted: Fri Jan 12, 2018 8:30 pm    Post subject: Reply with quote

Info Per Request :
Code:

Darkstar ~ # emerge --info
Portage 2.3.19 (python 3.5.4-final-0, default/linux/amd64/17.0/desktop, gcc-6.4.0, unavailable, 4.9.76-gentoo-Fam15h x86_64)
=================================================================
System uname: Linux-4.9.76-gentoo-Fam15h-x86_64-AMD_FX-tm-9590_Eight-Core_Processor-with-gentoo-2.4.1
KiB Mem:    32859328 total,  30985792 free
KiB Swap:    8191996 total,   8191996 free
Timestamp of repository gentoo: Fri, 12 Jan 2018 16:30:01 +0000
Head commit of repository gentoo: f5cf75073f46664e96e5df189da6bf9e085dbe13
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.4.6-r1::gentoo, 3.5.4-r1::gentoo
dev-util/cmake:           3.10.1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.9::gentoo (virtual/os-headers)
sys-libs/glibc:           2.26-r5::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:

Testing
    location: /usr/local/portage
    masters: gentoo

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-mtune=bdver2 -march=bdver2 -O2 -pipe --param l1-cache-size=16 --param l1-cache-line-size=64 --param l2-cache-size=2048 -fstack-protector-strong"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CPPFLAGS="-D_GLIBCXX_USE_CXX11_ABI=1"
CXXFLAGS="-mtune=bdver2 -march=bdver2 -O2 -pipe --param l1-cache-size=16 --param l1-cache-line-size=64 --param l2-cache-size=2048 -fstack-protector-strong"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-mtune=bdver2 -march=bdver2 -O2 -pipe --param l1-cache-size=16 --param l1-cache-line-size=64 --param l2-cache-size=2048 -fstack-protector-strong"
FEATURES="assume-digests binpkg-logs cgroup compress-build-logs compress-index compressdebug config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles ipc-sandbox merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms split-elog split-log splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
FFLAGS="-mtune=bdver2 -march=bdver2 -O2 -pipe --param l1-cache-size=16 --param l1-cache-line-size=64 --param l2-cache-size=2048 -fstack-protector-strong"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US l10n_US"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aalib acl acpi alsa amd64 berkdb bidi blas bluray branding bzip2 cairo caps cdda cddb cdparanoia cdr cli consolekit crypt css cups cvs cxx dbm dbus dga dmx dri dts dvd dvdnav dvdr emboss enca encode enscript exif expat experimental faac faad fam fbcon ffmpeg fftw flac flatfile fltk fontconfig foomaticdb fortran ftp gcj gdbm geoip gif gimp git glamor glut gmp gnome-keyring gnutls gpm graphviz gsl gsm gstreamer gtk guile gzip hardened iconv icu idn imagemagick imap infinality inotify introspection ipv6 java javascript jbig joystick jpeg jpeg2k lame lapack lcms libass libcaca libffi libnotify libsamplerate libwww linguas_en_US lua lzma lzo mad matroska md5sum mhash mikmod mime minizip mng modplug modules mozilla mp3 mp4 mpeg mplayer multilib musepack musicbrainz ncurses nls nptl nsplugin odbc offensive ogg openal opengl openmp orc pam pango pcntl pcre pdf perl pic pie plotutils png pnm posix postscript ppds python qt3support rar readline recode sctp sdl seccomp session sharedmem shorten simplexml slang smp sndfile sockets sound sox speex spell sqlite ssl startup-notification static-libs subversion suid svg symlink syslog sysvipc szip taglib tcl tcpd tga theora threads tidy tiff timidity tk toolame truetype twolame udev unicode unwind usb vcd vdpau vorbis vpx wavpack wayland webp wmf wxwidgets x264 xattr xcb xcomposite xface xft xine xinerama xml xmlrpc xmp xosd xpm xscreensaver xv xvid xvmc zlib" ABI_X86="64 32" ALSA_CARDS="XonarDX CMI8788 AV200 AV100" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df memory syslog cgroups cpu smart thermal write_log" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3 sse4a sse4_1 sse4_2 fma fma4 avx xop aes pclmul popcnt xsave f16c fxsr bmi fma clfush abm tbm sahf lwp" CURL_SSL="gnutls" ELIBC="glibc" GRUB_PLATFORMS="efi-64 pc multiboot" INPUT_DEVICES="evdev mouse keyboard joystick" KERNEL="linux" L10N="en en-US l10n_US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="AMDGPU BPF X86" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="amdgpu i915" XFCE_PLUGINS="brightness power" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Contents of Package.Mask :
Code:

>=app-arch/file-roller-3.20.4:0
x11-drivers/ati-drivers
=sys-apps/attr-2.4.48
sys-auth/consolekit
>media-sound/easytag-2.1.8
>www-client/firefox-45.8.0
=virtual/libc-1
<sys-libs/glibc-2.26-r5
dev-java/icedtea-bin
dev-java/icedtea-web
<sys-devel/libtool-2.4.3-r2
<sys-apps/openrc-0.13.0
<sys-process/procps-3.3.9-r2
<dev-lang/perl-5.18.0
>=sys-kernel/gentoo-sources-4.10.0
>=sys-kernel/linux-headers-4.10
x11-drivers/xf86-video-modesetting
>xfce-base/xfce4-meta-4.10
>xfce-base/garcon-0.2.0
>xfce-base/libxfce4ui-4.10.0
>xfce-base/libxfce4util-4.10.1
>xfce-base/xfce4-appfinder-4.10.1
>xfce-base/xfce4-panel-4.10.1
>xfce-base/xfce4-session-4.10.1-r2
>xfce-base/xfce4-settings-4.10.1
>xfce-base/xfconf-4.10.0
>xfce-base/xfdesktop-4.10.2
>xfce-base/xfwm4-4.10.1
<=media-libs/mesa-12.0.0
>x11-terms/xfce4-terminal-0.6.3
>x11-themes/gtk-engines-xfce-2.9.0
>media-video/parole-0.5.4
>xfce-extra/xfce-theme-manager-0.3.5
>xfce-extra/xfce4-notifyd-0.2.4
>media-gfx/ristretto-0.8.0-r1
>xfce-base/libxfce4ui-4.12.1-r2:0


Contents of Package.UnMask :
Code:

>=x11-base/xorg-server-1.19.0
app-emulation/wine-desktop-common
app-emulation/wine-gecko
app-emulation/wine-desktop-common
app-emulation/wine-mono
app-emulation/wine-staging
app-eselect/eselect-wine
app-emulation/wine-any
virtual/wine


Do you need anything from "package.accept_keywords"?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41298
Location: 56N 3W

PostPosted: Fri Jan 12, 2018 10:02 pm    Post subject: Reply with quote

assemblerhead,

Code:
ACCEPT_KEYWORDS="amd64"
tells that you have have stable system.

Code:
eix glibc
[I] sys-libs/glibc
     Available versions:  (2.2) [M](~)2.18-r1^s{tbz2} [M]2.19-r1^s{tbz2} [M]2.20-r2^s{tbz2} [M]2.21-r2^s [M]2.22-r4^s{tbz2} [M]2.23-r4^s [M](~)2.24-r4^s 2.25-r9^s{tbz2} (~)2.25-r10^s (~)2.26-r3^s{tbz2} (~)2.26-r5^s{tbz2}
shows the latest stable glibc to be 2.25-r9, which is what you should have, unless
Code:
 [ebuild     UD#] sys-libs/glibc-2.25-r10
has gone stable is the last 24 hours.

As you currently have glibc-2.26-r5 installed, you must have keyworded it sometime/somehow, to get it to build, to have it installed.

Downgrading glibc is a very bad thing. Portage won't let you, its that bad.

Add =sys-libs/glibc-2.26-r5 to your package.accept_keywords. It can't be there now or portage would not want to downgrade glibc.

All those >category/package-version masks are going te lead to grief when the installed versions are removed.
If you really want to stay in the past, make a local overlay and keep the ebuilds. Be aware of the security things that will pass you by too.

Remove both
Code:
=virtual/libc-1
<sys-libs/glibc-2.26-r5
from package.mask. They don't do what you think they do.

The
Code:
<sys-devel/libtool-2.4.3-r2
<sys-apps/openrc-0.13.0
<sys-process/procps-3.3.9-r2
<dev-lang/perl-5.18.0
<=media-libs/mesa-12.0.0
entries should be redundant too.

Why did you install glibc-2.26-r5 and why did you change the setting that allowed it to be installed?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
assemblerhead
n00b
n00b


Joined: 23 Jan 2016
Posts: 14
Location: TX,US

PostPosted: Fri Jan 12, 2018 11:54 pm    Post subject: Replying / Modified - Tested - Again Reply with quote

net-libs/libnsl REQUIRE(S) glibc 2.26. Chromium was/is sucking it in, through OpenJade --> OpenSP --> libnsl

All the package.mask ( mostly XFCE ) are already in a local overlay.
I froze it because I could not longer tell where the buttons are on any of the GUIs.
Backed up the versions until things became readable again.

Removed both glibc entries from package.mask.
Added =sys-libs/glibc-2.26-r5 to package.accept_keywords. ( Had sys-libs/glibc ~amd 64 before )
Tried again, result :
Code:

Darkstar ~ # emerge -pv --update --newuse --tree --deep --with-bdeps=y @world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild     U  ] www-plugins/adobe-flash-28.0.0.137:22::gentoo [28.0.0.126:22::gentoo] USE="nsplugin ppapi" ABI_X86="32 64 (-x32)" 34,716 KiB
[ebuild  N     ] virtual/libc-1::gentoo  0 KiB
[nomerge       ] dev-ruby/json-1.8.6-r1::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby22 (-ruby23) (-ruby24)"
[nomerge       ]  virtual/rubygems-11::gentoo  RUBY_TARGETS="ruby22 (-rbx) (-ruby23)"
[nomerge       ]   dev-ruby/rubygems-2.6.14::gentoo  USE="-server {-test}" RUBY_TARGETS="ruby22 (-ruby23) (-ruby24)"
[ebuild   R    ]    dev-lang/ruby-2.2.9:2.2::gentoo  USE="berkdb gdbm ipv6 ncurses readline ssl tk -debug -doc -examples -jemalloc -libressl -rdoc -rubytests -socks5* -xemacs" 0 KiB
[ebuild     U  ] sys-devel/gcc-6.4.0-r1:6.4.0::gentoo [6.4.0:6.4.0::gentoo] USE="cxx fortran graphite (multilib) nls nptl objc objc++ objc-gc openmp pch (pie) sanitize ssp vtv (-altivec) (-awt) -cilk -debug -doc (-fixed-point) (-gcj) -go (-hardened) (-jit) (-libssp) -mpx -pgo -regression-test -vanilla" 14 KiB
[nomerge       ] sys-apps/iproute2-4.14.1-r2::gentoo  USE="berkdb iptables ipv6 -atm -minimal (-selinux)"
[ebuild     U  ]  virtual/libelf-3:0/1::gentoo [1:0/1::gentoo] ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     UD ]  sys-libs/glibc-2.25-r9:2.2::gentoo [2.26-r5:2.2::gentoo] USE="audit caps gd (multilib) rpc%* suid -debug (-hardened) -headers-only -nscd -profile (-selinux) -systemtap (-vanilla) (-doc%)" 0 KiB

Total: 6 packages (3 upgrades, 1 downgrade, 1 new, 1 reinstall), Size of downloads: 34,729 KiB
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12707

PostPosted: Sat Jan 13, 2018 12:55 am    Post subject: Re: Replying / Modified - Tested - Again Reply with quote

assemblerhead wrote:
net-libs/libnsl REQUIRE(S) glibc 2.26
Not exactly. Some versions of net-libs/libnsl have RDEPEND="!<sys-libs/glibc-2.26". The stable version of net-libs/libnsl does not have such a block. You must have tried to use unstable net-libs/libnsl, at which point it would request that you use a newer glibc.

assemblerhead wrote:
Added =sys-libs/glibc-2.26-r5 to package.accept_keywords. ( Had sys-libs/glibc ~amd 64 before )
That explains how you upgraded to version 2.26 without it being marked as stable.
assemblerhead wrote:
Tried again, result :
Please post the output of emerge --pretend --verbose '~sys-libs/glibc-2.26'. This command should fail, but its failure message will tell us why your system still wants to downgrade sys-libs/glibc.
Back to top
View user's profile Send private message
assemblerhead
n00b
n00b


Joined: 23 Jan 2016
Posts: 14
Location: TX,US

PostPosted: Sat Jan 13, 2018 1:19 am    Post subject: Another test result Reply with quote

Okay, just tried this ...
Code:

Darkstar ~ # emerge --pretend --verbose ~sys-libs/glibc-2.26

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] sys-libs/glibc-2.26-r5:2.2::gentoo  USE="audit caps gd (multilib) suid -debug -doc (-hardened) -headers-only -nscd -profile (-selinux) -systemtap (-vanilla)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB
Darkstar ~ #


Okay .... this is getting very weird.

Code:

Darkstar ~ # equery d sys-libs/glibc-2.25
 * These packages depend on sys-libs/glibc-2.25:
dev-java/oracle-jdk-bin-1.8.0.152-r1 (!prefix ? sys-libs/glibc)
dev-java/oracle-jre-bin-1.8.0.152-r1 (!prefix ? sys-libs/glibc)
dev-libs/libev-4.23 (elibc_glibc ? >=sys-libs/glibc-2.9_p20081201)
dev-lisp/sbcl-1.4.3 (elibc_glibc ? >=sys-libs/glibc-2.6)
media-video/makemkv-1.10.8 (sys-libs/glibc[multilib?])
net-libs/libnsl-0 (elibc_glibc ? <sys-libs/glibc-2.26)
sys-apps/iproute2-4.14.1-r2 (elibc_glibc ? >=sys-libs/glibc-2.7)
sys-devel/gcc-6.4.0 (elibc_glibc ? >=sys-libs/glibc-2.13)
www-plugins/adobe-flash-28.0.0.126 (>=sys-libs/glibc-2.4)


Code:

Darkstar ~ # equery d sys-libs/glibc-2.26
 * These packages depend on sys-libs/glibc-2.26:
dev-java/oracle-jdk-bin-1.8.0.152-r1 (!prefix ? sys-libs/glibc)
dev-java/oracle-jre-bin-1.8.0.152-r1 (!prefix ? sys-libs/glibc)
dev-libs/libev-4.23 (elibc_glibc ? >=sys-libs/glibc-2.9_p20081201)
dev-lisp/sbcl-1.4.3 (elibc_glibc ? >=sys-libs/glibc-2.6)
media-video/makemkv-1.10.8 (sys-libs/glibc[multilib?])
net-libs/libnsl-0 (elibc_glibc ? <sys-libs/glibc-2.26)
sys-apps/iproute2-4.14.1-r2 (elibc_glibc ? >=sys-libs/glibc-2.7)
sys-devel/gcc-6.4.0 (elibc_glibc ? >=sys-libs/glibc-2.13)
www-plugins/adobe-flash-28.0.0.126 (>=sys-libs/glibc-2.4)


Beginning to think I may have succeeded at breaking a Gentoo box. 8O
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3465
Location: Germany

PostPosted: Sat Jan 13, 2018 4:56 am    Post subject: emerge && glibc, how do I stop a emerge forced DOWNG Reply with quote

assemblerhead wrote:
Code:
Darkstar ~ # equery d sys-libs/glibc-2.26
[...]
net-libs/libnsl-0 (elibc_glibc ? <sys-libs/glibc-2.26)
[...]

For your already installed sys-libs/glibc-2.26 version,
you need >net-libs/libnsl-0

Code:
echo "~net-libs/libnsl-1.2.0" >> /etc/portage/package.accept_keywords
should work.
Back to top
View user's profile Send private message
assemblerhead
n00b
n00b


Joined: 23 Jan 2016
Posts: 14
Location: TX,US

PostPosted: Sat Jan 13, 2018 3:41 pm    Post subject: [SOLVED] Thanks Reply with quote

Just tried it this morning.

It worked! :D

Thank You.

Code:

Darkstar ~ # emerge -pv --update --tree --newuse --deep --with-bdeps=y @world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild     U  ] www-plugins/adobe-flash-28.0.0.137:22::gentoo [28.0.0.126:22::gentoo] USE="nsplugin ppapi" ABI_X86="32 64 (-x32)" 34,716 KiB
[ebuild  rR    ] app-text/opensp-1.5.2-r3::gentoo  USE="nls static-libs -doc {-test}" 0 KiB
[ebuild  N     ] virtual/libc-1::gentoo  0 KiB
[nomerge       ] dev-ruby/test-unit-3.1.9:2::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby22 (-ruby23)"
[nomerge       ]  virtual/rubygems-11::gentoo  RUBY_TARGETS="ruby22 (-rbx) (-ruby23)"
[nomerge       ]   dev-ruby/rubygems-2.6.14::gentoo  USE="-server {-test}" RUBY_TARGETS="ruby22 (-ruby23) (-ruby24)"
[ebuild   R    ]    dev-lang/ruby-2.2.9:2.2::gentoo  USE="berkdb gdbm ipv6 ncurses readline ssl tk -debug -doc -examples -jemalloc -libressl -rdoc -rubytests -socks5* -xemacs" 0 KiB
[ebuild  r  U ~] net-libs/libnsl-1.2.0:0/2::gentoo [0:0/1::gentoo] ABI_X86="32%* (64%*) (-x32)" 205 KiB
[ebuild     U  ] sys-devel/gcc-6.4.0-r1:6.4.0::gentoo [6.4.0:6.4.0::gentoo] USE="cxx fortran graphite (multilib) nls nptl objc objc++ objc-gc openmp pch (pie) sanitize ssp vtv (-altivec) (-awt) -cilk -debug -doc (-fixed-point) (-gcj) -go (-hardened) (-jit) (-libssp) -mpx -pgo -regression-test -vanilla" 14 KiB
[nomerge       ] media-libs/mesa-17.3.1::gentoo  USE="dri3 egl gallium gbm gles2 llvm nptl opencl openmax osmesa pic unwind vdpau vulkan wayland xa xvmc -bindist -classic -d3d9 -debug -gles1 -pax_kernel (-selinux) -vaapi -valgrind" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="i915 radeon radeonsi (-freedreno) -i965 (-imx) -intel -nouveau -r100 -r200 -r300 -r600 (-vc4) -virgl (-vivante) -vmware"
[ebuild     U  ]  virtual/libelf-3:0/1::gentoo [1:0/1::gentoo] ABI_X86="32 (64) (-x32)" 0 KiB

Total: 7 packages (4 upgrades, 1 new, 2 reinstalls), Size of downloads: 34,934 KiB

The following packages are causing rebuilds:

  (net-libs/libnsl-1.2.0:0/2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (app-text/opensp-1.5.2-r3:0/0::gentoo, ebuild scheduled for merge)
Darkstar ~ #

Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41298
Location: 56N 3W

PostPosted: Sat Jan 13, 2018 4:09 pm    Post subject: Reply with quote

assemblerhead,

You are just finding the expected minefield when you mix testing and stable. Its a feature, its not broken :)

A stable package may not depend on a testing package. That is by definition, a bug.
A testing package may not depend on a masked package. That's a bug too.

When you mix stable and testing, the wheel comes off when stable foo depends on stable bar but you want testing baz, which depends on testing bar.
You get to keep all the pieces then, since both versions of bar cannot be installed at the same time.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
assemblerhead
n00b
n00b


Joined: 23 Jan 2016
Posts: 14
Location: TX,US

PostPosted: Sat Jan 13, 2018 11:01 pm    Post subject: Thanks Reply with quote

Agreed. It does cause a headache almost weekly.

IMPORTANT : this is a home desktop. NOT a production / high availability system.

I learn by doing. If I stop poking, prodding, and tweaking ... I'll never learn anything.
On the flip side .... getting my fingers caught in the gears occasionally is par for the course.

Thanks to all who helped. :D
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41298
Location: 56N 3W

PostPosted: Sun Jan 14, 2018 10:29 am    Post subject: Re: Thanks Reply with quote

assemblerhead wrote:
Agreed. It does cause a headache almost weekly.

IMPORTANT : this is a home desktop. NOT a production / high availability system.

I learn by doing. If I stop poking, prodding, and tweaking ... I'll never learn anything.
On the flip side .... getting my fingers caught in the gears occasionally is par for the course.

Thanks to all who helped. :D


Agreed!

I run all ~arch. That's on arm, arm64, amd64 and x86. My SPARC failed :(
I still "get my fingers caught in the gears occasionally" which adds to the fun.

Enjoy your Gentoo.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum