Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot run a program with wine (MountMGR failed + Bad EXE)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
wichtounet
Tux's lil' helper
Tux's lil' helper


Joined: 17 Mar 2012
Posts: 114

PostPosted: Tue Jan 09, 2018 10:30 am    Post subject: Cannot run a program with wine (MountMGR failed + Bad EXE) Reply with quote

Hi,

I'm trying to run a program with wine but without success.

Code:
~ WINEARCH=win64 wine64 Downloads/PathOfBuilding-Setup-1.4.73.exe
fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
wine: Bad EXE format for Z:\home\wichtounet\Downloads\PathOfBuilding-Setup-1.4.73.exe.


This is with wine-vanilla (64 no-multilib). I tried with and without udisks USE flag, but with the same results. When I use winecfg, I can see the drives, but then when I run an application, there is an error with the mount manager. And then, in winecfg, the drives disappeared.

Any idea what's causing this issue ?

I've seen that I'm not the only one having this kind of issue, but I haven't found a solution in the existing threads.

I've only tried wine-vanilla, should I try vanilla-staging ?

Should I simply switch to a multilib installation ?

Thanks
Back to top
View user's profile Send private message
BobWya
Apprentice
Apprentice


Joined: 12 Aug 2012
Posts: 225
Location: Cambridge,UK

PostPosted: Tue Jan 09, 2018 5:23 pm    Post subject: Re: Cannot run a program with wine (MountMGR failed + Bad EX Reply with quote

wichtounet wrote:

...

Should I simply switch to a multilib installation ?

Thanks


Yes!!

A pure 64-bit Wine build is not officially supported by the Wine project. :cry:

If you look at any Windows installer, PE executable, with the readpe utility (pev package builds are in my Overlay ::bobwya)...
You'll find that even 64-bit Windows programs have 32-bit installers.

Bob
_________________
system: G751JT (ASUS-NotebookSKU); processor: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz; memory: 32GiB System Memory; display: GM204M [GeForce GTX 970M]; disk: 2048GB Samsung SSD 850;BD-CMB UJ172 S;1024GB Samsung SSD 850
Back to top
View user's profile Send private message
wichtounet
Tux's lil' helper
Tux's lil' helper


Joined: 17 Mar 2012
Posts: 114

PostPosted: Wed Jan 10, 2018 10:33 am    Post subject: Re: Cannot run a program with wine (MountMGR failed + Bad EX Reply with quote

BobWya wrote:
wichtounet wrote:
Should I simply switch to a multilib installation ?


Yes!!Bob


That's pretty sad :(

Thanks for the answer.

I won't bother with wine then.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum