Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201801-02 ] OptiPNG
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message

Joined: 12 May 2004
Posts: 2038

PostPosted: Mon Jan 08, 2018 12:26 am    Post subject: [ GLSA 201801-02 ] OptiPNG Reply with quote

Gentoo Linux Security Advisory

Title: OptiPNG: Multiple vulnerabilities (GLSA 201801-02)
Severity: normal
Exploitable: remote
Date: 2018-01-07
Bug(s): #637936, #639690
ID: 201801-02


Multiple vulnerabilities have been found in OptiPNG, the worst of
which may allow execution of arbitrary code.


OptiPNG is a PNG optimizer that re-compresses image files to a smaller
size, without losing any information.

Affected Packages

Package: media-gfx/optipng
Vulnerable: < 0.7.6-r2
Unaffected: >= 0.7.6-r2
Architectures: All supported architectures


Multiple vulnerabilities have been discovered in OptiPNG. Please review
the referenced CVE identifiers for details.


A remote attacker could entice a user to process a specially crafted
image file, possibly resulting in execution of arbitrary code with the
privileges of the process or a Denial of Service condition.


There is no known workaround at this time.


All OptiPNG users should upgrade to the latest version:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=media-gfx/optipng-0.7.6-r2"




Last edited by GLSA on Mon Jan 15, 2018 4:17 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum