Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
WTF? SystemV vs systemd after years?!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
furanku
l33t
l33t


Joined: 08 May 2003
Posts: 902
Location: Hamburg, Germany

PostPosted: Fri Dec 22, 2017 10:03 pm    Post subject: WTF? SystemV vs systemd after years?! Reply with quote

Code:
[blocks B      ] sys-apps/sysvinit ("sys-apps/sysvinit" is blocking sys-apps/systemd-236-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/systemd-236-r1:0/2::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd[pam] required by (sys-auth/pambase-20150213-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-209:0= required by (net-misc/networkmanager-1.10.0:0/0::gentoo, installed)
    >=sys-apps/systemd-186:0/2= required by (sys-apps/accountsservice-0.6.45:0/0::gentoo, installed)
    sys-apps/systemd:0/2=[abi_x86_32(-),abi_x86_64(-)] required by (media-sound/pulseaudio-11.1:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (sys-apps/dbus-1.12.2:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (net-fs/samba-4.7.3:0/0::gentoo, installed)
    >=sys-apps/systemd-206:0/2= required by (gnome-base/gvfs-1.32.1:0/0::gentoo, installed)
    sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.24.3:0/0::gentoo, installed)
    >=sys-apps/systemd-44:0= required by (gnome-extra/gnome-system-monitor-3.24.0:0/0::gentoo, installed)
    sys-apps/systemd required by (x11-base/xorg-server-1.19.5:0/1.19.5::gentoo, installed)
    sys-apps/systemd required by (sys-apps/util-linux-2.31-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-206:0= required by (gnome-base/gvfs-1.32.1:0/0::gentoo, installed)
    >=sys-apps/systemd-183:0/2= required by (gnome-base/gnome-session-3.24.1:0/0::gentoo, installed)
    >=sys-apps/systemd-186:0= required by (sys-apps/accountsservice-0.6.45:0/0::gentoo, installed)
    >=sys-apps/systemd-183:0= required by (gnome-base/gnome-session-3.24.1:0/0::gentoo, installed)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-control-center-3.24.3:2/2::gentoo, installed)
    >=sys-apps/systemd-209 required by (sys-fs/udisks-2.7.5:2/2::gentoo, installed)
    >=sys-apps/systemd-186:0=[pam] required by (gnome-base/gdm-3.24.3:0/0::gentoo, installed)
    >=sys-apps/systemd-44:0/2= required by (gnome-extra/gnome-system-monitor-3.24.0:0/0::gentoo, installed)
    >=sys-apps/systemd-209:0= required by (sys-apps/gnome-disk-utility-3.24.1:0/0::gentoo, installed)
    >=sys-apps/systemd-209:0/2= required by (net-misc/networkmanager-1.10.0:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (net-misc/freerdp-2.0.0_rc1:0/2::gentoo, installed)
    sys-apps/systemd:0/2= required by (sys-auth/polkit-0.113-r4:0/0::gentoo, installed)
    >=sys-apps/systemd-204 required by (app-admin/packagekit-base-1.1.7:0/18::gentoo, installed)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-shell-3.24.3:0/0::gentoo, installed)
    sys-apps/systemd:0= required by (net-fs/samba-4.7.3:0/0::gentoo, installed)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-7:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (dev-qt/qtcore-5.9.3:5/5.9::gentoo, installed)
    >=sys-apps/systemd-205:0= required by (sys-fs/lvm2-2.02.166-r2:0/0::gentoo, installed)
    >=sys-apps/systemd-44:0/2= required by (x11-misc/colord-1.3.4:0/2::gentoo, installed)
    sys-apps/systemd:0= required by (net-misc/freerdp-2.0.0_rc1:0/2::gentoo, installed)
    >=sys-apps/systemd-209:0/2= required by (sys-apps/gnome-disk-utility-3.24.1:0/0::gentoo, installed)
    sys-apps/systemd required by (virtual/tmpfiles-0:0/0::gentoo, installed)
    sys-apps/systemd:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (sys-apps/systemd:0=[abi_x86_32(-),abi_x86_64(-)]) required by (media-sound/pulseaudio-11.1:0/0::gentoo, installed)
    sys-apps/systemd:= required by (x11-misc/sddm-0.17.0:0/0::gentoo, installed)
    >=sys-apps/systemd-183 required by (net-misc/modemmanager-1.6.4:0/1::gentoo, installed)
    sys-apps/systemd required by (sys-process/procps-3.3.12-r1:0/5::gentoo, installed)
    sys-apps/systemd required by (net-wireless/bluez-5.47-r1:0/3::gentoo, installed)
    sys-apps/systemd:= required by (net-nds/rpcbind-0.2.4-r1:0/0::gentoo, installed)
    sys-apps/systemd required by (x11-wm/mutter-3.24.4:0/0::gentoo, installed)
    >=sys-apps/systemd-186:0/2=[pam] required by (gnome-base/gdm-3.24.3:0/0::gentoo, installed)
    sys-apps/systemd required by (app-admin/syslog-ng-3.13.2:0/0::gentoo, installed)
    >=sys-apps/systemd-44:0= required by (x11-misc/colord-1.3.4:0/2::gentoo, installed)
    sys-apps/systemd:0= required by (sys-apps/dbus-1.12.2:0/0::gentoo, installed)
    >=sys-apps/systemd-217:0 required by (virtual/udev-217:0/0::gentoo, installed)
    sys-apps/systemd required by (net-print/cups-2.2.6:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (x11-misc/sddm-0.17.0:0/0::gentoo, installed)
    sys-apps/systemd required by (kde-misc/systemd-kcm-9999:5/5::kde, installed)
    sys-apps/systemd:0/2= required by (net-nds/rpcbind-0.2.4-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-205:0/2= required by (sys-fs/lvm2-2.02.166-r2:0/0::gentoo, installed)
    >=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-apps/systemd-212-r5:0/2[abi_x86_32(-),abi_x86_64(-)]) required by (virtual/libudev-232:0/1::gentoo, installed)
    sys-apps/systemd required by (virtual/service-manager-0:0/0::gentoo, installed)
    sys-apps/systemd:= required by (dev-qt/qtcore-5.9.3:5/5.9::gentoo, installed)
    sys-apps/systemd:0= required by (sys-auth/polkit-0.113-r4:0/0::gentoo, installed)

  (sys-apps/sysvinit-2.88-r9:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/sysvinit-2.86-r6[selinux?] (>=sys-apps/sysvinit-2.86-r6) required by (sys-apps/openrc-0.34.11:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Using systemd since years.

[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 6627

PostPosted: Fri Dec 22, 2017 10:21 pm    Post subject: Reply with quote

And what does the output above it say?
Back to top
View user's profile Send private message
furanku
l33t
l33t


Joined: 08 May 2003
Posts: 902
Location: Hamburg, Germany

PostPosted: Fri Dec 22, 2017 10:24 pm    Post subject: Reply with quote

Code:
# emerge -DuaN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-devel/llvm-common-5.0.1 [5.0.0]
[ebuild  N     ] sys-apps/sysvinit-2.88-r9  USE="(-ibm) (-selinux) -static"
[ebuild     U  ] dev-libs/libassuan-2.5.1 [2.4.3-r1]
[ebuild     U  ] app-office/libreoffice-l10n-5.4.4.2 [5.4.3.2]
[ebuild  NS    ] sys-kernel/gentoo-sources-4.14.8-r1 [4.14.7] USE="-build -experimental -symlink"
[ebuild     U  ] media-libs/faad2-2.8.8 [2.8.6]
[ebuild   R    ] dev-qt/qtlockedfile-2.4.1_p20150629  USE="-qt4*"
[ebuild     U  ] media-libs/lv2-1.14.0-r1 [1.14.0] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] media-libs/harfbuzz-1.7.4 [1.7.2]
[ebuild     U  ] sys-devel/llvm-5.0.1 [5.0.0]
[ebuild     U  ] dev-libs/libical-2.0.0-r3 [2.0.0-r2]
[ebuild     U  ] sys-libs/libomp-5.0.1 [5.0.0]
[ebuild     U  ] media-libs/openimageio-1.7.17 [1.6.13] USE="python* -doc% -field3d% -ptex%" CPU_FLAGS_X86="sse2%* -avx% -avx2% -avx512f% -f16c% -sse3% -sse4_1% -sse4_2% -ssse3%" PYTHON_SINGLE_TARGET="-python3_6%" PYTHON_TARGETS="python3_6%*"
[ebuild  NS    ] sys-libs/compiler-rt-sanitizers-5.0.1 [5.0.0] USE="{-test}"
[ebuild     U  ] sys-devel/clang-5.0.1 [5.0.0]
[ebuild  NS    ] sys-libs/compiler-rt-5.0.1 [5.0.0] USE="clang {-test}"
[ebuild  NS    ] sys-devel/clang-runtime-5.0.1 [5.0.0] USE="compiler-rt openmp sanitize -libcxx" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] sys-apps/systemd-236-r1  USE="sysv-utils*"
[ebuild     U  ] net-fs/nfs-utils-2.3.1 [2.2.2_rc1_p20171107]
[ebuild  N     ] sys-apps/openrc-0.34.11  USE="ncurses netifrc pam unicode -audit -debug -newnet (-prefix) (-selinux) -static-libs"
[ebuild     U  ] www-client/google-chrome-unstable-65.0.3298.3 [65.0.3294.5]
[ebuild     U  ] net-print/cups-filters-1.18.0 [1.17.9]
[ebuild     U  ] app-crypt/gnupg-2.2.4 [2.2.3]
[ebuild     U  ] net-libs/webkit-gtk-2.18.4 [2.18.3]
[ebuild   R    ] dev-qt/qtsingleapplication-2.6.1_p20150629  USE="-qt4*"
[ebuild     U  ] sci-mathematics/geogebra-5.0.339.0_p20170308-r1 [5.0.339.0_p20170308]
[ebuild     U  ] net-p2p/qbittorrent-4.0.3 [4.0.1]
[ebuild     U  ] media-video/ffmpeg-3.4.1 [3.4]
[ebuild     U  ] app-office/libreoffice-5.4.4.2 [5.4.3.2]
[blocks B      ] sys-apps/sysvinit ("sys-apps/sysvinit" is blocking sys-apps/systemd-236-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/systemd-236-r1:0/2::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd[pam] required by (sys-auth/pambase-20150213-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-209:0= required by (net-misc/networkmanager-1.10.0:0/0::gentoo, installed)
    >=sys-apps/systemd-186:0/2= required by (sys-apps/accountsservice-0.6.45:0/0::gentoo, installed)
    sys-apps/systemd:0/2=[abi_x86_32(-),abi_x86_64(-)] required by (media-sound/pulseaudio-11.1:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (sys-apps/dbus-1.12.2:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (net-fs/samba-4.7.3:0/0::gentoo, installed)
    >=sys-apps/systemd-206:0/2= required by (gnome-base/gvfs-1.32.1:0/0::gentoo, installed)
    sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.24.3:0/0::gentoo, installed)
    >=sys-apps/systemd-44:0= required by (gnome-extra/gnome-system-monitor-3.24.0:0/0::gentoo, installed)
    sys-apps/systemd required by (x11-base/xorg-server-1.19.5:0/1.19.5::gentoo, installed)
    sys-apps/systemd required by (sys-apps/util-linux-2.31-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-206:0= required by (gnome-base/gvfs-1.32.1:0/0::gentoo, installed)
    >=sys-apps/systemd-183:0/2= required by (gnome-base/gnome-session-3.24.1:0/0::gentoo, installed)
    >=sys-apps/systemd-186:0= required by (sys-apps/accountsservice-0.6.45:0/0::gentoo, installed)
    >=sys-apps/systemd-183:0= required by (gnome-base/gnome-session-3.24.1:0/0::gentoo, installed)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-control-center-3.24.3:2/2::gentoo, installed)
    >=sys-apps/systemd-209 required by (sys-fs/udisks-2.7.5:2/2::gentoo, installed)
    >=sys-apps/systemd-186:0=[pam] required by (gnome-base/gdm-3.24.3:0/0::gentoo, installed)
    >=sys-apps/systemd-44:0/2= required by (gnome-extra/gnome-system-monitor-3.24.0:0/0::gentoo, installed)
    >=sys-apps/systemd-209:0= required by (sys-apps/gnome-disk-utility-3.24.1:0/0::gentoo, installed)
    >=sys-apps/systemd-209:0/2= required by (net-misc/networkmanager-1.10.0:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (net-misc/freerdp-2.0.0_rc1:0/2::gentoo, installed)
    sys-apps/systemd:0/2= required by (sys-auth/polkit-0.113-r4:0/0::gentoo, installed)
    >=sys-apps/systemd-204 required by (app-admin/packagekit-base-1.1.7:0/18::gentoo, installed)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-shell-3.24.3:0/0::gentoo, installed)
    sys-apps/systemd:0= required by (net-fs/samba-4.7.3:0/0::gentoo, installed)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-7:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (dev-qt/qtcore-5.9.3:5/5.9::gentoo, installed)
    >=sys-apps/systemd-205:0= required by (sys-fs/l
...


Thanks for your answer!
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7854
Location: Austria

PostPosted: Fri Dec 22, 2017 10:38 pm    Post subject: Reply with quote

So why is openrc scheduled for merge on your system? PS: We would know much more about your system config if you added --verbose to emerge.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
furanku
l33t
l33t


Joined: 08 May 2003
Posts: 902
Location: Hamburg, Germany

PostPosted: Fri Dec 22, 2017 10:49 pm    Post subject: Reply with quote

Thanks again your your answer. I really appreciate your efforts to help me!

Code:
# emerge --verbose -DuaN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-devel/llvm-common-5.0.1::gentoo [5.0.0::gentoo] 22.880 KiB
[ebuild  N     ] sys-apps/sysvinit-2.88-r9::gentoo  USE="(-ibm) (-selinux) -static" 0 KiB
[ebuild     U  ] dev-libs/libassuan-2.5.1::gentoo [2.4.3-r1::gentoo] USE="-static-libs" 552 KiB
[ebuild     U  ] app-office/libreoffice-l10n-5.4.4.2::gentoo [5.4.3.2::gentoo] USE="-offlinehelp" L10N="de en -af -am -ar -as -ast -be -bg -bn -bn-IN -bo -br -brx -bs -ca -ca-valencia -cs -cy -da -dgo -dz -el -en-GB -en-ZA -eo -es -et -eu -fa -fi -fr -ga -gd -gl -gu -gug -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kmr-Latn -kn -ko -kok -ks -lb -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa -pl -pt -pt-BR -ro -ru -rw -sa -sat -sd -si -sid -sk -sl -sq -sr -sr-Latn -ss -st -sv -sw-TZ -ta -te -tg -th -tn -tr -ts -tt -ug -uk -uz -ve -vi -xh -zh-CN -zh-TW -zu" 20.954 KiB
[ebuild  NS    ] sys-kernel/gentoo-sources-4.14.8-r1:4.14.8-r1::gentoo [4.14.7:4.14.7::gentoo] USE="-build -experimental -symlink" 240 KiB
[ebuild     U  ] media-libs/faad2-2.8.8::gentoo [2.8.6::gentoo] USE="-digitalradio -static-libs" ABI_X86="(64) -32 (-x32)" 1.044 KiB
[ebuild   R    ] dev-qt/qtlockedfile-2.4.1_p20150629::gentoo  USE="qt5 -doc -qt4*" 0 KiB
[ebuild     U  ] media-libs/lv2-1.14.0-r1::gentoo [1.14.0::gentoo] USE="-doc -plugins" ABI_X86="(64%*) -32% (-x32)" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" 0 KiB
[ebuild     U  ] media-libs/harfbuzz-1.7.4:0/0.9.18::gentoo [1.7.2:0/0.9.18::gentoo] USE="cairo glib graphite icu introspection truetype -debug -fontconfig -static-libs {-test}" ABI_X86="32 (64) (-x32)" 1.678 KiB
[ebuild     U  ] sys-devel/llvm-5.0.1:5::gentoo [5.0.0:5::gentoo] USE="libffi ncurses -debug -doc -gold -libedit {-test}" ABI_X86="32 (64) (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" 96 KiB
[ebuild     U  ] dev-libs/libical-2.0.0-r3:0/2::gentoo [2.0.0-r2:0/2::gentoo] USE="-doc -examples -static-libs" 0 KiB
[ebuild     U  ] sys-libs/libomp-5.0.1::gentoo [5.0.0::gentoo] USE="-hwloc -ompt {-test}" ABI_X86="(64) -32 (-x32)" 2.027 KiB
[ebuild     U  ] media-libs/openimageio-1.7.17::gentoo [1.6.13::gentoo] USE="gif opengl python* ssl truetype -colorio -doc% -ffmpeg -field3d% -jpeg2k -opencv -ptex% -qt4 -raw" CPU_FLAGS_X86="sse2%* -avx% -avx2% -avx512f% -f16c% -sse3% -sse4_1% -sse4_2% -ssse3%" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6%" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6%*" 26.529 KiB
[ebuild  NS    ] sys-libs/compiler-rt-sanitizers-5.0.1:5.0.1::gentoo [5.0.0:5.0.0::gentoo] USE="{-test}" 1.464 KiB
[ebuild     U  ] sys-devel/clang-5.0.1:5::gentoo [5.0.0:5::gentoo] USE="static-analyzer xml -debug -default-compiler-rt -default-libcxx -doc {-test} (-z3)" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" PYTHON_TARGETS="python2_7" 11.846 KiB
[ebuild  NS    ] sys-libs/compiler-rt-5.0.1:5.0.1::gentoo [5.0.0:5.0.0::gentoo] USE="clang {-test}" 0 KiB
[ebuild  NS    ] sys-devel/clang-runtime-5.0.1:5.0.1::gentoo [5.0.0:5.0.0::gentoo] USE="compiler-rt openmp sanitize -libcxx" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild   R    ] sys-apps/systemd-236-r1:0/2::gentoo  USE="acl gcrypt kmod lz4 pam (policykit) seccomp ssl sysv-utils* -apparmor -audit -build -cryptsetup -curl -elfutils -gnuefi -http -idn -importd -libidn2 -lzma -nat -qrcode (-selinux) {-test} -usrmerge -vanilla -xkb" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] net-fs/nfs-utils-2.3.1::gentoo [2.2.2_rc1_p20171107::gentoo] USE="ipv6 ldap libmount nfsidmap nfsv4 tcpd uuid -caps -kerberos -nfsdcld -nfsv41 (-selinux)" 835 KiB
[ebuild  N     ] sys-apps/openrc-0.34.11::gentoo  USE="ncurses netifrc pam unicode -audit -debug -newnet (-prefix) (-selinux) -static-libs" 0 KiB
[ebuild     U  ] www-client/google-chrome-unstable-65.0.3298.3::gentoo [65.0.3294.5::gentoo] USE="plugins" L10N="de -am -ar -bg -bn -ca -cs -da -el -en-GB -es -es-419 -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt-BR -pt-PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh-CN -zh-TW" 51.675 KiB
[ebuild     U  ] net-print/cups-filters-1.18.0::gentoo [1.17.9::gentoo] USE="dbus foomatic jpeg ldap pdf png postscript tiff zeroconf -ipp_autosetup -pclm -perl -static-libs {-test}" 1.424 KiB
[ebuild     U  ] app-crypt/gnupg-2.2.4::gentoo [2.2.3::gentoo] USE="bzip2 gnutls ldap nls readline smartcard usb -doc (-selinux) -tofu -tools -wks-server" 6.418 KiB
[ebuild     U  ] net-libs/webkit-gtk-2.18.4:4/37::gentoo [2.18.3:4/37::gentoo] USE="(X) egl geolocation gstreamer introspection jit libnotify opengl spell wayland webgl (-aqua) -coverage -doc -gles2 -gnome-keyring -nsplugin {-test}" 14.481 KiB
[ebuild   R    ] dev-qt/qtsingleapplication-2.6.1_p20150629::gentoo  USE="X qt5 -doc -qt4*" 0 KiB
[ebuild     U  ] sci-mathematics/geogebra-5.0.339.0_p20170308-r1::gentoo [5.0.339.0_p20170308::gentoo] 0 KiB
[ebuild     U  ] net-p2p/qbittorrent-4.0.3::gentoo [4.0.1::gentoo] USE="X dbus -debug -webui" 4.175 KiB
[ebuild     U  ] media-video/ffmpeg-3.4.1:0/55.57.57::gentoo [3.4:0/55.57.57::gentoo] USE="X alsa bzip2 encode gpl hardcoded-tables iconv mp3 network opengl postproc pulseaudio samba sdl svg threads truetype vorbis x264 xcb xvid zlib (-altivec) -amr -amrenc -bluray -bs2b -cdio -celt -chromaprint -chromium -cpudetection -debug -doc -fdk -flite -fontconfig -frei0r -fribidi -gcrypt -gme -gmp -gnutls -gsm -iec61883 -ieee1394 -jack -jpeg2k -kvazaar -ladspa -libass -libcaca -libilbc -librtmp -libsoxr -libv4l -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) (-mmal) -modplug -nvenc -openal -openh264 -openssl -opus -oss -pic -rubberband -snappy -speex -ssh -static-libs {-test} -theora -twolame -v4l -vaapi -vdpau -vpx -wavpack -webp -x265 -zeromq -zimg -zvbi" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx mmxext sse sse2 -3dnow -3dnowext -aes -avx -avx2 -fma3 -fma4 -sse3 -sse4_1 -sse4_2 -ssse3 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher" 9.939 KiB
[ebuild     U  ] app-office/libreoffice-5.4.4.2::gentoo [5.4.3.2::gentoo] USE="bluetooth branding cups dbus gtk kde -coinmp -collada -debug -eds -firebird -gltf -googledrive -gstreamer -gtk3 -java -jemalloc -libressl -mysql -odk -pdfimport -postgres -quickstarter {-test} -vlc (-gnome%*)" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python3_4 -python2_7 -python3_5 -python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" 191.407 KiB
[blocks B      ] sys-apps/sysvinit ("sys-apps/sysvinit" is blocking sys-apps/systemd-236-r1)

Total: 29 packages (20 upgrades, 2 new, 4 in new slots, 3 reinstalls), Size of downloads: 369.657 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/systemd-236-r1:0/2::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd[pam] required by (sys-auth/pambase-20150213-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-209:0= required by (net-misc/networkmanager-1.10.0:0/0::gentoo, installed)
    >=sys-apps/systemd-186:0/2= required by (sys-apps/accountsservice-0.6.45:0/0::gentoo, installed)
    sys-apps/systemd:0/2=[abi_x86_32(-),abi_x86_64(-)] required by (media-sound/pulseaudio-11.1:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (sys-apps/dbus-1.12.2:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (net-fs/samba-4.7.3:0/0::gentoo, installed)
    >=sys-apps/systemd-206:0/2= required by (gnome-base/gvfs-1.32.1:0/0::gentoo, installed)
    sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.24.3:0/0::gentoo, installed)
    >=sys-apps/systemd-44:0= required by (gnome-extra/gnome-system-monitor-3.24.0:0/0::gentoo, installed)
    sys-apps/systemd required by (x11-base/xorg-server-1.19.5:0/1.19.5::gentoo, installed)
    sys-apps/systemd required by (sys-apps/util-linux-2.31-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-206:0= required by (gnome-base/gvfs-1.32.1:0/0::gentoo, installed)
    >=sys-apps/systemd-183:0/2= required by (gnome-base/gnome-session-3.24.1:0/0::gentoo, installed)
    >=sys-apps/systemd-186:0= required by (sys-apps/accountsservice-0.6.45:0/0::gentoo, installed)
    >=sys-apps/systemd-183:0= required by (gnome-base/gnome-session-3.24.1:0/0::gentoo, installed)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-control-center-3.24.3:2/2::gentoo, installed)
    >=sys-apps/systemd-209 required by (sys-fs/udisks-2.7.5:2/2::gentoo, installed)
    >=sys-apps/systemd-186:0=[pam] required by (gnome-base/gdm-3.24.3:0/0::gentoo, installed)
    >=sys-apps/systemd-44:0/2= required by (gnome-extra/gnome-system-monitor-3.24.0:0/0::gentoo, installed)
    >=sys-apps/systemd-209:0= required by (sys-apps/gnome-disk-utility-3.24.1:0/0::gentoo, installed)
    >=sys-apps/systemd-209:0/2= required by (net-misc/networkmanager-1.10.0:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (net-misc/freerdp-2.0.0_rc1:0/2::gentoo, installed)
    sys-apps/systemd:0/2= required by (sys-auth/polkit-0.113-r4:0/0::gentoo, installed)
    >=sys-apps/systemd-204 required by (app-admin/packagekit-base-1.1.7:0/18::gentoo, installed)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-shell-3.24.3:0/0::gentoo, installed)
    sys-apps/systemd:0= required by (net-fs/samba-4.7.3:0/0::gentoo, installed)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-7:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (dev-qt/qtcore-5.9.3:5/5.9::gentoo, installed)
    >=sys-apps/systemd-205:0= required by (sys-fs/lvm2-2.02.166-r2:0/0::gentoo, installed)
    >=sys-apps/systemd-44:0/2= required by (x11-misc/colord-1.3.4:0/2::gentoo, installed)
    sys-apps/systemd:0= required by (net-misc/freerdp-2.0.0_rc1:0/2::gentoo, installed)
    >=sys-apps/systemd-209:0/2= required by (sys-apps/gnome-disk-utility-3.24.1:0/0::gentoo, installed)
    sys-apps/systemd required by (virtual/tmpfiles-0:0/0::gentoo, installed)
    sys-apps/systemd:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (sys-apps/systemd:0=[abi_x86_32(-),abi_x86_64(-)]) required by (media-sound/pulseaudio-11.1:0/0::gentoo, installed)
    sys-apps/systemd:= required by (x11-misc/sddm-0.17.0:0/0::gentoo, installed)
    >=sys-apps/systemd-183 required by (net-misc/modemmanager-1.6.4:0/1::gentoo, installed)
    sys-apps/systemd required by (sys-process/procps-3.3.12-r1:0/5::gentoo, installed)
    sys-apps/systemd required by (net-wireless/bluez-5.47-r1:0/3::gentoo, installed)
    sys-apps/systemd:= required by (net-nds/rpcbind-0.2.4-r1:0/0::gentoo, installed)
    sys-apps/systemd required by (x11-wm/mutter-3.24.4:0/0::gentoo, installed)
    >=sys-apps/systemd-186:0/2=[pam] required by (gnome-base/gdm-3.24.3:0/0::gentoo, installed)
    sys-apps/systemd required by (app-admin/syslog-ng-3.13.2:0/0::gentoo, installed)
    >=sys-apps/systemd-44:0= required by (x11-misc/colord-1.3.4:0/2::gentoo, installed)
    sys-apps/systemd:0= required by (sys-apps/dbus-1.12.2:0/0::gentoo, installed)
    >=sys-apps/systemd-217:0 required by (virtual/udev-217:0/0::gentoo, installed)
    sys-apps/systemd required by (net-print/cups-2.2.6:0/0::gentoo, installed)
    sys-apps/systemd:0/2= required by (x11-misc/sddm-0.17.0:0/0::gentoo, installed)
    sys-apps/systemd required by (kde-misc/systemd-kcm-9999:5/5::kde, installed)
    sys-apps/systemd:0/2= required by (net-nds/rpcbind-0.2.4-r1:0/0::gentoo, installed)
    >=sys-apps/systemd-205:0/2= required by (sys-fs/lvm2-2.02.166-r2:0/0::gentoo, installed)
    >=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-apps/systemd-212-r5:0/2[abi_x86_32(-),abi_x86_64(-)]) required by (virtual/libudev-232:0/1::gentoo, installed)
    sys-apps/systemd required by (virtual/service-manager-0:0/0::gentoo, installed)
    sys-apps/systemd:= required by (dev-qt/qtcore-5.9.3:5/5.9::gentoo, installed)
    sys-apps/systemd:0= required by (sys-auth/polkit-0.113-r4:0/0::gentoo, installed)

  (sys-apps/sysvinit-2.88-r9:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/sysvinit-2.86-r6[selinux?] (>=sys-apps/sysvinit-2.86-r6) required by (sys-apps/openrc-0.34.11:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

~ #


[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
furanku
l33t
l33t


Joined: 08 May 2003
Posts: 902
Location: Hamburg, Germany

PostPosted: Fri Dec 22, 2017 10:57 pm    Post subject: Reply with quote

I just switched last week to 2017 profile. Synced and emerged daily since that without problems.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7854
Location: Austria

PostPosted: Fri Dec 22, 2017 11:02 pm    Post subject: Reply with quote

Still strange. Do the same emerge command with adding '--exclude openrc' and let's see what complains.

What profile are you using?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
furanku
l33t
l33t


Joined: 08 May 2003
Posts: 902
Location: Hamburg, Germany

PostPosted: Fri Dec 22, 2017 11:53 pm    Post subject: Reply with quote

Code:
 # eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/13.0
  [2]   default/linux/amd64/13.0/selinux
  [3]   default/linux/amd64/13.0/desktop
  [4]   default/linux/amd64/13.0/desktop/gnome
  [5]   default/linux/amd64/13.0/desktop/gnome/systemd
  [6]   default/linux/amd64/13.0/desktop/plasma
  [7]   default/linux/amd64/13.0/desktop/plasma/systemd
  [8]   default/linux/amd64/13.0/developer
  [9]   default/linux/amd64/13.0/no-multilib
  [10]  default/linux/amd64/13.0/systemd
  [11]  default/linux/amd64/13.0/x32
  [12]  default/linux/amd64/17.0
  [13]  default/linux/amd64/17.0/selinux
  [14]  default/linux/amd64/17.0/hardened
  [15]  default/linux/amd64/17.0/hardened/selinux
  [16]  default/linux/amd64/17.0/desktop
  [17]  default/linux/amd64/17.0/desktop/gnome
  [18]  default/linux/amd64/17.0/desktop/gnome/systemd
  [19]  default/linux/amd64/17.0/desktop/plasma
  [20]  default/linux/amd64/17.0/desktop/plasma/systemd *
  [21]  default/linux/amd64/17.0/developer
  [22]  default/linux/amd64/17.0/no-multilib
  [23]  default/linux/amd64/17.0/no-multilib/hardened
  [24]  default/linux/amd64/17.0/no-multilib/hardened/selinux
  [25]  default/linux/amd64/17.0/systemd
  [26]  default/linux/amd64/17.0/x32
  [27]  hardened/linux/amd64
  [28]  hardened/linux/amd64/selinux
  [29]  hardened/linux/amd64/no-multilib
  [30]  hardened/linux/amd64/no-multilib/selinux
  [31]  hardened/linux/amd64/x32
  [32]  default/linux/musl/amd64
  [33]  hardened/linux/musl/amd64
  [34]  default/linux/musl/amd64/x32
  [35]  hardened/linux/musl/amd64/x32
  [36]  default/linux/uclibc/amd64
  [37]  hardened/linux/uclibc/amd64

# emerge -DuaN --exclude openrc --verbose @world                                                       
                                                                                                                                                 
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=sys-apps/openrc-0.15" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/openrc-9999::gentoo (masked by: missing keyword)
- sys-apps/openrc-0.34.11::gentoo (masked by: exclude option)
- sys-apps/openrc-0.32.1::gentoo (masked by: exclude option)
- sys-apps/openrc-0.28::gentoo (masked by: exclude option)

(dependency required by "net-misc/netifrc-0.6.0::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

~ #



I'm using the KDE Live-overlay.
Back to top
View user's profile Send private message
furanku
l33t
l33t


Joined: 08 May 2003
Posts: 902
Location: Hamburg, Germany

PostPosted: Sat Dec 23, 2017 12:06 am    Post subject: Reply with quote

Seems like unmerging net-misc/netifrc solved the problem. THANKS!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum