Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SOLVED Xorg server problem with nvidia engt 430 card
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
mikefot
Apprentice
Apprentice


Joined: 19 Nov 2014
Posts: 247

PostPosted: Mon Dec 18, 2017 9:26 am    Post subject: SOLVED Xorg server problem with nvidia engt 430 card Reply with quote

Dear All,

I am continuing on the kernel list from here (https://forums.gentoo.org/viewtopic-t-1073840.html).

I need to recompile the kernel (4.12.12) to better recognise the nvidia engt 430 card I am using.

I am getting a kms modesetting error.

The discussion here seems helpful:

https://wiki.gentoo.org/wiki/Xorg/Guide#Kernel_modesetting

and part of

https://wiki.gentoo.org/wiki/NVidia/nvidia-driver

I am going down the nouveau route NOT the proprietary drivers.

I will check the settings in the kernel and if I can find anything that is wrong or missing I will make the changes and update the kernel.

If anyone is aware of any new settings or recent innovations in kernel settings in this area I would be grateful for pointers.

More on this shortly.

Regards

Michael Fothergill


Last edited by mikefot on Tue Dec 19, 2017 12:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
mikefot
Apprentice
Apprentice


Joined: 19 Nov 2014
Posts: 247

PostPosted: Mon Dec 18, 2017 11:58 am    Post subject: should I have libinput in my make.conf file Reply with quote

Dear All,

My make.conf file looks like this at present:

Code:
bong portage # more make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
MAKEOPTS ="-j1"
USE="bindist introspection hpn ipv6 mmx pam pie selinux sse sse2 static X policykit"
FEATURES="ccache"
CCACHE_SIZE="30G"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
INPUT_DEVICES="evdev synaptics"
VIDEO_CARDS="nouveau"

GENTOO_MIRRORS="http://www.mirrorservice.org/sites/distfiles.gentoo.org/ rsync://rsync.mirrorservice.org/distfiles.gentoo.org/"



Should I have e.g. libinput present in the INPUT_DEVICES section nowadays?

Is it meant to replace evdev?

I am running gentoo stable on an FX8350 box and using either an old PS2 mouse and dumbish keyboard OR if needed a USB keyboard and mouse that light up and are a low end gamerish.....

Comments appreciated.

MF
Back to top
View user's profile Send private message
mikefot
Apprentice
Apprentice


Joined: 19 Nov 2014
Posts: 247

PostPosted: Mon Dec 18, 2017 6:43 pm    Post subject: I reconfigured the kernel Reply with quote

Dear All,

I reconfigured the kernel. I had forgotten to turn on the nouveau option in the kernel.

I also installed the firmware package.

But this still has not cured the Xorg kernel modesetting problem.

The section of the kernel that deals with the frame buffer seems different somewhat to the description in the documentation.

Maybe it has been upgraded in some way and I am still missing something.

https://wiki.gentoo.org/wiki/Xorg/Guide#Kernel_modesetting

I found something called
Quote:
ETI Support for frame buffer devices
but could NOT find
Quote:
Support for frame buffer devices
itself.

I could not find the basic framebuffer console support option
Quote:
<*> Framebuffer Console Support
- maybe it has been renamed etc.

I think I might need to change the * checked for the nouveau option to M since I am using the firmware package.

That could be a cure for the Xorg crash in my case.

Comments appreciated.

Regards

MF
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum