Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dependency conflict while doing upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
hubot
n00b
n00b


Joined: 14 Aug 2017
Posts: 18

PostPosted: Sun Dec 17, 2017 3:42 pm    Post subject: Dependency conflict while doing upgrade Reply with quote

I've got following error when I tried upgrade Gentoo:

Code:

tux ~ # emerge -DNupv @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] net-analyzer/nmap-7.60::gentoo [7.40::gentoo] USE="ipv6 nls nse ssl -libressl -libssh2% -ncat -ndiff -nmap-update -nping (-system-lua) -zenmap" LINGUAS="-de -fr -hi -hr -it -ja -pl -pt_BR -ru -zh" PYTHON_TARGETS="python2_7" 10,152 KiB
[ebuild     U ~] net-analyzer/hydra-8.5::gentoo [8.1::gentoo] USE="gtk idn pcre ssl -firebird -libressl% -mysql -ncp -oracle -postgres -subversion" 1,166 KiB

Total: 2 packages (2 upgrades), Size of downloads: 11,318 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-scheme/guile:12

  (dev-scheme/guile-2.2.3:12/12::dantrell-gnome, ebuild scheduled for merge) conflicts with
    >=dev-scheme/guile-1.6.4-r1[deprecated,discouraged] required by (www-client/elinks-0.12_pre6-r1:0/0::gentoo, installed)
                                           ^^^^^^^^^^^

dev-libs/libsodium:0

  (dev-libs/libsodium-1.0.15:0/23::gentoo, ebuild scheduled for merge) conflicts with
    dev-libs/libsodium:0/18 required by (dev-python/pynacl-1.1.2:0/0::gentoo, installed)
                      ^^^^^
    >=dev-libs/libsodium-0.6.1:0/18=[asm,urandom] required by (net-libs/tox-0.1.10:0/0.1::gentoo, installed)
                              ^^^^^^             


 * IMPORTANT: 16 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


Can anyone help me?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 17328
Location: here

PostPosted: Sun Dec 17, 2017 3:51 pm    Post subject: Reply with quote

Add discouraged use flag to dev-scheme/guile through /etc/portage/package.use
Code:
# echo "dev-scheme/guile discouraged" >> /etc/portage/package.use

For dev-libs/libsodium try to add --backtrack=50 option to emerge command, if not work try with
Code:
# emerge -1  dev-libs/libsodium net-libs/tox

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum