Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mysql-workbench >= 3.6.9 not able to connect to any host
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
ziller
n00b
n00b


Joined: 04 Sep 2006
Posts: 28
Location: Switzerland

PostPosted: Sat Dec 16, 2017 4:40 pm    Post subject: mysql-workbench >= 3.6.9 not able to connect to any host Reply with quote

Since updating mysql workbench from 3.6.4 to 3.6.10, or 3.6.9, I can no longer connect to any host. Not even localhost, or using the TCP/IP over SSH option. Every connection attempt gives "Unsupported option provided to mysql_options()".

I found older bugs referring to the same error, but those are all related to old style password hashing, which is already disabled on every host I'm trying to connect to.

Workbench log is not particularly helpful:
Code:

17:23:36 [WRN][       WBModule]: OS not found on supported OS list. OS string: ' x86_64'
17:23:39 [ERR][SQL Editor Form]: SqlEditorForm: exception in do_connect method: Exception: Unsupported option provided to mysql_options()
17:23:39 [ERR][  GRTDispatcher]: exception in grt execute_task, continuing: Exception: Unsupported option provided to mysql_options()
17:23:39 [ERR][  GRTDispatcher]: worker: task 'execute sql queries' has failed with error:.Unsupported option provided to mysql_options()
17:23:39 [ERR][    WQE backend]: Got an exception during connection: Unsupported option provided to mysql_options()
17:23:39 [ERR][SQL Editor Form]: SQL editor could not be connected: Unsupported option provided to mysql_options()
17:23:39 [ERR][SQL Editor Form]: Your connection attempt failed for user '****' from your host to server at dbc06.****.net:3
306:
  Unsupported option provided to mysql_options()

Please:
1 Check that mysql is running on server dbc06.****.net
2 Check that mysql is running on port 3306 (note: 3306 is the default, but this can be changed)
3 Check the **** has rights to connect to dbc06.****.net from your address (mysql rights define what clients can connect to
the server and from which machines)
4 Make sure you are both providing a password if needed and using the correct password for dbc06.****.net connecting from the host address you're connecting from


Downgrading back to 6.3.4 works okay
Back to top
View user's profile Send private message
ziller
n00b
n00b


Joined: 04 Sep 2006
Posts: 28
Location: Switzerland

PostPosted: Sun Dec 17, 2017 12:03 pm    Post subject: Reply with quote

Ok, found a workaround. This whole issue seems to be due to workbench requiring mysql 5.7 to be installed on the system. But since that's not available here (yet), replacing it with mariadb also works.

Has to be mariadb < 10.2.8 though, due to this bug. Works well with 10.1.29.
Back to top
View user's profile Send private message
KWhat
l33t
l33t


Joined: 04 Sep 2005
Posts: 620
Location: Los Angeles

PostPosted: Thu Mar 08, 2018 4:47 am    Post subject: Reply with quote

Thanks for figuring this out, I ended up going back to =dev-db/mysql-workbench-6.3.4-r2 to work around the issue.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum