Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]: qt4 and qt5
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2658

PostPosted: Sun Dec 03, 2017 2:32 am    Post subject: Reply with quote

Hi, guys,
I believe I got rid of everything that is not exist in the kde-apps and kde-plasma.

This is the conflicting list I got:

Code:

IgorDellGentoo /home/igor/dbhandler # emerge -u1pv $(qlist -I kde-frameworks/*)

 * IMPORTANT: config file '/etc/portage/package.use' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] kde-frameworks/extra-cmake-modules-5.37.0-r1:5/5.37::gentoo  USE="-doc {-test}" 305 KiB
[ebuild     U  ] x11-misc/xdg-utils-1.1.1-r1::gentoo [1.1.1::gentoo] USE="perl -doc" 0 KiB
[ebuild  N     ] kde-frameworks/kf-env-4:5::gentoo  0 KiB
[ebuild  NS    ] dev-qt/qttest-4.8.7:4::gentoo [5.7.1:5/5.7::gentoo] USE="exceptions (-aqua) -debug -pch" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild   R    ] sys-auth/polkit-qt-0.112.0-r1::gentoo  USE="qt4 qt5* -debug -examples" 0 KiB
[ebuild  NS    ] kde-frameworks/oxygen-icons-5.37.0:5/5.37::gentoo [4.14.3:4/4.14::gentoo] USE="{-test}" 228918 KiB
[uninstall     ] kde-frameworks/oxygen-icons-4.14.3:4/4.14::gentoo  USE="(-aqua) -sources"
[blocks b      ] kde-frameworks/oxygen-icons:4 ("kde-frameworks/oxygen-icons:4" is blocking kde-frameworks/oxygen-icons-5.37.0)
[uninstall     ] kde-base/legacy-icons-4.11.22:4/4.11::gentoo  USE="(-aqua)"
[blocks b      ] >=kde-frameworks/oxygen-icons-5.19.0:5 (">=kde-frameworks/oxygen-icons-5.19.0:5" is blocking kde-base/legacy-icons-4.11.22)
[ebuild  N     ] kde-frameworks/kcoreaddons-5.37.0:5/5.37::gentoo  USE="nls -debug -doc (-fam) {-test}" 341 KiB
[ebuild  N     ] kde-frameworks/ki18n-5.37.0:5/5.37::gentoo  USE="-debug -doc {-test}" PYTHON_SINGLE_TARGET="python3_4 -python2_7 -python3_5 (-python3_6)" PYTHON_TARGETS="python2_7 python3_4 -python3_5 (-python3_6)" 573 KiB
[ebuild  N     ] kde-frameworks/kwidgetsaddons-5.37.0:5/5.37::gentoo  USE="nls -debug -doc {-test}" 2125 KiB
[ebuild  N     ] kde-frameworks/kwindowsystem-5.37.0:5/5.37::gentoo  USE="X nls -debug -doc {-test}" 164 KiB
[ebuild  N     ] kde-frameworks/kdbusaddons-5.37.0:5/5.37::gentoo  USE="X nls -debug -doc {-test}" 35 KiB
[ebuild  N     ] kde-frameworks/kcrash-5.37.0:5/5.37::gentoo  USE="nls -debug -doc {-test}" 22 KiB
[ebuild  N     ] kde-frameworks/karchive-5.37.0:5/5.37::gentoo  USE="bzip2 lzma -debug -doc {-test}" 111 KiB
[ebuild  N     ] kde-frameworks/kconfig-5.37.0:5/5.37::gentoo  USE="nls -debug -doc {-test}" 228 KiB
[ebuild  N     ] kde-frameworks/kitemviews-5.37.0:5/5.37::gentoo  USE="nls -debug -doc {-test}" 74 KiB
[ebuild  N     ] kde-frameworks/kguiaddons-5.37.0:5/5.37::gentoo  USE="-debug -doc {-test}" 40 KiB
[ebuild  N     ] kde-frameworks/kcodecs-5.37.0:5/5.37::gentoo  USE="nls -debug -doc {-test}" 214 KiB
[ebuild  N     ] kde-frameworks/kdoctools-5.37.0:5/5.37::gentoo  USE="-debug -doc {-test}" 408 KiB
[ebuild  NS    ] kde-frameworks/kfilemetadata-5.37.0:5/5.37::gentoo [4.14.3:4/4.14::gentoo] USE="exif pdf taglib -debug -doc -epub -ffmpeg -libav -office {-test}" 214 KiB
[ebuild  N     ] kde-frameworks/kauth-5.37.0:5/5.37::gentoo  USE="nls (policykit) -debug -doc {-test}" 83 KiB
[ebuild  N     ] kde-frameworks/kconfigwidgets-5.37.0:5/5.37::gentoo  USE="man -debug -doc {-test}" 367 KiB
[ebuild  N     ] kde-frameworks/kiconthemes-5.37.0:5/5.37::gentoo  USE="-debug -doc {-test}" 201 KiB
[ebuild  N     ] kde-plasma/polkit-kde-agent-5.10.5:5::gentoo  USE="-debug" 41 KiB

Total: 23 packages (1 upgrade, 18 new, 3 in new slots, 1 reinstall, 2 uninstalls), Size of downloads: 234454 KiB
Conflict: 2 blocks

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

kde-frameworks/kdelibs:4

  (kde-frameworks/kdelibs-4.14.37:4/4.14::gentoo, ebuild scheduled for merge) conflicts with
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kdepim-l10n-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/killbots-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kalzium-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua,handbook] required by (kde-plasma/ksysguard-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/okular-15.08.3-r1:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ktouch-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kmines-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/ksystemlog-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kubrick-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kstars-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/granatier-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kturtle-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kwrited-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/ksquares-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kanagram-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kwordquiz-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kjumpingcube-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kapman-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ark-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kteatime-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/phonon-kde-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kcron-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kwrite-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/filelight-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kwordquiz-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/keditbookmarks-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kblackbox-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kfourinline-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/rocs-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/granatier-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/picmi-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/zeroconf-ioslave-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kbreakout-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/dolphin-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/ktimer-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kshisen-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/bomber-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kollision-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kgeography-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/knetwalk-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/baloo-widgets-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kwrite-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kiriki-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/rocs-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/marble-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/libkcddb-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kruler-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/artikulate-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/libkcddb-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kollision-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kcalc-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kdiamond-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kolourpaint-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kbounce-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/gwenview-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kig-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/gwenview-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/okular-15.08.3-r1:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kwin-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/killbots-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/ark-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ksystemlog-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/knetwalk-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kapman-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kqtquickcharts-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-frameworks/kfilemetadata-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/dragon-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kalgebra-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-plasma/kgamma-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kdepim-l10n-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/dolphin-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kbounce-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/cantor-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/krdc-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kigo-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kfourinline-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kanagram-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kturtle-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kiriki-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/analitza-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/konquest-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kblackbox-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kate-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kpat-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kblocks-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/konquest-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/konsole-4.14.3-r2:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kblocks-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kgeography-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kdiamond-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kcharselect-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kalzium-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kget-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kiten-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kigo-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/marble-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/dragon-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/blinken-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/krdc-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kinfocenter-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kamera-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kamera-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kcolorchooser-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kbreakout-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kcron-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kpat-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/katomic-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kteatime-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/step-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/klettres-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/thumbnailers-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kget-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua,handbook] required by (kde-plasma/kmenuedit-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/bovo-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/klines-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kstars-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kolourpaint-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/khelpcenter-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/khelpcenter-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kalgebra-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ksquares-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/khotkeys-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ktimer-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kdialog-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kmix-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kcharselect-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/katomic-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/step-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/ktouch-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kdegraphics-mobipocket-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/bovo-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kfind-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kshisen-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/klettres-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/blinken-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/khangman-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/khangman-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kmplot-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/filelight-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/ksysguard-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kate-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/konsole-4.14.3-r2:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kfind-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kjumpingcube-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua,opengl] required by (kde-plasma/kwin-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^       
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/klines-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua,handbook] required by (kde-plasma/kinfocenter-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kbruch-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kcalc-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/artikulate-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kbruch-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kmenuedit-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kiten-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/svgpart-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/cantor-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kig-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/bomber-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kmines-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ksnakeduel-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kubrick-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/parley-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kmplot-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/parley-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-plasma/kgamma-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kmix-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/juk-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kruler-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/juk-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         


!!! The following installed packages are masked:
- sys-firmware/b43-firmware-6.30.163.46::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# MichaŠGórny <mgorny@gentoo.org> (22 May 2017)
# for Maciej S. Szmigiero <mail@maciej.szmigiero.name>
# Any version above 5.100.138 breaks b43 driver in various ways.
# Also, b43 wiki page says to use 5.100.138. Bug #541080.

- sys-devel/binutils-2.25.1-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# MichaŠGórny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- sys-libs/glibc-2.21-r2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16872
Location: here

PostPosted: Sun Dec 03, 2017 9:12 am    Post subject: Reply with quote

Hu wrote:
Remove all packages that are no longer in tree. As a general rule, Gentoo maintainers do not create/retain blockers for packages that no longer exist, so Portage will offer you substantially less help in resolving conflicts that involve dead packages.

Code:
emerge -C =kde-apps/kdepim-l10n-4.14.3-r1 =kde-apps/killbots-4.14.3 =kde-apps/kalzium-4.14.3 =kde-plasma/ksysguard-4.11.22 =kde-apps/okular-15.08.3-r1 =kde-apps/ktouch-4.14.3 =kde-apps/kmines-4.14.3 =kde-apps/ksystemlog-15.08.3 =kde-apps/kubrick-15.08.3 =kde-apps/kstars-4.14.3-r1 =kde-apps/granatier-4.14.3 =kde-apps/kturtle-4.14.3 =kde-plasma/kwrited-4.11.22 =kde-apps/ksquares-4.14.3 =kde-apps/kanagram-4.14.3 =kde-apps/kwordquiz-4.14.3 =kde-apps/kjumpingcube-4.14.3 =kde-apps/kapman-4.14.3 =kde-apps/ark-4.14.3-r1 =kde-apps/kteatime-4.14.3 =kde-apps/phonon-kde-15.08.3 =kde-apps/kcron-4.14.3 =kde-apps/kwrite-4.14.3 =kde-apps/filelight-4.14.3 =kde-apps/kwordquiz-4.14.3 =kde-apps/keditbookmarks-15.08.3 =kde-apps/kblackbox-4.14.3 =kde-apps/kfourinline-4.14.3 =kde-apps/rocs-4.14.3 =kde-apps/granatier-4.14.3 =kde-apps/picmi-4.14.3 =kde-apps/zeroconf-ioslave-15.08.3 =kde-apps/kbreakout-4.14.3 =kde-apps/dolphin-4.14.3-r1 =kde-apps/ktimer-4.14.3 =kde-apps/kshisen-4.14.3 =kde-apps/bomber-4.14.3 =kde-apps/kollision-4.14.3 =kde-apps/kgeography-4.14.3 =kde-apps/knetwalk-4.14.3 =kde-apps/baloo-widgets-4.14.3 =kde-apps/kwrite-4.14.3 =kde-apps/kiriki-4.14.3 =kde-apps/rocs-4.14.3 =kde-apps/marble-4.14.3 =kde-apps/libkcddb-15.08.3 =kde-apps/kruler-4.14.3 =kde-apps/artikulate-4.14.3 =kde-apps/libkcddb-15.08.3 =kde-apps/kollision-4.14.3 =kde-apps/kcalc-4.14.3 =kde-apps/kdiamond-4.14.3 =kde-apps/kolourpaint-15.08.3 =kde-apps/kbounce-4.14.3 =kde-apps/gwenview-4.14.3 =kde-apps/kig-4.14.3 =kde-apps/gwenview-4.14.3 =kde-apps/okular-15.08.3-r1 =kde-plasma/kwin-4.11.22 =kde-apps/killbots-4.14.3 =kde-apps/ark-4.14.3-r1 =kde-apps/ksystemlog-15.08.3 =kde-apps/knetwalk-4.14.3 =kde-apps/kapman-4.14.3 =kde-apps/kqtquickcharts-4.14.3 =kde-frameworks/kfilemetadata-4.14.3 =kde-apps/dragon-4.14.3 =kde-apps/kalgebra-4.14.3 =kde-plasma/kgamma-4.14.3 =kde-apps/kdepim-l10n-4.14.3-r1 =kde-apps/dolphin-4.14.3-r1 =kde-apps/kbounce-4.14.3 =kde-apps/cantor-4.14.3 =kde-apps/krdc-15.08.3 =kde-apps/kigo-15.08.3 =kde-apps/kfourinline-4.14.3 =kde-apps/kanagram-4.14.3 =kde-apps/kturtle-4.14.3 =kde-apps/kiriki-4.14.3 =kde-apps/analitza-4.14.3 =kde-apps/konquest-15.08.3 =kde-apps/kblackbox-4.14.3 =kde-apps/kate-4.14.3 =kde-apps/kpat-4.14.3 =kde-apps/kblocks-4.14.3 =kde-apps/konquest-15.08.3 =kde-apps/konsole-4.14.3-r2 =kde-apps/kblocks-4.14.3 =kde-apps/kgeography-4.14.3 =kde-apps/kdiamond-4.14.3 =kde-apps/kcharselect-4.14.3 =kde-apps/kalzium-4.14.3 =kde-apps/kget-15.08.3 =kde-apps/kiten-4.14.3 =kde-apps/kigo-15.08.3 =kde-apps/marble-4.14.3 =kde-apps/dragon-4.14.3 =kde-apps/blinken-4.14.3 =kde-apps/krdc-15.08.3 =kde-plasma/kinfocenter-4.11.22 =kde-apps/kamera-15.08.3 =kde-apps/kamera-15.08.3 =kde-apps/kcolorchooser-15.08.3 =kde-apps/kbreakout-4.14.3 =kde-apps/kcron-4.14.3 =kde-apps/kpat-4.14.3 =kde-apps/katomic-4.14.3 =kde-apps/kteatime-4.14.3 =kde-apps/step-4.14.3 =kde-apps/klettres-4.14.3 =kde-apps/thumbnailers-15.08.3 =kde-apps/kget-15.08.3 =kde-plasma/kmenuedit-4.11.22 =kde-apps/bovo-4.14.3 =kde-apps/klines-4.14.3 =kde-apps/kstars-4.14.3-r1 =kde-apps/kolourpaint-15.08.3 =kde-apps/khelpcenter-4.14.3 =kde-apps/khelpcenter-4.14.3 =kde-apps/kalgebra-4.14.3 =kde-apps/ksquares-4.14.3 =kde-plasma/khotkeys-4.11.22 =kde-apps/ktimer-4.14.3 =kde-apps/kdialog-15.08.3 =kde-apps/kmix-4.14.3-r1 =kde-apps/kcharselect-4.14.3 =kde-apps/katomic-4.14.3 =kde-apps/step-4.14.3 =kde-apps/ktouch-4.14.3 =kde-apps/kdegraphics-mobipocket-15.08.3 =kde-apps/bovo-4.14.3 =kde-apps/kfind-15.08.3 =kde-apps/kshisen-4.14.3 =kde-apps/klettres-4.14.3 =kde-apps/blinken-4.14.3 =kde-apps/khangman-4.14.3 =kde-apps/khangman-4.14.3 =kde-apps/kmplot-4.14.3 =kde-apps/filelight-4.14.3 =kde-plasma/ksysguard-4.11.22 =kde-apps/kate-4.14.3 =kde-apps/konsole-4.14.3-r2 =kde-apps/kfind-15.08.3 =kde-apps/kjumpingcube-4.14.3 =kde-plasma/kwin-4.11.22 =kde-apps/klines-4.14.3 =kde-plasma/kinfocenter-4.11.22 =kde-apps/kbruch-4.14.3 =kde-apps/kcalc-4.14.3 =kde-apps/artikulate-4.14.3 =kde-apps/kbruch-4.14.3 =kde-plasma/kmenuedit-4.11.22 =kde-apps/kiten-4.14.3 =kde-apps/svgpart-15.08.3 =kde-apps/cantor-4.14.3 =kde-apps/kig-4.14.3 =kde-apps/bomber-4.14.3 =kde-apps/kmines-4.14.3 =kde-apps/ksnakeduel-15.08.3 =kde-apps/kubrick-15.08.3 =kde-apps/parley-4.14.3 =kde-apps/kmplot-4.14.3 =kde-apps/parley-4.14.3 =kde-plasma/kgamma-4.14.3 =kde-apps/kmix-4.14.3-r1 =kde-apps/juk-15.08.3 =kde-apps/kruler-4.14.3 =kde-apps/juk-15.08.3


This command remove all package that cause aqua issue in your system.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2658

PostPosted: Sun Dec 03, 2017 7:46 pm    Post subject: Reply with quote

Hi,
After updating kde-apps I tried again with the world.
Got following:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/xapian:0

  (dev-libs/xapian-1.2.22:0/1.2.22::gentoo, installed) pulled in by
    dev-libs/xapian:0/1.2.22= required by (kde-apps/khelpcenter-17.04.3:5/5::gentoo, installed)
                   ^^^^^^^^^^                                                                                                     

  (dev-libs/xapian-1.4.4:0/30::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/xapian-1.3:=[chert] required by (kde-apps/akonadi-search-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^                ^^^                                                                                                                                                                         

media-libs/giflib:0

  (media-libs/giflib-4.1.6-r3:0/0::gentoo, installed) pulled in by
    media-libs/giflib:0/0= required by (media-libs/libwebp-0.5.2:0/6::gentoo, installed)
                     ^^^^^                                                                                                 
    media-libs/giflib:0/0= required by (kde-frameworks/kdelibs-4.14.37:4/4.14::gentoo, installed)
                     ^^^^^                                                                                                           
    media-libs/giflib:0/0= required by (sci-libs/gdal-2.0.3:0/2::gentoo, installed)
                     ^^^^^                                                                                             
    media-libs/giflib:0/0= required by (kde-frameworks/khtml-5.37.0:5/5.37::gentoo, installed)
                     ^^^^^                                                                                                       

  (media-libs/giflib-5.1.4:0/7::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/giflib:0/7 required by (dev-java/icedtea-bin-3.6.0:8/8::gentoo, ebuild scheduled for merge)
                     ^^^^                                                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Any idea how to solve?

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2658

PostPosted: Sun Dec 03, 2017 10:52 pm    Post subject: Reply with quote

Hi,
Nevermind the previous post. I fixed those.

However, here is, hopefully, the last thing:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2m:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-0.9.8g:0[-bindist] required by (net-voip/telepathy-gabble-0.18.4:0/0::gentoo, ebuild scheduled for merge)
                                ^^^^^^^^                                                                                                                           
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by (dev-python/cryptography-2.0.2-r1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                   
    >=dev-libs/openssl-1.0.1:0=[bindist=] required by (net-misc/openssh-7.5_p1-r3:0/0::gentoo, ebuild scheduled for merge)
                                ^^^^^^^^                                                                                                                     

  (dev-libs/openssl-1.0.2g-r2:0/0::gentoo, installed) pulled in by
    dev-libs/openssl:0[bindist=] required by (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, installed)
                       ^^^^^^^^                                                                                                   


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


It is asking for a mixing "bindist" USE-flag.

How do I fix something like this?

And thios is what I have in my package.use:

Code:

igor@IgorDellGentoo ~ $ cat /etc/portage/package.use
app-forensics/afflib python fuse
app-forensics/sleuthkit aff ewf
dev-lang/python sqlite
dev-libs/protobuf python
dev-python/PyQt4 help
dev-db/sqlite secure-delete
www-client/firefox system-sqlite system-cairo system-jpeg -gstreamer
=app-office/akonadi-server-1.12.1-r1 soprano
>=media-libs/harfbuzz-0.9.38 icu
>=media-libs/phonon-4.7.2 designer
>=dev-libs/libgit2-0.21.5 threads
>=app-text/ghostscript-gpl-9.15-r1 cups
net-irc/quassel -server
dev-db/freetds odbc mssql
dev-qt/qtdeclarative webkit

>=dev-libs/libgdata-0.16.1 gnome
>=www-servers/apache-2.2.29 apache2_modules_auth_digest apache2_mpms_prefork
=sys-apps/portage-2.2.26 -xattr
dev-libs/libgit2 ssh
dev-libs/libgit2-glib ssh
app-crypt/pinentry gnome-keyring
sys-apps/portage -xattr
>=media-libs/gst-plugins-bad-1.10.3 egl
>=net-libs/webkit-gtk-2.18.2 -egl


>=dev-libs/openssl-1.0.2m -bindist
>=dev-qt/qtnetwork-5.7.1 bindist


Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5561
Location: Austria

PostPosted: Sun Dec 03, 2017 10:56 pm    Post subject: Reply with quote

Code:
>=dev-libs/openssl-1.0.2m -bindist
>=dev-qt/qtnetwork-5.7.1 bindist

What did we say about bindist? :roll:
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2658

PostPosted: Mon Dec 04, 2017 12:27 am    Post subject: Reply with quote

asurm,
I don't know why I changed it. ;-)
I changed it back to be "-bindist" for both and now I am doing the rebuild of the "world".

It is 538 packets so it will take some time.

After that I will continue with the upgrade to KDE5 (aka Plasma).

Hopefully that will happen smoother than this preparation. ;-)
I will update this thread if something will go wrong.

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5561
Location: Austria

PostPosted: Mon Dec 04, 2017 12:34 am    Post subject: Reply with quote

asturm wrote:
Remove any definition of USE bindist from your make.conf and package.use

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2658

PostPosted: Mon Dec 04, 2017 3:55 pm    Post subject: Reply with quote

Hi, guys,
Have 2 more questions:

1. It looks I am getting gcc-6.4. Does this mean I will get C++11 for free and will not need to supply this option thru the "-std=c++11" flag?
2. Do you think it will be better to run preserve-rebuild after world merges or wait until KDE5 will be installed? My take is to wait, but whats your insight?

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2658

PostPosted: Wed Dec 06, 2017 6:16 pm    Post subject: Reply with quote

Hi,
Just to give an update:

The emerge world finished successfully.
I then tried to emerge plasma-meta, but to my surprise "emerge -pv plasma-meta" said that the package will be re-built, not installed.

I guess that's normal and so I will continue this journey with emerge @preserved-rebuild tonight following emerge --depclean to get rid of the packages that are not needed.

Hopefully those 2 will run smoothly. If not - I will come back with more posts.

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2658

PostPosted: Thu Dec 07, 2017 1:45 am    Post subject: Reply with quote

Hi,
So here is what I got:

Code:

IgorDellGentoo /home/igor/dbhandler # emerge @preserved-rebuild

 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-util/kdevelop:4".
(dependency required by "@preserved-rebuild" [argument])


Now this problem should be solved with KDevelop update, right?

Here is the results:

Code:

IgorDellGentoo /home/igor/dbhandler # emerge -pv kdevelop

 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-libs/libomp-3.9.1:0/3.9::gentoo  USE="-hwloc -ompt" ABI_X86="(64) -32 (-x32)" 1984 KiB
[ebuild  N     ] sys-devel/clang-runtime-3.9.1::gentoo  USE="openmp -libcxx" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] dev-util/kdevelop-pg-qt-2.0.0-r1:5::gentoo  USE="-debug {-test}" 621 KiB
[ebuild   R    ] sys-devel/llvm-3.9.1-r1:0/3.9.1::gentoo  USE="clang* libffi ncurses sanitize static-analyzer xml -debug -default-compiler-rt -default-libcxx -doc -gold -libedit (-lldb) -multitarget -ocaml -python {-test}" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" PYTHON_TARGETS="python2_7" 11911 KiB
[ebuild  N     ] sys-devel/clang-3.9.1-r100:0/3.9.1::gentoo  USE="static-analyzer -debug -multitarget -python" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" 0 KiB
[ebuild  N     ] kde-apps/libkomparediff2-17.04.3:5::gentoo  USE="-debug {-test}" 175 KiB
[ebuild  NS    ] kde-apps/kapptemplate-17.04.3:5::gentoo [4.14.3:4/4.14::gentoo] USE="handbook -debug {-test}" 481 KiB
[ebuild  NS    ] dev-util/kdevplatform-5.1.1:5::gentoo [1.7.2-r1:4::gentoo] USE="welcomepage -cvs -debug -reviewboard -subversion {-test}" 2000 KiB
[uninstall     ] dev-util/kdevplatform-1.7.2-r1:4::gentoo  USE="classbrowser konsole (-aqua) -cvs -debug -reviewboard -subversion {-test}" LINGUAS="ru -bs -ca -ca@valencia -da -de -el -en_GB -es -et -fi -fr -gl -it -kk -nb -nl -pl -pt -pt_BR -sk -sl -sv -th -tr -uk -zh_CN -zh_TW"
[blocks b      ] dev-util/kdevplatform:4 ("dev-util/kdevplatform:4" is blocking dev-util/kdevplatform-5.1.1)
[ebuild  NS    ] dev-util/kdevelop-5.1.1:5::gentoo [4.7.2:4::gentoo] USE="gdbui handbook ninja plasma qmake -debug -okteta -qthelp {-test}" 4576 KiB
[uninstall     ] kde-apps/kapptemplate-4.14.3:4/4.14::gentoo  USE="handbook (-aqua) -debug"
[blocks b      ] <kde-apps/kapptemplate-16.04.0 ("<kde-apps/kapptemplate-16.04.0" is blocking dev-util/kdevelop-5.1.1)
[blocks b      ] kde-apps/kapptemplate:4 ("kde-apps/kapptemplate:4" is blocking kde-apps/kapptemplate-17.04.3)
[uninstall     ] dev-util/kdevelop-4.7.2:4::gentoo  USE="cmake cxx gdbui (-aqua) -debug -okteta -qthelp {-test}" LINGUAS="ru -bs -ca -ca@valencia -da -de -el -en_GB -es -et -fi -fr -gl -hu -it -kk -nb -nds -nl -pl -pt -pt_BR -sk -sl -sv -th -tr -uk -zh_CN -zh_TW"
[blocks b      ] dev-util/kdevelop:4 ("dev-util/kdevelop:4" is blocking dev-util/kdevplatform-5.1.1, dev-util/kdevelop-5.1.1)

Total: 9 packages (5 new, 3 in new slots, 1 reinstall, 3 uninstalls), Size of downloads: 21746 KiB
Conflict: 4 blocks

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-devel/clang-3.9.1-r100::gentoo
# required by dev-util/kdevelop-5.1.1::gentoo
# required by kdevelop (argument)
>=sys-devel/llvm-3.9.1-r1 clang


Now for some reason I will now need llvm installed, which I don't need. So I tried:

Code:

IgorDellGentoo /home/igor # equery d llvm
 * These packages depend on llvm:
media-libs/mesa-17.0.6 (vulkan ? sys-devel/llvm:4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
                       (vulkan ? >=sys-devel/llvm-3.9.0:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
                       (sys-devel/llvm:4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
                       (>=sys-devel/llvm-3.6.0:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
                       (<sys-devel/llvm-5[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
                       (video_cards_radeonsi ? sys-devel/llvm[llvm_targets_AMDGPU])
                       (video_cards_radeonsi ? sys-devel/llvm[video_cards_radeon])
                       (opencl ? sys-devel/llvm:4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
                       (opencl ? >=sys-devel/llvm-3.6.0:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
sys-devel/llvm-3.9.1-r1 (>=sys-devel/llvm-3.5)


And so it looks like I should just recompile mesa with "USE=-vulkan".

Am I right in this analisys?

Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6
Page 6 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum