Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
error when starting teamviewer 12.0.85001
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
papandreoos
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2014
Posts: 80

PostPosted: Thu Oct 26, 2017 9:15 am    Post subject: error when starting teamviewer 12.0.85001 Reply with quote

i installed wine with virtual/wine which installed wine-vanilla 2.18-r1.
i also install teamviewer from gentoo repository.
of course i start service: systemctl start teamviewerd12 before starting teamviewer12.
but when i start teamviewer i get a program error, in microsoft windows window.
it says that: the program (unidentified) has encountered a series problem and need to close.
if i press show details i get this:
Code:
Unhandled exception: page fault on read access to 0xffffffff in 32-bit code (0x7e63b631).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:7e63b631 ESP:0032f678 EBP:7cb71b10 EFLAGS:00010202(  R- --  I   - - - )
 EAX:00000000 EBX:00000000 ECX:00000001 EDX:0032f854
 ESI:00000000 EDI:00000001
Stack dump:
0x0032f678:  00000000 00000000 7cb71ae0 01000000
0x0032f688:  00090001 7cb2a848 7e65a000 00010001
0x0032f698:  00000001 69cc6e00 7e629f09 69cc6e00
0x0032f6a8:  7cb72ba0 7e65a000 00000020 00000000
0x0032f6b8:  7cb71b10 f7c0af58 00000014 7cb71b68
0x0032f6c8:  00001000 00000000 00000000 0032f6c4
Backtrace:
=>0 0x7e63b631 in libxcb.so.1 (+0xd631) (0x7cb71b10)
  1 0x7e638c0c in libxcb.so.1 (+0xac0b) (0x7cb71b10)
  2 0x7e63a94b in libxcb.so.1 (+0xc94a) (0x00000000)
  3 0x7e63aad7 xcb_wait_for_reply+0x86() in libxcb.so.1 (0x7cb71b1c)
  4 0x7e64a4b0 xcb_query_extension_reply+0x1f() in libxcb.so.1 (0x00000000)
  5 0x7e63bfa7 xcb_get_extension_data+0x96() in libxcb.so.1 (0x00000000)
  6 0x7e638e5f xcb_prefetch_maximum_request_length+0x7e() in libxcb.so.1 (0x7e7a5000)
  7 0x7e638eef xcb_get_maximum_request_length+0x2e() in libxcb.so.1 (0x7e7a5000)
  8 0x7e68523b XOpenDisplay+0x8ca() in libx11.so.6 (0x7e7a5000)
  9 0x7dc49cf3 get_linux_info+0x52() in tvwine (0x0032fad0)
  10 0x006255fd in teamviewer (+0x2255fc) (0x0032fd04)
0x7e63b631: (bad)   
Modules:
Module   Address         Debug info   Name (82 modules)
PE     400000- 16b6000   Export          teamviewer
ELF   7ac00000-7ac56000   Deferred        riched20<elf>
  \-PE   7ac10000-7ac56000   \               riched20
ELF   7b800000-7ba4e000   Deferred        kernel32<elf>
  \-PE   7b810000-7ba4e000   \               kernel32
ELF   7bc00000-7bcc8000   Deferred        ntdll<elf>
  \-PE   7bc10000-7bcc8000   \               ntdll
ELF   7bf00000-7bf04000   Deferred        <wine-loader>
ELF   7dc37000-7dc53000   Dwarf           tvwine<elf>
  \-PE   7dc40000-7dc52000   \               tvwine
ELF   7dc53000-7dcd3000   Deferred        gdiplus<elf>
  \-PE   7dc60000-7dcd3000   \               gdiplus
ELF   7dcd3000-7dcf6000   Deferred        imm32<elf>
  \-PE   7dce0000-7dcf6000   \               imm32
ELF   7dcf6000-7de1a000   Deferred        oleaut32<elf>
  \-PE   7dd10000-7de1a000   \               oleaut32
ELF   7de1a000-7de59000   Deferred        dsound<elf>
  \-PE   7de20000-7de59000   \               dsound
ELF   7de59000-7df3f000   Deferred        quartz<elf>
  \-PE   7de70000-7df3f000   \               quartz
ELF   7df3f000-7df54000   Deferred        avicap32<elf>
  \-PE   7df40000-7df54000   \               avicap32
ELF   7df54000-7df7d000   Deferred        msacm32<elf>
  \-PE   7df60000-7df7d000   \               msacm32
ELF   7df7d000-7e034000   Deferred        winmm<elf>
  \-PE   7df90000-7e034000   \               winmm
ELF   7e034000-7e05f000   Deferred        msvfw32<elf>
  \-PE   7e040000-7e05f000   \               msvfw32
ELF   7e05f000-7e094000   Deferred        uxtheme<elf>
  \-PE   7e070000-7e094000   \               uxtheme
ELF   7e094000-7e185000   Deferred        comctl32<elf>
  \-PE   7e0a0000-7e185000   \               comctl32
ELF   7e185000-7e1f5000   Deferred        shlwapi<elf>
  \-PE   7e190000-7e1f5000   \               shlwapi
ELF   7e1f5000-7e41d000   Deferred        shell32<elf>
  \-PE   7e200000-7e41d000   \               shell32
ELF   7e43f000-7e4b3000   Deferred        rpcrt4<elf>
  \-PE   7e450000-7e4b3000   \               rpcrt4
ELF   7e4b3000-7e5df000   Deferred        ole32<elf>
  \-PE   7e4d0000-7e5df000   \               ole32
ELF   7e5df000-7e5e6000   Deferred        libxfixes.so.3
ELF   7e5e6000-7e5f2000   Deferred        libxcursor.so.1
ELF   7e5f2000-7e605000   Deferred        libxi.so.6
ELF   7e605000-7e609000   Deferred        libxcomposite.so.1
ELF   7e609000-7e616000   Deferred        libxrandr.so.2
ELF   7e616000-7e622000   Deferred        libxrender.so.1
ELF   7e622000-7e629000   Deferred        libxdmcp.so.6
ELF   7e629000-7e62e000   Deferred        libxau.so.6
ELF   7e62e000-7e65b000   Dwarf           libxcb.so.1
ELF   7e65b000-7e7a8000   Dwarf           libx11.so.6
ELF   7e7a8000-7e7bd000   Deferred        libxext.so.6
ELF   7e7ed000-7e861000   Deferred        winex11<elf>
  \-PE   7e800000-7e861000   \               winex11
ELF   7e891000-7e8bc000   Deferred        libexpat.so.1
ELF   7e8bc000-7e907000   Deferred        libfontconfig.so.1
ELF   7e907000-7e920000   Deferred        libz.so.1
ELF   7e920000-7e95f000   Deferred        libpng16.so.16
ELF   7e95f000-7e971000   Deferred        libbz2.so.1
ELF   7e971000-7ea2d000   Deferred        libfreetype.so.6
ELF   7ea5d000-7ea76000   Deferred        version<elf>
  \-PE   7ea60000-7ea76000   \               version
ELF   7ea76000-7eae1000   Deferred        advapi32<elf>
  \-PE   7ea80000-7eae1000   \               advapi32
ELF   7eae1000-7ebe6000   Deferred        gdi32<elf>
  \-PE   7eaf0000-7ebe6000   \               gdi32
ELF   7ebe6000-7ed36000   Deferred        user32<elf>
  \-PE   7ec00000-7ed36000   \               user32
ELF   7ef17000-7ef24000   Deferred        libnss_files.so.2
ELF   7ef24000-7ef32000   Deferred        libnss_nis.so.2
ELF   7ef32000-7ef4d000   Deferred        libnsl.so.1
ELF   7ef4d000-7ef57000   Deferred        libnss_compat.so.2
ELF   7ef57000-7ef73000   Deferred        libgcc_s.so.1
ELF   7ef73000-7efd0000   Deferred        libm.so.6
ELF   7efd1000-7f000000   Deferred        ws2_32<elf>
  \-PE   7efe0000-7f000000   \               ws2_32
ELF   f7b18000-f7b1d000   Deferred        libdl.so.2
ELF   f7b1d000-f7ce5000   Deferred        libc.so.6
ELF   f7ce5000-f7d04000   Deferred        libpthread.so.0
ELF   f7d06000-f7d10000   Deferred        librt.so.1
ELF   f7d34000-f7ee7000   Dwarf           libwine.so.1
ELF   f7ee9000-f7f0e000   Deferred        ld-linux.so.2
ELF   f7f11000-f7f12000   Deferred        [vdso].so
Threads:
process  tid      prio (all id:s are in hex)
00000008 (D) C:\TeamViewer\TeamViewer.exe
   0000001d    0
   0000001c    0
   0000001b    0
   00000009    0 <==
0000000e services.exe
   00000011    0
   00000010    0
   0000000f    0
00000018 explorer.exe
   0000001a    0
   00000019    0
System information:
    Wine build: wine-1.6
    Platform: i386
    Host system: Linux
    Host version: 4.13.9-gentoo


wine-vanilla merge details:
Code:
app-emulation/wine-vanilla-2.18-r1::gentoo was built with the following:
USE="X alsa cups fontconfig gecko gstreamer jpeg lcms ldap mono mp3 ncurses nls opengl perl png pulseaudio realtime run-exes ssl threads truetype udev udisks xcomposite xml -capi -custom-cflags -dos -gphoto2 -gsm -netapi -odbc -openal -opencl -osmesa -oss -pcap -prelink -samba -scanner (-selinux) -test -v4l -xinerama" ABI_X86="32 64 (-x32)" LINGUAS="-ar -bg -ca -cs -da -de -el -en -en_US -eo -es -fa -fi -fr -he -hi -hr -hu -it -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW"


teamviewer merge details:
Code:
net-misc/teamviewer-12.0.85001::gentoo was built with the following:
USE="-system-wine" ABI_X86="(64)"


please tell me if you need more information :-).
thanks!

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
gavin_darkglider1
n00b
n00b


Joined: 04 Nov 2017
Posts: 9

PostPosted: Sun Nov 05, 2017 2:35 am    Post subject: Reply with quote

I am having essentially the same issue. Unfortunatly, teamviewer uses its own version of wine, which I am thinking isnt linked against the newer libs that gentoo is installing. Unfortunatly, I cant downgrade them. It also might be due to a bump in compiler versions since that version of wine was compiled. I am still trying to work out the issues myself, but I will say I didnt have it until I rebuilt my whole system, to clean it up a bit, and re optimize a few things. If anyone has any ideas, I would appreciate them.
Back to top
View user's profile Send private message
gavin_darkglider1
n00b
n00b


Joined: 04 Nov 2017
Posts: 9

PostPosted: Sun Nov 05, 2017 4:09 am    Post subject: Reply with quote

Found the answer: Recompile libxcb with cflags="-01 -march(Your March here) -pipe" Standard gentoo optimization uses CFLAGS="-O2 -march(Your March here) -pipe" You can set this on a per package basis in /etc/portage/package.env.

More info on bug can be found here: https://bugs.gentoo.org/621918
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 11441

PostPosted: Sun Nov 05, 2017 4:27 pm    Post subject: Reply with quote

gavin_darkglider1 wrote:
Found the answer: Recompile libxcb with cflags="-01 -march(Your March here) -pipe" Standard gentoo optimization uses CFLAGS="-O2 -march(Your March here) -pipe" You can set this on a per package basis in /etc/portage/package.env.
Are you sure about those instructions? Setting cflags has no impact on most build systems, and setting CFLAGS to include -01 is a very common initial mistake that leads to bogus "C compiler does not work" error reports, when the real problem is "C compiler does not work with the chosen invalid CFLAGS." C compilers understand -ON to change optimization level, but reject -0N as an invalid argument.
Back to top
View user's profile Send private message
papandreoos
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2014
Posts: 80

PostPosted: Sun Nov 05, 2017 5:36 pm    Post subject: Reply with quote

i can approve this.
i did what @gavin_darkglider1 suggested (the package.env thing. there is a wiki page) and i now have a working teamviewer at last.
thank you :-)

[EDIT]
details:
i added this line
Code:
CFLAGS="-O1 -march=(Your March here) -pipe"

to a file called libxcb-cflags.conf (i think you can call it in whatever name you want).
this file is in
Code:
/etc/portage/env
folder.
then i open the file:
Code:
/etc/portage/package.env

and there i add this line:
Code:
x11-libs/libxcb libxcb-cflags.conf


now you recompile libxcb.
then teamviewer will work :-)


Last edited by papandreoos on Mon Nov 06, 2017 10:28 am; edited 1 time in total
Back to top
View user's profile Send private message
gavin_darkglider1
n00b
n00b


Joined: 04 Nov 2017
Posts: 9

PostPosted: Mon Nov 06, 2017 12:03 am    Post subject: Reply with quote

@HU Yes, I am sure, I spent a whole day messing with it after rebuilding my whole system, for different hardware. I needed teamviewer for work, so getting it to work wasnt optional. lol. While I would agree, changing the flag system wide is a bad idea, for this individual package, at least on the 1.12-r2 version included with portage, it does fix the problem with teamviewer, and as far as I can tell, it doesnt break anything elsewhere..... At least it shouldnt, but that is yet to be seen.

I might not ever really post on these forums, but I have been running Gentoo since 2004, before they released stage 3 tarballs to build the system. lol. So, I have plenty of experience debugging this stuff, since when I started portage wasnt nearly as far along as it is now, and builds failed more often than they succeeded. lol. Hell, I even have custom patchsets for a lot of apps, that I have pieced together over the years to make various things work the way I want(Pulseaudio network compression using opus, Wifi Injection patches for gentoo-sources, patches for various games to get them compiled properly, etc)..... Hell, one day if I can find the time, I might just start my own overlay, so others can enjoy all the work I have done for myself.
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 4535

PostPosted: Mon Nov 06, 2017 1:30 am    Post subject: Reply with quote

gavin_darkglider1 wrote:
@HU Yes, I am sure, I spent a whole day messing with it after rebuilding my whole system, for different hardware. I needed teamviewer for work, so getting it to work wasnt optional. lol. While I would agree, changing the flag system wide is a bad idea, for this individual package, at least on the 1.12-r2 version included with portage, it does fix the problem with teamviewer, and as far as I can tell, it doesnt break anything elsewhere..... At least it shouldnt, but that is yet to be seen.

Hu was gently pointing out that what you posted was full of typos and never would have worked. It doesn't break anything, but that's only because what you wrote has so many errors that they're cancelling each other out and never reach the compiler.
_________________
*.ebuild // /etc/service/*
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 508
Location: Venice FL

PostPosted: Tue Dec 05, 2017 12:34 am    Post subject: Reply with quote

As it turned out, I had same issue, thank you for running down the quick fix.

Maybe this new version (13) will make for a nice change https://www.phoronix.com/scan.php?page=news_item&px=TeamViewer-13-For-Linux

64bit could be an improvement.

George
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5577
Location: Austria

PostPosted: Tue Dec 05, 2017 1:07 am    Post subject: Reply with quote

Someone needs to port it, otherwise teamviewer-10, 11 and 12 will be gone. https://bugs.gentoo.org/620736
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
AJM
n00b
n00b


Joined: 25 Sep 2002
Posts: 68
Location: Aberdeen, Scotland

PostPosted: Tue Dec 05, 2017 8:21 pm    Post subject: Reply with quote

I must be doing something stupid, because libxcb refuses to build with -O1 here.

Code:
cat /etc/portage/package.env
x11-libs/libxcb libxcb-cflags.conf


Code:
cat /etc/portage/env/libxcb-cflags.conf
CFLAGS="-O1 -march=sandybridge -pipe"


Code:
emerge -1 --info libxcb |grep CFLAGS
CFLAGS="-march=sandybridge -O2 -pipe "
FCFLAGS="-O2 -pipe"


Portage is definitely seeing the .conf file as it complains if I change the reference to a file that isn't there. Any ideas?
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 508
Location: Venice FL

PostPosted: Tue Dec 05, 2017 8:59 pm    Post subject: Reply with quote

Code:
 #  cat /etc/portage/env/optimizeO1.conf
CFLAGS="-march=native -O1 -pipe "
CXXFLAGS="${CFLAGS} "


Code:
#  cat /etc/portage/package.env
x11-libs/libxcb optimizeO1.conf


Code:
#  emerge -1 --info libxcb | tail -n5
x11-libs/libxcb-1.12-r2::gentoo was built with the following:
USE="xkb -doc (-selinux) -static-libs -test" ABI_X86="32 (64) (-x32)"
CFLAGS="-march=native -O1 -pipe"
CXXFLAGS="-march=native -O1 -pipe"



worked for me,.
Back to top
View user's profile Send private message
AJM
n00b
n00b


Joined: 25 Sep 2002
Posts: 68
Location: Aberdeen, Scotland

PostPosted: Tue Dec 05, 2017 10:30 pm    Post subject: Reply with quote

thumper wrote:

worked for me,.


Yeah... and for everyone else it seems, which makes me even more puzzled as to what's wrong with my setup. It's effectively identical to what you've done (barring the precise name of the .conf file) - unless I've made a stupid typo or something, but if I have I can't see it.
Back to top
View user's profile Send private message
vasettoo
n00b
n00b


Joined: 11 Nov 2012
Posts: 74

PostPosted: Wed Dec 06, 2017 9:43 am    Post subject: Reply with quote

Bear in mind that 'x11-libs/libX11' might need rebuild with CFLAGS change too.
Now I can start TV12 but got stuck at 'Initializing display parameters' message. Seems to me the problem is with nouveau display driver and will try installing nvidia proprietary one.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum