Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] QT cannot "see" breeze theme
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 47

PostPosted: Tue Dec 05, 2017 8:59 am    Post subject: [Solved] QT cannot "see" breeze theme Reply with quote

Hi All,

Today, I loaded up clementine and I noticed it looked terrible.

I loaded up qtconfig and saw breeze was no longer available and it too looked terrible.

This is very strange, breeze is installed and working with plasma and gtk apps (see image). Do you know how to troubleshoot this?


These are the versions of breeze and plasma I am using:

[ebuild R ~] kde-plasma/breeze-5.11.4:5::gentoo USE="X -debug -qt4 -wayland" 0 KiB
[ebuild R ~] kde-plasma/plasma-meta-5.11.4:5::gentoo USE="bluetooth crypt display-manager grub gtk handbook pam pulseaudio sddm wallpapers -networkmanager -plymouth -sdk" 0 KiB


Last edited by davidsmind on Tue Dec 05, 2017 9:12 am; edited 1 time in total
Back to top
View user's profile Send private message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 47

PostPosted: Tue Dec 05, 2017 9:00 am    Post subject: Reply with quote

https://imgur.com/a/YmJ8p
Back to top
View user's profile Send private message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 47

PostPosted: Tue Dec 05, 2017 9:06 am    Post subject: Reply with quote

This all started happening after this merge

Code:

1512376363:  >>> emerge (1 of 10) app-text/poppler-0.57.0-r1 to /
1512376396:  >>> AUTOCLEAN: app-text/poppler:0
1512376397:  >>> unmerge success: app-text/poppler-0.57.0-r1
1512376400:  >>> emerge (2 of 10) x11-misc/synergy-1.6.3 to /
1512376422:  >>> AUTOCLEAN: x11-misc/synergy:0
1512376424:  >>> unmerge success: x11-misc/synergy-1.6.3
1512376426:  >>> emerge (3 of 10) media-gfx/graphviz-2.38.0-r1 to /
1512376504:  >>> AUTOCLEAN: media-gfx/graphviz:0
1512376505:  >>> unmerge success: media-gfx/graphviz-2.38.0-r1
1512376508:  >>> emerge (4 of 10) net-dns/avahi-0.7 to /
1512376553:  >>> AUTOCLEAN: net-dns/avahi:0
1512376555:  >>> unmerge success: net-dns/avahi-0.7
1512376558:  >>> emerge (5 of 10) media-sound/pulseaudio-10.0 to /
1512376658:  >>> AUTOCLEAN: media-sound/pulseaudio:0
1512376659:  >>> unmerge success: media-sound/pulseaudio-10.0
1512376662:  >>> emerge (6 of 10) kde-frameworks/kdelibs-4.14.37 to /
1512377153:  >>> AUTOCLEAN: kde-frameworks/kdelibs:4
1512377167:  >>> unmerge success: kde-frameworks/kdelibs-4.14.37
1512377175:  >>> emerge (7 of 10) kde-plasma/breeze-5.11.4 to /
1512377205:  >>> AUTOCLEAN: kde-plasma/breeze:5
1512377207:  >>> unmerge success: kde-plasma/breeze-5.11.4
1512377209:  >>> emerge (8 of 10) kde-plasma/oxygen-5.11.4 to /
1512377250:  >>> AUTOCLEAN: kde-plasma/oxygen:5
1512377253:  >>> unmerge success: kde-plasma/oxygen-5.11.4
1512377255:  >>> emerge (9 of 10) media-video/avidemux-2.6.20 to /
1512377310:  >>> AUTOCLEAN: media-video/avidemux:2.6
1512377312:  >>> unmerge success: media-video/avidemux-2.6.20
1512377314:  >>> emerge (10 of 10) media-libs/avidemux-plugins-2.6.20 to /
1512377363:  >>> AUTOCLEAN: media-libs/avidemux-plugins:2.6
1512377364:  >>> unmerge success: media-libs/avidemux-plugins-2.6.20


So I suspect the new oxygen or breeze to be responsible.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16931
Location: here

PostPosted: Tue Dec 05, 2017 9:08 am    Post subject: Reply with quote

clementine use qt4, maybe set qt4 use flag to breeze?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 47

PostPosted: Tue Dec 05, 2017 9:12 am    Post subject: Reply with quote

Yup.

Weird, I never had the qt4 flag set for breeze before and it always worked. But that was the solution.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16931
Location: here

PostPosted: Tue Dec 05, 2017 9:15 am    Post subject: Reply with quote

davidsmind wrote:
Weird, I never had the qt4 flag set for breeze before and it always worked. But that was the solution.

But you installed kdelibs from another package, but with your last depclean portage removed this package
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 47

PostPosted: Tue Dec 05, 2017 9:28 am    Post subject: Reply with quote

hrmm, no something has definitely changed systemwide.

I built synergy and it built without qt4.

It seems that something changed (I admit, I could be responsible) that qt4 is now explicitly -qt4, but not in my make.conf

Code:
(01:27:33) david@gothbox:/usr/portage/x11-misc/synergy $ cat /etc/portage/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=core-avx2 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="realtime mmx sse sse2 dvdr fbcondecor dbus policykit udev udisks ntfs \
   fuse fat icu amd64 dos alsa nvidia vdpau xmpp semantic-desktop \
   fat32 lastfm mtp X vpn matroska acpi steamruntime gimp git ffmpeg \
   xvfb id3tag twolame joystick libass facebook google theora xcb \
   openssl ssl equalizer pulseaudio jack sndfile taglib musepack sox \
   zeitgeist threads acoustid widevine abi_x86_32 nfs btrfs -plymouth \
   infinality fontforge bash-completion kde musicbrainz offensive \
   scanner opengl qt5 rss smp startup-notification truetype vaapi \
   telepathy vhosts vim-syntax x264 subversion systemd bluetooth \
   cddb curl geoip lame lm_sensors mmap client-libs openal xattr \
   xft lighttpd lzma uvm grub -fam -libav googledrive google  \
   chromecast gstreamer -eglfs -gles2"

CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
#DISTDIR="${PORTDIR}/distfiles"
#PORTDIR="/usr/portage"
#PKGDIR="${PORTDIR}/packages"
MAKEOPTS="-j5 --load-average"

GENTOO_MIRRORS="http://gentoo.gossamerhost.com rsync://gentoo.gossamerhost.com/gentoo-distfiles/ rsync://mirror.the-best-hosting.net/gentoo-distfiles http://mirror.the-best-hosting.net http://gentoo.mirrors.tera-byte.com/"
VIDEO_CARDS="nvidia"

#PORTDIR_OVERLAY="/var/lib/layman/make.conf"
PORTAGE_TMPDIR="/tmp"
LINGUAS="en ja"

#source /var/lib/layman/make.conf
GRUB_PLATFORMS="emu efi-32 efi-64 pc"

USE_PYTHON="3.5"
PYTHON_SINGLE_TARGET="python3_5"
PYTHON_TARGETS="python2_7 python3_5"

RUBY_TARGETS="ruby20 ruby21"
FEATURES="sandbox candy news parallel-fetch parallel-install -ebuild-locks clean-logs"
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5575
Location: Austria

PostPosted: Tue Dec 05, 2017 9:34 am    Post subject: Reply with quote

qt4 was dropped from desktop profile, qt5 was added.

qt4 support flags were added to plasma-desktop for compatibility, but breeze and oxygen were forgotten. fixed that now, thanks for your report.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 47

PostPosted: Tue Dec 05, 2017 9:52 am    Post subject: Reply with quote

Oh, wow, excellent.

And what about synergy? It's a much different application (loses startup scripts etc) without qt enabled.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5575
Location: Austria

PostPosted: Tue Dec 05, 2017 9:55 am    Post subject: Reply with quote

If it loses startup scripts, that should not depend on a qt4 flag - imo (a bug that should be filed).

Long-term though, Qt4 will go away and with it (at least) the gui option for synergy.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum