Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] setlocale: unsupported locale setting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
klas
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2017
Posts: 89
Location: Bradford, UK

PostPosted: Thu Nov 23, 2017 12:36 pm    Post subject: [SOLVED] setlocale: unsupported locale setting Reply with quote

Hi
I am having this problem each time I try to install some stuff , it complains

Code:


grodos /usr/share/doc # emerge --ask app-misc/screen
setlocale: unsupported locale setting
setlocale: unsupported locale setting




Code:

During startup - Warning messages:
1: Setting LC_COLLATE failed, using "C"
2: Setting LC_MEASUREMENT failed, using "C"


Any one know how to fix this
_________________
... peace has always been with you...all you need to do is to sense it...


Last edited by klas on Sun Nov 26, 2017 1:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6817

PostPosted: Thu Nov 23, 2017 12:46 pm    Post subject: Reply with quote

You will get your locales define in your system with locale -a and what you try to use in /etc/env.d/02locale

Last edited by krinn on Thu Nov 23, 2017 12:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7681
Location: ~Brussels - Belgique

PostPosted: Thu Nov 23, 2017 12:47 pm    Post subject: Reply with quote

Hi,

Take a look at the file /etc/locale-gen and see if your system locale is defined it that file
then run locale-gen (it comes from glibc)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
klas
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2017
Posts: 89
Location: Bradford, UK

PostPosted: Thu Nov 23, 2017 1:31 pm    Post subject: Reply with quote

in /etc/locale.gen
Code:

#
# Whenever glibc is emerged, the locales listed here will be automatically
# rebuilt for you.  After updating this file, you can simply run `locale-gen`
# yourself instead of re-emerging glibc.

en_GB ISO-8859-1
en_GB.UTF-8 UTF-8
#en_US ISO-8859-1
#en_US.UTF-8 UTF-8
#ja_JP.EUC-JP EUC-JP
#ja_JP.UTF-8 UTF-8
#ja_JP EUC-JP
#en_HK ISO-8859-1
#en_PH ISO-8859-1
#de_DE ISO-8859-1
#de_DE@euro ISO-8859-15
#es_MX ISO-8859-1
#fa_IR UTF-8



on terminal # locale

Code:

grodos /usr/share/doc # locale
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_GB.UTF-8
LC_CTYPE=en_GB.UTF-8
LC_NUMERIC=en_GB.ISO-8859-1
LC_TIME=en_GB.ISO-8859-1
LC_COLLATE=C
LC_MONETARY=en_GB.ISO-8859-1
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT=gd_GB.ISO-8859-1
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
grodos /usr/share/doc # locale -a
C
POSIX
en_GB
en_GB.iso88591
en_GB.utf8
grodos /usr/share/doc #


Any help ?
_________________
... peace has always been with you...all you need to do is to sense it...
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6817

PostPosted: Thu Nov 23, 2017 1:59 pm    Post subject: Reply with quote

if you set /etc/env.d/02locale with only LANG=fr_FR it will read /usr/share/i18n/locales and try to match it with a know locale setting ; which will have all LC_* variables define in it.

so you should look at why you have different locales in use (ie: LANG=en_GB.UTF-8 doesn't match LC_NUMERIC) ; it mean you must have play bad in 02locale or bash/env...
and while you have badly play with your locale: LC_MEASUREMENT=gd_GB.ISO-8859-1 is set to locale that doesn't exists.



If it could help you, here's mine (and yes, it mean just cleaning up everything you have done and changing fr_FR to en_GB would do wonder for you, because you have/usr/share/i18n/locales/en_GB ready made) :
Code:
>cat /etc/env.d/02locale
# Configuration file for eselect
# This file has been automatically generated.
LANG="fr_FR"
LC_COLLATE="C"
>grep -v "#" /etc/locale.gen

fr_FR UTF-8
>locale -a
C
POSIX
fr_FR
fr_FR.utf8
>locale
LANG=fr_FR
LC_CTYPE="fr_FR"
LC_NUMERIC="fr_FR"
LC_TIME="fr_FR"
LC_COLLATE=C
LC_MONETARY="fr_FR"
LC_MESSAGES="fr_FR"
LC_PAPER="fr_FR"
LC_NAME="fr_FR"
LC_ADDRESS="fr_FR"
LC_TELEPHONE="fr_FR"
LC_MEASUREMENT="fr_FR"
LC_IDENTIFICATION="fr_FR"
LC_ALL=
Back to top
View user's profile Send private message
klas
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2017
Posts: 89
Location: Bradford, UK

PostPosted: Sun Nov 26, 2017 1:30 pm    Post subject: Reply with quote

Thanks . That solved my problem
_________________
... peace has always been with you...all you need to do is to sense it...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum