Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
spideroakone-bin failed to merge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
vcmota
n00b
n00b


Joined: 19 Jun 2017
Posts: 47

PostPosted: Fri Nov 17, 2017 6:39 pm    Post subject: spideroakone-bin failed to merge Reply with quote

I have just setup a novel gentoo install from scratch, and I am slowly building my system to my needs. However, I just can`t install spideroakone-bin, it fails just after downloading the binary, complaining about differences between the expected size of the download and the actual size. This is what I have

Code:

mossadegh ~ # emerge --ask app-backup/spideroak-bin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-backup/spideroak-bin-6.3.0-r1  USE="X dbus"

Would you like to merge these packages? [Yes/No] Yes

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) app-backup/spideroak-bin-6.3.0-r1::gentoo
>>> Downloading 'https://spideroak.com/release/spideroak/deb_x64'
--2017-11-17 16:22:58--  https://spideroak.com/release/spideroak/deb_x64
Resolving spideroak.com... 74.126.144.79
Connecting to spideroak.com|74.126.144.79|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 26882606 (26M) [application/x-debian-package]
Saving to: '/usr/portage/distfiles/spideroak-bin-6.3.0_amd64.deb'

/usr/portage/distfi 100%[===================>]  25.64M  1.10MB/s    in 24s

2017-11-17 16:23:24 (1.05 MB/s) - '/usr/portage/distfiles/spideroak-bin-6.3.0_amd64.deb' saved [26882606/26882606]

!!! Fetched file: spideroak-bin-6.3.0_amd64.deb VERIFY FAILED!
!!! Reason: Filesize does not match recorded size
!!! Got:      26882606
!!! Expected: 26863968
Refetching... File renamed to '/usr/portage/distfiles/spideroak-bin-6.3.0_amd64.deb._checksum_failure_.52iipl7v'

!!! Couldn't download 'spideroak-bin-6.3.0_amd64.deb'. Aborting.
 * Fetch failed for 'app-backup/spideroak-bin-6.3.0-r1', Log file:
 *  '/var/tmp/portage/app-backup/spideroak-bin-6.3.0-r1/temp/build.log'

>>> Failed to emerge app-backup/spideroak-bin-6.3.0-r1, Log file:

>>>  '/var/tmp/portage/app-backup/spideroak-bin-6.3.0-r1/temp/build.log'

 * Messages for package app-backup/spideroak-bin-6.3.0-r1:

 * Fetch failed for 'app-backup/spideroak-bin-6.3.0-r1', Log file:
 *  '/var/tmp/portage/app-backup/spideroak-bin-6.3.0-r1/temp/build.log'


I updated the @world set, as well as repositories, and the error still persist. Just in case:

Code:

mossadegh ~ # emerge --info
Portage 2.3.13 (python 3.4.5-final-0, hardened/linux/amd64/selinux, gcc-5.4.0, glibc-2.25-r9, 4.12.12-gentoo x86_64)
=================================================================
System uname: Linux-4.12.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-3612QM_CPU_@_2.10GHz-with-gentoo-2.4.1
KiB Mem:     8043228 total,   2023252 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Fri, 17 Nov 2017 18:00:01 +0000
Head commit of repository gentoo: 3266783b8abfccebbb6f719d11ab974ce77f34cb
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.8::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.15-r2::gentoo
sys-devel/binutils:       2.28.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox selinux sesandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://gentoo.c3sl.ufpr.br/gentoo/ rsync://gentoo.c3sl.ufpr.br/gentoo/ http://gentoo.c3sl.ufpr.br/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl alsa amd64 berkdb bzip2 cli consolekit cracklib crypt cxx dbus dri gdbm hardened iconv ipv6 justify modules multilib ncurses nls nptl open_perms openmp pam pcre pie policykit pulseaudio readline savedconfig seccomp selinux session ssl ssp tcpd udev udisks unconfined unicode urandom xattr xtpax zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2 mmxext" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="nouveau radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Thank you all for your attention.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16887
Location: here

PostPosted: Fri Nov 17, 2017 6:57 pm    Post subject: Reply with quote

It's a bug because current link for download in ebuild download version 6.4.0.
As workaround unmask and install version 6.4.0, and then report a new bug
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
vcmota
n00b
n00b


Joined: 19 Jun 2017
Posts: 47

PostPosted: Fri Nov 17, 2017 7:13 pm    Post subject: Reply with quote

I just did: https://bugs.gentoo.org/637956. Thank you!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum