Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Midori failed to emerge (xfce4)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
skaman814
n00b
n00b


Joined: 11 Nov 2017
Posts: 13

PostPosted: Tue Nov 14, 2017 4:33 pm    Post subject: Midori failed to emerge (xfce4) Reply with quote

Hi :D

I'm trying to get a web-browser working on my first installation, any one will do at this point ;-), this attempt is with Midori. There is another post here: https://forums.gentoo.org/viewtopic-t-1067938-highlight-emerge+midori.html which seems to be related. They suggested downgrading vala to version 0.34 and pointed out a known bug here: https://bugs.gentoo.org/628108 related to vala. I ran "emerge --search vala" and came up with this:
Code:
*  dev-lang/vala
      Latest version available: 0.36.5
      Latest version installed: 0.36.5
      Size of files: 2,783 KiB
      Homepage:      https://wiki.gnome.org/Projects/Vala
      Description:   Compiler for the GObject type system
      License:       LGPL-2.1

*  dev-libs/vala-common
      Latest version available: 0.36.5
      Latest version installed: 0.36.5
      Size of files: 2,783 KiB
      Homepage:      https://wiki.gnome.org/Projects/Vala
      Description:   Build infrastructure for packages that use Vala
      License:       LGPL-2.1

*  xfce-extra/xfce4-vala
      Latest version available: 4.10.3-r3
      Latest version installed: [ Not Installed ]
      Size of files: 86 KiB
      Homepage:      https://wiki.xfce.org/vala-bindings
      Description:   Vala bindings for the Xfce desktop environment
      License:       LGPL-2.1


Since xfce is the desktop environment I installed, so the first part of my question is: should I add a -gnome use flag in my /etc/portage/make.conf and update my @world? Should I just manually install xfce4-vala? Or just downgrade the two vala versions that are currently installed? My guess is to downgrade the 2 that are currently installed, but then I thought the other two solutions may save some head scratching later on down the road.

The second part of my question is just about the current attempt to install midori. The output of my emerge --info, emerge -pqv and the build log can be found in this pastebin: https://pastebin.com/eEZwSffy I was trying to see if the issue I was having was actually related to vala, or am I encountering a different problem?
Back to top
View user's profile Send private message
skaman814
n00b
n00b


Joined: 11 Nov 2017
Posts: 13

PostPosted: Tue Nov 14, 2017 5:24 pm    Post subject: Reply with quote

Well, of course after I post I got it to start compiling, lol. Guess I need a rubber duck for my desk. I am still wondering if it's a good idea or not to add -gnome to my /etc/portage/make.conf?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16600
Location: here

PostPosted: Tue Nov 14, 2017 5:32 pm    Post subject: Reply with quote

skaman814 wrote:
Well, of course after I post I got it to start compiling, lol. Guess I need a rubber duck for my desk. I am still wondering if it's a good idea or not to add -gnome to my /etc/portage/make.conf?

I think you can disable gnome use flag in xfce4, if for some reason a package require it use package.use
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
skaman814
n00b
n00b


Joined: 11 Nov 2017
Posts: 13

PostPosted: Tue Nov 14, 2017 6:24 pm    Post subject: Reply with quote

thank you fedeliallalinea :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum