Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] LXQT mit Problemen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1128
Location: Eppingen, Germany

PostPosted: Fri Oct 27, 2017 7:38 pm    Post subject: [gelöst] LXQT mit Problemen Reply with quote

Hallo zusammen,

seit ein paar Tagen startet LXQT mit openbox ohne die Starterleiste und mit amerikanischer Tastatur. Die andere WM (lightdm und sddm) laufen gar nicht und bringen sofort wieder den login und die Passwortabfrage. In den logs habe ich nichts gefunden. localegen ist gelaufen, aber die Tastaturbelegung bleibt amerikanisch.

Vermutlich habe ich das mit einem world/update verursacht. Sonst habe ich nur die jdkhome neu gesetzt nach einem Update.

Hat jemand eine Idee?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Sun Nov 12, 2017 10:40 am; edited 1 time in total
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1128
Location: Eppingen, Germany

PostPosted: Sat Nov 04, 2017 10:25 am    Post subject: Reply with quote

Ich habe nur das Standard-openbox-Desktop-Menue. Da startet nur firefox, keine Konsole. Der Runner (ALt + F2) geht auch nicht. Tastaturbelegung ist amerikanisch, umstellen auf Deutsch klappt nicht. Wechsel der Konsole mit Strg+ALt+F1 etc klappt auch nicht - anscheinend ist mein LXQT auf Konsole 1. Auf Strg+Alt+F2 kann ich wechseln, der Rechner reagiert allerdings sehr langsam....

vim mit amerikanischer Tastatur ist schwierig....

Umstellen auf deutsche Tastatur scheitert, locale-gen laeuft problemlos, aber deutsche Tastatur kann nicht eingestellt werden.

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
sdoubleyou
n00b
n00b


Joined: 27 May 2016
Posts: 42

PostPosted: Sat Nov 04, 2017 1:06 pm    Post subject: Reply with quote

Arbeitest Du mit einem DM oder startest Du es über .xinitrc?

hast du schon einmal setxkbmap -layout de ausprobiert?
Wie sieht denn Deine /etc/conf.d/keymaps aus? Steht dort ein keymaps=de?
hast Du eine Datei unter /etc/X11/xorg.conf.d/10-evdev.conf?
Steht dort
Code:
Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "xkb_layout" "de"
EndSection


Sind aber auch nur ein paar Ideen wo ich nachschauen würde :wink:
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1128
Location: Eppingen, Germany

PostPosted: Sat Nov 04, 2017 4:20 pm    Post subject: Reply with quote

DM ist bzw. war lightdm. .xinitrc habe ich nicht.

In /etc/conf.d/keymaps habe ich us gefunden statt de. Das war aber schon mal anders... hat auf deutsch funktioniert. Ist jetzt wieder de - hilft aber nicht.


In /etc/X11/xorg.conf.d/ habe ich eine 00-keyboard.conf, keine 10-evdev.conf. Da sind etwa die Angaben enthalten, die Du in der 10-evdev.conf vermutest.

Kann ich leider derzeit nicht kopieren, nur abtippen...:

Identifier system-keyboard
Option XkbLayout Lang de_DE.utf8

(Gleichheitszeichen und Anfuehrungsstriche finde ich gerade nicht :? )

Openbox ist jetzt auf VT1 statt VT7. Wenn ich vim in einer anderen VT starte, bleibt der Bildschirm schwarz.... schwierig, etwas in den Konfigurationen anzupassen...

uhai

Tastatur stimmt wieder - Wiki - Lokalisation/HowTo für systemd hat geholfen. Warum das allerdings zerschossen war....?
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1128
Location: Eppingen, Germany

PostPosted: Sun Nov 12, 2017 10:43 am    Post subject: gelöst!! Reply with quote

Meine .xinitrc mit dem Startaufruf für LXQT hat gefehlt. Warum die allerdings "verlroen" ging ist mir unklar...

Jedenfalls läuft das jetzt wieder.

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum