Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
System updating issues?
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1074

PostPosted: Mon Oct 16, 2017 7:16 am    Post subject: Reply with quote

Still issues... I decided to unmerge KDE - do not use it and if will be needed I will install it in the future -
but still errors and do not know how to work it out - Please advise!
Code:
make: *** [Makefile:1917: all] Error 2
 * ERROR: net-print/cups-filters-1.16.4::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-print/cups-filters-1.16.4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-print/cups-filters-1.16.4::gentoo'`.
 * The complete build log is located at '/home/emptydirectory/portage/net-print/cups-filters-1.16.4/temp/build.log'.
 * The ebuild environment file is located at '/home/emptydirectory/portage/net-print/cups-filters-1.16.4/temp/environment'.
 * Working directory: '/home/emptydirectory/portage/net-print/cups-filters-1.16.4/work/cups-filters-1.16.4'
 * S: '/home/emptydirectory/portage/net-print/cups-filters-1.16.4/work/cups-filters-1.16.4'

>>> Failed to emerge net-print/cups-filters-1.16.4, Log file:

>>>  '/home/emptydirectory/portage/net-print/cups-filters-1.16.4/temp/build.log'
*** Resuming merge...

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

 * Messages for package net-print/cups-filters-1.16.4:

 * ERROR: net-print/cups-filters-1.16.4::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-print/cups-filters-1.16.4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-print/cups-filters-1.16.4::gentoo'`.
 * The complete build log is located at '/home/emptydirectory/portage/net-print/cups-filters-1.16.4/temp/build.log'.
 * The ebuild environment file is located at '/home/emptydirectory/portage/net-print/cups-filters-1.16.4/temp/environment'.
 * Working directory: '/home/emptydirectory/portage/net-print/cups-filters-1.16.4/work/cups-filters-1.16.4'
 * S: '/home/emptydirectory/portage/net-print/cups-filters-1.16.4/work/cups-filters-1.16.4'
 * One or more packages are either masked or have missing dependencies:
 *
 *   >=net-print/cups-filters-1.0.43 pulled in by:
 *     (net-print/cups-2.1.4:0/0::gentoo, installed)
 *
 * The resume list contains packages that are either masked or have
 * unsatisfied dependencies. Please restart/continue the operation
 * manually, or use --skipfirst to skip the first package in the list and
 * any other packages that may be masked or have missing dependencies.
 *
 * The following package has failed to build, install, or execute postinst:
 *
 *  (net-print/cups-filters-1.16.4:0/0::gentoo, ebuild scheduled for merge), Log file:
 *   '/home/emptydirectory/portage/net-print/cups-filters-1.16.4/temp/build.log


https://paste.pound-python.org/show/MRCcobogQBpTfKIfWpbB/
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1362

PostPosted: Mon Oct 16, 2017 7:24 am    Post subject: Reply with quote

Code:
qpdf_pdftopdf_processor.cc:(.text+0x28e): undefined reference to `QPDFWriter::setMinimumPDFVersion(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)'
qpdf_pdftopdf_processor.cc:(.text+0x2b7): undefined reference to `QPDFWriter::setExtraHeaderText(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)'
qpdf_pdftopdf_processor.cc:(.text+0x314): undefined reference to `QPDFWriter::setMinimumPDFVersion(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)'


This looks to be the usual common problem, from switching to gcc-5 and not following the news about this...

https://www.gentoo.org/support/news-items/2015-10-22-gcc-5-new-c++11-abi.html
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1074

PostPosted: Mon Oct 16, 2017 7:39 am    Post subject: Reply with quote

ct85711,

As you can see in my previous post I already run this command:
Code:
revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc

and it gave regular output. But now, after removing KDE by:
Code:
emerge --unmerge kde-apps/kde-apps-meta
emerge --unmerge kde-apps/kde-l10n

and run again this command:
Code:
revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc

get following error:
Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtxmlpatterns:5

  (dev-qt/qtxmlpatterns-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtxmlpatterns:5/5.7 (Argument)
    ~dev-qt/qtxmlpatterns-5.7.1 required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                         
    >=dev-qt/qtxmlpatterns-5.7.1:5 required by (kde-frameworks/syntax-highlighting-5.37.0-r1:5/5.37::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^^^                                                                                                                                                                               
    (and 6 more with the same problems)

  (dev-qt/qtxmlpatterns-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-5.6.2 required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                         

dev-qt/qtsql:5

  (dev-qt/qtsql-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtsql:5/5.7 (Argument)
    >=dev-qt/qtsql-5.7.1:5 required by (kde-apps/kate-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                                                                     
    ~dev-qt/qtsql-5.7.1 required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                     
    (and 16 more with the same problems)

  (dev-qt/qtsql-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-5.6.2 required by (dev-qt/qtwebkit-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                     

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtdbus-5.7.1:5 required by (kde-frameworks/knotifications-5.38.0:5/5.38::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                                                       
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    dev-qt/qtdbus:5/5.7 (Argument)
    (and 96 more with the same problems)

  (dev-qt/qtdbus-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.6.2 required by (dev-qt/qtgui-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 

dev-qt/qtsvg:5

  (dev-qt/qtsvg-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtsvg:5/5.6 (Argument)

  (dev-qt/qtsvg-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtsvg-5.7.1:5 required by (kde-apps/kfourinline-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                                                                             
    (and 41 more with the same problem)

dev-qt/qtwebkit:5

  (dev-qt/qtwebkit-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtwebkit:5/5.6 (Argument)

  (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtwebkit-5.7.1:5 required by (kde-apps/marble-17.04.3:5/17.04::gentoo, ebuild scheduled for merge)
    ^^                ^^^^^^^                                                                                                                                                           
    (and 3 more with the same problem)

dev-qt/qtscript:5

  (dev-qt/qtscript-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtscript:5/5.6 (Argument)

  (dev-qt/qtscript-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtscript-5.7.1:5 required by (kde-apps/kdenlive-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^                ^^^^^^^                                                                                                                                                         
    (and 10 more with the same problem)

dev-qt/qtmultimedia:5

  (dev-qt/qtmultimedia-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtmultimedia:5/5.6 (Argument)

  (dev-qt/qtmultimedia-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtmultimedia-5.7.1:5 required by (kde-apps/kwave-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^                    ^^^^^^^                                                                                                                                                       
    (and 3 more with the same problem)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.6.2[gles2=] required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                 
    dev-qt/qtgui:5/5.6 (Argument)
    (and 12 more with the same problems)

  (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.7.1[egl] required by (dev-qt/qtwayland-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                           
    >=dev-qt/qtgui-5.7.1:5=[dbus] required by (kde-plasma/plasma-integration-5.10.5:5/5::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^^                                                                                                                                                                           
    (and 208 more with the same problems)

dev-qt/qttest:5

  (dev-qt/qttest-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qttest-5.7.1:5 required by (kde-frameworks/kdelibs4support-5.37.0:5/5.37::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                                                         
    dev-qt/qttest:5/5.7 (Argument)
    ~dev-qt/qttest-5.7.1 required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         

  (dev-qt/qttest-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttest-5.6.2 required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         

dev-qt/qtopengl:5

  (dev-qt/qtopengl-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtopengl-5.6.2 required by (dev-qt/qtwebkit-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                ^^^^^                                                                                                                                     
    dev-qt/qtopengl:5/5.6 (Argument)
    (and 1 more with the same problems)

  (dev-qt/qtopengl-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtopengl-5.7.1 required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                ^^^^^                                                                                                                                     
    >=dev-qt/qtopengl-5.7.1:5 required by (kde-apps/gwenview-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^                ^^^^^^^                                                                                                                                                         
    (and 2 more with the same problems)

dev-qt/designer:5

  (dev-qt/designer-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/designer:5/5.6 (Argument)

  (dev-qt/designer-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/designer-5.7.1:5 required by (kde-frameworks/kross-5.37.0:5/5.37::gentoo, ebuild scheduled for merge)
    ^^                ^^^^^^^                                                                                                                                                               
    (and 3 more with the same problem)

dev-qt/qtcore:5

  (dev-qt/qtcore-5.7.1-r3:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtcore-5.7.1:5 required by (kde-apps/artikulate-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                                           
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    dev-qt/qtcore:5/5.7 (Argument)
    (and 259 more with the same problems)

  (dev-qt/qtcore-5.6.2-r1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtimageformats-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                           
    (and 22 more with the same problem)

dev-qt/qtdeclarative:5

  (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtdeclarative:5/5.6 (Argument)
    ~dev-qt/qtdeclarative-5.6.2 required by (dev-qt/qtmultimedia-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                         
    (and 7 more with the same problems)

  (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtdeclarative-5.7.1:5 required by (kde-frameworks/krunner-5.37.0:5/5.37::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^^^                                                                                                                                                                 
    ~dev-qt/qtdeclarative-5.7.1 required by (dev-qt/linguist-tools-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                           
    (and 58 more with the same problems)

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtwidgets:5/5.6 (Argument)
    ~dev-qt/qtwidgets-5.6.2[gles2=] required by (dev-qt/qtprintsupport-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                                   
    (and 8 more with the same problems)

  (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtwidgets-5.7.1:5 required by (kde-apps/kdebugsettings-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^                                                                                                                                                               
    ~dev-qt/qtwidgets-5.7.1[gles2=] required by (dev-qt/qtopengl-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                             
    (and 182 more with the same problems)

dev-qt/qtprintsupport:5

  (dev-qt/qtprintsupport-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtprintsupport-5.6.2 required by (dev-qt/designer-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                      ^^^^^                                                                                                                                     
    dev-qt/qtprintsupport:5/5.6 (Argument)

  (dev-qt/qtprintsupport-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtprintsupport-5.7.1:5 required by (kde-apps/kmplot-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^^                                                                                                                                                       
    ~dev-qt/qtprintsupport-5.7.1 required by (dev-qt/designer-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                      ^^^^^                                                                                                                                     
    (and 25 more with the same problems)

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtnetwork:5/5.7 (Argument)
    ~dev-qt/qtnetwork-5.7.1 required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                     
    >=dev-qt/qtnetwork-5.7.1:5 required by (media-plugins/kipi-plugins-5.5.0:5/5::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^                                                                                                                                                                 
    (and 43 more with the same problems)

  (dev-qt/qtnetwork-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.6.2 required by (dev-qt/qtwebkit-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                     
    (and 4 more with the same problem)

dev-qt/qtxml:5

  (dev-qt/qtxml-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtxml:5/5.7 (Argument)
    ~dev-qt/qtxml-5.7.1 required by (dev-qt/linguist-tools-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                           
    >=dev-qt/qtxml-5.7.1:5 required by (kde-apps/granatier-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                                                                           
    (and 65 more with the same problems)

  (dev-qt/qtxml-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxml-5.6.2 required by (dev-qt/designer-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                     
    (and 1 more with the same problem)

dev-qt/linguist-tools:5

  (dev-qt/linguist-tools-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/linguist-tools:5/5.6 (Argument)

  (dev-qt/linguist-tools-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/linguist-tools-5.7.1:5 required by (kde-frameworks/kauth-5.38.0:5/5.38::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^^                                                                                                                                                               
    (and 24 more with the same problem)

dev-qt/qtquickcontrols:5

  (dev-qt/qtquickcontrols-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtquickcontrols:5/5.6 (Argument)

  (dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtquickcontrols-5.7.1:5 required by (kde-apps/kalgebra-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^                       ^^^^^^^                                                                                                                                                         
    (and 5 more with the same problem)

dev-qt/qtimageformats:5

  (dev-qt/qtimageformats-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtimageformats:5/5.6 (Argument)

  (dev-qt/qtimageformats-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtimageformats-5.7.1:5 required by (kde-apps/gwenview-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^^                                                                                                                                                         

dev-qt/qtgraphicaleffects:5

  (dev-qt/qtgraphicaleffects-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtgraphicaleffects:5/5.6 (Argument)

  (dev-qt/qtgraphicaleffects-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtgraphicaleffects-5.7.1:5 required by (kde-plasma/plasma-desktop-5.10.5:5/5::gentoo, ebuild scheduled for merge)
    ^^                          ^^^^^^^                                                                                                                                                                 
    ~dev-qt/qtgraphicaleffects-5.7.1 required by (dev-qt/qtquickcontrols2-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                          ^^^^^                                                                                                                                             
    (and 4 more with the same problems)

dev-qt/qtwebchannel:5

  (dev-qt/qtwebchannel-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtwebchannel:5/5.6 (Argument)

  (dev-qt/qtwebchannel-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtwebchannel-5.7.1:5 required by (www-client/qupzilla-2.1.2:0/0::gentoo, ebuild scheduled for merge)
    ^^                    ^^^^^^^                                                                                                                                                         
    ~dev-qt/qtwebchannel-5.7.1[qml] required by (dev-qt/qtwebengine-5.7.1-r2:5/5.7::gentoo, ebuild scheduled for merge)
    ^                    ^^^^^                                                                                                                                               

dev-qt/qtpositioning:5

  (dev-qt/qtpositioning-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtpositioning:5/5.6 (Argument)

  (dev-qt/qtpositioning-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtpositioning-5.7.1:5 required by (kde-apps/marble-17.04.3:5/17.04::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^^^                                                                                                                                                           

dev-qt/qtwayland:5

  (dev-qt/qtwayland-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtwayland:5/5.6 (Argument)

  (dev-qt/qtwayland-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtwayland-5.7.1:5[egl(+)] required by (kde-frameworks/kwayland-5.37.0:5/5.37::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^                                                                                                                                                                         

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/akonadi-17.04.3-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/akonadi-17.04.3:5 required by (kde-apps/akonadi-contacts-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-apps/akonadi-17.04.3:5 required by (kde-apps/kgpg-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-apps/akonadi-17.04.3:5 required by (kde-apps/akonadi-mime-17.04.3:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kdepimlibs-4.14.10_p20160611:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
    kde-apps/kdepimlibs:4

  (kde-apps/akonadi-1.13.1_pre20160203-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    kde-apps/akonadi:4
    kde-apps/akonadi:4 required by (kde-apps/kdepimlibs-4.14.10_p20160611:4/4.14::gentoo, ebuild scheduled for merge)

  (kde-apps/akonadi-mime-17.04.3:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/akonadi-mime-17.04.3:5 required by (kde-apps/akonadi-contacts-17.04.3:5/5::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16506
Location: here

PostPosted: Mon Oct 16, 2017 7:59 am    Post subject: Reply with quote

After remove kde meta package, you shoud run a depclean for remove all dependencies (run command with --ask option and check if all that emerge would remove is ok)
Code:
# emerge --depclean --ask

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1074

PostPosted: Mon Oct 16, 2017 8:38 am    Post subject: Reply with quote

fedeliallalinea,

Looks like endless loop... :cry:
As you can see depclean recommends me to run emerge @world, and we have seen its result..
May be need to "Also, note that it may be necessary to manually uninstall
* packages that no longer exist in the portage tree, since it may
* not be possible to satisfy their dependencies" as depclean recommends, but what packages need to unmerge?
Code:
emerge --depclean

 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence of this, it often becomes necessary to run
 * `emerge --update --newuse --deep @world` prior to depclean.

Calculating dependencies... done!
 * Dependencies could not be completely resolved due to
 * the following required packages not being installed:
 *
 *   ~dev-qt/qtxmlpatterns-5.6.2 pulled in by:
 *     dev-qt/qtdeclarative-5.6.2
 *
 *   ~dev-qt/qtsql-5.6.2 pulled in by:
 *     dev-qt/qtwebkit-5.6.2
 *
 *   >=dev-qt/qtdeclarative-5.7.1:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/qtdeclarative-5.6.2
 *
 *   x11-base/xorg-server:0/1.19.2= pulled in by:
 *     x11-drivers/xf86-input-evdev-2.10.5
 *
 *   dev-libs/xapian:0/1.2.22= pulled in by:
 *     kde-apps/khelpcenter-16.12.3
 *
 *   ~dev-qt/qtnetwork-5.6.2 pulled in by:
 *     dev-qt/qtwebkit-5.6.2
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/qtgui-5.6.2
 *
 *   >=kde-apps/kde-l10n-16.12.3 pulled in by:
 *     kde-apps/kdecore-meta-16.12.3
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/qtwebengine-5.6.2
 *
 *   ~dev-qt/qtnetwork-5.6.2 pulled in by:
 *     dev-qt/qtwebengine-5.6.2
 *
 *   ~dev-qt/qttest-5.6.2 pulled in by:
 *     dev-qt/qtdeclarative-5.6.2
 *
 *   ~dev-qt/qtnetwork-5.6.2 pulled in by:
 *     dev-qt/qtdeclarative-5.6.2
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/qtgraphicaleffects-5.6.2
 *
 *   >=kde-frameworks/kconfig-5.37.0:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   >=kde-frameworks/knotifications-5.37.0:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   >=dev-qt/qtgui-5.7.1:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   >=kde-frameworks/kdbusaddons-5.37.0:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   ~dev-qt/qtxml-5.6.2 pulled in by:
 *     dev-qt/designer-5.6.2
 *
 *   >=net-libs/miniupnpc-1.7:0/14= pulled in by:
 *     net-p2p/transmission-2.92-r2
 *
 *   >=dev-qt/qtdbus-5.6.1:5/5.6= pulled in by:
 *     kde-frameworks/kauth-5.29.0
 *
 *   >=kde-frameworks/kcoreaddons-5.37.0:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   >=kde-frameworks/kwidgetsaddons-5.37.0:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/qtopengl-5.6.2
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/qtwidgets-5.6.2
 *
 *   >=dev-qt/qtx11extras-5.7.1:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   >=kde-frameworks/kconfigwidgets-5.37.0:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/linguist-tools-5.6.2
 *
 *   >=kde-frameworks/kservice-5.37.0:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   ~dev-qt/qtcore-4.8.6[-aqua,-debug,abi_x86_64(-)] pulled in by:
 *     dev-qt/qtmultimedia-4.8.6-r1
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/designer-5.6.2
 *
 *   dev-libs/icu:0/58.1= pulled in by:
 *     dev-qt/qtwebengine-5.6.2
 *
 *   >=dev-qt/qtcore-5.6.1:5/5.6= pulled in by:
 *     kde-plasma/kwin-5.8.6
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/qtscript-5.6.2
 *
 *   >=kde-frameworks/kio-5.37.0:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   >=kde-frameworks/ki18n-5.37.0:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   >=kde-frameworks/kiconthemes-5.37.0:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   ~dev-qt/qtgui-4.8.6[-aqua,-debug,abi_x86_64(-)] pulled in by:
 *     dev-qt/qtmultimedia-4.8.6-r1
 *
 *   >=net-print/cups-filters-1.0.43 pulled in by:
 *     net-print/cups-2.1.4
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/qtprintsupport-5.6.2
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/qtsvg-5.6.2
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/qtwebchannel-5.6.2
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/qtquickcontrols-5.6.2
 *
 *   ~dev-qt/qtdbus-5.6.2 pulled in by:
 *     dev-qt/qtgui-5.6.2
 *
 *   >=dev-qt/qtwidgets-5.7.1:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   ~dev-qt/qtxml-5.6.2 pulled in by:
 *     dev-qt/linguist-tools-5.6.2
 *
 *   ~dev-qt/qtnetwork-5.6.2 pulled in by:
 *     dev-qt/designer-5.6.2
 *
 *   >=kde-plasma/plasma-workspace-5.10.5:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   dev-libs/icu:0/58.1= pulled in by:
 *     dev-qt/qtwebkit-5.6.2
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/qtwayland-5.6.2
 *
 *   ~dev-qt/qtcore-5.6.2 pulled in by:
 *     dev-qt/qtx11extras-5.6.2
 *
 *   >=kde-frameworks/kcmutils-5.37.0:5 pulled in by:
 *     kde-misc/kdeconnect-1.0.3
 *
 *   ~dev-qt/qtcore-5.6.2[icu] pulled in by:
 *     dev-qt/qtwebkit-5.6.2
 *
 * Have you forgotten to do a complete update prior to depclean? The
 * most comprehensive command for this purpose is as follows:
 *
 *   emerge --update --newuse --deep --with-bdeps=y @world
 *
 * Note that the --with-bdeps=y option is not required in many
 * situations. Refer to the emerge manual page (run `man emerge`)
 * for more information about --with-bdeps.
 *
 * Also, note that it may be necessary to manually uninstall
 * packages that no longer exist in the portage tree, since it may
 * not be possible to satisfy their dependencies.

_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16506
Location: here

PostPosted: Mon Oct 16, 2017 9:03 am    Post subject: Reply with quote

Another way is rebuild kde-apps/kde-l10n and kde-apps/kde-apps-meta and than run revdep-rebuild with --backtrack=100 option
Code:
revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc --backtrack=100

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1074

PostPosted: Mon Oct 16, 2017 10:25 am    Post subject: Reply with quote

Hope I used the right command to rebuild but it also failed:
Code:
emerge -avuD  kde-apps/kde-apps-meta

output:
Code:
Total: 254 packages (242 upgrades, 8 new, 4 in new slots, 4 uninstalls), Size of downloads: 44,091 KiB
Conflict: 12 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.9.2 required by (dev-qt/qtdbus-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                   

  (dev-qt/qtcore-5.7.1-r3:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtsql-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    (and 28 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qdbus-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/audiocd-kio-17.04.3:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/audiocd-kio-17.04.3 required by (kde-apps/kdemultimedia-meta-17.04.3:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/audiocd-kio-16.08.3:4/16.08::gentoo, installed) pulled in by
    >=kde-apps/audiocd-kio-4.4:4[-aqua] required by (media-sound/amarok-2.8.90-r2:4/4::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16506
Location: here

PostPosted: Mon Oct 16, 2017 10:53 am    Post subject: Reply with quote

pmam wrote:
Hope I used the right command to rebuild but it also failed:
Code:
emerge -avuD  kde-apps/kde-apps-meta

Ok and also you should add --backtrack=100
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1074

PostPosted: Mon Oct 16, 2017 11:27 am    Post subject: Reply with quote

With this command:
Code:
emerge -avuD  kde-apps/kde-apps-meta --backtrack=100

Still blocked:
Code:
  (dev-qt/qtcore-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.9.2 required by (dev-qt/qtdbus-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                   

  (dev-qt/qtcore-5.7.1-r3:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtsql-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    (and 28 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qdbus-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/audiocd-kio-17.04.3:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/audiocd-kio-17.04.3 required by (kde-apps/kdemultimedia-meta-17.04.3:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/audiocd-kio-16.08.3:4/16.08::gentoo, installed) pulled in by
    >=kde-apps/audiocd-kio-4.4:4[-aqua] required by (media-sound/amarok-2.8.90-r2:4/4::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16506
Location: here

PostPosted: Mon Oct 16, 2017 12:34 pm    Post subject: Reply with quote

One problem, but not sure, is amarok. Try to uninstall this package
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1074

PostPosted: Tue Oct 17, 2017 5:45 am    Post subject: Reply with quote

fedeliallalinea,

Get the same issues after unmerge amarok...
See below output of:
Code:
emerge @preserved-rebuild

Maybe it is better to wait for some time and try to sync and update again -
Hope some packages updating will work it out...
If not, looks that time for new gentoo installing has arrived...
Thanks
Code:
NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by kde-frameworks/kcmutils-5.38.0::gentoo
# required by kde-plasma/kde-cli-tools-5.10.5::gentoo
# required by kde-apps/khelpcenter-17.04.3::gentoo
# required by @preserved-rebuild (argument)
=dev-qt/qtdeclarative-5.9.2 ~amd64
# required by dev-qt/linguist-tools-5.7.1::gentoo[qml]
# required by kde-frameworks/kitemviews-5.38.0::gentoo[nls]
# required by kde-frameworks/kcmutils-5.38.0::gentoo
# required by kde-plasma/kde-cli-tools-5.10.5::gentoo
# required by kde-apps/khelpcenter-17.04.3::gentoo
# required by @preserved-rebuild (argument)
=dev-qt/qtdeclarative-5.7.1-r1 ~amd64

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! All ebuilds that could satisfy "~dev-qt/qtgui-5.7.1[gles2=]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-qt/qtgui-5.7.1-r1::gentoo (masked by: backtracking: slot conflict)

(dependency required by "dev-qt/qtdeclarative-5.7.1-r1::gentoo" [ebuild])
(dependency required by "dev-qt/linguist-tools-5.7.1::gentoo[qml]" [ebuild])
(dependency required by "kde-frameworks/kitemviews-5.38.0::gentoo[nls]" [ebuild])
(dependency required by "kde-frameworks/kcmutils-5.38.0::gentoo" [ebuild])
(dependency required by "kde-plasma/kde-cli-tools-5.10.5::gentoo" [ebuild])
(dependency required by "kde-apps/khelpcenter-17.04.3::gentoo" [ebuild])
(dependency required by "@preserved-rebuild" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1074

PostPosted: Tue Oct 17, 2017 9:16 am    Post subject: Similar issue on other machine Reply with quote

Due to the fact that I get similar issues on other machine I guess it is not a particular issue as I thought...
Here all steps I have done on the other machine - Sorry for the long post but I want to share much info as can help...
I have run 2 following commands:
Code:
# echo "0/1" | tee /var/db/pkg/sys-libs/zlib-1.2.11/SLOT /var/db/pkg/app-arch/bzip2-1.0.6-r8/SLOT
0/1

EDIT: I added this command and update next outputs -
Code:
find /var/db/pkg \( -name DEPEND -or -name RDEPEND \) -exec sed -i -e 's@\(\(sys-libs/zlib\|app-arch/bzip2\)\S*\):0/0=@\1:0/1=@g' \{} +

Code:
# revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please file bugs at: https://bugs.gentoo.org/
 * Collecting system binaries and libraries
 * Checking dynamic linking consistency
 * Assign files to packages

 !!! Dependant orphaned files: No installed package was found for the following:
   * /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libubsan.so.0.0.0
   * /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libasan.so.2.0.0
   * /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/32/libasan.so.2.0.0
   * /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libcc1.so.0.0.0
   * /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/plugin/libcc1plugin.so.0.0.0
   * /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/32/libubsan.so.0.0.0
   * /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/libtsan.so.0.0.0
   * /usr/lib64/gcc/x86_64-pc-linux-gnu/5.4.0/liblsan.so.0.0.0
   * Warning: "www-plugins/adobe-flash-26.0.0.151" ebuild not found..
   * Warning: "media-libs/libraw-0.18.2" ebuild not found..
   * Warning: "app-text/libwpd-0.10.1" ebuild not found..

emerge --exclude gcc --oneshot --complete-graph=y sys-apps/gptfdisk:0 app-text/libwps:0 sys-libs/db:5.3 dev-util/gperf:0 www-plugins/adobe-flash:2 dev-qt/qtscript:4 dev-libs/librevenge:0 gnome-extra/gnome-system-monitor:0 media-video/vlc:0/5-8 dev-qt/qtcore:4 media-gfx/graphite2:0 sys-block/thin-provisioning-tools:0 dev-util/re2c:0 dev-libs/qqwing:0/2 dev-libs/libfilezilla:0 dev-cpp/pangomm:1.4 app-text/openjade:0 app-text/mythes:0 x11-libs/wxGTK:3.0 net-misc/netkit-telnetd:0 dev-util/patchelf:0 app-crypt/pinentry:0 dev-games/openscenegraph:0/35 app-text/libwpg:0.3 dev-cpp/clucene:1 dev-libs/liborcus:0/0.11 dev-cpp/libcmis:0.5 app-text/rarian:0 dev-cpp/gtkmm:3.0 app-crypt/gpgme:1/11 media-libs/webrtc-audio-processing:0 media-libs/libfreehand:0 dev-qt/qtsql:4 dev-cpp/cairomm:0 dev-libs/boehm-gc:0 dev-libs/gjs:0 dev-cpp/glibmm:2 app-text/libmspub:0 media-libs/libcdr:0 net-libs/libproxy:0 dev-games/simgear:0 app-text/libetonyek:0 media-libs/taglib:0 media-libs/gexiv2:0 net-analyzer/nmap:0 dev-libs/libixion:0/0.11 media-libs/glu:0 dev-util/ragel:0 app-text/libodfgen:0 dev-qt/qtsvg:4 dev-util/ninja:0 media-tv/kodi:0 app-text/libebook:0 media-libs/libraw:0 app-text/libwpd:0 dev-libs/liblinear:0/3 dev-python/subunit:0 dev-cpp/atkmm:0 sys-fs/jmtpfs:0 app-text/poppler:0/62 media-libs/flac:0 dev-libs/elfutils:0 dev-libs/gmp:0/10.4 media-libs/libpagemaker:0 games-puzzle/gnome-sudoku:0 dev-qt/qtgui:4 net-print/cups:0 dev-libs/libpcre:3 sys-devel/gettext:0 media-gfx/exiv2:0/14 gnome-extra/evolution-data-server:0/59 media-libs/musicbrainz:5/1 net-libs/gnutls:0/30 sys-libs/ncurses:0/6 app-text/qpdf:0/13 net-dns/avahi:0 media-gfx/imagemagick:0/6.9.9.0 dev-libs/libsigc++:2 dev-lang/spidermonkey:0/mozjs185 media-libs/audiofile:0/1 dev-qt/qt3support:4 dev-libs/icu:0/58.2 net-ftp/filezilla:0 media-libs/libvpx:0/3 media-libs/tiff:0 dev-libs/libcdio:0/15 dev-lang/swig:0 dev-python/PyQt4:0 dev-libs/pugixml:0 dev-qt/qtopengl:4 app-text/libmwaw:0 media-libs/libvisio:0 app-text/opensp:0 dev-util/cmake:0 media-libs/mesa:0 dev-qt/qtdbus:4 app-text/hunspell:0/1.6 app-portage/eix:0 x11-libs/vte:2.91 dev-libs/libical:0/2 dev-libs/boost:0/1.62.0 app-text/enchant:0 dev-util/cppunit:0 sys-apps/groff:0 net-libs/webkit-gtk:4/37 app-text/libabw:0 net-print/hplip:0 dev-libs/tinyxml:0 dev-qt/qtchooser:0 media-plugins/gst-plugins-taglib:1.0 dev-lang/spidermonkey:24 sys-devel/llvm:0/3.9.1 net-print/cups-filters:0 app-office/libreoffice-bin:0 media-sound/pulseaudio:0 games-simulation/flightgear:0
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "www-plugins/adobe-flash:2".


And get this output when try to updating:
Code:
 # emerge --update --deep --with-bdeps=y --newuse --complete-graph  @world
Calculating dependencies... done!
[ebuild   R    ] app-arch/bzip2-1.0.6-r8 [1.0.6-r8]
[ebuild     U  ] sys-apps/baselayout-2.4.1-r2 [2.3]
[ebuild     U  ] sys-devel/autoconf-archive-2017.03.21 [2016.03.20-r1]
[ebuild     U  ] dev-libs/libatomic_ops-7.6.0 [7.4.2] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] sys-devel/gcc-config-1.8-r1 [1.7.3]
[ebuild     U  ] sys-apps/net-tools-1.60_p20161110235919 [1.60_p20160215155418]
[ebuild     U  ] media-libs/libdvdcss-1.4.0 [1.3.0]
[ebuild     U  ] dev-libs/libbsd-0.8.6 [0.8.3]
[ebuild     U  ] sys-apps/coreutils-8.26 [8.25]
[ebuild     U  ] app-portage/portage-utils-0.64 [0.62]
[ebuild     U  ] dev-python/pyparsing-2.2.0 [2.1.10]
[ebuild     U  ] dev-python/chardet-3.0.4 [2.3.0] USE="{-test%}"
[ebuild  N     ] dev-python/asn1crypto-0.22.0  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)"
[ebuild     U  ] dev-python/PySocks-1.6.7 [1.5.6] PYTHON_TARGETS="(-pypy3)"
[ebuild  N     ] app-crypt/rhash-1.3.5  USE="nls -debug -openssl -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] sys-apps/gentoo-systemd-integration-7 [6]
[ebuild     U  ] net-wireless/wpa_supplicant-2.6-r3 [2.6-r2]
[ebuild     U  ] media-libs/libraw-0.18.4 [0.18.2]
[ebuild     U  ] sys-apps/portage-2.3.8 [2.3.6]
[ebuild     U  ] app-portage/gentoolkit-0.4.0 [0.3.3] PYTHON_TARGETS="(-python3_6)"
[ebuild     U  ] sys-apps/openrc-0.32.1 [0.28]
[ebuild     U  ] sys-libs/zlib-1.2.11-r1 [1.2.11]
[ebuild  N     ] dev-libs/json-c-0.12  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild   R    ] app-misc/jq-1.5-r3  USE="(-valgrind%*)"
[ebuild     U  ] dev-util/ragel-6.10 [6.7-r1]
[ebuild     U  ] net-dns/bind-tools-9.11.1_p3 [9.11.1_p1]
[ebuild   R    ] sys-devel/gcc-5.4.0-r3  USE="-pgo%"
[ebuild     U  ] sys-apps/file-5.32 [5.30]
[ebuild     U  ] net-wireless/bluez-5.47-r1 [5.43-r1] USE="alsa%* mesh%*"
[ebuild     U  ] dev-util/cmake-3.8.2 [3.7.2] USE="-server%"
[ebuild     U  ] www-plugins/adobe-flash-27.0.0.170 [26.0.0.151]
[ebuild     U  ] sys-block/thin-provisioning-tools-0.7.0 [0.4.1] USE="-static%"
[ebuild     U  ] media-libs/openjpeg-2.3.0 [2.2.0]
[ebuild     U  ] x11-base/xorg-server-1.19.4 [1.19.3]
[ebuild     U  ] app-text/libwpd-0.10.1-r1 [0.10.1]
[ebuild     U  ] app-text/poppler-0.57.0 [0.45.0]
[ebuild     U  ] media-fonts/noto-20170403 [20160531]
[ebuild     U  ] net-print/cups-filters-1.16.4 [1.13.5] USE="-ipp_autosetup%"
[ebuild     U  ] dev-lang/perl-5.24.3 [5.24.1-r2]
[ebuild     U  ] virtual/perl-Test-Harness-3.360.100_rc-r2 [3.360.100_rc-r1]
[ebuild     U  ] virtual/perl-File-Spec-3.630.100_rc-r2 [3.630.100_rc-r1]
[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-7.100.200_rc-r2 [7.100.200_rc-r1]
[ebuild     U  ] virtual/perl-Parse-CPAN-Meta-1.441.700.100_rc-r2 [1.441.700.100_rc-r1]
[ebuild   R    ] dev-libs/openssl-1.0.2l  USE="-bindist*"
[ebuild     U  ] virtual/perl-Digest-SHA-5.950.100_rc-r4 [5.950.100_rc-r3]
[ebuild     U  ] virtual/perl-libnet-3.80.100_rc-r2 [3.80.100_rc-r1]
[ebuild     U  ] virtual/perl-JSON-PP-2.273.0.100_rc-r4 [2.273.0.100_rc-r3]
[ebuild  NS    ] sys-kernel/gentoo-sources-4.12.12 [4.12.5] USE="-build -experimental -symlink"
[ebuild     U  ] www-servers/apache-2.4.27-r1 [2.4.27]
[ebuild     U  ] sys-apps/help2man-1.47.4 [1.46.6]
[ebuild     U  ] dev-python/cryptography-2.0.2 [1.7.1]
[ebuild     U  ] media-libs/libgphoto2-2.5.14 [2.5.12]
[ebuild     U  ] sys-auth/polkit-0.113-r4 [0.113] USE="(-elogind)"
[ebuild     U  ] net-dns/libidn2-2.0.4 [2.0.2]
[ebuild     U  ] dev-python/pyopenssl-17.2.0 [16.2.0]
[ebuild     U  ] net-libs/gnutls-3.5.15 [3.5.13]
[ebuild     U  ] dev-python/urllib3-1.22 [1.16] PYTHON_TARGETS="(-pypy3)"
[ebuild     U  ] dev-python/requests-2.18.2-r1 [2.12.5] USE="ssl%* -socks5%"
[ebuild     U  ] dev-vcs/git-2.13.6 [2.13.5]
[ebuild     U  ] media-video/ffmpeg-3.3.4 [3.3.3]
[ebuild     U  ] www-client/firefox-bin-52.4.1 [52.3.0]
[ebuild     U  ] mail-client/thunderbird-bin-52.4.0 [52.3.0]
[ebuild     U  ] dev-lang/ruby-2.2.8 [2.2.6]
[ebuild     U  ] dev-ruby/rubygems-2.6.13 [2.5.2] RUBY_TARGETS="(-ruby24)"
[ebuild     U  ] dev-ruby/json-1.8.6-r1 [1.8.3] RUBY_TARGETS="(-ruby24)"
[ebuild     UD ] dev-util/pycharm-community-2016.3.2-r1 [2017.1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.19.4:0/1.19.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.19.3:0/1.19.3::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.19.3= required by (x11-drivers/xf86-input-evdev-2.10.5:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                             
    (and 2 more with the same problem)

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2l:0/0::gentoo, installed) pulled in by
    >=dev-libs/openssl-1.0.1:0/0=[bindist] required by (net-misc/openssh-7.5_p1-r1:0/0::gentoo, installed)
                                  ^^^^^^^                                                                                                     
    >=dev-libs/openssl-1.0.1:0=[bindist=] required by (net-misc/openssh-7.5_p1-r1:0/0::gentoo, installed)
                                ^^^^^^^^                                                                                                     

  (dev-libs/openssl-1.0.2l:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by (dev-python/cryptography-2.0.2:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                 

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/cryptography-2.0.2::gentoo
# required by dev-python/requests-2.18.2-r1::gentoo[ssl]
# required by gnome-extra/chrome-gnome-shell-8-r1::gentoo
# required by gnome-base/gnome-shell-3.22.3-r2::gentoo[browser-extension]
# required by gnome-base/gdm-3.22.3-r1::gentoo
# required by gnome-base/gnome-3.22.2::gentoo
# required by @selected
# required by @world (argument)
>=dev-libs/openssl-1.0.2l -bindist

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

Is it a good idea to use this portage tip?
Quote:
The --autounmask-backtrack=y * option can be used to force further backtracking, but there is no
* guarantee that it will produce a solution.


If I add >=dev-libs/openssl-1.0.2l -bindist to package.use looks like it is getting more complicated:
Code:
# emerge --update --deep --with-bdeps=y --newuse --complete-graph  @world
Calculating dependencies... done!
[ebuild   R    ] app-arch/bzip2-1.0.6-r8 [1.0.6-r8]
[ebuild     U  ] sys-apps/baselayout-2.4.1-r2 [2.3]
[ebuild     U  ] dev-libs/libatomic_ops-7.6.0 [7.4.2] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] sys-devel/autoconf-archive-2017.03.21 [2016.03.20-r1]
[ebuild     U  ] sys-devel/gcc-config-1.8-r1 [1.7.3]
[ebuild     U  ] sys-apps/net-tools-1.60_p20161110235919 [1.60_p20160215155418]
[ebuild     U  ] media-libs/libdvdcss-1.4.0 [1.3.0]
[ebuild     U  ] dev-libs/libbsd-0.8.6 [0.8.3]
[ebuild     U  ] sys-apps/coreutils-8.26 [8.25]
[ebuild     U  ] app-portage/portage-utils-0.64 [0.62]
[ebuild     U  ] dev-python/pyparsing-2.2.0 [2.1.10]
[ebuild     U  ] dev-python/chardet-3.0.4 [2.3.0] USE="{-test%}"
[ebuild  N     ] dev-python/asn1crypto-0.22.0  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)"
[ebuild     U  ] dev-python/PySocks-1.6.7 [1.5.6] PYTHON_TARGETS="(-pypy3)"
[ebuild  N     ] app-crypt/rhash-1.3.5  USE="nls -debug -openssl -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] sys-apps/gentoo-systemd-integration-7 [6]
[ebuild     U  ] media-libs/libraw-0.18.4 [0.18.2]
[ebuild     U  ] sys-apps/portage-2.3.8 [2.3.6]
[ebuild     U  ] app-portage/gentoolkit-0.4.0 [0.3.3] PYTHON_TARGETS="(-python3_6)"
[ebuild     U  ] sys-apps/openrc-0.32.1 [0.28]
[ebuild     U  ] sys-libs/zlib-1.2.11-r1 [1.2.11]
[ebuild  N     ] dev-libs/json-c-0.12  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild   R    ] app-misc/jq-1.5-r3  USE="(-valgrind%*)"
[ebuild     U  ] dev-util/ragel-6.10 [6.7-r1]
[ebuild   R    ] sys-devel/gcc-5.4.0-r3  USE="-pgo%"
[ebuild     U  ] sys-apps/file-5.32 [5.30]
[ebuild     U  ] net-wireless/bluez-5.47-r1 [5.43-r1] USE="alsa%* mesh%*"
[ebuild     U  ] sys-block/thin-provisioning-tools-0.7.0 [0.4.1] USE="-static%"
[ebuild     U  ] app-text/libwpd-0.10.1-r1 [0.10.1]
[ebuild     U  ] media-fonts/noto-20170403 [20160531]
[ebuild     U  ] dev-lang/perl-5.24.3 [5.24.1-r2]
[ebuild     U  ] virtual/perl-Test-Harness-3.360.100_rc-r2 [3.360.100_rc-r1]
[ebuild   R    ] dev-libs/openssl-1.0.2l  USE="bindist"
[ebuild     U  ] virtual/perl-File-Spec-3.630.100_rc-r2 [3.630.100_rc-r1]
[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-7.100.200_rc-r2 [7.100.200_rc-r1]
[ebuild     U  ] virtual/perl-Parse-CPAN-Meta-1.441.700.100_rc-r2 [1.441.700.100_rc-r1]
[ebuild     U #] dev-libs/openssl-1.1.0f [1.0.2l] USE="-bindist* -tls-heartbeat*"
[ebuild     U  ] virtual/perl-Digest-SHA-5.950.100_rc-r4 [5.950.100_rc-r3]
[ebuild     U  ] virtual/perl-libnet-3.80.100_rc-r2 [3.80.100_rc-r1]
[ebuild     U  ] virtual/perl-JSON-PP-2.273.0.100_rc-r4 [2.273.0.100_rc-r3]
[ebuild  NS    ] sys-kernel/gentoo-sources-4.12.12 [4.12.5] USE="-build -experimental -symlink"
[ebuild  r  U  ] x11-base/xorg-server-1.19.4 [1.19.3]
[ebuild     U  ] sys-apps/help2man-1.47.4 [1.46.6]
[ebuild     U  ] dev-python/cryptography-2.0.2 [1.7.1]
[ebuild     U  ] net-dns/bind-tools-9.11.1_p3 [9.11.1_p1]
[ebuild     U  ] media-libs/libgphoto2-2.5.14 [2.5.12]
[ebuild     U  ] sys-auth/polkit-0.113-r4 [0.113] USE="(-elogind)"
[ebuild     U  ] net-dns/libidn2-2.0.4 [2.0.2]
[ebuild     U  ] dev-util/cmake-3.8.2 [3.7.2] USE="-server%"
[ebuild     U  ] dev-python/pyopenssl-17.2.0 [16.2.0]
[ebuild  rR    ] x11-drivers/xf86-video-ati-7.9.0
[ebuild  rR    ] x11-drivers/xf86-input-libinput-0.25.1
[ebuild  rR    ] x11-drivers/xf86-input-evdev-2.10.5
[ebuild     U  ] www-servers/apache-2.4.27-r1 [2.4.27]
[ebuild     U  ] net-libs/gnutls-3.5.15 [3.5.13]
[ebuild     U  ] media-libs/openjpeg-2.3.0 [2.2.0]
[ebuild  r  U  ] sys-libs/binutils-libs-2.28.1 [2.28-r1]
[ebuild     U  ] net-wireless/wpa_supplicant-2.6-r3 [2.6-r2]
[ebuild     U  ] dev-python/urllib3-1.22 [1.16] PYTHON_TARGETS="(-pypy3)"
[ebuild  rR    ] x11-libs/cairo-1.14.8
[ebuild     U  ] dev-python/requests-2.18.2-r1 [2.12.5] USE="ssl%* -socks5%"
[ebuild     U  ] dev-vcs/git-2.13.6 [2.13.5]
[ebuild     U  ] app-text/poppler-0.57.0 [0.45.0]
[ebuild     U  ] www-plugins/adobe-flash-27.0.0.170 [26.0.0.151]
[ebuild     U  ] net-print/cups-filters-1.16.4 [1.13.5] USE="-ipp_autosetup%"
[ebuild     U  ] media-video/ffmpeg-3.3.4 [3.3.3]
[ebuild     U  ] mail-client/thunderbird-bin-52.4.0 [52.3.0]
[ebuild     U  ] www-client/firefox-bin-52.4.1 [52.3.0]
[ebuild     U  ] dev-lang/ruby-2.2.8 [2.2.6]
[ebuild     U  ] dev-ruby/rubygems-2.6.13 [2.5.2] RUBY_TARGETS="(-ruby24)"
[ebuild     U  ] dev-ruby/json-1.8.6-r1 [1.8.3] RUBY_TARGETS="(-ruby24)"
[ebuild     UD ] dev-util/pycharm-community-2016.3.2-r1 [2017.1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2l:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.1:0=[bindist=] required by (net-misc/openssh-7.5_p1-r1:0/0::gentoo, installed)
                                ^^^^^^^^                                                                                                     
    dev-libs/openssl:0/0=[abi_x86_32(-),abi_x86_64(-)] required by (net-misc/curl-7.55.1:0/0::gentoo, installed)
                    ^^^^^                                                                                                                           
    (and 16 more with the same problems)

  (dev-libs/openssl-1.1.0f:0/1.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by (dev-python/cryptography-2.0.2:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                 

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following packages are causing rebuilds:

  (x11-base/xorg-server-1.19.4:0/1.19.4::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/xf86-video-ati-7.9.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-libinput-0.25.1:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-evdev-2.10.5:0/0::gentoo, ebuild scheduled for merge)
  (sys-libs/binutils-libs-2.28.1:0/2.28.1::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-libs/cairo-1.14.8:0/0::gentoo, ebuild scheduled for merge)

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-python/m2crypto-0.24.0::gentoo
# required by net-wireless/crda-3.18-r1::gentoo
# required by net-wireless/wpa_supplicant-2.6-r3::gentoo
# required by net-misc/networkmanager-1.4.4-r1::gentoo[wifi]
# required by gnome-base/gnome-shell-3.22.3-r2::gentoo[networkmanager]
# required by x11-terms/gnome-terminal-3.22.2::gentoo[gnome-shell]
# required by gnome-base/gnome-core-apps-3.22.2::gentoo
# required by gnome-base/gnome-3.22.2::gentoo
# required by @selected
# required by @world (argument)
=dev-libs/openssl-1.1.0f ~amd64

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by dev-python/m2crypto-0.24.0::gentoo
# required by net-wireless/crda-3.18-r1::gentoo
# required by net-wireless/wpa_supplicant-2.6-r3::gentoo
# required by net-misc/networkmanager-1.4.4-r1::gentoo[wifi]
# required by gnome-base/gnome-shell-3.22.3-r2::gentoo[networkmanager]
# required by x11-terms/gnome-terminal-3.22.2::gentoo[gnome-shell]
# required by gnome-base/gnome-core-apps-3.22.2::gentoo
# required by gnome-base/gnome-3.22.2::gentoo
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Lars Wendler <polynomial-c@gentoo.org> (26 Aug 2016)
# Masked while being tested and reverse deps aren't fully compatible
=dev-libs/openssl-1.1.0f

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by net-misc/openssh-7.5_p1-r1::gentoo[ssl,-static]
# required by virtual/ssh-0::gentoo[-minimal]
# required by @system
# required by @world (argument)
=dev-libs/openssl-1.0.2l bindist

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16506
Location: here

PostPosted: Tue Oct 17, 2017 1:24 pm    Post subject: Reply with quote

Remove dev-libs/openssl-1.1.0f from package.unmask, this version break compilation of many packages.
Disable use flag bindist globally in make.conf and run emerge with --autounmask=n as workaround of this bug
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1074

PostPosted: Tue Oct 17, 2017 2:52 pm    Post subject: Reply with quote

fedeliallalinea,

I did not have dev-libs/openssl-1.1.0 in package.unmask and had USE="bindist.." in make.conf.
So, I just changed to USE="-bindist.." and added --autounmask=n to emerge @world and now it is running nicely... :)
Hope it will keep going and I am going to check this trick on the first machine...
Thanks a lot
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1074

PostPosted: Wed Oct 18, 2017 9:05 am    Post subject: Reply with quote

Regarding the first machine issue:
Due to the error massage
Code:
ERROR: net-print/cups-filters-1.16.4::gentoo failed

I found this topic: https://forums.gentoo.org/viewtopic-t-1035730-start-0.html and reemerged app-text/qpdf as suggested there:
Quote:
This is due to gcc5's libstdc++ ABI change.
You needs to reemerge app-text/qpdf.

Also added --autounmask=n and now emerge @world running nicely :)

Thanks
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1074

PostPosted: Thu Oct 19, 2017 8:23 am    Post subject: Reply with quote

After long running of updating the first machine, there is an error:
Code:
 * ERROR: dev-qt/qtwebkit-5.7.1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtwebkit-5.7.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtwebkit-5.7.1::gentoo'`.
 * The complete build log is located at '/home/emptydirectory/portage/dev-qt/qtwebkit-5.7.1/temp/build.log'.
 * The ebuild environment file is located at '/home/emptydirectory/portage/dev-qt/qtwebkit-5.7.1/temp/environment'.
 * Working directory: '/home/emptydirectory/portage/dev-qt/qtwebkit-5.7.1/work/qtwebkit-opensource-src-5.7.1'
 * S: '/home/emptydirectory/portage/dev-qt/qtwebkit-5.7.1/work/qtwebkit-opensource-src-5.7.1'

>>> Failed to emerge dev-qt/qtwebkit-5.7.1, Log file:

>>>  '/home/emptydirectory/portage/dev-qt/qtwebkit-5.7.1/temp/build.log'
*** Resuming merge...

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

 * Messages for package dev-qt/qtwebkit-5.7.1:

 * ERROR: dev-qt/qtwebkit-5.7.1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtwebkit-5.7.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtwebkit-5.7.1::gentoo'`.
 * The complete build log is located at '/home/emptydirectory/portage/dev-qt/qtwebkit-5.7.1/temp/build.log'.
 * The ebuild environment file is located at '/home/emptydirectory/portage/dev-qt/qtwebkit-5.7.1/temp/environment'.
 * Working directory: '/home/emptydirectory/portage/dev-qt/qtwebkit-5.7.1/work/qtwebkit-opensource-src-5.7.1'
 * S: '/home/emptydirectory/portage/dev-qt/qtwebkit-5.7.1/work/qtwebkit-opensource-src-5.7.1'
 * One or more packages are either masked or have missing dependencies:
 *
 *   ~dev-qt/qtdeclarative-5.6.2 pulled in by:
 *     (dev-qt/qtwebkit-5.6.2:5/5.6::gentoo, installed)
 *
 * The resume list contains packages that are either masked or have
 * unsatisfied dependencies. Please restart/continue the operation
 * manually, or use --skipfirst to skip the first package in the list and
 * any other packages that may be masked or have missing dependencies.
 *
 * The following package has failed to build, install, or execute postinst:
 *
 *  (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, ebuild scheduled for merge), Log file:
 *   '/home/emptydirectory/portage/dev-qt/qtwebkit-5.7.1/temp/build.log'
 *

 * GNU info directory index is up-to-date.

 * IMPORTANT: 4 config files in '/etc' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.

Here /home/emptydirectory/portage/dev-qt/qtwebkit-5.7.1/temp/build.log:
https://paste.pound-python.org/show/HM8xPdRH45FyVTnGpWkK/
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16506
Location: here

PostPosted: Thu Oct 19, 2017 8:45 am    Post subject: Reply with quote

Switch system to ruby22 with eselect ruby set ruby22
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1074

PostPosted: Sun Oct 22, 2017 9:15 am    Post subject: Reply with quote

Code:
Switch system to ruby22 with eselect ruby set ruby22

This helped and updating was running for a while but failed again:
Code:
make[1]: Leaving directory '/home/emptydirectory/portage/kde-frameworks/kfilemetadata-5.37.0/work/kfilemetadata-5.37.0_build'
make: *** [Makefile:128: all] Error 2
 * ERROR: kde-frameworks/kfilemetadata-5.37.0::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=kde-frameworks/kfilemetadata-5.37.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=kde-frameworks/kfilemetadata-5.37.0::gentoo'`.
 * The complete build log is located at '/home/emptydirectory/portage/kde-frameworks/kfilemetadata-5.37.0/temp/build.log'.
 * The ebuild environment file is located at '/home/emptydirectory/portage/kde-frameworks/kfilemetadata-5.37.0/temp/environment'.
 * Working directory: '/home/emptydirectory/portage/kde-frameworks/kfilemetadata-5.37.0/work/kfilemetadata-5.37.0_build'
 * S: '/home/emptydirectory/portage/kde-frameworks/kfilemetadata-5.37.0/work/kfilemetadata-5.37.0'

>>> Failed to emerge kde-frameworks/kfilemetadata-5.37.0, Log file:

>>>  '/home/emptydirectory/portage/kde-frameworks/kfilemetadata-5.37.0/temp/build.log'
*** Resuming merge...

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB
 * emerge --keep-going: kde-apps/baloo-widgets-17.04.3 dropped because it
 * requires >=kde-frameworks/baloo-5.37.0:5, >=kde-
 * frameworks/kfilemetadata-5.37.0:5, >=kde-frameworks/kfilemetadata-5.37.0:5
 * emerge --keep-going: kde-plasma/plasma-desktop-5.10.5 dropped because it
 * requires >=kde-frameworks/baloo-5.37.0:5, >=kde-plasma/plasma-
 * workspace-5.10.5:5
 * emerge --keep-going: kde-apps/kdebase-meta-17.04.3 dropped because it
 * requires >=kde-plasma/plasma-meta-5.10.5, >=kde-apps/kdecore-meta-17.04.3
 * emerge --keep-going: kde-plasma/plasma-workspace-5.10.5-r1 dropped because
 * it requires >=kde-frameworks/baloo-5.37.0:5
 * emerge --keep-going: kde-apps/k3b-17.04.3-r1 dropped because it requires
 * >=kde-frameworks/kfilemetadata-5.37.0:5[taglib], >=kde-
 * frameworks/kfilemetadata-5.37.0:5[taglib]
 * emerge --keep-going: kde-frameworks/baloo-5.37.0 dropped because it
 * requires >=kde-frameworks/kfilemetadata-5.37:5, >=kde-
 * frameworks/kfilemetadata-5.37:5
 * emerge --keep-going: kde-plasma/kdeplasma-addons-5.10.5 dropped because it
 * requires >=kde-plasma/plasma-workspace-5.10.5:5
 * emerge --keep-going: kde-apps/kdecore-meta-17.04.3 dropped because it
 * requires >=kde-apps/dolphin-17.04.3
 * emerge --keep-going: kde-plasma/powerdevil-5.10.5 dropped because it
 * requires >=kde-plasma/plasma-workspace-5.10.5:5
 * emerge --keep-going: kde-plasma/khotkeys-5.10.5 dropped because it requires
 * >=kde-plasma/plasma-workspace-5.10.5:5
 * emerge --keep-going: kde-plasma/plasma-meta-5.10.5 dropped because it
 * requires >=kde-plasma/plasma-desktop-5.10.5:5, >=kde-
 * plasma/khotkeys-5.10.5:5, >=kde-plasma/kmenuedit-5.10.5:5, >=kde-plasma
 * /plasma-workspace-5.10.5:5, >=kde-plasma/kdeplasma-addons-5.10.5:5, >=kde-
 * plasma/powerdevil-5.10.5:5
 * emerge --keep-going: kde-plasma/kmenuedit-5.10.5 dropped because it
 * requires >=kde-plasma/khotkeys-5.10.5:5
 * emerge --keep-going: kde-apps/dolphin-17.04.3 dropped because it requires
 * >=kde-frameworks/baloo-5.37.0:5, >=kde-apps/baloo-widgets-17.04.3:5, >=kde-
 * frameworks/kfilemetadata-5.37.0:5, >=kde-frameworks/kfilemetadata-5.37.0:5

 * Messages for package kde-frameworks/kfilemetadata-5.37.0:

 * ERROR: kde-frameworks/kfilemetadata-5.37.0::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=kde-frameworks/kfilemetadata-5.37.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=kde-frameworks/kfilemetadata-5.37.0::gentoo'`.
 * The complete build log is located at '/home/emptydirectory/portage/kde-frameworks/kfilemetadata-5.37.0/temp/build.log'.
 * The ebuild environment file is located at '/home/emptydirectory/portage/kde-frameworks/kfilemetadata-5.37.0/temp/environment'.
 * Working directory: '/home/emptydirectory/portage/kde-frameworks/kfilemetadata-5.37.0/work/kfilemetadata-5.37.0_build'
 * S: '/home/emptydirectory/portage/kde-frameworks/kfilemetadata-5.37.0/work/kfilemetadata-5.37.0'

 * Messages for package kde-apps/baloo-widgets-17.04.3:

 * emerge --keep-going: kde-apps/baloo-widgets-17.04.3 dropped because it
 * requires >=kde-frameworks/baloo-5.37.0:5, >=kde-
 * frameworks/kfilemetadata-5.37.0:5, >=kde-frameworks/kfilemetadata-5.37.0:5

 * Messages for package kde-plasma/plasma-desktop-5.10.5:

 * emerge --keep-going: kde-plasma/plasma-desktop-5.10.5 dropped because it
 * requires >=kde-frameworks/baloo-5.37.0:5, >=kde-plasma/plasma-
 * workspace-5.10.5:5

 * Messages for package kde-apps/kdebase-meta-17.04.3:

 * emerge --keep-going: kde-apps/kdebase-meta-17.04.3 dropped because it
 * requires >=kde-plasma/plasma-meta-5.10.5, >=kde-apps/kdecore-meta-17.04.3

 * Messages for package kde-plasma/plasma-workspace-5.10.5-r1:

 * emerge --keep-going: kde-plasma/plasma-workspace-5.10.5-r1 dropped because
 * it requires >=kde-frameworks/baloo-5.37.0:5

 * Messages for package kde-apps/k3b-17.04.3-r1:

 * emerge --keep-going: kde-apps/k3b-17.04.3-r1 dropped because it requires
 * >=kde-frameworks/kfilemetadata-5.37.0:5[taglib], >=kde-
 * frameworks/kfilemetadata-5.37.0:5[taglib]

 * Messages for package kde-frameworks/baloo-5.37.0:

 * emerge --keep-going: kde-frameworks/baloo-5.37.0 dropped because it
 * requires >=kde-frameworks/kfilemetadata-5.37:5, >=kde-
 * frameworks/kfilemetadata-5.37:5

 * Messages for package kde-plasma/kdeplasma-addons-5.10.5:

 * emerge --keep-going: kde-plasma/kdeplasma-addons-5.10.5 dropped because it
 * requires >=kde-plasma/plasma-workspace-5.10.5:5

 * Messages for package kde-apps/kdecore-meta-17.04.3:

 * emerge --keep-going: kde-apps/kdecore-meta-17.04.3 dropped because it
 * requires >=kde-apps/dolphin-17.04.3

 * Messages for package kde-plasma/powerdevil-5.10.5:

 * emerge --keep-going: kde-plasma/powerdevil-5.10.5 dropped because it
 * requires >=kde-plasma/plasma-workspace-5.10.5:5

 * Messages for package kde-plasma/khotkeys-5.10.5:

 * emerge --keep-going: kde-plasma/khotkeys-5.10.5 dropped because it requires
 * >=kde-plasma/plasma-workspace-5.10.5:5

 * Messages for package kde-plasma/plasma-meta-5.10.5:

 * emerge --keep-going: kde-plasma/plasma-meta-5.10.5 dropped because it
 * requires >=kde-plasma/plasma-desktop-5.10.5:5, >=kde-
 * plasma/khotkeys-5.10.5:5, >=kde-plasma/kmenuedit-5.10.5:5, >=kde-plasma
 * /plasma-workspace-5.10.5:5, >=kde-plasma/kdeplasma-addons-5.10.5:5, >=kde-
 * plasma/powerdevil-5.10.5:5

 * Messages for package kde-plasma/kmenuedit-5.10.5:

 * emerge --keep-going: kde-plasma/kmenuedit-5.10.5 dropped because it
 * requires >=kde-plasma/khotkeys-5.10.5:5

 * Messages for package kde-apps/dolphin-17.04.3:

 * emerge --keep-going: kde-apps/dolphin-17.04.3 dropped because it requires
 * >=kde-frameworks/baloo-5.37.0:5, >=kde-apps/baloo-widgets-17.04.3:5, >=kde-
 * frameworks/kfilemetadata-5.37.0:5, >=kde-frameworks/kfilemetadata-5.37.0:5
 *
 * The following 14 packages have failed to build, install, or execute
 * postinst:
 *
 *  (kde-frameworks/kfilemetadata-5.37.0:5/5.37::gentoo, ebuild scheduled for merge), Log file:
 *   '/home/emptydirectory/portage/kde-frameworks/kfilemetadata-5.37.0/temp/build.log'
 *  (kde-apps/baloo-widgets-17.04.3:5/5::gentoo, ebuild scheduled for merge)
 *  (kde-plasma/plasma-desktop-5.10.5:5/5::gentoo, ebuild scheduled for merge)
 *  (kde-apps/kdebase-meta-17.04.3:5/5::gentoo, ebuild scheduled for merge)
 *  (kde-plasma/plasma-workspace-5.10.5-r1:5/5::gentoo, ebuild scheduled for merge)
 *  (kde-apps/k3b-17.04.3-r1:5/5::gentoo, ebuild scheduled for merge)
 *  (kde-frameworks/baloo-5.37.0:5/5.37::gentoo, ebuild scheduled for merge)
 *  (kde-plasma/kdeplasma-addons-5.10.5:5/5::gentoo, ebuild scheduled for merge)
 *  (kde-apps/kdecore-meta-17.04.3:5/5::gentoo, ebuild scheduled for merge)
 *  (kde-plasma/powerdevil-5.10.5:5/5::gentoo, ebuild scheduled for merge)
 *  (kde-plasma/khotkeys-5.10.5:5/5::gentoo, ebuild scheduled for merge)
 *  (kde-plasma/plasma-meta-5.10.5:5/5::gentoo, ebuild scheduled for merge)
 *  (kde-plasma/kmenuedit-5.10.5:5/5::gentoo, ebuild scheduled for merge)
 *  (kde-apps/dolphin-17.04.3:5/5::gentoo, ebuild scheduled for merge)
 *

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: kde-frameworks/kdelibs-4.14.34
 *  - /usr/lib64/libkdewebkit.so.5
 *  - /usr/lib64/libkdewebkit.so.5.14.29
 *      used by /usr/lib64/kde4/htmlthumbnail.so (kde-apps/kdebase-kioslaves-16.04.3-r2)
Use emerge @preserved-rebuild to rebuild packages using these libraries

 * IMPORTANT: 4 config files in '/etc' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.

https://paste.pound-python.org/show/qcMxUi1BlqIXZlPx59FR/
Just note that as you can see in previous post, I already unmreged kde.
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16506
Location: here

PostPosted: Sun Oct 22, 2017 9:28 am    Post subject: Reply with quote

Code:
undefined reference to `Exiv2::ExifKey::ExifKey(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)'

Typically gcc 4 to 5 upgrade issue. Read news

EDIT: as workaround you can try torebuild only media-gfx/exiv2 for finish upgrade, but after finish you need to run revdep-rebuild
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1074

PostPosted: Mon Oct 23, 2017 12:10 pm    Post subject: Reply with quote

I did as you suggested:
Quote:
EDIT: as workaround you can try to rebuild only media-gfx/exiv2 for finish upgrade, but after finish you need to run revdep-rebuild

and after some workaround the system is updated finally :)
Here 2 files that etc-update ask me what to do with -
I do not familiar and have not changed any config regarding UPower,
so please advise if need to choose option 1) Replace original with update?
Thanks
Code:

Showing differences between /etc/dbus-1/system.d/org.freedesktop.UPower.conf and /etc/dbus-1/system.d/._cfg0000_org.freedesktop.UPower.conf
--- /etc/dbus-1/system.d/org.freedesktop.UPower.conf    2015-03-16 11:43:01.237952718 +0200
+++ /etc/dbus-1/system.d/._cfg0000_org.freedesktop.UPower.conf  2017-10-11 19:14:35.000000000 +0300
@@ -19,8 +19,6 @@
            send_interface="org.freedesktop.DBus.Properties"/>
     <allow send_destination="org.freedesktop.UPower.Device"
            send_interface="org.freedesktop.DBus.Properties"/>
-    <allow send_destination="org.freedesktop.UPower.QoS"
-           send_interface="org.freedesktop.DBus.Properties"/>
     <allow send_destination="org.freedesktop.UPower.KbdBacklight"
            send_interface="org.freedesktop.DBus.Properties"/>
     <allow send_destination="org.freedesktop.UPower.Wakeups"
@@ -31,8 +29,6 @@
     <allow send_destination="org.freedesktop.UPower"
            send_interface="org.freedesktop.UPower.Device"/>
     <allow send_destination="org.freedesktop.UPower"
-           send_interface="org.freedesktop.UPower.QoS"/>
-    <allow send_destination="org.freedesktop.UPower"
            send_interface="org.freedesktop.UPower.KbdBacklight"/>
     <allow send_destination="org.freedesktop.UPower"
           send_interface="org.freedesktop.UPower.Wakeups"/>


Code:
Showing differences between /etc/UPower/UPower.conf and /etc/UPower/._cfg0000_UPower.conf
--- /etc/UPower/UPower.conf     2015-03-16 11:43:00.919952726 +0200
+++ /etc/UPower/._cfg0000_UPower.conf   2017-10-11 19:14:35.000000000 +0300
@@ -3,29 +3,6 @@
 
 [UPower]
 
-# This is the smallest amount of time that UPower gives to session and system
-# processes after the suspend or hibernate request is given.
-# If the session power management component uses AboutToSuspend() then the
-# session process can only make this time larger than the value below, never
-# smaller.
-#
-# Reducing this time means the suspend happens quicker, but might also not give
-# some processes enough time to save state.
-#
-# default=1000
-SleepTimeout=1000
-
-# This controls whether hibernate is allowed when using encrypted swap.
-#
-# default=true
-AllowHibernateEncryptedSwap=true
-
-# This controls whether we want the powersave commands to be run when running
-# on battery or plugging AC.
-#
-# default=true
-RunPowersaveCommand=true
-
 # Enable the Watts Up Pro device.
 #
 # The Watts Up Pro contains a generic FTDI USB device without a specific
@@ -41,20 +18,77 @@
 # default=false
 EnableWattsUpPro=false
 
-# Poll the kernel for dock state changes.
+# Don't poll the kernel for battery level changes.
 #
-# Some drivers are still broken, and do not send out uvents when the
-# connected state changes.
+# Some hardware will send us battery level changes through
+# events, rather than us having to poll for it. This option
+# allows disabling polling for hardware that sends out events.
 #
 # default=false
-PollDockDevices=false
+NoPollBatteries=false
 
 # Do we ignore the lid state
 #
 # Some laptops are broken. The lid state is either inverted, or stuck
 # on or off. We can't do much to fix these problems, but this is a way
-# for users to make the laptop panel vanish and for programs like
-# gnome-power-manager to not suspend on system startup.
+# for users to make the laptop panel vanish, a state that might be used
+# by a couple of user-space daemons. On Linux systems, see also
+# by a couple of user-space daemons. On Linux systems, see also
+# logind.conf(5).
 #
 # default=false
 IgnoreLid=false
+
+# Policy for warnings and action based on battery levels
+#
+# Whether battery percentage based policy should be used. The default
+# is to use the time left, change to true to use the percentage, which
+# should work around broken firmwares. It is also more reliable than
+# the time left (frantically saving all your files is going to use more
+# battery than letting it rest for example).
+# default=true
+UsePercentageForPolicy=true
+
+# When UsePercentageForPolicy is true, the levels at which UPower will
+# consider the battery low, critical, or take action for the critical
+# battery level.
+#
+# This will also be used for batteries which don't have time information
+# such as that of peripherals.
+#
+# If any value is invalid, or not in descending order, the defaults
+# will be used.
+#
+# Defaults:
+# PercentageLow=10
+# PercentageCritical=3
+# PercentageAction=2
+PercentageLow=10
+PercentageCritical=3
+PercentageAction=2
+
+# When UsePercentageForPolicy is false, the time remaining at which UPower
+# will consider the battery low, critical, or take action for the critical
+# battery level.
+#
+# If any value is invalid, or not in descending order, the defaults
+# will be used.
+#
+# Defaults:
+# TimeLow=1200
+# TimeCritical=300
+# TimeAction=120
+TimeLow=1200
+TimeCritical=300
+TimeAction=120
+
+# The action to take when "TimeAction" or "PercentageAction" above has been
+# reached for the batteries (UPS or laptop batteries) supplying the computer
+#
+# Possible values are:
+# PowerOff
+# Hibernate
+# HybridSleep
+#
+# If HybridSleep isn't available, Hibernate will be used
+# If Hibernate isn't available, PowerOff will be used
+CriticalPowerAction=HybridSleep
lines 60-117/117 (END)

_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16506
Location: here

PostPosted: Mon Oct 23, 2017 1:56 pm    Post subject: Reply with quote

My policy is when a configuration file isn't changed by me, I replace original with update
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1074

PostPosted: Mon Oct 23, 2017 1:59 pm    Post subject: Reply with quote

fedeliallalinea,

Thanks a lot
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum